Содержание

• Структура Руководства

• Что вы должны знать

• Принятые обозначения

ГЛАВА 1 .КОНЦЕПЦИЯ СИСТЕМЫ 1С: ПРЕДПРИЯТИЕ

• Конфигурируемость

• Функционирование системы

• Краткое описание объектов системы

• Базовые объекты Константы

• Справочники

• Перечисления

• Документы

• Журналы документов

• Отчеты и обработки

• Регистры

• Специализированные объекты конфигурации (ветвь Общие)

• Типы данных, используемые системой

• Технологические средства конфигурирования и администрирования системы 1С: Предприятие

ГЛАВА 2 .ОСНОВНЫЕ ПОНЯТИЯ СИСТЕМЫ 1С: ПРЕДПРИЯТИЕ

• Понятие "конфигурация"

• Объект конфигурации

• Свойства объекта конфигурации

• Основные виды объектов конфигурации

• Подчиненные группы объектов

• Типизированные и типообразующие объекты

• Форма объекта

• Модуль

• Макет

ГЛАВА 3 . РАБОТА С КОНФИГУРАЦИЕЙ

• Открытие конфигурации

• Сохранение конфигурации

• Закрытие конфигурации

• Сохранение конфигурации в файл

• Дерево объектов конфигурации

• Настройка сортировки

• Создание и удаление объекта конфигурации. Создание объекта конфигурации

• Удаление объекта конфигурации

• Описание структуры конфигурации

• Палитра свойств

• Диалог редактирования объекта

• Основные свойства объектов конфигурации

• Свойства конфигурации

• Ка тегория свойств - Основные

• Категория свойтв - Представление

• Категория свойств - Справочная информация

• Создание описания объекта конфигурации

• Глобальный поиск и замена

• Конструкторы. Конструктор печати

• Конструктор ввода на основании

ГЛАВА 4 . ОБЪЕКТЫ КОНФИГУРАЦИИ

• Глобальный модуль

• Ветвь конфигурации Общие"

• Подсистемы

• Общие модули

• Роли

• Критерии отбора

• Редактор индивидуальных пользовательских интерфейсов

• Ведение списка пользовательских интерфейсов

• Свойства панели

• Редактирование интерфейса

• Создание нового подменю

• Перемещение и копирование подменю

• Порядок следования

• Расположение и показ панелей

• Макеты

• Картинки

• Стили

• Языки

• Константы

• Свойства константы

• Формы для ввода констант

• Справочники

• Свойства справочника

• Документы

• Свойства документа

• Нумераторы

• Управление списком нумераторов

• Свойства нумератора

• Последовательности документов

• Управление списком последовательностей

• Свойства последовательности документов

• Работа с последовательностями документов

• Ввод документов «на основании»

• Организация ввода документов «на основании»

• Журналы документов

• Создание журнала

• Редактирование журнала

• Графы журнала документов

• Пример создания формы журнала

• Перечисления

• Редактирование перечисления

• Отчеты и обработки

• Редактирование свойств отчета

• Обработки

• Сохранение и восстановление значений настроек отчетов и обработок

• Внешние обработки

• Создание внешней обработки

• Использование внешних обработок

• Редактирование внешней обработки

• Описание формы внешней обработки

• Внешние обработки и объекты конфигурации

• Копирование обработки во внешнюю обработку

• Замена обработки на внешнюю обработку

• Добавление внешней обработки в структуру конфигурации

• Сравнение и объединение внешних обработок

• Регистры

• Регистры сведений

• Общая информация о регистрах сведений

• Записи регистра сведений

• Редактирование регистра сведений

• Разработка структуры регистра сведений

• Свойства измерения (ресурса, реквизита) регистра сведений

• Упорядочивание списка измерений регистра сведений

• Регистры накоплений

• Общая информация о регистрах накопления

• Движения регистра накопления

• Итоги регистра накопления

• Регистры остатков и регистры оборотов

• Редактирование регистра накопления

• Разработка структуры регистра накопления

• Свойства измерения (ресурса, реквизита) регистра накопления

• Упорядочивание списка измерений регистра накопления

ГЛАВА 5 . СРАВНЕНИЕ И ОБЪЕДИНЕНИЕ КОНФИГУРАЦИЙ

• Условия сравнения конфигураций

• Запуск режима сравнения и объединения конфигураций

• Окно Объединение конфигураций

• Установка соответствия объектов

• Режим объединения

• Установка порядка подчиненных объектов

• Просмотр различий

• Отбор объектов и запуск процесса объединения

ГЛАВА 6 .РЕДАКТОР ФОРМ

• Создание формы

• Редактирование формы

• Страницы формы

• Вставка и размещение элементов управления в форме

• Рекомендации по оформлению

• Вставка элементов управления в форму

• Вставка элементов управления в табличный документ, расположенный в форме

• Работа с реквизитами формы

• Использование режима Вставить данные

• Разметочная сетка

• Выравнивание элементов управления Выравнивающие линии

• Прикрепление выравнивающей линии к элементу управления

• Невидимые выравнивающие линии

• Выравнивание элементов управления с помощью специальных маркеров

• Выполнение действий с группой выделенных элементов

• Управление выравниванием и распределение элементов управления

• Установка размера

• Порядок элементов

• Привязка элементов управления к границам формы

• Простая привязка границ

• Сложная привязка границ

• Автоматическая привязка границ, назначение авто-привязки

• Авто-привязка границ элементов управления

• Область действия привязок

• Автоматическая привязка нескольких элементов управления

• Пересекающиеся элементы управления

• Использование разделителей для коррекции механизма авто-привязок

• Установка ручных привязок

• Категория свойств Основные

• Категория свойств Редактирование

• Категория свойств Использование

• Категория свойств Оформление

• Категория свойств Текущая страница

• Категория свойств Окно

• Категория свойств События

• Элементы управления, размещаемые в форме

• Общие свойства элементов управления

• Категория свойств Основные

• Категория свойств Расположение

• Категория свойств Оформление

• Особенные свойства элементов управления

• Диаграмма

• Индикатор

• Категория свойств Данные

• Категория свойств Характеристики

• Календарь

• Категория свойств Основные

• Категория свойств События

• Кнопка

• Категория свойств Основные

• Категория свойств Оформление

• Категория свойств Характеристики

• Категория свойств События

• Командная панель

• Категория свойств Основные

• Категория свойств Характеристики

• Надпись

• Категория свойств Основные

• Категория свойств Оформление

• Категория свойств Характеристики

• Категория свойств События

• Панель

• Категория свойств Основная

• Категория свойств Использование

• Категория свойств Текущая страница

• Категория свойств События

• Переключатель

• Категория свойств Характеристики

• Категория свойств Использование

• Поле ввода

• Категория свойств Основные

• Категория свойств Характеристики

• Категория свойств Использование

• Категория свойств Оформление

• Категория свойств События

• Поле выбора

• Категория свойств Использование

• Категория свойств События

• Поле картинки

• Категория свойств Основные

• Категория свойств События

• Поле списка

• Категория свойств Использование

• Категория свойств События

• Полоса регулирования

• Категория свойств Данные

• Категория свойств Характеристики

• Категория свойств События

• Разделитель

• Категория свойств Характеристики

• Рамка группы

• Категория свойств Основные

• Табличное поле

• Настройка табличного поля

• Свойства табличного поля Категория свойств Основные

• Категория свойств Использование

• Категория свойств Характеристики

• Категория свойств Оформление

• Категория свойств События

• Добавление, размещение и удаление колонок

• Свойства колонок

• Категория свойств Основные

• Категория свойств Характеристики

• Свойства ячеек

• Категория свойств Основные

• Категория свойств Характеристики

• Категория свойств Использование

• Категория свойств Оформление

• Категория свойств События

• Табличный документ

• Текстовый документ

• Категория свойств Оформление

• Конструкторы форм

• Модуль

ГЛАВА 7 . ДИАГРАММА

• Основные принципы и понятий

• Создание элемента управления Диаграмма

• Настройка диаграммы

• Формат общей области диаграммы Категория свойств Основные

• Категория свойств Оформление

• Категория свойств Серии

• Категория свойств Точки

• Категория свойств Характеристики

• Категория свойств Область данных

• Категория свойств События

• Формат областей построения легенды и заголовка диаграммы

• Категория свойств Оформление

ГЛАВА 8 . РЕДАКТОР ТЕКСТОВ

• Редактирование модулей

• Выделение цветом синтаксических конструкций

• Группировка

• Форматирование модуля

• Форматирование синтаксических конструкций

• Вставка / удаление признака комментария

• Переход по процедурам и функциям модуля

• Синтаксический контроль модуля

ГЛАВА 9 . ТАБЛИЧНЫЙ РЕДАКТОР

• Что такое "таблица" в системе 1C: Предприятие

• Работа с макетом

• Общие принципы проектирования макета

• Работа с таблицей, размещенной в форме

• Работа с табличным документом

• Сохранение табличного документа

• Просмотр таблицы

• Выделение ячеек, строк и столбцов таблицы

• Имена

• Поиск и замена

• Изменение высоты строк и ширины столбцов

• Ввод текста в ячейку

• Просмотр и редактирование свойств таблицы и ячеек

• Свойства таблицы

• Установка изображения в качестве фона листа

• Определение области печати

• Настройка печати

• Определение повторяющихся строк и столбцов

• Свойства ячеек таблицы

• Категория свойств Основные

• Категории свойств Макет

• Категория свойств Значения

• Категория свойств Положение

• Категория свойств Оформление

• Панель редактирования

• Отображение панели редактирования

• Ввод и редактирование текста

• Ввод и редактирование имен

• Перемещение и копирование ячеек

• Добавление и удаление ячеек

• Разбиение ячеек

• Задание различной ширины колонок

• Скрытие и отображение строк и столбцов

• Объединение ячеек

• Работа с именованными областями таблицы

• Создание именованной области

• Режим просмотра именованных областей

• Удаление именованных областей

• Изменение размеров именованных областе й

• Работа с группами таблицы

• Создание группы

• Режим просмотра групп

• Удаление группы

• Изменение размеров группы. Вложенные и внешние группы

• Использование графических объектов

• Вставка графических объектов

• Привязка графических объектов

• Выделение графических объектов

• Выравнивание группы графических объектов

• Установка размера группы графических объектов

• Перемещение и копирование графических объектов

• Изменение размеров графических объектов

• Изменение порядка расположения графических объектов

• Удаление графических объектов

• Группировка графических объектов

• Имена графических объектов

• Работа с OLE-объектами

• Работа с диаграммой

• Область данных диаграммы

• Вставка элементов управления

• Привязка элементов управления

• Размещение элементов управления в таблице

• Настройка печати

• Колонтитулы

• Разбиение на страницы

• Автоматическое повторение строк и столбцов

• Задание области печати

• Настройка параметров страницы

• Печать таблицы

ГЛАВА 10 . HTML-РЕДАКТОР

• Создание HTML-документа

• Создание описания объекта конфигурации

• Сохранение

• Редактирование

• Ввод текста

• Форматирование текста

• Вставка и работа с таблицей

• Вставка картинки

• Надпись

• Ссылки

• Линия

• Редактирование в HTML-формате

• Просмотр результата

ГЛАВА 11 . АДМИНИСТРИРОВАНИЕ

• Ведение списка пользователей

• Создание нового пользователя

• Копирование пользователя

• Установка пароля

• Удаление пользователя

• Редактирование свойств пользователя

• Региональные установки информационной базы

ГЛАВА 12 . СЕРВИСНЫЕ ВОЗМОЖНОСТИ

• Служебные окна

• Состояние (режим размещения) окна

• Настройка параметров Конфигуратора

• Установка параметров редактора

• Установка параметров текста модуля

• Настройка показа группировки

• Установка параметров редактирования формы

• Сетка

• Указатели

• Авто прокрутка

• Выравнивающие линии

• Установка параметров администрирования

• Калькулятор

• Календарь

• Шаблоны текста

• Ведение списка шаблонов

• Редактирование шаблона

• Управляющие конструкции шаблона

• Синтакс-Помощник

• Окно Синтакс-Помощника

• Копирование элементов встроенного языка

• Поиск в Синтакс-Помощнике

• Панели инструментов

• Виды панелей инструментов

• Управление панелями инструментов

• Закладка "Панели инструментов"

• Создание панелей инструментов

• Переименование панели инструментов

• Удаление панели инструментов

• Восстановление системных панелей инструментов

• Редактирование панелей инструментов

• Сравнение файлов

ГЛАВА 13 . ОТЛАДЧИК

• Использование Отладчика

• Запуск Отладчика

• Отладка внешних обработок

• Точка останова

• Пошаговое выполнение

• Диалог "Выражение"

• Табло

• Стек вызовов

• Замеры производительности

• Варианты порядка действий

• Результаты замера

• Сортировка результатов замера

• Выборочное суммирование результатов замера

• Сохранение результатов

rep_d@tut.by


Содержание


Введение

Данная версия предназначена для ознакомления партнеров фирмы «1С» с архитектурными особенностями и технологическими возможностями системы 1С: Предприятие версии 8.0.

Настоящая книга является руководством по конфигурированию и администрированию системы 1С: Предприятие.


Введение


Структура руководства

Руководство содержит описание общей концепции системы 1С: Предприятие и рассказывает о приемах работы с базовыми объектами системы, о создании индивидуальных пользовательских интерфейсов и наборов нрав пользователей, а также описание принципов администрирования системы 1С: Предприятие и служебных режимов работы.

В главе 1 излагается концепция системы 1С: Предприятие: заложенные в нее принципы, общая схема работы и другое.

Глава 2 посвящена основным понятиям системы 1С: Предприятие, которые используются в настоящем Руководстве, дается расшифровка ключевых понятий системы 1С: Предприятие, рассказывается об основных приемах создания и редактирования объектов конфигурации.

Глава 3 посвящена работе с конфигурацией в целом: редактированию свойств конфигурации, копированию объектов конфигурации, сохранению конфигурации, объединению конфигураций, вспомогательным режимам работы.

Глава 4 подробно рассказывает о работе с основными видами объектов конфигурации, используемых в системе 1С: Предприятие.

Глава 5 посвящена сравнению и объединению конфигураций.

Глава 6 подробно рассказывает о специализированном редакторе форм системы 1С: Предприятие.

Глава 7 посвящена описанию использования и настройки элемента управления «Диаграмма».

Главы 8 , 9 и 10 рассказывают об использовании текстового редактора, редактора таблиц и редактора HTML-документов.

Глава 11 посвящена возможностям администрирования в системе 1С: Предприятие. Рассказывается о порядке создания и ведения списка пользователей системы 1С: Предприятие, о присвоении пользователям наборов пользовательских прав и назначении индивидуальных пользовательских интерфейсов.

Глава 12 рассказывает о сервисных режимах Конфигуратора системы 1С: Предприятие: настройке параметров Конфигуратора, работе с Синтакс-Помощником, настройке шаблонов, использовании встроенного калькулятора и календаря, сравнении файлов, особенностях работы с окнами в системе 1С: Предприятие.

Глава 13 посвящена работе с Отладчиком, облегчающим проектирование программных модулей системы 1С: Предприятие.


Структура Руководства


Что вы должны знать

Характер изложения данного Руководства предполагает, что вы знакомы с операционной системой компьютера, на котором работает система 1С: Предприятие (Microsoft Windows 98 MS Windows NT, MS Windows 2000, MS Windows XP, далее -MS Windows), и владеете базовыми навыками работы в ней.

Вам должны быть знакомы следующие понятия и навыки:

  • использование меню «Пуск» («Start») для вызова программ;
  • приемы работы с окнами;
  • приемы работы с мышью;
  • стандартные приемы работы с текстом и электронными таблицами (ввод текста, ввод значений в ячейки таблицы, редактирование, форматирование, печать и др.);
  • работа с меню;
  • использование управляющих элементов диалогов;
  • стандартные диалоги:
  • понятие Буфера Обмена MS Windows и приемы работы с ним;
  • настройка операционной системы MS Windows с помощью Панели Управления.

Если вы недостаточно хорошо владеете перечисленными выше понятиями и навыками, рекомендуем обратиться к документации по операционной системе.


Что вы должны знать


Принятые обозначения

Для лучшего понимания излагаемого материала в настоящем Руководстве приняты некоторые общие приемы выделения отдельных элементов текста. Соглашение о таких приемах приведено ниже.

Обозначения клавиш. Клавиши, такие как Enter, Esc, Del и подобные, будут обозначаться надписями на самих клавишах, без кавычек.

Для ссылок на клавиши управления курсором (клавиши со стрелками) будет использоваться фраза «клавиши управления курсором» (без кавычек), когда необходимо сослаться сразу на все эти клавиши. Если необходимо упомянуть эти клавиши по отдельности, будут использоваться выражения «Стрелка Вверх», «Стрелка Вниз», «Стрелка Вправо» и «Стрелка Влево» (без кавычек).

Комбинации клавиш. Когда для выполнения какой-либо команды необходимо нажать комбинацию из двух клавиш, она дается в виде Ctrl+FЗ.

Обозначения кнопок. Наименования кнопок в форме будут даваться их названиями в кавычках, например, «ОК», «Отмена», «Удалить» и так далее.

Ключевые слова встроенного языка. Ключевые слова встроенного языка системы 1С: Предприятие выделяются шрифтом и пишутся так, как в программных модулях: РабочаяДата.

используется пункт «Таблица — Режимы — Масштаб», что эквивалентно тексту: «Для выбора Описание действия с помощью меню. Для описания выбора пункта меню используется следующая конструкция: «Меню — Подменю — Подменю — ... — Пункт». Например: «Для выбора масштаба изображения используется пункт «Масштаб» подменю «Режимы» меню «Таблица» главного меню программы». Если выбор осуществляется не из главного меню программы, то это указывается дополнительно.


Принятые обозначения


Глава 1.Концепция системы 1С: Предприятие

1С: Предприятие является универсальной системой автоматизации деятельности предприятия. За счет своей универсальности, система 1С: Предприятие может быть использована для автоматизации самых разных участков экономической деятельности предприятия: учета товарных и материальных средств, взаиморасчетов с контрагентами и т.д.


Глава 1.Концепция системы 1С: Предприятие


Конфигурируемость

Основной особенностью системы 1С: Предприятия является ее конфигурируемость. Собственно система 1С: Предприятие представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов предметной области. Конкретный набор объектов, структуры информационных массивов, алгоритмы обработки информации определяет конкретная конфигурация. Вместе с конфигурацией система 1С: Предприятие выступает в качестве уже готового к использованию программного продукта, ориентированного на определенные типы предприятий и классы решаемых задач.

Конфигурация создается штатными средствами системы. Конфигурация обычно поставляется фирмой «1С» в качестве типовой для конкретной области применения, но может быть изменена, дополнена пользователем системы, а также разработана заново.


Конфигурируемость


Функционирование системы

Функционирование системы делится на два процесса — конфигурирование (описание модели предметной области средствами системы) и исполнение (обработку данных предметной области).

Результатом конфигурирования является конфигурация, которая представляет собой модель предметной области.

На этапе конфигурирования система оперирует такими универсальными понятиями (объектами), как «Документ», «Журнал документов». «Справочник», «Реквизит», «Форма», «Регистр» и другие. Совокупность этих понятий и определяет концепцию системы. В свою очередь процесс конфигурирования распадается на несколько составляющих, (деление носит условный характер), определяющих последовательность написания и назначение томов описания. Это «визуальное» конфигурирование (создание структуры конфигурации, форм диалогов и выходных документов, механизм работы пользователей с данными (интерфейс) и права доступа различных групп пользователей к различной информации) и написание программ на встроенном языке 1С: Предприятия для обработки входных и выходных данных.

На уровне системы определены сами понятия объектов и стандартные операции по их обработке. Средства конфигурирования позволяют описать структуры информации, входящей в эти объекты, и алгоритмы, описывающие специфику их обработки, для отражения различных особенностей учета.

Информационная структура проектируется на уровне предусмотренных в системе типов обрабатываемых объектов предметной области (константы, справочники, документы, регистры, перечисления и др.).

В процессе исполнения система уже оперирует конкретными понятиями, описанными на этапе конфигурирования (справочниками товаров и организаций, счетами, накладными и т. д.).

При работе пользователя в режиме исполнения конфигурации обработка информации выполняется как штатными средствами системы, так и с использованием алгоритмов, созданных на этапе конфигурирования.


Функционирование системы


Краткое описание объектов системы

В этом параграфе перечислены основные тины объектов (подробнее см. параграф «Объукт конфигурвции»), поддерживаемых системой 1С: Предприятие.


Краткое описание объектов системы


Базовые объекты Константы

Для работы с постоянной и условно постоянной информацией в системе используются объекты типа «Константа». Информация, хранящаяся в константах, редко изменяется, но, как правило, часто используется в работе. Например, в константах может храниться наименование предприятия, его ИНН, фамилии директора и главного бухгалтера и другая подобная информация.

В системе может быть описано неограниченное количество констант.


Базовые объекты Константы


Справочники

Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа «Справочник».

Обычно справочниками являются списки материалов, товаров, организаций, валют, сотрудников и др.

Механизм поддержки справочников позволяет спроектировать и поддерживать самые различные справочники. На этапе конфигурирования можно описать, какими свойствами обладает каждый конкретный справочник. К настраиваемым свойствам относятся, например, длина и тип кода, количество уровней иерархии, поддержка уникальности кодов, набор реквизитов справочника.

Помимо кода и наименования, механизм работы со справочниками позволяет создавать набор реквизитов для хранения любой дополнительной информации об элементе справочника. Например, для номенклатуры это может быть закупочная и отпускная цены, производитель, для сотрудника должность, образование, адрес места жительства и т.д., а также табличные части, в которых хранится однотипная информация, число которой может быть переменным, например, описание комплектующих изделия, состав семьи сотрудника, телефоны организации и т.д.

Для каждого справочника может быть задано несколько форм просмотра и редактирования.

Для описания соподчиненных сущностей можно использовать подчиненные справочники. В этом случае в подчиненном справочнике каждый элемент «принадлежит» к определенному элементу справочника-владельца.

В конкретной конфигурации создается необходимое количество справочников, для хранения данных об объектах, используемых при автоматизации данной предметной области. Например, это могут быть справочники - «Организации», «Товары», «Сотрудники» и т.д.


Справочники


Перечисления

Перечисления используются в системе 1С: Предприятие для описания постоянных наборов значений, не изменяемых в процессе работы конфигурации.

На этапе конфигурирования можно описать практически неограниченное количество видов перечислений. В отличие от справочника, значения перечислений задаются на этапе конфигурирования, и не могут быть изменены на этапе исполнения.

Типичными примерами перечислений являются виды оплаты (наличная, безналичная, бартер), статус клиента (постоянный, разовый) и т.д.

Одной из главных особенностей перечислений, отличающей их от справочников, является то, что набор значений перечисления не изменяется при работе конечного пользователя с программой. Например, алгоритм конфигурации может быть ориентирован на то, что каждый клиент имеет один из двух статусов — либо «постоянный», либо «разовый», в этом случае указание статуса клиента выполняется путем выбора одного из значений перечисления. Пользователь не может добавить новый статус.

В отличие от перечислений, для справочников конкретные значения обычно вводятся пользователем при работе с программой, например: наименования товаров, контрагентов и прочее.


Перечисления


Документы

Документы предназначены для отражения хозяйственных событий предприятия, которые имеют отношение к автоматизируемой предметной области. Например, в конфигурации, предназначенной для учета торговых операций, могут быть такие документы, как счет, приходная накладная, расходная накладная и проч. При помощи документов отражаются и платежи с расчетного счета, и операции по кассе, и движения по складу, и прочие подобные события.

В процессе конфигурирования настраивается произвольное количество видов документов. Типичными примерами видов документов являются такие документы, как «Платежное поручение», «Счет», «Приходная накладная», «Расходная накладная», «Накладная на внутреннее перемещение», «Приходный кассовый ордер» и другие. Каждый вид документа предназначен для отражения своего типа событий. Это определяет его структуру и свойства, которые описываются в конфигурации.

Каждый вид документа может иметь неограниченное количество реквизитов и табличный частей. Несколько табличных частей требуются в тех случаях, когда одним документом необходимо зарегистрировать разные по сути, но связанные события, например: отразить поступление товара на склад и зарегистрировать понесенные дополнительные затраты — оплату транспорта, грузчиков, и др.

Для документа создаются формы ввода — экранные аналоги реальных документов. Если в других формах используются данные документов, то для включения этой информации разрабатываются формы для выбора. Для просмотра списка документов создаются формы списков.

Все документы характеризуются номером, датой и временем. При настройке для документа также задаются длина номера документа, условия поддержки уникальности номеров и другие.

Документы играют центральную роль для основных механизмов, реализуемых системой. Все документы образуют единую хронологическую последовательность. Фактически, эта последовательность отражает последовательность событий — так, как они происходили реально. Внутри даты последовательность документов определяется их временем, при этом время документа является не столько средством отражения реального (астрономического) времени ввода документа, сколько средством, позволяющим четко упорядочить документы внутри одной даты. Данные, вводимые в документ (в реквизиты и табличные части документа), обычно содержат информацию о происшедшем событии: например, в накладной — информацию о том, с какого склада, каких товаров и сколько отгружено, какие дополнительные затраты произведены при приобретении товаров.

Для документа весьма важным действием является его проведение. Если документ не является «проводимым», это значит, что событие, которое он отражает, не влияет на состояние учета, который ведется в данной конкретной конфигурации. Если документ проводится, то он изменяет состояние тех или иных учитываемых данных. При проведении документ может отразить зафиксированное им событие в механизмах, реализуемых различными регистрами.

Например, в торговом предприятии выписка клиенту счета на оплату не изменяет состояния товарных или денежных средств предприятия, так как счет в данном случае — это только выражение намерения клиента приобрести товар. В этом случае в конфигурации для учета торговых операций документ «Счет» может быть не проводимым.

Однако если выписка счета сопровождается резервированием товара для данного клиента, то в этом случае документ «Счет» следует делать проводимым, так как операция выписки счета еще и «замораживает», временно выключает из оборота определенное количество товаров. В этом случае конфигурация для учета торговых операций должна уметь отслеживать зарезервированный товар.


Документы


Журналы документов

Журналы документов предназначены для просмотра документов. Каждый вид документа может входить в несколько журналов. Журнал документов не добавляет новых данных в систему, а являются средством для отображения в едином списке документов нескольких видов.

Например, может быть создан журнал «Складские документы», в котором будут отображаться все приходные и расходные накладные и накладные на внутреннее перемещение.

Для журнала могут быть определены графы журнала, предназначенные для отображения реквизитов документов разного вида, отнесенных к данному журналу. Например, журнал торговых документов может содержать графу «Контрагент», в которой будут отражаться реквизит «Комитент» документа «Прием на комиссию», реквизит «Организация» документа «Приходная накладная» и т.д.

Журнал может иметь несколько форм визуального представления.


Журналы документов


Отчеты и обработки

Для описания отчетов и процедур обработки информации на этапе конфигурирования может быть создано неограниченное число отчетов и обработок. Отчеты и обработки могут иметь несколько форм, предназначенных, например, для ввода параметров формирования отчета или параметров обработки данных. Например, для выдачи складской справки — выбрать конкретный склад.

Алгоритм получения отчета описывается с использованием встроенного языка. Для вывода отчетов может быть использован как текстовый формат, так и специализированный табличный формат отчетов (макеты).

Система также поддерживает разработки внешних обработок, хранящихся не в самой конфигурации, а в отдельных файлах.


Отчеты и обработки


Регистры

Регистры предназначены для хранения и обработки различной информации, отражающей хозяйственную или организационную деятельность предприятия, и не имеющей объектной природы.

В регистрах обычно хранится информация об изменении состояний объектов, или другая информация, не отражающая непосредственно объекты предметной области. Например, в регистрах может храниться информация о курсах валют или информация о приходе и расходе товаров.

В системе 1С: Предприятие существует 2 вида регистров: регистры сведений и регистры накопления.

Основная задача регистра сведений — хранить существенную для прикладной задачи информацию, состав которой развернут по определенной комбинации значений и, при необходимости, развернут во времени. Регистры сведений информация, в которых развернута во времени, называются периодическими.

Для периодических регистров сведений система поддерживает такие стандартные операции, как получение наиболее позднего или наиболее раннего значения (например, получение последней введенной цены по конкретному товару и конкретному конкуренту), а также получения среза наиболее поздних или ранних значений. Например, могут быть получены все последние введенные цены по различным товарам и конкурентам.

Регистры накопления в системе 1С: Предприятие используются для учета информации о наличии и движении каких-либо величин — материальных, денежных и др. Вся информация о хозяйственных операциях, которая вводится с использованием документов, должна быть отражена в регистрах. Тогда эту информацию можно будет извлечь, проанализировать и представить пользователю в виде отчетных форм.

Регистры накоплений предназначены для хранения и получения остатков и оборотов по заранее определенным в конфигурации измерениям. Методы встроенного языка позволяет получить остатки регистра накопления на заданный момент времени. Есть возможность фильтрации по значениям измерений, а также получения остатков в разрезе других измерений.


Регистры


Специализированные объекты конфигурации (ветвь Общие)

Помимо базовых объектов, описывающих предметную область учета, конфигурация содержит ряд вспомогательных объектов не относящихся непосредственно к деятельности предприятия, однако, тесно связанных с функционированием самой системы. Это механизмы взаимодействия пользователей с системой 1С: Предприятие (интерфейсы, критерии отбора, права доступа различных групп пользователей к различной информации), вспомогательные объекты оформительского назначения, позволяющие производить конфигурирование на основе сформированных стилей, библиотеки картинок, с учетом национального языка. Глобальный и общие модули, в которых располагаются процедуры и функции, доступные из прочих модулей конфигурации, общие макеты печатных форм и много другое.


Специализированные объекты конфигурации (ветвь Общие)


Типы данных, используемые системой

Многие значения, обрабатываемые системой (константы, реквизиты справочников, реквизиты документов, измерения регистров, реквизиты форм отчетов и другие), описываются одним из доступных типов данных.

К базовым типам данных, поддерживаемых системой, относятся:

• число

• строка

• дата

• булево («истина» или «ложь»).

Однако, кроме базовых типов, созданные в конфигурации документы, справочники, перечисления также образуют типы данных. Например, после создания справочника «Склады» в конфигурации, помимо прочих, появляется тип «СправочникСсылка.Склады». Если в документе или справочнике создать реквизит такого типа («СправочникСсылка.Склады»), то это позволит хранить в документе ссылку на конкретный элемент справочника «Склады».


Типы данных, используемые системой


Технологические средства конфигурирования

Для описания специфических алгоритмов обработки информации и создания интерфейса, ориентированного на удобное представление описанных в конфигурации данных, в системе 1С: Предприятие используется несколько технологических механизмов.

Встроенный программный язык. Необходимость наличия встроенного языка определена концепцией настраиваемости системы. Синтаксис встроенного языка вполне отвечает стандартам высокоуровневых языков.

Язык является предметно-ориентированным. Он поддерживает специализированные типы данных предметной области, определяемые конфигурацией системы. Работа с этими типами данных в языке организована с использованием объектной техники. Язык ориентирован на пользователей различной квалификации. В частности, его отличает мягкая типизация данных (обеспечивающая быстрое написание программных модулей) и жесткий контроль синтаксических конструкций, уменьшающий вероятность ошибок.

Так как система сочетает в себе визуальные и языковые средства конфигурирования, использование встроенного языка в системе имеет событийно-зависимую ориентацию, то есть языковые модули используются в конкретных местах для отработки отдельных алгоритмов, настраиваемых в процессе конфигурации. Так, например, для документа можно описать алгоритм автоматического заполнения реквизитов при вводе нового документа. Данная процедура будет вызвана системой в нужный момент.

Механизм запросов . Для получения произвольных отчетов сложной структуры в системе предусмотрен предметно-ориентированный механизм запросов. Данное средство опирается на существующую условно-переменную структуру информационной базы системы, что позволяет сравнительно просто описывать достаточно сложные запросы.

Встроенный текстовый редактор используется для создания программных модулей на встроенном языке и для редактирования документов в текстовом виде.

Одной из особенностей редактора является возможность контекстного выделения цветом синтаксических конструкций встроенного языка, а также группировка различных синтаксических конструкций.

Благодаря тому, что встроенный язык системы имеет мощные средства манипулирования текстами, текстовый формат может быть успешно использован для обмена с другими системами самой различной информацией.

Встроенный редактор форм. Работа с настраиваемыми структурами данных и работа в интерфейсе операционной системы MS Windows вызывает необходимость произвольной настройки форм для ввода и редактирования информации. Для этого в системе 1С: Предприятие существует встроенный редактор форм.

Редактор позволяет оформить большинство окон, которые используются в системе для ввода и просмотра предметной информации (формы документов, справочников, настройки отчетов).

Встроенный редактор табличных документов . Для всех выходных документов (первичных документов и отчетов) в системе предусмотрен единый формат — формат табличных документов.

Редактор табличных документов — это мощное средство, сочетающее в себе оформительские возможности табличной структуры и векторной графики. Он может быть использован как для создания небольших документов с очень сложной структурой линий (типа платежного поручения), так и для объемных ведомостей, журналов и других подобных документов.

Редактор табличных документов предоставляет пользователям богатый набор оформительских возможностей (шрифты цвета, линии, узоры). Имеется возможность вывода информации в графическом виде (диаграммы).

Одной из главных особенностей редактора табличных документов является ориентация на формирование отчетов при помощи встроенного языка системы 1С :Предприятие. Гибкое построение отчетов с его помощью становится возможным благодаря наличию механизма манипулирования именованными областями документа. Редактор табличных документов позволяет манипулировать не только горизонтальными, но и вертикальными областями, что делает возможным создание отчетов, масштабируемых не только в высоту, но и в ширину.

С другой стороны, табличный документ может выступать в качестве элемента управления формы и, таким образом, использоваться для ввода данных.

Конструкторы. Конструкторы — вспомогательные инструменты, облегчающие разработку стандартных элементов системы 1С: Предприятие. В системе имеются, например, конструкторы форм констант, справочников, документов, журналов документов, отчетов и других объектов, конструкторы печатных форм, конструкторы движений регистров и другие.

Система настройки пользовательских интерфейсов. Для того, чтобы интерфейс конкретной конфигурации системы полностью отражал настроенные структуры данных и алгоритмы, в системе 1С: Предприятие, помимо редактора диалоговых форм и табличных документов, предусмотрена возможность настройки общих интерфейсных компонент системы: меню, панелей инструментов, комбинаций клавиш.

На этапе конфигурирования может быть создано несколько пользовательских интерфейсов для разных категорий пользователей (руководителей, менеджеров, кладовщиков и других).

Подсистемы. Конфигуратор позволяет на этапе проектирования в рамках одной конфигурации выделить различные подсистемы, например, торговый учет и исследовательский комплекс. Для каждого объекта конфигурации можно указать, к какой подсистеме относится данный объект. Допускается указание принадлежности к нескольким подсистемам. Это позволяет легко и быстро настраивать конфигурацию по различным видам деятельности и производить выбор объектов, относящихся к определенной подсистеме.

Система настройки прав доступа (роли). Данная система позволяет описывать наборы прав, соответствующие должностям пользователей или виду деятельности. Структура прав определяется конкретной конфигурацией системы. Например, могут быть введены такие наборы прав, как «Главный бухгалтер», «Кладовщик», «Менеджер», «Начальник отдела».

Сам список пользователей создается уже для конкретной организации. Каждому пользователю назначается одна или несколько ролей, основной интерфейс и язык, используемые при работе с программой.

Отладчик. Для удобства разработки конфигурации в системе предусмотрен отладчик. Отладчик позволяет прослеживать исполнение программных модулей конфигурации, замерять сравнительное время исполнения, просматривать содержимое переменных.

Администрирование работы пользователей . Для отслеживания текущего состояния работы системы используется режим ведения списка пользователей и просмотра списка активных пользователей. Он позволяет просмотреть, кто из пользователей в настоящий момент работает с конкретной информационной базой, и в каком режиме.


Технологические средства конфигурирования

Технологические средства конфигурирования и администрирования системы 1С: Предприятие


Глава 2.Основные понятия системы 1С: Предприятие

В этой главе рассматриваются основные понятия, которыми оперирует система 1С: Предприятие. Данная глава будет полезна тем, кто еще не знаком с системой 1С: Предприятие.

Описание тех или иных механизмов будет сопровождаться примерами. Возможно, что в описании будут встречаться еще незнакомые вам понятия и термины. Продолжайте чтение: смысл используемых терминов будет ясен в процессе изложения, а для более подробной информации всегда можно обратиться к соответствующим главам настоящего Руководства.


Глава 2.Основные понятия системы 1С: Предприятие


Понятие конфигурация

Основу концепции системы 1С: Предприятие составляет понятие конфигурация.

Конфигурацией в системе 1С: Предприятие называется совокупность взаимосвязанных составных частей:

• структуры учетных данных, форм их ввода, выбора, печати;

• состав механизмов учета итоговых данных и движений учетных данных;

• состав различных отчетов и обработок;

• набора пользовательских интерфейсов;

• набора ролей (прав доступа);

• набора общих процедур и функций (Глобальный модуль и общие модули),

макетов табличных документов, и др.;

• вспомогательных объектов: наборы пользовательских интерфейсов, наборы

прав, а также различная вспомогательная информация (картинки, шаблоны,

стили и т.д.).

Фактически, структура конфигурации является моделью предметной области. Создание конфигурации выполняется при помощи Конфигуратора. Созданная конфигурация используется системой 1С:Предприятие для реализации программного окружения, пригодного для выполнения необходимых учетных задач.

Пользовательским интерфейсом в системе 1С: Предприятие называется совокупность команд главного меню и панелей инструментов, настроенных на работу с конкретными объектами данных документами, справочниками, журналами и т.д. Как правило, пользовательский интерфейс создается для конкретной категории пользователей. Цель создания интерфейса - обеспечить быстрый доступ пользователей к той информации, которая необходима им в соответствии с их обязанностями.

Роли в системе 1С: Предприятие определяют полномочия пользователей на работу с информацией, которая обрабатывается в системе. Совокупность предоставляемых пользователю полномочий определяется, как правило, кругом его обязанностей.

Операция назначения ролей пользователю решает две основные задачи.

С одной стороны, ограничивается круг пользователей конфиденциальной информации, которая, безусловно, всегда присутствует в любой системе учета.

С другой стороны, запрет выполнения определенных операций (в первую очередь, операций удаления и корректировки данных) позволяет в какой-то степени предотвратить возможные потери информации.

Все составные части конфигурации тесно связаны между собой и требуют, как правило, согласованного внесения изменений (особенно это касается пользовательских прав).

Так, назначение ролей может выполняться только для существующих объектов конфигурации (конкретных документов, журналов, справочников, отчетов). Добавление в структуру конфигурации нового объекта должно сопровождаться внесением соответствующих изменений в роли.

Команды, которые можно связать с элементами пользовательского интерфейса, управляют конкретными объектами конфигурации. Очевидно, что нет смысла включать в пользовательский интерфейс команды по работе с информацией, доступ к которой пользователю запрещен.


Понятие конфигурация


Объект конфигурации

Под объектом конфигурации в системе 1С:Предприятие понимается формальное описание группы понятий (предметной области, средств взаимодействия пользователя с системой) со сходными характеристиками и одинаковым предназначением.

Приведем такой пример. Объект конфигурации «Справочник» в системе 1С: Предприятие предназначен для ведения списков однородных элементов данных — справочников, картотек, нормативных сборников и тому подобное. Использование объектов конфигурации этого типа позволяет организовать ведение любых справочников, необходимых для автоматизации деятельности предприятия.

Как правило, объекты конфигурации типа «Справочник» являются компьютерными аналогами реально существующих на предприятии справочников, например, справочника сотрудников или номенклатуры товаров, хотя могут использоваться и для организации списков, не имеющих явных физических аналогов.

Реализованный в системе 1С: Предприятие, при помощи объекта конфигурации, компьютерный аналог конкретного понятия предметной области будем называть объектом конфигурации.


Объект конфигурации


Свойства объекта конфигурации

Каждый объект конфигурации обладает уникальным набором свойств. Этот набор описан на уровне системы и не может быть изменен в процессе настройки конфигурации задачи. Набор свойств объекта конфигурации определяется, в основном, его назначением в системе 1С: Предприятие.

Главным свойством любого объекта конфигурации является имя — краткое наименование объекта конфигурации. При создании нового объекта конфигурации ему автоматически присваивается условное имя. состоящее из слова, определяемого по виду объекта, и цифры (например, при создании реквизита создается реквизит с именем «Реквизит1», при создании документа — «Документ1», и т.д.). Это имя можно изменить в процессе редактирования свойств объекта конфигурации, при этом система отслеживает уникальность имен. Имя объекта конфигурации не может пустым.

Некоторые свойства из всего набора свойств, присущих объекту конфигурации, доступны для редактирования и могут быть так или иначе изменены в процессе конфигурирования системы 1С: Предприятие. Характер изменений и их пределы также задаются на уровне системы. Целенаправленным изменением свойств объекта конфигурации специалист, осуществляющий конфигурирование системы, может добиться требуемого поведения объекта при работе системы. Однако такие изменения не затрагивают сущности объекта и не позволяют добиться от него действий, не свойственных объектам данного типа.

Приведем такой пример. Объект конфигурации «Константа» в системе 1С: Предприятие предназначен для хранения информации, которая не изменяется во времени или изменяется очень редко. Простым примером константы может служить название предприятия: оно, как правило, не меняется в процессе деятельности предприятия.
Константа обладает следующим набором редактируемых свойств:
• имя константы;
• синоним;
• комментарий;
• подсистемы;
• тип данных.
В наиболее общем случае, значение в константу вводится один раз (как, например, название предприятия). С точки зрения использования константы, неважно, что именно храниться в константе, главным является то, что константа сохранила записанное в нее значение.
Способность сохранять введенные в нее значение — неотъемлемая особенность константы в системе 1С: Предприятие. Редактирование свойств константы на эту способность не влияет.


Свойства объекта конфигурации


Основные виды объектов конфигурации

Все объекты конфигурации, которые существуют в системе 1С:Предприятие, образуют несколько основных видов. Каждый вид объектов конфигурации представляет собой как раз те «строительные элементы», из которых будет создаваться конфигурация.

Формально объекты конфигурации объединяются в виды в дереве конфигурации. Названия видов пользователь видит на первом уровне дерева конфигурации, когда открывает окно «Конфигурация» в Конфигураторе (см. рисунок).

Несмотря на отсутствие формального определения, названия видов объектов конфигурации широко используются при работе с системой 1С: Предприятие.

Например, специалист, осуществляющий конфигурирование системы 1С:Предприятие, видит свою цель в разработке необходимого набора справочников, документов, отчетов, журналов, которые будут реализовывать требуемую систему учета. Конечный пользователь системы 1С:Предприятие — руководитель, бухгалтер, менеджер, кладовщик — также оперирует конкретными справочниками, документами и т. д. для решения стоящих перед ним задач. Общение между двумя этими категориями пользователей также будет происходить в понятиях видов объектов конфигурации.

Ниже приведена краткая характеристика основных видов объектов конфигурации системы 1С: Предприятие (см. таблицу). Подробная информация об объектах конфигурации, объединяемых в каждом из этих видов, будет изложена далее в настоящем Руководстве.

Наименование | Краткая характеристика
Общие | Группа вспомогательных объектов конфигурации, с помощью которых осуществляется создание конфигурации, механизмов взаимодействия пользователя с учетными данными и др.
Константы | Постоянные (условно-постоянные) величины. Константы хранят информацию, которая не изменяется или изменяется достаточно редко: название организации, ее почтовый адрес и так далее.
Справочники | Списки однородных элементов данных. Используются для хранения нормативно- справочной информации.
Документы | Служат для ввода информации о совершенных хозяйственных операциях.
Журналы документов | Служат для отображения списков документов разного вида.
Перечисления | Списки значений, задаваемые на этапе конфигурирования.
Отчеты | Средство получения выходной информации. Источником данных для построения отчетов служат документы, справочники и регистры, также используется информация, хранящаяся в константах.
Обработки | Объекты конфигурации этого вида используются для выполнения различных действий над информационной базой.

Объект данных какого-либо вида является уже конкретным документом, отчетом, журналом, константой и так далее. Как правило, каждый элемент используется для работы со вполне определенной информацией предметной области.


Основные виды объектов конфигурации


Подчиненные группы объектов

В зависимости от вида объекта конфигурации объект может иметь различные подчиненные группы объекты. Виды таких подчиненных объектов представлены в таблице:

Подчиненная группа объектов | Виды объектов, которым принадлежит
Реквизиты | Справочники, Документы, Регистры, Отчеты, Обработки, Табличные части
Табличные части | Справочники, Документы, Отчеты, Обработки
Формы | Справочники, Документы, Журналы, Отчеты, Обработки
Макеты | Справочники, Документы, Журналы, Отчеты, Обработки
Графы Измерения | Журналы Последовательности, Регистры
Ресурсы | Регистры

Реквизиты — дополнительная информация об объекте, доступная только в пределах этого объекта.

Табличные части — наборы дополнительной информации об объекте, представленной в виде таблицы.

Формы — форма используется для ввода, просмотра и редактирования информации, хранящейся в объекте конфигурации, содержит модуль формы — программу на встроенном языке системы 1С: Предприятие. Способность иметь визуальное представление позволяет объекту конфигурации организовать интерактивное взаимодействие с пользователем. Характер такого взаимодействия разрабатывается специалистом, осуществляющим конфигурирование системы 1С: Предприятие, и определяется, в основном, типом объекта конфигурации. Для разработки форм в Конфигураторе применяется комплексный редактор форм, позволяющий редактировать все компоненты формы во взаимосвязи. Каждый объект может иметь несколько форм.

• Макеты — табличные документы, предназначенные для формирования печатных форм объекта.

• Графы — графы журнала документов.

• Изменения — объекты конфигурации, данные о которых учитываются в регистре.

• Ресурсы — данные, учитываемые в регистре.

Группы подчиненных объектов не удаляются и не имеют редактируемых свойств.


Подчиненные группы объектов


Типизированные и типообразующие объекты

Одним из основных свойств некоторых объектов конфигурации является тип данных. Это свойство определяет, какого рода информацию может содержать объект конфигурации. Тип данных объекта конфигурации назначается при создании или редактировании свойств объекта в процессе настройки конфигурации.

Объекты конфигурации, для которых может быть указан тип информации, содержащейся в объекте, в системе 1С: Предприятие называются типизированными объектами конфигурации.

Такие объекты конфигурации как «Справочник», «Документ», «Обработка», не являются типизированными объектами, так как содержат «комплексную» информацию, и, в свою очередь, содержат типизированные объекты конфигурации.

Типы данных, которые может принимать объект конфигурации, можно разделить на две группы.

Первую группу составляют базовые типы данных: «число», «строка», «дата» и «булево». Соответственно, информация, хранящаяся в объекте конфигурации, может быть числом, произвольной строкой символов, датой или логической величиной.

Кроме этого, некоторые объекты конфигурации системы 1С: Предприятие также могут образовывать типы данных. Например, константе может быть назначен тип данных «Документ Ссылка». В этом случае значение константы будет представлять собой ссылку на один из существующих в системе 1С:Преднриятие документов.

Объекты конфигурации, которые могут образовывать типы значений конфигурации, в системе 1С Предприятие называются типообразующими объектами конфигурации. Такими объектами в системе 1С: Предприятие являются:

• справочники;
• документы;
• перечисления.

Необходимо обратить внимание, что типообразующие объекты конфигурации образуют тип данных сразу после создания в Конфигураторе объекта любого из таких типов. Например, когда в Конфигураторе создается новый справочник, то в списке типов данных появляется очередной тип данных, представляющий собой ссылку на элемент этого справочника. Такой тип данных может быть присвоен любому из типизированных объектов конфигурации.


Типизированные и типообразующие объекты


Форма объекта

Совокупность экранного диалога, модуля и реквизитов формы называется формой.

Большинство объектов конфигурации в системе 1С: Предприятие могут иметь визуальную форму. В самом общем случае форма, как объект конфигурации, состоит из следующих частей:

• экранный диалог, используемый для ввода и редактирования информации,

хранящейся в объекте конфигурации;

• модуль формы — программа на встроенном языке системы 1С:

Предприятие. Как правило, модуль формы выполняет обработку вводимой в

диалог информации для целей входного контроля, выполнения расчетов и т.п.;

• список реквизитов объекта конфигурации.

Способность иметь визуальное представление позволяет объекту конфигурации организовать интерактивное взаимодействие с пользователем. Характер такого взаимодействия разрабатывается специалистом, осуществляющим конфигурирование системы 1С: Предприятие, и определяется, в основном, типом объекта конфигурации.

Для разработки форм в Конфигураторе применяется комплексный редактор форм, позволяющий редактировать все компоненты формы во взаимосвязи.


Форма объекта


Модуль

Модулем называется программа на встроенном языке системы 1С: Предприятие. Модули располагаются в заданных точках структуры конфигурации и вызываются для выполнения в заранее известные моменты работы системы 1С: Предприятие. Специалист, выполняющий конфигурирование системы, может использовать модули для описания сложных алгоритмов взаимодействия объектов конфигурации, для которых недостаточно имеющихся в Конфигураторе визуальных средств.

Приведем такой пример.
В системе 1С: Предприятие может быть организован удобный для пользователей режим ввода новых документов — «ввод на основании». Суть этого режима проста: за основу берется документ-образец (например, счет на оплату), из которого в новый создаваемый документ (например, расходную накладную) переносится информация о получателе, товарах, ценах, количестве.
Перенос информации из документа-образца выполняется при помощи процедуры обработки события ввода документа на основании ОбработкаЗаполнения(Основание), где Основание — ссылка на объект-образец, на основании которого производится заполнение реквизитов нового документа. Процедура должна располагаться в модуле создаваемого документа.

Предварительная настройка режима «ввода на основании» для конкретного документа выполняется в Конфигураторе диалоговыми средствами. Однако алгоритм переноса информации из документа-образца в новый документ должен создать специалист, выполняющий конфигурирование системы. Этот алгоритм хранится в модуле, «привязанном» к форме документа, и выполняется всякий раз при показе документа.

В конфигурации существует несколько видов модулей. Это Глобальный модуль. Общие модули, модули форм и модули объектов конфигурации (Справочники, Документы, Отчеты и Обработки).


Модуль


Макет

Макетом и системе программ 1С: Предприятие называется объект конфигурации, предназначенный для формирования печатных форм.

Общие таблицы печатных форм располагаются на ветви «ОбщиеМакеты» дерева конфигурации, печатные формы объектов конфигурации (справочников, документов, журналов документов, регистров, отчетов и обработок) располагаются в подчиненных объектах «Макеты».


Макет


Глава 3. Работа с конфигурацией

В этой главе будут рассмотрены общие приемы работы с объектами конфигурации, которые применимы к объектам любых типов. Особенности создания и редактирования объектов конфигурации различных типов рассматриваются далее в соответствующих главах Руководства.

В данной главе в основном рассматриваются визуальные средства управления объектами конфигурации, имеющиеся в Конфигураторе. Для изучения возможностей встроенного языка следует обратиться к книге «1С: Предприятие. Описание встроенного языка».


Глава 3. Работа с конфигурацией


Открытие конфигурации

Работа с конфигурацией осуществляется в окне «Конфигурация». Для открытия конфигурации выберите пункт «Конфигурация — Открыть конфигурацию». На экран выводится окно «Конфигурация».

Чтобы увеличить рабочую область для работы с различными объектами, окно «Конфигурация» можно временно закрыть. Закрытие окна «Конфигурация» не означает завершение работы с отдельными ее составляющими, открытыми для редактирования: закрывается не конфигурация, а окно конфигурации. Для открытия окна «Конфигурация» выберите пункт «Конфигурация — Окно конфигурации».


Открытие конфигурации


Сохранение конфигурации

Для сохранения конфигурации в процессе редактирования (без завершения работы с конфигурацией) выберите пункт «Конфигурация — Сохранить конфигурацию». Если конфигурация была модифицирована (были произведены изменения), то Конфигуратор выводит сообщение «Конфигурация была изменена. Сохранить изменения?». Для сохранения внесенных изменений выберите кнопку «Да».

При сохранении программа анализирует изменения в структуре конфигурации. Если были добавлены, удалены или модифицированы объекты, то на экран выводится диалог со списком изменений для подтверждения сохранения. Для подтверждения сохранения нажмите кнопку «Принять», для отказа от сохранения — кнопку «Отказ». В случае отказа от сохранения конфигурация не закрывается и можно продолжить работу.


Сохранение конфигурации


Закрытие конфигурации

Для закрытия конфигурации выберите пункт «Конфигурация — Закрыть конфигурацию». При этом, если конфигурация была модифицирована (были произведены изменения), то Конфигуратор выводит сообщение «Конфигурация была изменена. Сохранить изменения?». Для сохранения внесенных изменений выберите кнопку «Да».


Закрытие конфигурации


Сохранение конфигурации в файл

Текущую (открытую) конфигурацию можно сохранить в файл на диске. Файл конфигурации используется для переноса конфигурации на другое рабочее место, для создания временного архива и т.д.

Для сохранения конфигурации в файл на диск выберите пункт «Конфигурация — Сохранить конфигурацию в файл». На экран выводится стандартный диалог выбора файла. Выберите каталог и укажите имя файла, в который будет записана конфигурация.

Сохраненный файл конфигурации необходим для операции сравнения и объединения конфигураций (см. главу « Сравнение и объединение конфигураций »).


Сохранение конфигурации в файл


Дерево объектов конфигурации

Конфигурация представляется в виде древовидной структуры, каждая ветвь которой описывает определенную составляющую конфигурации. Объекты конфигурации в дереве конфигурации представлены своими именами. Например, на ветви «Документы» располагаются объекты всех документов, используемых в конфигурации, а на ветви «Расходная Накладная» описывается объект документа «Расходная накладная», на ветви «Общие — Роли» — всех ролей (прав доступа к информации), используемых для различных видов пользователей, а на ветви «Менеджер» — права доступа менеджера отдела продаж, и т.д.

Корневые ветви дерева объединяют объекты конфигурации, логически связанные между собой и имеющие общее назначение.

Например, ветвь «Документы» объединяет объекты типа «Последовательности», «Нумераторы» и собственно объекты конфигурации типа «Документ». Все эти объекты предназначены для организации ввода документов в системе 1С: Предприятие.

Приемы работы с деревом конфигурации не отличаются от приемов работы с другими «древовидными» списками в операционной системе MS Windows (например, со структурой папок, изображаемой на левой панели программы «Проводник»).

Существует одна удобная возможность при работе с деревом конфигурации: если выделить наименование конфигурации, расположенное в корневом узле дерева конфигурации, и нажать клавишу «*» на правой цифровой клавиатуре, дерево раскроется полностью. Однако повторным нажатием клавиши «*» также полностью свернуть дерево нельзя — это придется делать отдельно для каждой ветви.

Полностью раскрытое дерево позволяет просмотреть все объекты, существующие в конфигурации.

Объекты конфигурации в пределах «своей» группы объектов конфигурации можно расставить в требуемом порядке. В таком же порядке объекты конфигурации будут выдаваться в различных списках.

Для перестановки объекта конфигурации необходимо выделить его в окне «Конфигурация» и использовать кнопки («Переместить вверх»), («Переместить вниз»), («Упорядочить список») в панели инструментов окна «Конфигурация».


Дерево объектов конфигурации


Настройка сортировки

Данный режим предназначен для сортировки объектов конфигурации. За один раз могут быть отсортированы однотипные объекты конфигурации подчиненные одному объекту конфигурации. Например, формы конкретного справочника.

Сортировать по: Выбор свойства, по которому будет выполняться сортировка.

• Имени. Сортировка будет выполнена по именам объектов конфигурации;

• Синониму. Сортировка будет выполнена по синонимам объектов

конфигурации;

• Комментарию. Сортировка будет выполнена по комментариям объектов

конфигурации;

Направление сортировки: Выбор направления сортировки

• По возрастанию. Будет выполняться сортировка в порядке возрастания;

• По убыванию. Будет выполняться сортировка по убыванию.


Настройка сортировки


Создание и удаление объекта конфигурации. Создание объекта конфигурации

Управление большинством объектов конфигурации выполняется в окне «Конфигурация». В этом параграфе будут изложены общие приемы создания объектов конфигурации, применимые к объектам конфигурации любых типов. Для создания нового объекта конфигурации необходимо выполнить следующие действия:

• в дереве конфигурации выделите наименование типа объекта конфигурации или любого из

существующих объектов конфигурации того типа, который должен быть у создаваемого объекта;

• выберите пункт «Действия — Добавить» окна «Конфигурация».

Создание нового подчиненного объекта можно также производить следующим образом:

• откройте диалог редактирования объекта (выберите пункт «Действия — Изменить» окна

«Конфигурация»);

• на закладке «Основное» укажите нужный вид подчиненного объекта;

• нажмите кнопку «Добавить».

В результате этих действий на текущей ветви дерева конфигурации появится новый объект, а на экран для редактирования свойств этого объекта будет автоматически вызвана палитра свойств (если палитра еще не была открыта) или диалог редактирования объекта конфигурации. Для объектов, имеющих широкий набор редактируемых свойств, дополнительно к палитре свойств может вызываться диалог редактирования (о работе в диалоге см.« Диалог редактирования объекта »).

Для некоторых типов объектов в системе имеются конструкторы форм — вспомогательные инструменты, облегчающий разработку форм объектов конфигурации системы 1С: Предприятие. Они запускаются при создании новых объектов.

Новому объекту конфигурации присваивается условное имя, состоящее из слова, соответствующего типу создаваемого объекта, и числа — порядкового номера нового объекта конфигурации. Например, для нового справочника имя будет начинаться со слова «Справочник». Палитра свойств объекта будет содержать значения свойств, задаваемые по умолчанию.


Создание и удаление объекта конфигурации. Создание объекта конфигурации


Удаление объекта конфигурации

Для удаления объекта конфигурации укажите его в дереве конфигурации и выберите пункт «Действия - Удалить» окна «Конфигурация». Если на объект нет ссылок в других объектах конфигурации, объект удаляется, если ссылки есть,(объект используется), то выдается сообщение «Объект не может быть удален, так как на него есть ссылки в других объектах!». А в окно сообщений выводится список использования данного объекта.

Для перехода к объекту, в котором используется ссылка на удаляемый объект - дважды щелкните мышью наименование этого объекта в окне сообщений.


Удаление объекта конфигурации


Описание структуры конфигурации

Конфигуратор позволяет вывести в текстовом или табличном виде информацию обо всех объектах конфигурации. Для этого следует выбрать пункт «Конфигурация — Описание структуры метаданных».

На экран выводится диалог, в котором следует выбрать тип (текстовый или табличный) и имя фала, в который предполагается сохранить описание структуры конфигурации. Создание описания объектов конфигурации для сложных конфигураций может занимать продолжительное время.

После окончания создания описания конфигурации будет открыто окно с описанием в выбранном формате (текстовом или табличном).


Описание структуры конфигурации


Палитра свойств

Процесс редактирования объекта конфигурации заключается в изменении свойств объекта с целью добиться требуемого поведения объекта в процессе использования.

Палитра свойств — это диалог в виде набора свойств, которые можно определить для объекта конфигурации. Состав свойств зависит от типа редактируемого объекта.

В этом разделе описываются основные приемы работы с палитрой свойств.

Для вызова палитры свойств укажите объект конфигурации и выберите пункт «Правка — Свойства».

Свойства объекта в палитре свойств группируются по категориям. Число категорий и состав свойств, размещенных в каждой категории, зависит от вида рассматриваемого объекта. Например, для реквизита документа палитра свойств содержит только категории свойств Основные и Тип данных.

Состав свойств также зависит от выбранных значений других свойств. Например, в свойстве «Тип» при выборе базового типа «Число» добавляются свойства, характеризующие выбранный тип: Длина, Точность и Неотрицательное.

Панель инструментов палитры свойств состоит из пяти кнопок. С помощью первых трех кнопок (слева) производится управление показом свойств.

Кнопка Действие

 Производит вывод свойств объекта, отсортированных по алфавиту. Сами категории не показываются.
Производит вывод свойств объекта, отсортированных по категориям.

При нажатой кнопке, выводятся только важные свойства объекта; при отжатой — все свойства

Записать изменения в текстовое поле свойства
Отмена изменений в текстовом поле свойства

Категории свойств можно располагать в виде закладок или списком. При расположении свойств списком сами свойства могут располагаться списком по категориям или по алфавиту (при этом наименования категорий не показываются).

Для выбора способа показа категорий (должен быть включен показ категорий ) в любом свободном месте диалога палитры свойств откройте контекстное меню и выберите нужный способ показа («Закладками» или «Списком»). Если

выбран способ показа «Закладками», то кнопки ( [image] и [image]) становятся недоступными.

Если выбран способ показа «Закладками», то для перехода к свойствам другой категории необходимо щелкнуть мышью соответствующую закладку.

Для возврата к режиму показа категорий списком в окне свойств в контекстном меню выберите пункт «Списком».

Если выбран способ показа «Списком», то свойства объекта располагаются по категориям или по алфавиту. Для расположения по алфавиту нажмите кнопку [image] панели инструментов палитры свойств. Все свойства показываются подряд в алфавитном порядке.

Для расположения по категориям нажмите кнопку [image] панели инструментов. Все свойства группируются по категориям. Категории показываются в виде списка (одна под другой). Наименование категории показывается полужирным шрифтом. Слева от наименования расположена кнопка управления показом свойств, входящих в категорию. Кнопка позволяет скрыть или показать набор свойств. Кнопка [image] — означает, что свойства объекта данной категории показываются. При нажатии на кнопку, свойства объекта данной категории становятся не видны, а сама кнопка принимает вид .

Двойной щелчок мыши по наименованию категории свойств производит сворачивание всех остальных категорий и показу свойств данной категории.

При нажатой кнопке [image] производится показ только важных (основных) свойств объекта не зависимо от режима показа списком или закладками, по категориям или по алфавиту. Для просмотра всех свойств снова нажмите па кнопку [image] .

В зависимости от вида объекта его свойства бывают доступными или недоступными для изменения. Например, в текстовом документе свойства объекта предназначены только для показа числа строк и символов, а также статуса документа, но они не доступны для изменения.

Каждое свойство в палитре свойств имеет наименование, л также развернутое пояснение. Режим получения развернутого описания устанавливается с помощью контекстного меню, вызываемого в любом свободном месте палитры свойств (вне полей ввода). Если этот режим установлен, то при выборе свойства в нижней части палитры свойств выводится развернутое пояснение. Помимо пояснительного описания, может выводиться имя указанного свойства. По этому имени производится доступ к значению указанного свойства из программного модуля.

Способ ввода значений в палитре свойств зависит от типа редактируемого свойства. Для текстовых реквизитов — это обычный ввод текста (можно использовать буфер обмена), для свойств типа «флажок» — путем щелчка мышью. Значения некоторых свойств выбираются из списков. Поля таких свойств имеют кнопку [image] . Если поле свойства имеет кнопку выбора [image], то при ее нажатии открывается диалог, в котором производится выбор значения свойства. К таким свойствам относится, например, выбор файла картинки, определение цвета и другие. По кнопке редактирования [image] для текстовых данных вызывается диалог редактирования строки на разных языках, для событий — процедура модуля формы, отрабатывающая данное событие, для свойств из категории Представление — существующую форму объекта данных. По кнопке очистки [image] производится сброс значения указанного свойства.

При начале редактирования любого текстового поля палитры свойств, становятся доступными кнопки панели инструментов палитры свойств [image] («Отменить редактирование») и [image] («Сохранить»). Нажатие кнопки [image] отменяет произведенные изменения. Нажатие кнопки [image] записывает изменение.

В палитре свойств могут располагаться специальные ссылки, с помощью которых открываются связанные с выбранным объектом различные формы. Например, вызов справочной информации (описание) объекта конфигурации, различных форм, процедур модуля формы. Такие ссылки изображаются подчеркнутым текстом, например: Открыть. При подведении указателя мыши к ссылке, он принимает форму ладони. Нажатие ссылки открывает окно, связанное с этой ссылкой.


Палитра свойств


Диалог редактирования объекта

Для основных объектов конфигурации (Справочники, Документы, Журналы и др.) редактирование свойств объектов, управление составом подчиненных объектов, настройку взаимодействия объектов удобно производить с помощью диалога редактирования объекта.

В большинстве случаев диалог редактирования объекта вызывается при выборе пункта «Действия — Изменить» окна «Конфигурация». Редактируемые свойства располагаются на нескольких закладках.

На закладке «Основное» вводятся основные свойства объекта:

Имя, Синоним. Комментарий и Подсистемы. Внизу страницы расположен древовидный список подчиненных объектов. Состав подчиненных объектов может отличаться для объектов разных типов. Например, для объектов «Справочник» и «Документ» это «Реквизиты», «Табличные части», «Формы» и «Макеты».

Методы управления списком для всех объектов одинаковы.

В диалоге редактирования объекта расположены элементы управления, с помощью которых производится создание, удаление, открытие и сортировка реквизитов, форм, макетов, табличных частей и реквизитов табличных частей. Для добавления подчиненного объекта установите указатель на соответствующую ветвь подчиненной группы объекта и нажмите кнопку «Добавить». Кнопка «Открыть» открывает палитру свойств указанного элемента. Для удаления используйте кнопку «Удалить». Если требуется отсортировать реквизиты объекта конфигурации или реквизиты табличной части, установите указатель в нужный список объекта и нажмите кнопку «Сортировать». В открывшемся диалоге укажите критерии сортировки.

При создании новой формы запускается конструктор форм, с помощью которого производится выбор вида формы, подбор состава размещаемых в форме реквизитов и построение собственно формы. Подробнее о конструкторах форм см. раздел « Конструкторы форм » главы «Редактор форм» Порядок редактирования формы описан в главе « Редактор форм ».

При создании нового макета создается табличный документ. Порядок редактирования макета описан в главе « Табличный редактор ».


Диалог редактирования объекта


Основные свойства объектов конфигурации

Практически все объекты конфигурации имеют следующие свойства, располагающиеся в категории свойств Основные.

Имя — имя объекта конфигурации. Имя должно состоять из одного слова, начинаться с буквы и не содержать специальных символов, кроме «_». По имени производится доступ и управление объектом конфигурации средствами встроенного языка.

Синоним — помимо имени, можно указать также синоним имени. Если конфигурация создается для использования на разных языках, то следует указать синонимы на используемых языках. При работе с системой 1С: Предприятие он будет выдаваться в различных списках выбора, заголовках окон, текстах надписей, при формировании интерфейсов и т.д. с учетом текущего языка. Синоним не имеет ограничений на использование символов. Если синоним не задан, выбирается имя.

Имя или синоним, выдаваемые пользователю, также называются представлением объекта конфигурации.

Комментарий — произвольная строка символов. Как правило, расшифровывает и поясняет имя объекта. При показе в различных списках (например, в списке справочников для выбора нужного справочника), комментарий выдается в круглых скобках вслед за представлением объекта конфигурации.

Подсистемы. Многие объекты конфигурации в составе основных свойств имеют свойство Подсистемы — в свойстве указываются подсистемы, для которых предназначается данный объект. Допускается указывать несколько подсистем (подробнее о подсистемах см. параграф « Подсистемы » ).


Основные свойства объектов конфигурации


Свойства конфигурации

Конфигурация в целом имеет свои свойства, которые можно редактировать. открывается для имени конфигурации (установите указатель в корень дерева конфигурации). Помимо основных свойств (см. раздел « Основные свойства объектов конфигурации » ), присущих каждому объекту конфигурации, конфигурация имеет следующие свойства:

Категория свойств - Основные

Категория свойств - Представление

Категория свойств - Справочная информация


Свойства конфигурации


Категория свойств - Основные

Вариант встроенного языка — выбирается основной язык программирования («Русский» или «Английский»). Выбор определяет, на каком языке будет формироваться языковые конструкции в модулях и выдаваться информация о базовых типах данных.

Округление — устанавливает правила округления результатов числовых выражений. Если выбрано «Округлять 1,5 до I», то при округлении, например, денежных сумм до целых рублей, суммы до 50 копеек включительно будут отбрасываться, а свыше 50 копеек — округляться до целого рубля. При такой установке сумма 1 рубль 50 копеек будет округлена до 1 рубля, а сумма 1 рубль 51 копейка — до 2 рублей. Если выбрана установка «Округлять 1,5 до 2>>, то суммы до 50 копеек будут отбрасываться, а свыше 50 копеек включительно — округляться до целого рубля. Соответственно, сумма 1 рубль 49 копеек будет округлена до 1 рубля, а сумма 1 рубль 50 копеек — до 2 рублей. Правило округления, установленное в свойствах конфигурации, при вычислении конкретного выражения можно изменить, используя функцию Окр () встроенного языка системы 1С: Предприятие.

Основная роль — выбор основной роли конфигурации (будет использоваться, если список пользователей конфигурации пуст и не проводится авторизация доступа при начале работы программы). Роли задаются на ветви дерева конфигурации «Общие — Роли».

Глобальный модуль — по ссылке Открыть открывается окно редактирования Глобального модуля конфигурации.


Категория свойств - Основные


Категория свойств - Представление

Основной стиль — выбор стиля конфигурации по умолчанию. Стили задаются на ветви дерева конфигурации «Общие — Стили».

Основной язык — выбор языка конфигурации по умолчанию. Указанный язык будет использоваться для выдачи фиксированных терминов, когда такие термины выдаются системой 1С: Предприятие.

Основной интерфейс — выбор основного интерфейса конфигурации (будет использоваться, если не вводятся пользователи). Интерфейсы задаются на ветви дерева конфигурации «Общие - Интерфейсы».

Краткая информация — краткая информация о конфигурации.

Подробная информация — подробная информация о конфигурации.

Логотип — выбор логотипа. Выбор осуществляется в стандартном окне выбора картинки:

Заставка — выбор заставки. Выбор осуществляется в стандартном окне выбора картинки.

Основная форма констант — выбор основной формы для ввода и редактирования констант конфигурации. Формы для ввода констант формируются на ветви конфигурации «Константы — Формы».


Категория свойств - Представление


Категория свойств - Справочная информация

Включать в содержание помощи — если свойство установлено, то содержимое «Справочной информации» включается в общее описание конфигурации.

Справочная информация — по ссылке Открыть открывается окно редактирования описания конфигурации.


Категория свойств - Справочная информация


Создание описания объекта конфигурации

К некоторым объектам конфигурации можно «прикрепить» текст, объясняющий назначение и порядок использования объекта. Такой текст называется пользовательским описанием. При работе с системой 1С: Предприятие пользователь системы 1С:Предприятие может вывести описание на экран для просмотра.

Создание и корректировка пользовательского описания выполняется при помощи встроенного текстового редактора, который можно вызвать из палитры свойств объекта по ссылке Открыть свойства Справочная информация.

Для того, чтобы информация об объекте конфигурации попала в список описаний, установите свойство «Включать в содержание помощи».

Подробно работа с редактором текстов описана в главе « HTML-редактор ».


Создание описания объекта конфигурации


Глобальный поиск и замена

Режим глобального поиска и замены предназначен для поиска определенной строки во всех модулях, диалогах, таблицах, описаниях конфигурации и внешних файлах (внешние обработки, табличные документы). Найденный текст может быть заменен на другой. Этот режим может быть использован, например, для поиска всех вызовов некоторой глобальной процедуры или обращения к какому-либо реквизиту в разных модулях.

Вызов режима поиска осуществляется выбором пункта «Правка — Глобальный поиск», а режима замены — выбором пункта «Правка — Глобальная замена».

В этих режимах используется один и тот же диалог, в котором в режиме поиска недоступны реквизиты режима замены. Поэтому в этом разделе описывается процедура глобальной замены.

На экран будет выдан диалог для задания параметров поиска.

В поле «Искать» этого диалога следует ввести образец для поиска или нажать кнопку [image] раскрытия списка и выбрать один из образцов, которые были использованы ранее в операциях поиска. В поле «Заменить» введите текст, на который следует произвести замену найденного текста или нажать кнопку [image] раскрытия списка и выбрать один из образцов, которые были использованы ранее в операциях замены.

Чтобы различать при поиске прописные и строчные буквы, установите флажок «Учитывать регистр». При установленном флажке «Искать слово целиком» будут найдены только целые слова, а не части слов.

Ниже расположена панель, на закладках которой указывается, где следует искать указанный образец.

На закладке «Типы текстов» помечаются типы подчиненных объектов, в которых будет произведен поиск.

На закладке «Конфигурации» можно указать с точностью до объекта разделы конфигурации, в которых будет произведен поиск.

Для указания набора объектов установите переключатель «Выбранные объекты» и пометьте те объекты, в которых будет произведен поиск. В списке по умолчанию установлены пометки всех объектов. Чтобы снять установку снимите флажок в строке с наименованием конфигурации. Затем можно указывать конкретные объекты для поиска.

На третьей закладке «Файлы» можно указать каталог и типы файлов, в которых может производиться поиск. Если каталог не указан (реквизит «Каталог» не заполнен), то поиск в файлах не осуществляется.

Если был запущен режим поиска, то для начала поиска нажмите кнопку «Искать». На экран в окно «Результаты поиска» будет выведен список найденных.

Результат поиска можно просмотреть, а к каждому найденному значению можно перейти, если выбрать в результате поиска нужную строчку и нажать клавишу Enter.

Результат поиска можно запомнить в Буфер Обмена с помощью кнопки [image] панели инструментов окна результатов поиска.

Найденные вхождения можно заменить на другой текст. Для этого в панели инструментов окна результатов поиска нажмите кнопку [image]. На экран выводится запрос, в котором отображается найденный текст и содержится поле ввода. В поле ввода нужно ввести образец текста для замены и выбрать действие.

Если нажать кнопку «Пропустить», то текущий текст будет пропущен и на экран будет выведено очередное вхождение исходного текста в текущем окне или другое окно, содержащее исходный текст.

Кнопка «Заменить», производит замену и выбор очередной результат поиска.

Кнопка «Заменить все» производит замену всех найденных результатов поиска.

Если был запущен режим замены, то в поле «На текст» указывается образец текста, на который следует заменить исходный текст, указанный в ноле «Заменить».

Если перед заменой требуется посмотреть исходный текст, то для начала поиска нажмите кнопку «Пропустить». На экран выводится результат первого найденного исходного текста. Если нажать кнопку «Пропустить», то текущий текст будет пропущен и на экран будет выведено очередное вхождение исходного текста в текущем окне или другое окно, содержащее исходный текст.

Во время просмотра результатов поиска изменить условия поиска нельзя.


Глобальный поиск и замена


Конструкторы. Конструктор печати

Конструктор печати предназначен для создания макета с заданными именованными областями и процедуры печати для объекта конфигурации.

Конструктор печати работает с различными объектами конфигурации: справочниками, документами, журналами документов, регистрами сведений.

Основные приемы работы с конструктором печати будут рассмотрены ниже на примере работы со справочником. Для других видов объектов конфигурации работа с конструктором может несколько отличаться.

Для запуска конструктора печати в окне «Конфигурация» укажите требуемый объект. В контекстном меню выберите пункт «Конструкторы — Конструктор печати».

Конструктор предлагает выбрать место расположения процедуры формирования отчета «Новая процедура» и ввести имя процедуры, которая будет выполнять построение печатной формы. По умолчанию это имя «Печать».

Место расположения выбирается для новой формы. Оно может быть в модуле и в модуле формы (если выбрано последнее, то указывается, в какой именно форме будет расположена процедура).

Если такая процедура уже присутствует, то можно выбрать ее и Конструктор перепишет ее заново. При этом введенный ранее в тело процедуры текст будет потерян!

После нажатия кнопки «Далее ». Конструктор переходит к по выбору реквизитов шапки. Выберите и с помощью кнопок переноса сформируйте список реквизитов .

Если объект конфигурации имеет табличные части, то после нажатия кнопки «Далее>» Конструктор переходит к выбору реквизитов очередной табличной части. Список печати формируется аналогично списку реквизитов шапки.

Если объект конфигурации имеет табличные части, то после нажатия кнопки «Далее>» Конструктор переходит к выбору реквизитов подвала.

Для справочника эти действия конструктора могут отсутствовать, даже, если справочник имеет табличные части, в том случае, когда выбрана форма списка Если указанных реквизитов нет или выбрана форма списка, то конструктор предлагает выбрать режим вызова процедуры и режим просмотра печатной формы.

Нажатие кнопки «ОК» завершает работу конструктора печати.

В результате будет сформирован макет, а в указанной форме будет автоматически сформирована процедура печати.


Конструкторы. Конструктор печати


Конструктор ввода на основании

Конструктор ввода на основании облегчает задачу разработки процедуры, с помощью которой будет формироваться новый объект.

Конструктор ввода на основании применяется для справочников и документов.

Для запуска конструктора печати в окне «Конфигурация» укажите требуемый объект. В контекстном меню выберите пункт «Конструкторы — Конструктор ввода на основании». Если для выбранного объекта конфигурации определен режим ввода на основании, то указанный пункт контекстного меню будет доступен.

При запуске открывается диалог «Конструктор ввода на основании».

В верхней части содержится список объектов-оснований, список реквизитов объекта-основания, выбранного в первом списке.

В нижней части расположен список реквизитов результирующего объекта.

В список реквизитов объекта нужно поместить формулы, определяющие, как заполнять реквизиты документа по выбранным реквизитам объекта-основания.

Эти формулы можно создавать «вручную» следующим образом. Формула определяется в поле ввода «Формула заполнения реквизита» для реквизита объекта, выделенного в списке. Можно вручную набрать ее в этом поле (а также вручную редактировать в нем созданную ранее формулу). Правильность написания формул Конструктор не проверяет.

Можно также двойным щелчком в списке реквизитов объекта-основания помещать данные соответствующего реквизита в поле «Формула заполнения реквизита», причем сразу в правильной записи. Конструктор не проверяет соответствия типов выбранных реквизитов.

Возможна и комбинация двух описанных способов: данные из списка реквизитов объектов-оснований при помещении в поле ввода замещают не всю имеющуюся там информацию, а только выделенные символы.

По кнопке «Заполнять автоматически», после запроса и подтверждения, программа сама создаст формулы для заполнения по реквизитам объекта-основания. Ранее заполненные формулы при автоматическом заполнении не изменяются. Подбор среди реквизитов объекта-основания соответствий реквизитам документа осуществляется с учетом имен реквизитов, их идентификаторов и типов.

По кнопке «Очистить формулы", после запроса и подтверждения, очищаются все формулы, созданные как автоматически, так и вручную.

Формулы, созданные для объекта-основания, выбранного в списке объектов-оснований, запоминаются при переходе к другому объекту-основанию этого списка. Поэтому можно, не прекращая работы Конструктора, создать процедуры ввода на основании для нескольких документов-оснований. Можно также возвращаться к редактированию процедуры для какого-либо объекту -основания, снова выбирая его в списке.

Для прекращения работы Конструктора служат кнопки «ОК» и «Отмена» (соответственно, с сохранением и без сохранения сделанных изменений).

Кнопка «Обновить» позволяет отразить в модуле формы сделанные изменения без выхода из окна Конструктора.

В результате работы Конструктора в модуле объекта создается процедура ОбработкаЗаполнения. В начало процедуры Конструктор помещает предупреждение: «Данный фрагмент построен Конструктором. При повторном использовании Конструктора внесенные вручную изменения будут потеряны!».

При повторном использовании Конструктора все формулы, сформированные ранее для какого-либо документа-основания, будут появляться в списке реквизитов документа при выделении соответствующего документа-основания в списке документов-оснований. Конструктор предъявит для просмотра и редактирования формулы, сформированные при предыдущем его запуске, как с помощью кнопки «Заполнить формулы автоматически», так и вручную. Более того, он учтет и формулы, вручную внесенные в модуль документа, если они помещены в формируемую им процедуру. Правильность этих формул Конструктор не проверяет. Например, если для какого-то реквизита документа указано заполнение двумя различными реквизитами документа-основания, Конструктор для показа выберет один из них (по алфавиту). Именно он останется в модуле после обновления результатов работы Конструктора, вторая строка, соответствующая тому же реквизиту, будет удалена.

Конструктор движений регистров сведений

Конструктор движений регистров сведений применяется для документов.

Для запуска конструктора печати в окне «Конфигурация» укажите требуемый документ. В контекстном меню выберите пункт «Конструкторы — Конструктор движений регистров». Если для выбранного документа в свойстве Движения определен состав движений хотя бы по одному регистру сведений, то указанный пункт контекстного меню будет доступен.

При запуске Конструктор запрашивает выбор регистра, по которому будет произведено формирование процедуры ОбработкаПроведения. После выбора на экран выводится диалог

В разделе «Движения регистров» для каждого регистра производится заполнения формул атрибутов по данным реквизитов документа.

В список формул нужно поместить формулы, определяющие, как вычислять движения регистра по выбранным реквизитам объекта-основания.

Эти формулы можно создавать «вручную» следующим образом. Формула определяется в поле ввода «Выражение» для атрибута регистра, выделенного в списке. Можно вручную набрать ее в этом поле (а также вручную редактировать в нем созданную ранее формулу). Правильность написания формул Конструктор не проверяет.

Можно также двойным щелчком в списке реквизитов документа помещать данные соответствующего реквизита в поле «Выражение», причем, сразу в правильной записи. Конструктор не проверяет соответствия типов выбранных реквизитов.

В результате работы Конструктора в модуле объекта создается процедура ОбработкаПроведения. В начало процедуры Конструктор помещает предупреждение: «Данный фрагмент построен Конструктором. При повторном использовании Конструктора внесенные вручную изменения будут потеряны!».


Конструктор ввода на основании


Глава 4.Объекты конфигурации

В этой главе рассказывается о работе с конфигурацией в целом и о тех режимах и механизмах, которые используются для всех объектов конфигурации.

Описание действий по созданию и настройке основных объектов конфигурации (константы, справочники, документы, последовательности, журналы, перечисления, отчеты, обработки, регистры), а также некоторых объектов, располагающихся на ветви конфигурации «Общие» (критерии отбора, стили), в документации производится на примере использования диалога редактирования объекта (подробнее см.« Основные виды объектов конфигурации »). Аналогичные действия можно выполнять и палитре свойств объектов.


Глава 4.Объекты конфигурации


Глобальный модуль

Глобальным модулем называется модуль, который автоматически выполняется при старте системы 1С: Предприятие в момент загрузки конфигурации.

В глобальном модуле помещаются процедуры и функции, которые необходимо выполнять при запуске системы 1С:Предприятие, а также глобальные процедуры и функции, которые могут вызываться из любого другого модуля конфигурации. Помимо процедур и функций в глобальном модуле могут размещаться глобальные переменные, доступные из любых модулей конфигурации.

Процедуры и функции глобального модуля, для которых в заголовках указано ключевое слово «Экспорт», являются одной из составных частей глобального контекста. Подробнее о глобальном модуле можно узнать из книги «1С: Предприятие. Описание встроенного языка».

Для редактирования глобального модуля необходимо в палитре свойств окна «Конфигурация» в свойстве Глобальный модуль щелкнуть мышью ссылку Открыть. Текст глобального модуля будет выдан для редактирования в редакторе текстов системы 1С: Предприятие в режиме редактирования текста программного модуля.

Глобальный модуль, являясь частью конфигурации, сохраняется только в составе конфигурации. Использование пункта «Файл — Сохранить» приведет к выполнению процедуры сохранения сделанных изменений, применительно ко всей конфигурации.


Глобальный модуль


Ветвь конфигурации Общие

На этой ветви описываются такие объекты конфигурации, как Подсистемы, Общие модули. Роли, Критерии отбора. Интерфейсы, Макеты, Картинки, Стили, Языки. Эти объекты не описывают структуру данных и механизмы их обработки, они предназначены для установки правил работы пользователей с данными, для описания вспомогательных объектов, используемых для формирования различных форм, а также содержат общие модули и макеты печатных форм, доступные из любого модуля конфигурации.


Ветвь конфигурации Общие


Подсистемы

На ветви «Подсистемы» располагаются объекты, с помощью которых описываются различные виды деятельности, выполняемые с использованием данной конфигурации. Свойство Подсистемы имеют практически все объекты конфигурации.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Подсистемы» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ». На структуру объектов ветви «Подсистемы» не накладывается никаких ограничений по числу и вложенности.

Использование объектов конфигурации типа «Подсистемы» происходит в основном на этапе конфигурирования.

Для просмотра объектов конфигурации, относящихся к определенному набору подсистем, в окне «Конфигурация» можно произвести настройку фильтра отбора объектов. Выберите пункт «Действия - По подсистемам» окна «Конфигурация» и укажите необходимый набор подсистем, а также установите дополнительные признаки отбора «Включать объекты подчиненных подсистем» и «Включать объекты родительских подсистем».

Принадлежность объектов конфигурации к определенной подсистеме позволяет легко создавать пользовательские интерфейсы (подробнее см. раздел « Редактор индивидуальных пользовательских интерфейсов » ).

Значение свойства объекта конфигурации Подсистемы доступно в программе с помощью средств встроенного языка. Это предоставляет дополнительные возможности отбора данных.


Подсистемы


Общие модули

Объекты, расположенные на ветви дерева конфигурации «Общие модули», предназначены для размещения в них текстов функций и процедур, которые могут вызываться из любого другого модуля конфигурации.

Важно! В общем модуле глобальные переменные не размещаются.

Процедуры и функции общего модуля, для которых в заголовках указано ключевое слово «Экспорт», являются одной из составных частей глобального контекста. Подробнее о написании процедур и общем модуле можно узнать из книги «1С: Предприятие. Описание встроенного языка».

Для редактирования общего модуля необходимо в палитре свойств объекта типа «Общие модули» окна «Конфигурация» в свойстве Модуль щелкнуть мышью ссылку Открыть. Текст общего модуля будет выдан для редактирования в редакторе текстов системы 1С: Предприятие в режиме редактирования текста программного модуля.

Общий модуль, являясь частью конфигурации, сохраняется только в составе конфигурации.

В отличие от глобального модуля для объекта типа «Общие модули» добавляется свойство Предпочт. на сервере .

Если для сетевой версии программы в конфигурации есть объекты типа «Общие модули» и в каких-то из них свойство Предпочт. на сервере установлено и определен сервер исполнения приложения, то все функции и процедуры данного объекта будут исполняться на этом сервере. Сервер указывается при установке конфигурации (см. Руководство по установке и запуску раздел «Запуск системы 1С:Предприятие» параграф «Ведение списка информационных баз») и может быть изменен в любой момент времени.

В связи с тем, что в состав программ (как сетевых, так и однопользовательских) входит одна и та же типовая конфигурация, то для однопользовательских программ наличие установленного свойства Предпочт. на сервере не будет влиять на результат работы программы. При редактировании таких конфигураций пользователем установка этого свойства для объектов типа «Общие модули» не влияет на результат выполнения.


Общие модули


Роли

Каждый пользователь системы должен иметь свободный доступ к общей информации, такой, как справочники, константы или перечисления.

С другой стороны, необходимо, чтобы каждый пользователь имел дело только с той информацией, которая необходима ему для работы, и никак не мог своими неосторожными действиями повлиять на работу других пользователей или на работоспособность системы в целом.

Конфигуратор системы 1С:Предириятие содержит развитые средства администрирования, предназначенные для решения указанных задач.

Прежде всего, в процессе создания конфигурации создается необходимое число типовых Ролей, описывающих полномочия различных категорий пользователей на доступ к информации, обрабатываемой системой. Роли могут быть заданы в достаточно широких пределах - от возможности только просмотра ограниченного числа видов документов до полного набора прав по вводу, просмотру, корректировке и удалению любых видов данных.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа « Роли» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

В левой части диалога редактирования прав выводится дерево объектов конфигурации, но всем подсистемам. В правой - список прав но выбранному объекту конфигурации в дереве конфигурации. Права доступа могут иметь два состояния: — «Разрешено» и [image] — «Запрещено».

Так, например, для пользователя с ролью « Маркетолог» разрешены все действия с документом «ЦеныКонкурентов» и запрещены с документом «ПриходнаяНакладная».

Роли обычно указываются для каждого вида деятельности. При включении в список пользователей нового пользователя (см. главу « Администрирование » раздел « Ведение списка пользователей » ) ему может быть назначена определенная роль или совокупность ролей. В случае использования нескольких ролей алгоритм предоставления доступа по каждому объекту и виду нрава доступа (например, «Пометка на удаление») будет работать следующим образом:

• если хотя бы в одной роли есть разрешение, то доступ будет открыт;

• если во всех ролях есть запрещение, то доступ будет закрыт.

При создании повой роли все права устанавливаются Конфигуратором в состояние «Разрешено».

Чтобы открыть доступ, в левом списке выберите объект конфигурации, а в правом установите флажок в нужной строке действия. Если требуется открыть или закрыть доступ сразу ко всем объектам выбранной ветви, укажите в левой части эту ветвь и установите или снимите установку прав доступа.


Роли


Критерии отбора

Критерии отбора — одна из составляющих механизма отбора информации (из справочников, документов). С их помощью специалист, осуществляющий конфигурирование системы, создает предопределенные правила отбора. При использовании конфигурации по этим правилам будет выполняться отбор документов и элементов справочников.

Для лучшего понимания этого механизма ниже излагается схема организации отбора документов с использованием критериев отбора (по контрагенту).

Чтобы критерий отбора выполнял свои функции, в Конфигураторе для него должен быть создан список, состоящий из реквизитов справочников и документов. На состав списка не накладывается практически никаких ограничений: например, в отличие от графы журнала, для критерия отбора можно выбрать несколько реквизитов одного документа и реквизитов табличной части документа.

Критериев отбора может быть произвольное число, а каждый критерий может иметь несколько форм представления результатов отбора. Этот механизм полезен в случае поиска различной информации, например, требуется отобрать все документы, в которых используется (в реквизитах и табличных частях) определенный контрагент, при этом можно учитывать и другие условия отбора информации (например, поиск ведется только среди проведенных документов или в определенном интервале дат и т.д.).

Приемы создания, редактирования свойств и удаления объектов конфигурации типа « Критерии отбора» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объектов конфигурации ».

В диалоге редактирования объекта « Критерий отбора» укажите имя, синоним и комментарий. Если в конфигурации определено несколько подсистем, выберите подсистему, к которой относится данный критерий отбора. Если критерий отбора используется во всех подсистемах, укажите корневую строчку. Можно указать несколько различных подсистем.

В список реквизитов критерия отбора будут включаться только те справочники и документы, в палитре свойств которых в свойстве Подсистема указаны любая из выбранных подсистем.

Созданный для критерия отбора список реквизитов справочников и документов определяет, где будет осуществляться поиск требуемой информации при отборе документов и элементов справочника.

Тип критерия отбора может быть любым из стандартных типов или определенных как объекты дерева конфигурации, составным (состоящим из набора различных типов) и произвольным.

В первом случае тип критерия отбора выбирается однозначным выбором типа из структуры конфигурации («СправочникСсылка.Контрагенты»). В этом случае состав объектов, входящих в критерий отбора будет определяться строго по указанному типу:

Если указать составной тип критерия отбора (как показано на рисунке ниже), то состав реквизитов критерия отбора может быть расширен.

Критерий отбора может иметь форму для визуального представления результатов отбора. Для оперативности получения информации по отбору вызов формы можно разместить в пользовательском меню или на панели инструментов.

Если форм критерия отбора несколько, то в свойстве Основная форма указывается та форма, которая будет вызываться по умолчанию.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа « Критерии отбора» совпадают с общими приемами управления объектами конфигурации, изложенными « Создание и удаление объекта конфигурации » . Порядок редактирования формы описан в главе « Редактор форм ».

Если указать составной тип критерия отбора (как показано на левом рисунке ниже), то состав реквизитов критерия отбора может быть расширен.


Критерии отбора


Редактор индивидуальных пользовательских интерфейсов

Для эффективной работы пользователей в процессе настройки конфигурации задачи для каждого пользователя может быть создан индивидуальный пользовательский интерфейс. Такой интерфейс включает команды главного меню и панели инструментов, настроенные на работу пользователя с той информацией, доступ к которой разрешен набором его прав.

В Конфигураторе системы 1С:Предприятие функция создания списка пользователей (см. раздел « Ведение списка пользователей »), которым разрешен вход в систему, и функция создания пользовательского интерфейса отделены одна от другой. Такой подход имеет достаточную гибкость и простоту в использовании.

С одной стороны, возможно создать несколько типовых пользовательских интерфейсов с различным объемом команд. Каждый интерфейс предназначается для использования определенной категорией пользователей, например: кладовщиками, продавцами, менеджерами и так далее.

В случае, когда создается новый пользователь, принадлежащий к одной из указанных категорий, ему просто назначается заранее созданный типовой пользовательский интерфейс.

С другой стороны, при необходимости изменения интерфейса для категории пользователей нет необходимости в редактировании интерфейса каждого отдельного пользователя, входящего в эту категорию. В этом случае достаточно отредактировать текущий интерфейс этой категории пользователей или назначить ей новый типовой интерфейс — интерфейс будет автоматически обновлен для всех пользователей этой категории.

Конфигуратор системы 1С:Предприятие позволяет создавать практически неограниченное количество типовых пользовательских интерфейсов.

Созданные пользовательские интерфейсы являются неотъемлемой частью конфигурации.


Редактор индивидуальных пользовательских интерфейсов


Ведение списков пользовательских интерфейсов

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Интерфейсы» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

При создании в список интерфейсов добавляется новая строка и открывается палитра свойств этого интерфейса.

Совет. Желательно задавать пользовательским интерфейсам смысловые названия, которые бы отражали должность или характер выполняемых функций того пользователя, для которого создается данный пользовательский интерфейс.

Для создания главного меню и панелей инструментов выберите ветвь «Интерфейсы» и выберите пункт « Действия — Добавить ».

На экран выводится конструктор главного меню.

Конструктор содержит два списка: список подменю и список команд (пунктов) подменю. Первый содержит список подменю, создаваемых по умолчанию. Пометьте v те строки списка, которые необходимо включить в состав главного меню. Для уточнения состава команд, выберите подменю, и в списке команд отметьте те команды, которые следует включить в этом подменю. Например, для подменю «Справочники » будут показаны команды для работы с созданными в конфигурации справочниками.

Чтобы расположить пункты и команды меню в нужном порядке, используйте кнопки [image].

По умолчанию списки подменю и команд формируются по всем подсистемам конфигурации (подробнее о подсистемах см. раздел « Подсистемы »). Если в конфигурации определено несколько подсистем и создаваемый интерфейс предназначен для определенного вида деятельности, то с помощью выбора подсистем можно легко сформировать нужные подменю и команды, относящиеся к этой деятельности. Для этого нажмите кнопку «По подсистемам » и укажите те подсистемы, которые относятся к создаваемому интерфейсу.

Допускается указание нескольких подсистем. Если выбранная подсистема имеет подчиненные подсистемы, для включения всех объектов данной подсистемы достаточно установить флажок у этой ветви и флажок реквизита диалога «Включать объекты подчиненных подсистем» (как показано на рисунке).

Если указываемая подсистема не верхнего уровня, то для включения объектов, относящихся к подсистемам верхних уровней, установите флажок «Включать объекты родительских подсистем». Например (см. рис выше), следует выбрать все объекты подсистемы « Маркетинг» и общие объекты, относящиеся ко всей конфигурации, но без объектов подсистемы « ТорговыйУчет ». Выберите подсистему «Маркетинг » и установите флажок реквизита диалога «Включать объекты родительских подсистем».

Для выбранной подсистемы конструктор меню включит в списки подменю и команд только те объекты, которые имеют отношение к указанной подсистеме, и позволит разработчику вручную произвести коррекцию этих списков.

Для построения главного меню нажмите кнопку « Построить». На экран выводится окно редактора интерфейсов.

При создании нового интерфейса программа создает панель «Главное меню». В окне редактора панели создаются системные и пользовательские подменю. Системные подменю отмечены подчеркиванием.

Окно состоит из панели инструментов, списка панелей созданного интерфейса (при создании нового интерфейса содержит только главное меню) и редактора панели. Для каждого объекта типа «Интерфейс » можно создать только одно главное меню и неограниченное количество панелей инструментов.

С точки зрения редактора интерфейсов, действия по редактированию главного меню и панели инструментов очень схожие. Поэтому в дальнейшем будем называть меню и панели инструментов термином «панель». Если в контексте описания может возникнуть двусмысленное понимание, то будет использоваться точный термин. Некоторые различия понятий «меню » и « панели инструментов» будут описаны особо.

Новые пользовательские интерфейсы можно создавать путем копирования существующих интерфейсов, как внутри текущей конфигурации, так и между конфигурациями. Для копирования используются возможности Буфера Обмена MS Windows. Имя скопированного интерфейса должно быть преобразован с целью соблюдения уникальности.

В палитре свойств интерфейса есть свойство Переключаемый, с помощью которого производится настройка показа интерфейсов при переключении (см. книгу «Описание встроенного языка», описание метода ПереключитьИнтерфейс () ). Если свойство установлено, то интерфейсом можно управлять, если нет, то данный интерфейс будет показываться всегда.

Удаление пользовательского интерфейса осуществляется стандартным для объекта конфигурации образом.

После удаления пользовательского интерфейса следует отредактировать свойства пользователей, которым был назначен удаленный пользовательский интерфейс (указать для них другой пользовательский интерфейс).


Ведение списков пользовательских интерфейсов


Совет

Желательно задавать пользовательским интерфейсам смысловые названия, которые бы отражали должность или характер выполняемых функций того пользователя, для которого создается данный пользовательский интерфейс.


Свойства панели

В списке панелей окна редактирования интерфейса для нужной панели откройте палитру свойств.

В свойстве Заголовок задается наименование панели, в свойстве Тип — тип панели («Меню» или «Панель инструментов»). Заголовок главного меню не редактируется.

В свойстве Расположение задается место панели в окне программы. Панель можно расположить вверху, внизу, справа и слева.

Пользовательский интерфейс может содержать несколько панелей. В палитре свойств установите свойство С новой строки, если данная панель должна располагаться с новой строки. Если свойство не установлено, то панель будет расположена справа от предыдущей.

Если свойство Показывать установлено, то при запуске программы данная панель будет показываться.


Свойства панели


Редактирование интерфейса

Для редактирования интерфейса выберите в дереве объектов конфигурации нужный интерфейс и в палитре свойств свойства Интерфейс щелкните ссылку Открыть .

Для каждого пользовательского интерфейса можно создать несколько панелей инструментов.

Для создания новой панели инструментов в меню редактора интерфейсов выберите пункт «Добавить панель». В список панелей добавляется панель, имеющая тип «Панель инструментов».

Редактирование панели производится в редакторе панели редактора интерфейсов.

Структура меню и панели инструментов. Меню и панели инструментов имеет древовидную структуру. На первом уровне находятся основные подменю. Как правило, названия подменю первого уровня обозначают основные функциональные блоки задачи.

На последующих уровнях могут располагаться элементы трех типов: Действие, Подменю и Разделитель.

Действие непосредственно связано с выполнением каких-либо действий.

Подменю служит для дополнительной группировки команд и подменю. Выбор подменю непосредственного выполнения каких либо операции не вызывает, а только открывает список, который, в свою очередь, также может состоять из команд, подменю и разделителей. При выборе подменю (щелкнуть мышью наименование) открывается список вложенных подменю.

Названия команд и подменю, которые появляются в меню при его работе, также называют пунктами меню. В панели инструментов команду называют топкой панели инструментов.

Разделитель никакой функциональной нагрузки не несет и служит только для визуальной группировки логически связанных пунктов меню или кнопок панели инструментов. В работающем меню разделитель выглядит как горизонтальная черта между двумя пунктами меню. В панели инструментов разделитель выглядит как вертикальная черта между двумя кнопками панели.

Для панели инструментов обычно все команды располагаются на первом уровне и отображаются картинкой.

Главное меню может содержать стандартные подменю (например, «Файл», «Помощь», «Сервис» и т.д.). Такие подменю имеют ряд особенностей. В редакторе панели стандартные подменю имеют подчеркнутое наименование. Эти подменю предназначены для выполнения стандартных действий, например, открытие и сохранение файлов, настройки печати и проч. В стандартных подменю можно расположить пользовательские команды и подменю.

При выборе стандартного подменю показывается список подменю, который первоначально состоит их трех строк, разделенных разделителями. Верхняя и нижняя строки имеют наименование «Стандартные действия...». Они не выбираются и не редактируются. В них программа автоматически размещает команды и подменю, связанные с выбранным подменю верхнего уровня.

Добавление подменю в стандартном подменю производится в строке «Новая».


Редактирование интерфейса


Создание нового подменю

Список подменю панели пользовательского интерфейса может быть изменен. Можно дополнить новые, или удалить ненужные подменю, изменить названия существующих.

Для создания нового подменю выберите: для Главного меню подменю «Новая», для панели инструментов — кнопку [image] в свойстве Тип укажите тип («Действие» — для команды, «Подменю» или «Разделитель»). Если выбран самый верхний уровень, то в зависимости от типа панели (меню или панель инструментов) будет указан следующий тин по умолчанию:

Тип панели | Уровень | Тип по умолчанию
Меню | верхний | Действие
Подменю | другой | Действие
Панель инструментов | любой | Действие

При выборе типа подменю «Действие» в свойстве Действие указывается конкретное действие с объектом конфигурации. Для этого в свойстве Действие щелкните мышью кнопку выбора [image]. На экране открывается диалог «Выбор действия». Диалог имеет три закладки, на которых действия разделены по действиям над объектами конфигурации, запуску процедур глобального и общих модулей или стандартные действия общего назначения.

На закладке «Конфигурация» выбирается вид действия, выполняемого над объектом конфигурации.

Например, «Открыть справочник», «Ввести элемент» и т.д.

На закладке «Модули» выбирается процедура, расположенная в Глобальном или Общих модулях.

В список процедур включаются только те процедуры, которые являются внешними (имеют в заголовке процедуры описание «Экспорт») и не имеющих формальных параметров.

На закладке «Общие» выбирается стандартное действие, например: сохранение и печать документа, завершение работы программы и т.д.

Для выбора действия укажите его в диалоге и нажмите кнопку «ОК».

Если при выборе типа подменю выбрать «Разделитель», то он сразу вставляется в панель. Для разделителя не существует дополнительных свойств.

В свойстве Текст (если выбран не разделитель) указывается наименование подменю. Для определения «горячей клавиши» перед любым символом текста можно ввести символ «&». «Горячая клавиша» показывается в панели подчеркиванием и может быть только одна.

В свойстве Подсказка введите краткое пояснение, которое будет показываться в виде ярлыка при подведении указателя мыши (только для команд панели инструментов).

В свойстве Пояснение введите пояснительный текст, который будет показываться в строке состояния.

Для кнопок панели инструментов и команд меню можно выбрать картинку и способ отображения текста и картинки. Картинка указывается в свойстве Картинка и выбирается из библиотеки картинок (стандартные картинки или содержащиеся в конфигурации), из отдельного файла или файла-коллекции картинок.

В свойстве Отображение укажите, как будет показан пункт меню (в виде надписи, картинки или надписи и картинки одновременно). Если выбран способ «Авто», то для подменю будет показан текст, для пункта меню — и текст и картинка, а для кнопки панели инструментов — только картинка.

Для быстрого вызова укажите сочетание клавиш. Для этого установите курсор в свойстве Сочетание клавиш и нажмите нужную комбинацию клавиш (допускается использование комбинаций клавиш).


Создание нового подменю


Перемещение и копирование подменю

Созданные подменю можно копировать и перемещать как внутри одной панели, так и между панелями и между интерфейсами, а также между конфигурациями. Перемещение и копирование выполняются с использованием стандартных приемов перемещения и копирования.


Перемещение и копирование подменю


Порядок следования

Если в пользовательском интерфейсе создано несколько панелей, то их порядок можно настроить. Для этого в редакторе интерфейсов расположите панели с той последовательности, в которой они должны появляться на экране при работе с программой. Первая панель (верхняя строка списка) появляется на экране первой, вторая — второй и т.д.

Для перестановки панели необходимо выделить ее в списке и используйте кнопки«Переместить вверх», «Переместить вниз».


Порядок следования


Расположение и показ панелей

Расположение панели на экране, а также порядок следования нескольких панелей пользовательского интерфейса можно настроить.

Откройте пользовательский интерфейс, в редакторе панели выберите нужную панель. Откройте палитру свойств. В свойстве Расположение задается место панели в окне программы. Панель можно расположить вверху, внизу, справа и слева.

Пользовательский интерфейс может содержать несколько панелей. Установите свойство С новой строки, если данная панель должна располагаться с новой строки. Если свойство не установлено, то панель будет расположена справа от предыдущей.

Если свойство Показывать установлено, то при первом запуске программы при выборе этого пользовательского интерфейса данная панель будет показываться. Если пользователь в процессе работы уберет панель с экрана, то этот выбор запоминается и в следующем сеансе панель показана не будет.

Если свойство Показывать не установлено, то панель при первом запуске программы не показывается. Если пользователь в процессе работы установит показ панели, то в следующем сеансе панель также будет показана.


Расположение и показ панелей


Макеты

Механизм макетов (общих таблиц печатных форм, форм отчетов, справочных данных и т.д.) позволяет создавать шаблоны печатных форм, доступные из любого модуля текущей конфигурации.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Макеты» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

Подробно о порядке работы с редактором таблиц см. в главе « Табличный редактор ».


Макеты


Картинки

Конфигуратор позволяет включать в конфигурацию графические изображения — картинки. Картинки можно размещать в некоторых элементах управления, в формах, в макетах, а также обращаться к ним при помощи встроенного языка системы 1С: Предприятие.

При подготовке картинок для кнопок рекомендуется устанавливать их размер 16х16 точек или меньше. Для картинок, которые планируется использовать в поле списка и в табличном ноле, эти размеры должны быть не больше, чем 14х14 точек.

Для работы с картинками предназначен диалог «Библиотека картинок». Для вызова диалога выберите пункт «Все картинки» в окне «Конфигурация» на ветви «Общие» укажите ветвь «Картинки» и в контекстном меню.

На экран выводится диалог ведения списка картинок:

Для добавления новой картинки нажмите кнопку «Добавить»: На экран выводится диалог выбора картинки. Выберите файл, в котором расположена подготовленная заранее картинка. Задайте имя, по которому данная картинка будет выбираться средствами встроенного языка.

Чтобы картинка при вставке хорошо вписывалась в элемент управления или форму, желательно установить ей прозрачный фон. Это тот цвет существующего оригинала картинки, который приобретает свойство прозрачности. Благодаря прозрачности данного цвета сквозь него становятся видны детали той части формы, которую закрывает область картинки.

Для установки прозрачного фона нажмите кнопку «Установить прозрачный фон». Указатель мыши примет вид руки. Подведите его к той части картинки, цвет которой вы хотите сделать прозрачным, и щелкните левой кнопкой мыши. Выбранный цвет становится прозрачным.

Для снятия прозрачности нажмите кнопку «Убрать прозрачность».

Подобные действия можно выполнить с помощью ссылки Открыть в свойстве «Картинка».


Картинки


Стили

Стиль — это совокупность различных форм для оформления текстов, рамок элементов управления. Использование настроек, и других используемых составляющих стиля позволяет быстро выбрать нужное оформление.

Стиль состоит из отдельных элементов, называемых Элемент стиля. Существует стандартный набор элементов (см. рисунок), состав которого не подлежит изменению.

Конфигуратор позволяет создать произвольное число стилей, а также дополнительных элементов стилей.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Элементы стиля» и «Стили» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

При создании элемента стилей в палитре свойств этого элементов в свойстве Вид выберите вид элемента «Цвет», «Шрифт» или «Рамка». Это свойство определяет область применения данного элемента стиля.

При создании стиля в свойстве Стиль щелкните ссылку Открыть и в диалоге настройки стиля установите нужные значения. Для наглядности выбора настроек можно использовать другую форму диалога, которая позволяет визуально оценить установку каждого элемента стиля. Для вызова этой формы выберите пункт «Действия — Изменить». На экран выводится диалог редактирования стиля:

В левой части диалога располагаются группы различных элементов управления, предназначенных для демонстрации установок элементов стиля. При установке значения любого стандартного элемента стиля в этой группе сразу показывается результат этой установки.

Элементы стилей, созданные для данной конфигурации, располагаются в списке стилей под стандартными стилями (например, стиль «Пользовательский»).


Стили


Языки

Объекты конфигурации «Языки» предназначены для создания интерфейса программы на различных языках. Для каждого объекта конфигурации в палитре свойств, для свойства Синоним или Заголовок Конфигуратор резервирует строку для каждого объекта типа «Языки».

Рассмотрим пример формы для элемента справочника «Номенклатура». Для языка «Русский» надписи формы выглядят так:

Если на ветви «Языки» создано несколько объектов (например, «Русский» и «Английский»), то для выбора языка выберите пункт «Конфигурация — Язык редактирования конфигурации». В открывшемся диалоге выбора языка выберите язык просмотра конфигурации.

Аналогичный результат можно получить с помощью кнопки выбора языка, расположенной в строке состояния справа от

кнопок «CAP» и «NUM»

Конфигуратор заменит текст надписей на варианты надписей выбранного языка:

Разумеется, текст надписей должен быть заранее введен для каждого элемента управления. Для ввода текста в палитре свойств элемента управления «Надпись» в свойстве Заголовок (или Синоним, в зависимости от типа элемента управления) нажмите

кнопку [image]. На экран выводится диалог «Строки на разных языках»:

В конфигурации нет ограничений на число языков. Однако не следует создавать объекты типа «Языки» с запасом, т.к. создать объект «Язык» можно в любой момент времени.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Языки» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации » .

В свойстве Код языка указывается код языка, например, «EN» для языка «Английский».

Если в конфигурации определено два и более объектов типа «Языки», то для свойства Синоним и Заголовок элемента управления появляется кнопка редактирования [image] текста на разных языках.

Первый объект языка программа создает в соответствии с выбором языка (страны) при создании новой информационной базы.

Важно! Если тексты в свойствах Синоним или Заголовок введены, то изменение кода языка в свойстве Код языка приведет к «потере» введенных текстов. Тексты «восстанавливаются» при указании прежнего значения кода языка.


Языки


Важно

Если тексты в свойствах Синоним или Заголовок введены, то изменение кода языка в свойстве Код языка приведет к «потере» введенных текстов. Тексты «восстанавливаются» при указании прежнего значения кода языка.


Константы

В системе 1С: Предприятие константы предназначены для хранения постоянной или условно-постоянной информации. Такая информация либо совсем не изменяется в процессе деятельности предприятия, либо изменяется достаточно редко. Наиболее простой пример подобной информации — название организации, которое, как правило, не меняется.

Основная причина использования констант заключается в том, что в них один раз заносится какая-либо информация, которая затем может использоваться при формировании документов, в расчетах, при построении отчетных форм. Значение константы время от времени может редактироваться.

Рассмотрим такой пример. Наиболее часто на документах предприятия встречается подпись директора и главного бухгалтера. Естественно, что подписи эти должностные лица должны ставить самостоятельно. Но помимо самой подписи, в документах требуется ее расшифровка — фамилия подписавшего документ. Конечно, можно ввести фамилии директора и главного бухгалтера непосредственно в формы документов. Но, если какая-либо из фамилия изменится, то придется вновь редактировать все бланки документов и исправлять фамилии. Поэтому гораздо удобнее создать в Конфигураторе две константы — для хранения фамилий директора и главного бухгалтера, ввести эти фамилии в константы один раз, а в многочисленных бланках документов использовать имена констант для получения их значении. При смене директора или главного бухгалтера достаточно внести изменения только в константы — ввести в них новые фамилии — и все изменения автоматически будут отражены в тех местах, где эти константы используются .

Конфигуратор системы 1С:Предприятие позволяет создавать практически неограниченное количество констант для хранения любой нужной информации.


Константы


Свойства константы

Для работы с константами предназначена ветвь «Константы» дерева конфигурации. На ветви располагаются две подветви: «Константы», которая состоит из списка констант, и «Формы», созданных для ввода и редактирования значений основных констант.

Приемы создания, редактирования свойств и удаления констант совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации » .

Свойства константы редактируются в палитре свойств. Необходимо обратить внимание, что константа является типизированным объектом конфигурации (см. п. « Типизированные и типообразующие объекты »).

Тип — указываются тип константы. Тип константы может быть любым из стандартных типов конфигурации («Дата», «Число», «СправочникСсылка», «ДокументСсылка» и т.д.) или составным (состоящим из набора различных типов).

В зависимости от выбранного типа, палитра свойств может содержать дополнительные свойства, уточняющие выбранный тип.


Свойства константы


Формы для ввода констант

Формы для ввода констант используются для ввода значений констант. Конфигуратор позволяет создавать неограниченное число форм. Добавление формы производится стандартным путем (см. раздел « Создание и удаление объекта конфигурации »).

На экран вызывается конструктор формы констант.

Выберите тип формы. Если указан «Форма констант», то на следующем шаге конструктора будет предложено выбрать те константы, которые следует включить в форму

Пометьте те константы, которые следует разместить в форме. Нажмите кнопку «Готово». Если был установлен флажок «Открывать форму для редактирования», то на экран выводится созданная конструктором форма.

Описание работы с редактором форм см. в главу « Редактор форм ».


Формы для ввода констант


Справочники

При заполнении бланка какого-либо документа часто требуется указывать информацию, выбирая значение из заранее заданного списка.

Возьмем в качестве примера анкету, которую требуется заполнять при поступлении на работу.

При заполнении графы «Место рождения» необходимо указать населенный пункт. Хотя общее количество населенных пунктов достаточно большое, однако список всех населенных пунктов все таки ограничен. Фактически, место рождения можно указать, выбрав из подобного списка нужный населенный пункт. Такой список и представляет собой справочник.

Таким образом, можно сказать, что справочник является списком возможных значений того или иного реквизита документа (в широком смысле слова «документ»).

Справочники используются в тех случаях, когда необходимо исключить неоднозначный ввод информации.

Например, для того, чтобы покупатель, продавец, кладовщик, директор понимали, о каком товаре идет речь, каждый должен называть его одинаково. И в этом случае необходим справочник. Обычно в торговом предприятии он имеет вид прайс-листа, а если такой справочник хранится в компьютере, то в него заносят всю возможную номенклатуру товаров, с которыми работает торговая фирма.

Система 1С: Предприятие позволяет вести практически неограниченное количество необходимых справочников. Каждый справочник представляет собой список однородных объектов: сотрудников, организаций, товаров и т.д. Каждый такой объект будем называть элементом справочника.

Следует иметь в виду, что в Конфигураторе создается структура справочника, а собственно его содержимое — элементы справочника — вводятся при работе с программой пользователем. В процессе конфигурирования описывается структура информации, которая будет храниться в справочнике, разрабатывается экранное и, если необходимо, печатное представление справочника, задаются различные особенности его «поведения».

Как правило, справочники имеют предопределенные реквизиты код и наименование, при этом код может иметь тип число или строка.

Система 1С: Предприятие предоставляет широкие возможности по работе с кодами элементов справочника: автоматическое присвоение кодов, автоматический контроль уникальности кода и другие.

Справочник в системе 1С: Предприятие может быть иерархическим. В этом случае все данные справочника будут разделяться на два вида: «просто» элементы справочника и группы справочника. Группы — это логическое объединение элементов справочника. Примером иерархического справочника может служить справочник товаров, где группами являются группы товаров («Сантехника», «Бытовая химия» и.т.д.), а элементами — конкретные товары («Смеситель», «Зеркало», «Стиральный порошок»).

Использование иерархических справочников позволяет организовать ввод информации в справочник с нужной степенью детализации. Элементы и группы элементов в иерархическом справочнике можно переносить из одной группы в другую.

Помимо кода и наименование, для справочника можно создать набор реквизитов, позволяющих хранить дополнительную информацию об элементе справочника.

Например, справочник «Контрагенты» может содержать такие сведения как полное наименование контрагента, его ИНН, фамилии директора и главного бухгалтера, и другу информацию.

Если объект предметной области, которой соответствует справочник, имеет не только такие «простые» свойства, например, полное наименование или ИНН, но и составные (списочные) свойства, справочнику может быть создан набор табличных частей.

Например, в справочнике «Контрагенты» может быть создана табличная часть для списка телефонных номеров контрагента.

Для работы с информацией, хранящейся в справочнике, можно создать экранные формы. Могут быть созданы отдельные формы для просмотра списка элементов справочника, для редактирования элемента справочника, форму для выбора из справочника нужного элемента.

Конфигуратор позволяет создать несколько форм одного типа, например, форм для выбора из справочника нужного элемента, и использовать разные формы в разных случаях.


Свойства справочника

Для работы со справочниками предназначена ветвь «Справочники» дерева конфигурации. Приемы создания, редактирования свойств и удаления справочников совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

При создании нового справочника открывается диалог редактирования объекта (см. « Диалог редактирования объекта »), в котором описываются все свойства справочника. Данные по справочнику распределены на закладках. На закладке «Основное» размещены основные данные по справочнику.

Владелец. Подробного объяснения требует свойство Владелец.

Любой справочник может использоваться как сам по себе, так и быть подчиненным какому-либо другому справочнику. Например, справочник договоров может использоваться отдельно, а может быть связан со справочником организаций.

Чтобы подчинить справочник какому-либо из справочников, уже существующих в системе, в поле «Владелец» следует выбрать наименование этого справочника. Такой справочник в системе 1С: Предприятие называется владельцем, а сам справочник — подчиненным.

В отличие от многоуровневого справочника, в котором все элементы имеют одинаковую структуру, использование механизма подчиненных-справочников позволяет связать элементы разной структуры. В этом случае каждый элемент подчиненного справочника - будет логически связан с одним из элементов справочника-владельца.

Размещать группы сверху — если свойство установлено, то при работе с системой 1С: Предприятие при отображении справочника в виде иерархического списка группы окажутся в верхних строчках списка, а элементы справочника будут располагаться ниже. Если это свойство не установлено, расположение групп и элементов будет подчиняться установленным правилам сортировки (по коду, наименованию и пр.). Например, при создании новой группы с кодом, большим, чем у всех имеющихся групп и элементов (при сортировке по коду), в первом варианте эта подгруппа окажется нижней среди групп, но выше остальных элементов справочника; во втором варианте она займет самую нижнюю строчку.

Следует отметить, что установка или снятие свойства Размещать группы сверху не влияет на показ справочника в виде не иерархического списка.

Количество уровней. Справочники в системе 1С: Предприятие могут иметь более одного уровня вложенности. Возможное количество уровней вложенности справочника устанавливается при помощи свойства Количество уровней. Максимальное количество уровней — 10.

Реквизиты. Любой новый справочник можно представить в виде таблицы, которая имеет две колонки: код элемента справочника и его наименование. Система 1С:Предприятие, помимо кода и наименования, позволяет хранить дополнительную информацию об элементе справочника. При редактировании справочника можно описать набор дополнительных реквизитов, предназначенных для хранения таких дополнительных сведений.

При показе справочника на экране эти реквизиты могут представляться в виде колонок в таблице справочника. Кроме этого, сведения, хранящиеся в реквизитах, можно использовать при формировании в различных расчетах, при формировании отчетов и так далее.

Используя механизм реквизитов справочника, легко организовать, например, картотеку сотрудников. Для этого достаточно для справочника «Сотрудники» создать реквизиты для хранения сведений об образовании, паспортных данных и прочей кадровой информации. Используя встроенные средства поиска в справочнике, при использовании конфигурации нужная информация о сотруднике может быть легко найдена.

Табличные части. Для описания некоторых данных, относящихся к справочнику и не используемых самостоятельно, используют табличные части. Примером табличной части может служить состав семьи сотрудника (данные по каждому члену семьи описываются в реквизитах табличной части, а число членов семьи может быть произвольным), послужной список сотрудника и т.д.

Если бы в приведенном примере сведения по составу семей сотрудников могли использоваться самостоятельно, то их можно было бы выделить в отдельный справочник, подчиненный справочнику сотрудники,

Каждый справочник может иметь неограниченное число табличных частей.

Формы. Для удобства работы пользователей со справочником на этапе конфигурирования можно создать несколько видов экранных форм для показа справочника. Например, для ввода элемента справочника, группы, для ведения списка элементов, для выбора элемента справочника при формировании различных документов, отчетов и т.д.

Макеты. Для просмотра и печати справочника предназначены макеты, размещаемые на ветви «Макеты» справочника.

На закладке «Данные» для создаваемого справочника указываются следующие данные:

Длина кода. Свойство устанавливает максимальную длину кода элемента справочника.

Конфигуратор позволяет установить длину кода, равной 0. Это может понадобиться в тех случаях, когда код элемента справочника не используется. Отсутствие кода экономит ресурсы системы 1С: Предприятие и незначительно ускоряет работу системы при записи элементов справочника.

При назначении этого свойства желательно реально определить возможную длину кода. Однако, следует иметь в виду, что в процессе эксплуатации конфигурации, если потребуется, длину кода можно увеличить.

Длина наименования. В свойстве устанавливается максимально возможная длина наименования элемента справочника.

Конфигуратор позволяет установить длину наименования, равной 0. Отсутствие наименования экономит ресурсы системы 1С: Предприятие и незначительно ускоряет работу системы при записи элементов справочника.

На закладке «Нумерация»:

Серии кодов. Свойство позволяет установить диапазон проверки кода на уникальность и автоматического присвоения кодов.

Если выбрана установка «Во всем справочнике», то при автоматическом присвоении кода или при вводе кода пользователем вручную уникальность кода будет проверяться среди всех элементов справочника.

Установка «В пределах подчинения» справедлива только для иерархических и подчиненных справочников. В этом случае уникальность кода будет проверяться системой только в пределах той группы и того элемента справочника-владельца, в которую вводится новый элемент справочника или редактируется уже существующий элемент.

При установке Серии кодов «В пределах подчинения» нормальной является ситуация, когда находящиеся в разных группах элементы справочника имеют одинаковые коды. Это следует учитывать, если требуется переносить элементы многоуровневого справочника из одной группы в другую. При совпадении кода переносимого элемента с кодом уже существующего элемента в группе будет выдано предупреждение, и элемент не будет перенесен.

Тип кода. Свойство позволяет выбрать тип значения для кода элемента справочника — «Число» или «Строка». Выбор строкового типа кода бывает полезен, когда используется сложная система кодирования, и код может включать, помимо цифр, также буквы и символы-разделители. Наиболее характерный пример — использование в качестве кодов артикулов для швейных изделий.

Следует обратить внимание, что выбор строкового типа кода не исключает возможности автоматического присвоения таких кодов.

Для самого первого элемента система формирует код вида «001» (количество нулей зависит от установленной длины кода), то есть код представляет собой строку символов, но все символы в этой строке являются цифрами. При вводе других элементов в справочник система будет продолжать присваивать коды аналогичным образом — «002», «003» и т. д.

Если требования к ведению справочника предполагают непременное использование смешанных буквенно-цифровых кодов, то для целей автоматической нумерации можно использовать коды вида «АА001». Здесь первая часть кода — символы «АА» — является текстовым префиксом, а вторая часть — символы «001» — будет интерпретироваться системой как число и использоваться при автоматическом присвоении очередного кода.

Например, если самым первым кодом в справочник введен код «АА001», то следующим автоматически присвоенным кодом будет код «АА002», затем — «АА003» и так далее по возрастающей.

Текстовый префикс можно задать вручную (при вводе в справочник нового элемента ввести такой «составной» код) или использовать возможности установки префикса из встроенного языка системы 1С: Предприятие (метод УстановитьНовыйКод () ).

Автонумерация. Установка свойства приводит к тому, что вновь введенному элементу в справочнике код будет присваиваться автоматически. Автоматически присвоенный код можно исправить.

Контроль уникальности. Если код используется для однозначной идентификации конкретного элемента в справочнике, он должен быть уникальным (не должен повторяться). Если свойство Контроль уникальности установлено, проверка кода на уникальность будет проводиться автоматически при вводе в справочник нового элемента.

Редактирование — в свойстве выбирается способ ввода и редактирования элемента справочника. Если выбрать «В списке», то информация по выбранному элементу будет вводиться в форме списка. Если выбрать «В диалоге», то будет открываться отдельная форма элемента справочника.

Основное представление — в свойстве задается представление элементов справочника. Например, значения типа «Справочник-Ссылка», введенные в реквизит документа, справочника или константу, будут представляться в виде кода или наименования элемента справочника в зависимости от данного свойства.

Основные формы. Элементы справочника могут создаваться различным способом (в списке, в диалоге), при этом для элемента и группы справочника можно также задавать различные формы. Выбор значений элементов также может осуществляться с помощью специально разработанных форм. Если форм для ввода и выбора несколько, то в свойстве Основные формы можно указать основные формы для каждого вида действия.

Ввод на основании. На закладке «Ввод на основании» производится выбор объектов конфигурации, для которых элемент данного справочника является основанием для ввода и объекты конфигурации, на основании которых может вводиться справочник.

Примером ввода на основании может служить ввод документа «передача на реализацию» на основании элемента справочника «Товары».

Для создания процедуры, осуществляющей подготовку данных создаваемого объекта на основании образца см. раздел « Конструктор ввода на основании ».


Свойства справочника


Документы

Документ — одно из основных понятий системы 1С: Предприятие. При помощи документов организуется ввод в систему информации о совершаемых хозяйственных действиях.

В большинстве своем документы, которые создаются в процессе настройки конфигурации задачи, являются электронными аналогами стандартных бумажных документов, однако, использование этого типа данных может выходить далеко за рамки простой фиксации информации о хозяйственных операциях.

Каждый документ содержит информацию о конкретной хозяйственной операции и характеризуется своим номером, датой и временем. Дата и время — наиболее важные характеристики документов, так как позволяют устанавливать строгую временную последовательность совершения операций.

В конфигурации описывается только структура документа, конкретные экземпляры документов вводятся при работе с программой пользователем. Например, созданный в конфигурации документ «Накладная» при работе с системой 1С: Предприятие позволит формировать накладные, которые будут иметь разнос содержание, но одинаковый набор реквизитов, одинаковую логику поведения и так далее.

Далее для простоты вместо термина структура документа будет использоваться термин документ, подразумевая под этим средства для ввода и визуализации документа.

Конфигуратор позволяет описать структуру документа, организовать диалог для ввода информации в документ и описать алгоритм построения печатной формы документа.

Для работы с документами в Конфигураторе может быть создано необходимое количество журналов. При создании документа можно указать перечень журналов, в которых будет осуществляться работа с документам этого вида. Для документов разных видов можно указывать один журнал, что позволяет произвольным образом группировать документы в журналах. Назначенные документу журналы можно менять.


Свойства документа

Для работы с документами предназначена ветвь «Документы» дерева конфигурации. На этой же ветви располагаются служебные объекты конфигурации — нумераторы и последовательности.

Приемы создания, редактирования свойств и удаления объектов конфигурации типа «Документ» совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

В этом параграфе будут описаны специфические свойства документа, в дополнение к общим свойствам объектов конфигурации, о которых говорилось в п. « Основные свойства объектов конфигурации ».

Свойства документа редактируются в палитре свойств или окне редактирования «Документ». Данные по документу в окне редактора распределены на закладках. На закладке «Основное» размещены основные данные по документу.

На закладке «Журналы» в реквизите «Регистрируется в журнале» можно указать журналы, в которых будут отражаться документы данного вида при работе с системой 1С:Предприятие. Журналы необходимо создать заранее, как это сделать — см. п. « Создание объекта конфигурации ».

Объект «Документ» имеет набор подчиненных групп объектов «Реквизиты», «Табличной части», «Формы» и «Макеты».

Элементы диалога «Документ», объединенные в группу «Нумерация документа», используются для назначения правил нумерации документов.

У любого документа существует обязательные реквизиты, которые создаются автоматически и которые удалить нельзя — это дата, время и номер документа. В отличие от даты и времени, для номера документа можно задать несколько параметров, которые будут управлять поведением этого реквизита при работе с документами создаваемого вида. Совокупность этих параметров будет определять правила нумерации документов при работе системы 1С: Предприятие.

Автонумерация — установка свойства приводит к тому, что вновь введенному документу номер будет присваиваться автоматически. Автоматически присвоенный номер можно исправить.

Нумератор . Документу может быть назначен нумератор из числа уже существующих в конфигурации. Для назначения документу нумератора из числа существующих в конфигурации следует выбрать имя нумератора в свойстве Нумератор. В этом случае прочие элементы группы «Нумерация документа» диалога, за исключением свойства Автонумерация, становятся недоступными, то есть правила нумерации документов данного вида будут полностью определяться назначенным нумератором. О создании и свойствах нумераторов см. раздел « Нумераторы » .

Использование нумераторов позволяет организовать сквозную нумерацию документов разных видов. Для этого всем документам, для которых требуется иметь сквозную нумерацию, должен быть назначен один нумератор. Контроль уникальности и присвоение очередного номера будет выполняться с учетом всех документов, для которых назначен этот нумератор.

Длина номера — устанавливает максимальную длину номера документа.

Тип номера — свойство аналогично свойству Тип кода справочника (см. раздел « Свойства справочника »)

Контроль уникальности — если это свойство установлено, то при вводе нового документа его номер проверяется на уникальность в пределах, установленных в свойстве Периодичность.

Периодичность — свойство устанавливает пределы контроля уникальности номеров документов и период повторяемости номеров. Если свойство «Контроль уникальности номеров документов» установлено, то в свойстве Периодичность указывается, в каких пределах будет осуществляться этот контроль.

При установленном свойстве «Автонумерация» система 1С: Предприятие будет присваивать очередной порядковый номер каждому новому документу. После завершения периода, установленного в свойстве Периодичность, нумерация документов начнется с 1.

Основные формы. В группе свойств указываются основные формы для каждого вида действия.

На закладке «Ввод на основании» размещено два списка объектов конфигурации. В нижнем производится выбор объектов, для которых данный документ является основанием для ввода, а в верхнем объектов конфигурации, на основании которых может вводиться документ.

Для создания процедуры, осуществляющей подготовку данных создаваемого объекта на основании образца см. раздел « Конструктор ввода на основании ».

На закладке «Движения» производится настройка поведения при проведении и отмене проведения документа.

Проведение — свойство устанавливает, разрешено ли проведение документа при записи. Если выбрано «Разрешить», то документ осуществляет движения регистров (изменяет их состояние).

Удаление движений — свойство доступно, если в свойстве «Проведение» выбрано «Разрешить». Оно задает автоматическое удаление всех записей при перепроведении или отмене проведения документа, которые документ записал в процессе проведения.

Автоматическое удаление производится системой при выполнении повторного проведения уже проведенного документа (перед записью новых движений), при удалении документа и при отмене проведения документа.

Режим автоматического удаления является основным, однако, для некоторых видов документов данное свойство может быть отключено. Это позволяет в процессе повторного проведения уже проведенного документа выборочно удалять те движения, которые были сделаны при прошлом проведении документа. Выборочное удаление движений выполняется средствами встроенного языка в модуле документа.

Отключение режима автоматического удаления движений выполняется в специальных случаях для отдельных видов документов. Например, это позволяет при проведении расходной накладной записать движения только по последней введенной строке, оставив без изменений движения, сделанные по ранее введенным строкам.


Свойства документа


Нумераторы

Нумератор представляет собой объект конфигурации, описывающий правила нумерации документов: тип и длина номера документа, его периодичность, необходимость контроля уникальности.

Основное назначение нумератора — обеспечить возможность сквозной нумерации документов разного вида, для этого таким документам назначается одинаковый нумератор.


Нумераторы


Управление списком нумераторов

Вся работа с объектами конфигурации типа «Нумератор» ведется в окне «Конфигурация». Для нумераторов отведена отдельная ветвь дерева конфигурации, которая расположена «внутри» ветви «Документы» и начинается у ключевого слова «Нумераторы». Приемы создания, редактирования свойств и удаления нумераторов совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».


Управление списком нумераторов


Свойства нумератора

В этом параграфе будут описаны специфические свойства нумераторов, в дополнение к общим свойствам объектов конфигурации, о которых говорилось в п. « Основные свойства объектов конфигурации ».

Тип номера — выбирается тип значения для номера документа — числовой или текстовый. Выбор текстового типа номера бывает полезен, когда используется сложная система нумерации документов, и номер документа может включать, помимо цифр, также буквы и символы-разделители.

Длина номера — устанавливает максимальную длину номера документа.

Периодичность — свойство устанавливает две важные характеристики нумератора: пределы контроля уникальности номеров документов и период повторяемости номеров.

Если свойство «Контроль уникальности номеров документов» установлено, свойство «Периодичность» устанавливает, в каких пределах осуществлять этот контроль.

Например, если установлена периодичность «В пределах дня», то уникальность номеров документов будет контролироваться в пределах суток: на следующие сутки номера документов могут повторяться, но в пределах суток они будут уникальны.

При установленном свойстве «Автонумерация» (см. п. « Свойства документа ») система 1С:Предприятие будет присваивать очередной порядковый номер каждому новому документу. После завершения периода, установленного в свойстве «Периодичность», нумерация документов начнется с 1.

Контроль уникальности — если это свойство установлено, то при вводе нового документа его номер проверяется на уникальность в пределах, установленных в свойстве «Периодичность».


Свойства нумератора


Последовательности документов

«Последовательности документов» являются вспомогательными объектами конфигурации. Они предназначены для обеспечения проведения определенных документов в строгой хронологической последовательности.

Все документы в системе 1С:Предприятие образуют единую хронологическую последовательность. Для этого каждый документ имеет дату и время. Даже если два документа имеют одинаковую дату и одинаковое время, они все равно располагаются в определенной последовательности, определяемой моментом их ввода в систему. Дата и время документа могут быть изменены. Таким образом, независимо от порядка ввода документов, они могут быть, расположены в последовательности, отражающей реальную последовательность происходивших в хозяйственной жизни предприятия событий, которые данные документы отражают.

В системе 1С: Предприятие в процессе проведения документ выполняет некоторые действия, которые отражаются данным документом в различных механизмах учета, поддерживаемых 1С: Предприятием.

Алгоритм проведения документа, как правило, отражает в учете данные, записанные в самом документе (в его реквизитах и табличных частях). Однако в некоторых случаях алгоритм проведения документа анализирует также и текущие итоги, используя их при проведении. Например, если документ списывает товары или материалы по средней себестоимости, то для определения суммы списания алгоритм проведения будет анализировать остатки товаров (материалов) на момент документа. Если списание выполняется по методам LIFO или FIFO, то алгоритм проведения будет анализировать существующие остатки товаров (материалов) в разрезе партий на момент позиции документа, определяемой датой и временем проведения документа.

Очевидно, что документы, основывающиеся при проведении на данных итогов, должны проводиться строго последовательно. Однако на практике, из-за ошибок при вводе информации и несвоевременного поступления документов, часто приходится вводить или исправлять документы «задним числом». Разумеется, в этом случае движения регистров, сформированные всеми последующими документами (расположенными после того, который был исправлен), становятся некорректными. Например, если выяснилось, что в одной из приходных накладных, введенных в начале месяца, было неверно указано количество товара, то во всех последующих расходных накладных, списывающих имеющиеся в наличии партии, необходимо заново проанализировать остатки с учетом внесенных изменений и заново записать движения регистров. То есть все документы, анализирующие остатки и расположенные после измененного документа, должны быть перепроведены.

Для автоматического контроля необходимости перепроведения документов используются объекты ветви «Последовательности». Каждый введенный в конфигурации объект «Последовательность» обеспечивает контроль за порядком проведения документов указанных видов. Таким образом, в системе может существовать несколько независимых последовательностей.


Последовательности документов


Управление списком последовательностей

Работа по созданию объектов конфигурации типа «Последовательность» ведется в окне «Конфигурация». Для последовательности отведена отдельная ветвь дерева конфигурации, которая расположена «внутри» ветви «Документы» и начинается у ключевого слова «Последовательности». Приемы создания, редактирования свойств и удаления последовательностей документов совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».


Управление списком последовательностей


Свойства последовательности документов

В этом параграфе будут описаны специфические свойства последовательностей документов, в дополнение к общим свойствам объектов конфигурации, о которых говорилось в п. « Создание и удаление объекта конфигурации ».

Свойства последовательности редактируются в окне редактирования «Последовательность».

На закладке «Использование» выбираются документы, которые относятся к данной последовательности, и движения, влияющие на последовательность.

Документы, входящие в последовательность. В верхней части диалога «Последовательность» указываются виды документов, которые относятся к данной последовательности. Для выбора вида документа установите флажок в строке списка.

В качестве документов, на проведение которых будет влиять данная последовательность, следует выбрать те виды документов, которые при проведении будут анализировать состояние различных регистров. Например, такими документами могут быть расходные накладные, накладные на передачу на реализацию и т.д.

Движения, влияющие на последовательность. Одним из основных свойств последовательности является свойство «Движения, влияющие на последовательность». Оно определяет, какие из движений будут влиять на необходимость перепроведения документов данной последовательности, то есть движения или итоги каких механизмов учета используются документами данной последовательности при проведении. Например, в качестве таких движений могут выступать движения регистров.

Для настройки данного параметра следует в списке выбрать (отметить) те виды регистров, движения которых будут нарушать данную последовательность.

Измерения. Последовательности могут иметь подчиненные объекты, называемые измерениями.

Если для последовательности не создано ни одного измерения, то при восстановлении данной последовательности будут перепроводиться все входящие документы. Если требуется, чтобы данная последовательность учитывала не все, а вполне определенные ситуации, то в последовательность включают измерение. В этом случае перепроводить нужно будет только те документы, которые изменяют состояние регистра с учетом свойств измерения.

Например, последовательность учитывает изменение состояния регистров по документам «Приходная накладная» и «Расходная накладная». Если требуется учитывать дополнительные критерии необходимости перепроведения указанных документов (например, требуется перепроводить документы по определенному значению номенклатуры), то в последовательность следует добавить измерение. В палитре свойств измерения указать его тип (СправочникСсылка.Номенклатура) и установить связь с реквизитами регистров.

В соответствии с выбранным типом измерения, в списки документов и регистров измерения включаются для выбора только те объекты, в состав которых входят указанные типы измерения.

Введение измерения позволяет ускорить процесс перепроведения документов, что особенно важно при значительном числе документов, т.к. будут перепроводиться только те документы, которые содержат данные по указанному значению измерения.


Свойства последовательности документов


Работа с последовательностями документов

При работе в режиме «1С: Предприятие» для каждой введенной в конфигурации последовательности документов система будет автоматически поддерживать границу последовательности. В качестве границы последовательности будет выступать позиция документа. При последовательном проведении документов, входящих в данную последовательность, граница последовательности будет устанавливаться на каждый вновь проведенный документ. Однако, если будет проводиться документ, относящийся к данной последовательности, но расположенный позже другого проведенного документа, относящегося к той же последовательности и находящегося после текущей границы последовательности, то граница последовательности сдвигаться не будет, так как нарушается последовательность проведения документов. Эта ситуация может быть проанализирована алгоритмом проведения документа.

При проведении документов задним числом, а также отмене проведения или удалении документов, если удаляются или записываются движения регистров, указанным как влияющие на данную последовательность, граница последовательности отодвигается на момент измененного документа.

Таким образом, граница последовательности будет продвигаться вперед при последовательном проведении относящихся к данной последовательности документов, и будет отодвигаться назад при изменении задним числом относящихся к данной последовательности движений регистров.

В режиме перепроведения документов (вызывается выбором пункта «Операции — Проведение документов») существует специальная возможность восстановления последовательности проведения документов. При ее использовании система автоматически выполняет перепроведение всех документов, относящихся к данной последовательности от границы последовательности, до указанного момента.

В приведенном нами примере с учетом товаров, проводимые расходные накладные будут сдвигать границу последовательности вперед. Любое изменение в движениях по регистру, на котором ведется стоимостной учет товаров, записанное раньше границы последовательности, будет отодвигать границу последовательности назад, на момент этого документа. После этого проводимые документы, находящиеся позже границы последовательности уже не будут двигать ее вперед, если между границей последовательности и проводимым документом окажутся проведенные документы из этой последовательности. Режим восстановления последовательности будет перепроводить все расходные накладные. Заметим, что приходные накладные, хотя и влияют своими движениями на границу последовательности, перепроводиться не будут, так как они не используют в алгоритме проведения остатков и не включены в список документов, относящихся к данной последовательности. После выполнения восстановления последовательности, проводимые после границы последовательности, документы снова будут двигать границу вперед.

Режим восстановления последовательности позволяет автоматически выполнить перепроведение всех документов, относящихся к последовательности от текущей позиции границы последовательности, до указанного момента. В верхней части диалога следует выбрать позицию, до которой будет выполняться перепроведение документа.


Работа с последовательностями документов


Ввод документов на основании

Одним из режимов ввода новых документов в процессе работы пользователя с системой 1С: Предприятие является режим ввода «на основании». С точки зрения пользователя, режим ввода «на основании» позволяет вводить документы, заполняя их реквизиты путем копирования информации из другого объекта информационной базы — документа или элемента справочника. В отличие от простого копирования документов, в результате которого создается документ того же вида, что и копируемый образец, режим ввода «на основании» позволяет создавать и переносить информацию в документ другого вида.


Ввод документов на основании

Ввод документов «на основании»


Организация ввода документов «на основании»

Для организации ввода документа «на основании» необходимо в диалоге редактирования объекта «Документ» на закладке «Ввод на основании» указать те объекты конфигурации, для которых данный вид документов может являться основанием.

Затем необходимо в модуле документа создать процедуру с зарезервированным именем ОбработкаЗаполнения (). Эта процедура выполняется:

• после выбора команды «Действия — Ввести на основании» и последующего выбора из списка нужного объекта-основания;

• после выбора пункта пользовательского меню, выполняющего команду «Ввод на основании». При вызове процедуры в качестве параметра ей передается объект-основание.

Текст этой процедуры должен быть разработан специалистом, осуществляющим конфигурирование системы. В тексте процедуры следует предусмотреть выполнение тех или иных операций по переносу информации — в зависимости от вида документа-образца, а также любые другие необходимые действия.

Для создания процедуры, осуществляющей подготовку данных создаваемого объекта на основании образца см. также раздел « Конструктор ввода на основании ».

Ввод документа на основании другого документа производится в журнале документов. Для этого необходимо выбрать документ, на основании которого будет создаваться новый документ, выбрать пункт «Действия — На основании» журнала и выбрать тип создаваемого документа. Данный пункт меню будет присутствовать только в том случае, когда журнал предназначен для документов, являющихся основанием для ввода других документов. Если журнал также содержит документы, не являющиеся основанием для ввода других документов, то при выборе такого документа в журнале данный пункт меню будет недоступен.

Примером сказанного может служить ввод документа «Расходная накладная» на основании документа «Счет».

По кнопке [image] выводится список типов документов, вводящихся на основании документа «Счет». После выбора типа документа на экран выводится форма нового документа «Расходная накладная», заполненного на основании документа-образца.


Организация ввода документов «на основании»


Журналы документов

В системе 1С: Предприятие журналы документов являются средством, позволяющем отображать документы разного вида в едином списке. Работая с журналом, пользователь может вводить документы, просматривать их, редактировать и удалять. Журналы позволяют группировать документы для просмотра и быстрого доступа к ним.

Пользователь может искать любой документ в журнале по содержимому граф, выполнять поиск документов по их номерам, осуществлять отбор документов по различным признакам.

Конфигуратор позволяет создавать любое необходимое число журналов.

При создании журнала для него создается экранная форма в виде таблицы, содержащей колонки для отображения вида документа, номера, даты и времени, а также дополнительных граф для отображения значений любых других реквизитов документов из числа, отображаемых в этом в журнале.


Создание журнала

Для работы с журналами документов предназначена ветвь «Журналы документов» дерева конфигурации. Приемы создания, редактирования свойств и удаления журналов документов совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

В системе 1С: Предприятие процессы создания журналов и размещения документов по конкретным журналам тесно связаны между собой. Указание отображения информации документа в определенном журнале синхронизировано с данными журнала о документах, информация о которых представлена в журнале.

При создании и журнала, и документов в список журналов и документов автоматически будет добавлен созданный журнал или документ. Для отражения данных документа в журнале необходимо или в журнале или в документе указать эту принадлежность. Указание принадлежности документа журналу можно производить как в журнале, так и в документе, т.к. эта операция синхронизирована.


Создание журнала


Редактирование журнала

В этом параграфе будут описаны уникальные свойства журналов, в дополнение к общим свойствам объектов конфигурации, о которых говорилось в п. « Основные свойства объектов конфигурации », и приемы редактирования объектов конфигурации типа «Журнал», отличные от общих приемов редактирования объектов конфигурации.

Формирование списка дополнительных граф и определение их состава выполняется в . Редактор имеет две закладки — «Основное», на которой вводятся основные свойства журнала, и «Прочее».

Каждый объект конфигурации типа «Журнал документов» может состоять из трех видов подчиненных объектов: Графы, Формы и Макеты . В Графах указывается общий реквизит всех документов, включаемый в журнал (см. параграф « Графы журнала документов »), на ветви Формы создается список экранных форм журнала, на ветви Макеты — список печатных форм.

На закладке «Данные» указывается, какие виды документов будут показываться в журнале.

Необходимо выбрать те документы, которые будут включаться в журнал. В свойстве Форма журнала указывается имя формы, используемой при вызове журнала по умолчанию.


Редактирование журнала


Графы журнала документов

Когда в Конфигураторе создается новый журнал документов, для работы с ним необходимо создать хотя бы одну форму журнала. Форма журнала создается с помощью конструктора форм (см. раздел « Конструкторы форм » ). Форма представляет собой таблицу, содержащую набор граф для показа различных реквизитов документов.

Так как журнал может хранить документы разных видов, при создании графы журнала требуется указать, значение какого реквизита того или иного документа будет помещаться в данную графу. Для выбора реквизитов документов, которые будут размещены в графе журнала, в палитре свойств графы в свойстве Ссылки нажмите кнопку выбора. На экран выводится диалог выбора реквизитов документов.

Укажите те реквизиты документов, данные которых должны отображаться в графе журнала.

Нельзя выбрать несколько реквизитов одного и того же документа.

Если реквизит какого-либо документа не выбран, то в данной графе журнала документов будет отсутствовать информация по всем документам этого вида. При выборе следует руководствоваться исключительно здравым смыслом и не смешивать в одной графе абсолютно разные понятия (например, наименование контрагента и сумму документа).

Помимо обязательных граф документов («Дата», «Номер», «Вид документа») и граф, указанных в подчиненной группе объектов журнала «Графы», в журнал можно добавить любое количество дополнительных граф. Новая графа добавляется в список граф выбранного объекта «Журналы», а затем с помощью пункта «Форма — Вставить реквизиты» производится вставка графы в форму.

Наличие в журнале дополнительных граф дает возможность пользователю получить наиболее важные сведения о документе уже при просмотре журнала, не открывая сам документ.


Графы журнала документов


Пример создания формы журнала

Предположим, что требуется создать форму журнала документов, в которой помимо списка документов находился список движений каждого проведенного документа. Формирование списка движений необходимо производить автоматически при смене строки в списке документов.

Выберем нужный журнал документов и с помощью конструктора форм (см. параграф « Конструкторы форм » ) создадим новую форму. Результат работы конструктора представлен на рисунке:

Разместим элемент управления типа «Табличное поле» и назначим ему тип значения «СписокРегистраНакопления.УчетНоменклатуры».

Имя «ТабличноеПоле!», задаваемое по умолчанию, заменим на «СписокРегистраНакопления».

Форма журнала будет выглядеть следующим образом:

Удалим колонку «Регистратор», т.к. в нашем случае регистратором будет являться текущий документ верхнего списка данной формы, и колонку «Активность». В палитре свойств списка документов в категории свойств События создадим процедуру-обработчик события Активация строки . В модуле формы введем следующий код в тело этой процедуры:

СписокРегистраНакопления .Отбор. Регистратор.Значение = ЭлементыФормы. Список .ТекущаяСтрока ;

Список — имя элемента управления списка документов;

Эта процедура будет запускаться каждый раз, когда в списке документов будет выбираться новая строка.

Для инициализации отбора в палитре свойств формы для события Перед открытием создадим предопределенную процедуру ПередОткрытием. В модуле формы в теле процедуры введем следующий код:

СписокРегистраНакопления.Отбор .Регистратор. Использование = Истина;

Форма журнала готова.

Если требуется ввести дополнительные критерии отбора (например, по контрагенту, по складу), то в форму следует добавить элементы управления типа «Поле ввода» для выбора этих значений. Полю ввода по выбору склада присвоим имя Склад, полю ввода по выбору контрагента — Контрагент.

В модуле формы для каждого поля ввода создадим предопределенные процедуры по событию «При изменении», устанавливающие отбор. По выбору склада —ВыбСкладПриИзменении(), по выбору контрагента — ВыбКонтрагентПриИзменении() .

Процедура ВыбСкладПриИзменении();

Если ВыбСклад. Пустая() Тогда

СписокДокументов .Отбор .ДокументыПоСкладу. Использование = Ложь;

СписокДокументов. Отбор .ДокументыПоСкладу . Значение = ВыбСклад;

Иначе

СписокДокументов. Отбор.ДокументыПоСкладу .Использование = Истина;

СписокДокументов . Отбор.ДокументыПоСкладу .Значение = ВыбСклад;

КонецЕсли;

СписокРегистраНакопления. Отбор .Регистратор . Значение = "" ;

КонецПроцедуры

Процедура ВыбКонтрагентПриИзменении ()

Если ВыбКонтрагент .Пустая () Тогда

СписокДокументов .Отбор. ДанныеПоКонтрагенту.Использование =Ложь;

СписокДокументов. Отбор.ДанныеПоКонтрагенту . Значение = ВыбКонтрагент ;

Иначе

СписокДокументов . Отбор. ДанныеПоКонтрагенту .Использование =Истина;

СписокДокументов. Отбор .ДанныеПоКонтрагенту . Значение= ВыбКонтрагент ;

КонецЕсли;

СписокРегистраНакопления. Отбор.Регистратор. Значение = "";

КонецПроцедуры

В режиме 1 С: Предприятие форма журнала будет выглядеть следующим образом .

Если не требуется специальной обработки выбора или активизации строки, то Конфигуратор позволяет установить просмотр списка регистра накопления без написания процедуры в модуле.

Для этих целей следует использовать свойство табличного поля Связь по регистратору (для справочников свойство Связь по родителю для иерархических справочников или свойство Связь по владельцу для подчиненных справочников). Для установки связи нажмите кнопку выбора свойства и в диалоге «Выбор связи» выберите событие (или объект), которое (выбор которого) приводит к отбору в списке.

Таким способом можно легко управлять отбором в списке. Для этого достаточно в форму разместить элемент управления «Поле ввода», назначить ему тип, например, справочника-владельца и в табличном поле в свойстве Связь по владельцу указать его для организации связи.


Пример создания формы журнала


Перечисления

Перечисление представляет собой служебный тип данных, который не используется самостоятельно, а применяется, в основном, в совокупности с другими типами данных. Определить перечисление можно как «список возможных значений реквизита».

Перечисления используются при вводе значений реквизитов документов, справочников, при вводе значений констант, в тех случаях, когда необходимо исключить неоднозначный ввод информации.

Рассмотрим в качестве примера такое понятие, как «статус покупателя». В простейшем случае покупатели бывают розничные и оптовые. Со статусом покупателя обычно связывают уровень предоставляемых скидок с продажной цены товаров.

Такой список «статусов» — «розничный», «оптовый» — может служить примером простого перечисления. При выписке расходной накладной от пользователя системы требуется указать статус покупателя, выбрав его из этого списка. Выбранный статус покупателя, в свою очередь, определяет размер продажных цен.

Если статус покупателя вводится в процессе настройки конфигурации задачи как перечисление, то специалист, выполняющий конфигурирование системы 1С: Предприятие, может заранее ввести варианты расчета продажных цен в зависимости от указанного статуса.

Прежде всего, перечисление не может пополняться в процессе работы с ним: список его значений задается при настройке перечисления в Конфигураторе.

Перечисление не имеет вложенности — все его значения находятся на одном уровне.

Основное отличие состоит в том, что список значений перечисления известен и доступен в Конфигураторе — сама конфигурация использует конкретные значения перечисления.

С функциональной точки зрения, перечисление проще в настройке и в использовании.

Использование перечисления позволяет ограничить число возможных вариантов, например, при вводе реквизита документа. Так как список значений перечисления создается в Конфигураторе, то тут же, в Конфигураторе, можно организовать проверку выбранного значения и описать действия, которые должны за этим выбором последовать.


Редактирование перечисления

Для работы с перечислениями предназначена ветвь «Перечисления» дерева конфигурации. Приемы создания, редактирования свойств и удаления перечислений совпадают с общими приемами управления объектами конфигурации, изложенными в разделе « Создание и удаление объекта конфигурации ».

Редактирование перечисления заключается в создании списка значений перечислений. Для редактирования перечисления используется диалог редактирования объекта «Перечисление».

Список значений перечисления создается при настройке конфигурации.

Список значений перечисления в режиме «1С: Предприятие» используется следующим образом: каждое значение перечисления представляется синонимом, если синоним не задан, то используется его имя.

В приведенном на рисунке примере значение перечисления «ЧастноеЛицо» будет представляться в виде «Частное лицо» (по введенному синониму).


Редактирование перечисления


Отчеты и обработки

Любая система автоматизации учета только тогда выполняет свои функции, когда она имеет средства обработки накопленной в системе информации и получения сводных данных в удобном для просмотра и анализа виде. Как правило, для решения подобных задач в системе автоматизации учета существует возможность формирования отчетов. Конфигуратор позволяет формировать набор различных отчетов, достаточных для удовлетворения потребности пользователей системы в достоверной и подробной выходной информации.

Для получения сводной выходной информации в системе 1С: Предприятие используются объекты конфигурации, называемые «Отчет». Объект этого типа содержит алгоритм формирования «бумажного» или «электронного» отчета на внутреннем языке системы 1С: Предприятие. Отчет может содержать одну или несколько форм, при помощи которых, при необходимости, можно организовать ввод каких-либо параметров, влияющих на ход алгоритма. Обычно отчет имеет и сделанные в табличном редакторе описания печатных форм (макеты), которые используются для вывода результатов выполнения алгоритма на экран и принтер.


Редактирование свойств отчета

Для работы с отчетами предназначена ветвь «Отчеты» дерева конфигурации.

Приемы редактирования свойств отчета совпадают с общими приемами редактирования свойств объекта конфигурации, изложенными в п. « Создание и удаление объекта конфигурации ».


Редактирование свойств отчета


Обработки

Для выполнение различных действий над информацией в системе 1С: Предприятие используются объекты конфигурации, называемые «Обработка». Например, с их помощью можно выполнять удаление из системы устаревших данных, импорт информации из других систем и многое другое. Характер выполняемых в этом случае действий отражает название объекта конфигурации — «Обработка», так как в результате информация, хранящаяся в системе, претерпевает какие-либо изменения.

Обработка может содержать одну или несколько форм, при помощи которых, при необходимости, можно организовать ввод каких-либо параметров, влияющих на ход алгоритма. Обычно обработка имеет сделанные в табличном редакторе описания печатных форм (макеты), которые используются для вывода результатов выполнения алгоритма на экран и принтер.

С точки зрения структуры и организации работы обработка не отличается от отчета.

Но есть и отличия. Любую обработку можно выделить из конфигурации в файл специального формата и использовать в режиме 1С: Предприятие. Такие обработки называют «Внешними» (подробнее см. раздел « Внешние обработки »).

С объектами конфигурации типа «Обработка» допускается выполнение следующих действий:

• сохранить обработку как внешнюю обработку;

• заменить обработку на внешнюю обработку;

• сравнить обработку с внешней обработкой;

• объединить обработку с внешней обработкой;

• сравнить внешние обработки;

• объединить внешние обработки.

Подробнее об этом см. раздел « Внешние обработки и объекты конфигурации ».


Обработки


Сохранение и восстановление значений настроек отчетов и обработок

Отчеты и обработки запускают периодически, при этом значения многих параметров настроек повторяются для одного вида отчета или обработки. Кроме того, часто нужно видеть, с какими параметрами запускался тот или иной отчет в последний раз.

Режим автоматического сохранения и восстановления значений настроек задается в палитре свойств формы в категории Основные (форму нужно предварительно открыть). Если свойство Сохранять значение установлено, то для данной формы параметры будут сохраняться при закрытии формы. Выбор перечня параметров, подлежащих сохранению, производится в свойстве Сохраняемые значения. По кнопке выбора открывается диалог, в котором следует отметить нужные сохраняемые параметры. Для использования механизма сохранения и восстановления значений параметров следует дополнительно в панель инструментов формы поместить пункты (кнопки) восстановления и сохранения набора значений параметров. Пункты выбираются из перечня действий панели инструментов формы.


Сохранение и восстановление значений настроек отчетов и обработок


Внешние обработки

Внешней обработкой в системе 1С: Предприятие называется обработка, хранящаяся вне конфигурации, в отдельном файле внешней обработки. Внешняя обработка служит для решения тех же задач, что и объекты конфигурации типа «Обработка».

Основное преимущество внешней обработки — возможность ее проектирования и отладки в процессе работы системы 1С: Предприятие. В этом случае разработка и отладка обработки значительно ускоряются: редактирование и сохранение внешней обработки выполняется в режиме Конфигуратора, без сохранения конфигурации в целом, а запуск — в режиме 1С:Предприятие.

Для выполнения внешняя обработка загружается при помощи пункта «Файл — Открыть» и работает так же, как и любая другая обработка конфигурации.

Любой объект конфигурации типа «Обработка» может быть скопирован в файл внешней обработки и наоборот — форма объекта конфигурации может быть заменена формой внешней обработки.

Для внешней обработки может быть создано описание, как и для других объектов конфигурации.

Для обеспечения целостности конфигурации внешние обработки рекомендуется использовать, в основном, в отладочных целях. После отладки алгоритма формирования обработки необходимо включить внешнюю обработку в конфигурацию.


Внешние обработки


Создание внешней обработки

Для создания внешней обработки необходимо выбрать пункт «Файл — Новый» и в выданном на экран запросе выбрать строку «Внешняя обработка».

На экран будет вызван редактор форм для разработки внешней обработки.

Так как внешняя обработка не является частью текущей конфигурации (хотя и очень тесно с ней связана), процедура ее сохранения отличается от процедуры сохранения изменений, описанной п. « Открытие конфигурации ». Для сохранения внешней обработки необходимо использовать пункт «Файл — Сохранить» или «Файл — Сохранить как...». В стандартном диалоге сохранения файла выберите тип файла «Внешняя обработка (*.epf)» и введите имя для сохраняемого внешней обработки.


Создание внешней обработки


Использование внешних обработок

Для использования внешней обработки при работе с системой 1С: Предприятие ее необходимо открыть так же, как это делается в Конфигураторе. Однако следует иметь в виду, что в системе 1С: Предприятие внешняя обработка открывается только для исполнения: пользователь не может его редактировать.

Компиляция модуля внешней обработки выполняется при открытии внешней обработки, поэтому после редактирования внешней обработки в Конфигураторе и ее сохранения необходимо вновь открыть эту обработку в системе 1С: Предприятие.


Использование внешних обработок


Редактирование внешней обработки

Редактирование внешней обработки выполняется в Конфигураторе.

Чтобы открыть существующую внешнюю обработку, выберите пункт «Файл — Открыть». В выданном на экран стандартном диалоге выберите тип файла «Внешняя обработка (*.epf)» и укажите имя открываемого файла внешней обработки.

При открытии внешней обработки в Конфигураторе автоматически открывается диалог редактирования объекта. В отличии от других объектов конфигурации отладка внешней обработки может производиться без перезапуска 1С: Предприятия. Достаточно после сохранения обработки заново вызвать ее на выполнение.


Редактирование внешней обработки


Описание формы внешней обработки

Форма внешней обработка может быть снабжена пользовательским описанием (см. параграф « Категория свойств справочная информация »).

Для редактирования описания в палитре свойств формы внешней обработки щелкните ссылку Открыть свойства Справочная информация.

В режиме запуска «1С: Предприятие» для просмотра описания внешнего отчета необходимо нажать клавишу F1. Чтобы описание формы упоминалось в содержании помощи, нужно установить свойство Включать содержание помощи.


Описание формы внешней обработки


Внешние обработки и объекты конфигурации

Существующие в конфигурации объекты конфигурации типа «Обработка» могут быть преобразованы во внешние обработки, и наоборот, внешние обработки могут заменять собой существующий объект конфигурации типа «Обработка». Также внешние обработки могут быть добавлены в структуру конфигурации как новые объекты конфигурации типа «Обработка».


Внешние обработки и объекты конфигурации


Копирование обработки во внешнюю обработку

Существующий объект конфигурации типа «Обработка» может быть скопирован во внешнюю обработку. Для этого выделите наименование объекта конфигурации в окне «Конфигурация» и в контекстном меню объекта конфигурации выберите пункт «Сохранить как внешнюю обработку». Затем в выданном на экран стандартном диалоге сохранения файла выберите тип файла «Внешняя обработка (*.epf)» и укажите имя файла внешней обработки.

В результате будет создана внешняя обработка, которая будет скопирована с выбранного объекта конфигурации, сам объект конфигурации при этом не изменится.

Выполнение этой операции целесообразно для последующей отладки создаваемой обработки. По окончании отладки внешняя обработка может быть вставлена в конфигурацию взамен существующего объекта конфигурации.


Копирование обработки во внешнюю обработку


Замена обработки на внешнюю обработку

Внешняя обработка может заменить собой существующий объект конфигурации типа «Обработка».

Для замены объекта конфигурации внешней обработкой необходимо выделить его наименование в окне «Конфигурация» и использовать пункт «Заменить на внешнюю обработку» контекстного меню объекта конфигурации. Затем в выданном на экран стандартном диалоге открытия файла выберите тип файла «Внешняя обработка (*.epf)» и укажите имя файла внешней обработки.


Замена обработки на внешнюю обработку


Добавление внешней обработки в структуру конфигурации

Существующая внешняя обработка может быть вставлена в структуру конфигурации как новый объект конфигурации типа «Обработка». Для этого необходимо в структуре конфигурации выделить наименование любого объекта конфигурации типа «Обработка» и использовать пункт «Вставить внешнюю обработку» контекстного меню объекта конфигурации. В выданном на экран стандартном диалоге открытия файла необходимо выбрать тип файла «Внешняя обработка (*.epf)» и указать имя файла внешней обработки, которую требуется вставить в структуру конфигурации.

В результате этих действии в дереве конфигурации появится новая обработка.


Добавление внешней обработки в структуру конфигурации


Сравнение и объединение внешних обработок

Внешние обработки можно сравнивать и объединять с обработками, расположенными в конфигурации, а также сравнивать и объединять с другими внешними обработками.

Для объединения с обработкой конфигурации в окне «Конфигурация» укажите нужную обработку, в контекстном меню выберите пункт «Объединить с внешней обработкой». В стандартном диалоге выбора файла выберите нужную внешнюю обработку.

На экран выводится окно «Объединение». Приемы работы: в окне полностью совпадают с приемами работы при объединении конфигураций (см. главу « Сравнение и объединение конфигураций »).

Для сравнения или объединения внешней обработки с другой внешней обработкой откройте исходную внешнюю обработку и в диалоге редактирования нажмите кнопку «Объединить с внешней обработкой». В стандартном даалоге выбора файла выберите нужную внешнюю обработку. Дальнейшие действия описаны в главе « Сравнение и объединение конфигураций » .


Сравнение и объединение внешних обработок


Регистры

Регистры 1С: Предприятия предназначены для хранения и обработки различной информации, отражающей хозяйственную или организационную деятельность предприятия, но не имеющей объектной природы.

Объекты информационной базы типа «документ» и «справочник» предназначены для хранения информации об объектах предметной области, таких как сотрудники, товары, материалы, валюты. Соответственно, каждый объект базы данных отражает соответствующий объект предметной области.

В регистрах обычно хранится информация об изменении состояний объектов или другая информация, не отражающая непосредственно объекты предметной области. Например, в регистрах может храниться информация о курсах валют или информация о приходе и расходе товаров.

Объект базы данных существует независимо от значений его полей и имеет самостоятельную ценность. Например, у сотрудника может поменяться фамилия, номер паспорта и любые другие поля. При этом он будет оставаться тем же самым физическим лицом.

Объект нельзя после удаления создать заново. Даже если завести все его поля в соответствии с удаленным объектом, то это будет уже другой объект. Для объекта система хранит внутренний идентификатор — ссылку. Ссылка уникальна в пределах всей информационной базы. Двух объектов с одинаковыми ссылками не может существовать на всем протяжении жизни информационной базы. Ссылки удаленных объектов не присваиваются вновь созданным объектам. Система предоставляет возможность хранить в полях базы данных ссылки на объекты базы данных.

Единицей хранения информации в регистрах является запись. Прикладная нагрузка записи регистра определяется исключительно хранящими в ней данными. Например, сама запись о курсе валюты не представляет собой ничего существенного. Она не со ответствует никакому объекту в предметной области. Существенным является только то, что в ней содержится: валюта, дата и курс валюты, установленный на эту дату. Можно удалить эту запись и внести такую же — это не повлияет на логику работы системы. Соответственно, у записей регистров не существует ссылок и в полях базы данных нельзя хранить ссылки на записи регистров.


Регистры сведений

В этом разделе будет рассказано о понятии «регистр сведений» и об основных принципах использования этих регистров.


Регистры сведений


Общая информация о регистрах сведений

Основная задача регистра сведений — хранить существенную для прикладной задачи информацию состав которой развернут по определенной комбинации значений и при необходимости развернут во времени. Например, если мы хотим хранить информацию о ценах конкурентов на продаваемые нами товары, то собранная информация о ценах разворачивается по товарам и конкурентам. А если мы хотим отслеживать динамику изменений цен, и будем заносить их периодически, то хранимая информация разворачивается также и во времени.

В системе «1С: Предприятие» для хранения подобных данных и работы с ними используется специальный механизм — регистры сведений.

Регистр сведений, фактически, представляет собой массив данных, необходимый, чтобы реализовать функцию, которая может выдать необходимую информацию по определенному набору аргументов. Аргументы функции называются измерениями, а результат функции — ресурсами. В приведенном выше примере регистр «ЦеныКонкурентов» будет содержать измерения «Конкурент» и «Товар», и ресурс «Цена». Ресурсов может быть больше чем один: например, можно хранить оптовую и розничную цены.

Для разворота этой информации во времени используется поле «Период» регистра. Оно не вносится в качестве измерения, а добавляется системой автоматически при создании периодического регистра.

Для периодических регистров сведений система поддерживает такие стандартные операции, как получение наиболее позднего или наиболее раннего значения по определенной комбинации измерений (например, получение последней введенной цены по конкретному товару и конкретному конкуренту), а также получения среза наиболее поздних или ранних значений. Например, могут быть получены все последние введенные цены по различным товарам и конкурентам.

Наиболее характерный пример периодической величины — курс валюты. При выполнении каких-либо расчетов (например, при определении рублевой цены пересчетом валютной цены по курсу) важно знать его величину на момент вычисления.

Особенно важно знать курс валюты при выполнении каких-либо расчетов «задним числом» — в этом случае необходимо «вспоминать» курс за уже прошедшие даты.

Чтобы иметь возможность получать подобные сведения, необходимо создать таблицу, графами в которой были бы, очевидно, наименование валюты, дата курса, и сама величина курса. Строки такой таблицы содержат курс определенной валюты на конкретную дату.

Дата | Валюта | Курс
31.01.2002 | USD | 30,1372
31.01.2002 | EUR | 26,5456
28.02.2002 | USD | 30,9404
28.02.2002 | EUR | 26,7120
30.03.2002 | USD | 31,1192
30.03.2002 | EUR | 27,1515

При обращении к подобной таблице следует иметь в виду, что в колонке «Курс» хранятся конкретные величины курса на опреде енную дату, и подразумевается, что на все последующие даты, до новой величины курса, курс не меняется. Поэтому для получения курса на какую-то промежуточную дату следует брать величину курса на ближайшую предыдущую дату, на которую сущтетвует записанный курс.

Также следует понимать, что различные значения валют в колонке «Валюта» фактически означают, что ведется параллельная история курсов нескольких валют. Иначе говоря, приведенную выше таблицу можно отобразить по-другому:

Дата | Курс USD | Курс EUR
31.01.2002 | 30,1372 | 26,5456
28.02.2002 | 30,9404 | 26,7120
30.03.2002 | 31,1192 | 27,1515

Подобных колонок курсов в таблице может быть столько, сколько курсов разных валют требуется хранить.

Если регистр не периодический, то поле «Период» для него не создается. В приведенном примере регистр «ЦеныКонкурентов» может быть непериодическим, если мы не хотим хранить историю изменения цен, а хотим иметь только актуальные цены. Тогда функция регистра сможет ответить на вопрос «какая сейчас цена у такого-то конкурента на такой-то товар», но не сможет ответить на вопрос «какая была цена у такого-то конкурента на такой-то товар в начале года».

Из описанных принципов работы регистра сведений вытекает то, что в системе может быть только одна запись с определенным набором и периодом измерений. Действительно, по одному товару по одному конкуренту может быть только одна цена. Если по какой-либо причине мы можем получить несколько цен и хотим занести эту информацию в базу данных, то нам нужно создать еще одно измерение для хранения того значения, по которому эти цены могут различаться. Например, можно завести измерение «ИсточникИнформации». Тогда можно будет вводить цены конкурентов в разрезе источников.

Уникальность записей по набору измерений принципиально отличает регистры сведений от регистров накоплений, которые позволяют вводить несколько записей с одинаковым значением измерений и периодом.


Общая информация о регистрах сведений


Записи регистра сведений

Строки регистра сведений, содержащие информацию о значениях ресурсов для определенных значений измерений и конкретного периода, называются записями. Записи в регистр сведений можно вносить двумя способами: вручную или документами.

Эти два варианта влияют на способ внесения информации, а не на основную логику работы регистра.

Документ, которым вносится запись в регистр сведений, называется регистратором.

Регистры, записываемые независимо, могут свободно редактироваться вручную или средствами встроенного языка. При этом, если измерение такого регистра назначено как «ведущее» и значением измерения является ссылка на объект базы данных, то будет считаться, что запись регистра имеет смысл, только пока существует этот объект. Например, если назначить ведущим измерение «Конкурент», то считается, что запись имеет смысл только как информация по данному конкуренту. Соответственно, при удалении конкурента записи по нему будут удалены автоматически.

Если регистр записывается регистратором, то это значит, что записи будут жестко подчинены регистраторам — документам. Обычно это значит, что записи будут порождаться при проведении документов. Соответственно, при удалении документа записи будут удаляться автоматически. В отличие от ведущих измерений, регистратор может быть только один.


Записи регистра сведений


Редактирование регистра сведений

Для работы с регистрами сведений предназначена ветвь «Регистры сведений» дерева конфигурации. Приемы создания, редактирования свойств и удаления регистров сведений совпадают с общими приемами управления объектами конфигурации, изложенными в параграфе « Создание и удаление объекта конфигурации ».

При редактировании регистра определяются его свойства, разрабатывается структура регистра: создаются наборы измерений, ресурсов и реквизитов регистра, создаются экранные формы просмотра и редактирования записей регистра, и, если необходимо, печатные формы регистра.

В этом разделе будут описаны уникальные свойства регистра сведений, в дополнение к общим свойствам объектов конфигурации, о которых говорилось в параграфе « Свойства объекта конфигурации ».

Регистр редактируется в диалоге редактирования « Регистр сведений». Свойства регистра собраны на закладках:

Периодичность . Это свойство позволяет указать, с какой периодичностью регистр должен сохранять значения ресурсов.

Это свойство напрямую влияет на возможность получения значений ресурсов регистра методами встроенного языка. Для непериодического регистра можно получить только последнее введенное значение ресурсов регистра — информация за предыдущие периоды в таком регистре отсутствует. Для периодических регистров нельзя получить значение с периодичностью меньшей, чем установленная периодичность регистра.

Периодичность не зависит от способа редактирования регистра.

Режим записи . Свойство определяет, каким образом будут вноситься записи в регистр: вручную или документами.

Основные формы записи и списка. Группа управляющих элементов позволяет указать, какие формы будут использоваться в качестве форм по умолчанию, соответственно, для просмотра набора записей и редактирования отдельной записи регистра сведений.

Редактирование . Редактирование записи регистра сведений может выполняться пользователем либо только в списке записей регистра, либо только в форме записи регистра, либо способ редактирования может быть выбран самим пользователем в процессе работы со справочником. Свойство задает способ редактирования записи


Редактирование регистра сведений


Разработка структуры регистра сведений

Разработка структуры регистра заключается в создании наборов измерений, ресурсов и реквизитов.

Для управления списком измерений, ресурсов и реквизитов регистра и редактирования их свойств служат управляющие элементы групп «Измерения», «Ресурсы», «Реквизиты» окна редактирования «Регистр». С точки зрения настройки элементы этих групп одинаковы. Про порядок использования этих управляющих элементов можно прочитать в разделе « Создание и удаление объекта конфигурации ».


Разработка структуры регистра сведений


Свойства измерения (ресурса, реквизита) регистра сведений

Свойства измерений, ресурсов и реквизитов редактируются при помощи палитры свойств. В основном они совпадают с общими свойствами объектов конфигурации, о которых говорилось в п. « Свойства объекта конфигурации » . Ниже в этом параграфе будут описаны уникальные свойства измерений, ресурсов и реквизитов.

Ведущее. Установка этого свойства имеет смысл для измерений, тип данных которых — ссылка на объект конфигурации. В этом случае считается, что запись регистра сведений имеет смысл, только пока существует этот объект. При удалении объекта записи по нему из регистра будут удалены автоматически.

Запрет пустых значений . Установка этого флажка включает механизм запрета записи регистра с пустым значением измерения.

Индексировать . Свойство доступно для редактирования, если измерение не является ведущим (см. выше). Для таких измерений создается отдельный индекс, что увеличивает производительность при работе с регистром.

При просмотре регистра в режиме «1С: Предприятие» существует возможность сортировать записи регистра по индексированному измерению. Необходимое число форм для просмотра и редактирования регистра должно быть создано в процессе разработки конфигурации.


Свойства измерения (ресурса, реквизита) регистра сведений


Упорядочивание списка измерений регистра сведений

Порядок расстановки измерений регистра сведений имеет важное значение.

Измерения, к которым необходим быстрый доступ, следует располагать в начале списка измерений.

Последовательность расстановки измерений регистра сведений влияет на возможность применения методов встроенного языка, использующих позиционный доступ к измерениям.

Также необходимо иметь в виду, что изменение порядка измерений требует реструктуризации информационной базы.

Важно. Изменение порядка измерений регистра может потребовать внесения изменений в строки программных модулей, в которых осуществляется обращение к этому регистру.


Упорядочивание списка измерений регистра сведений


Регистры накоплений

Регистры в системе 1С: Предприятие используются для накопления информации о наличии и движении средств — товарных, денежных и других. Вся информация о хозяйственных операциях, которая вводится с использованием документов или формируется при помощи расчетов, должна быть накоплена в регистрах. Тогда эту информацию можно будет извлечь, проанализировать и представить пользователю в виде отчетных форм.

В этом разделе будет рассказано о понятии «регистр накопления» и даны сведения об основных принципах использования


Регистры накоплений


Общая информация о регистрах накопления

Регистр накопления — это объект конфигурации, предназначенный для хранения итоговой информации.

Проблема, которая обычно возникает при создании «хранилища» сводной информации, состоит в определении его структуры: в каких разрезах следует накапливать сводные данные, чтобы затем можно было извлечь нужную информацию без утомительной обработки?. Система 1С:Предприятие использует простые и, в то же время, гибкие средства для создания регистров накопления: достаточно просто задать, в каких разрезах и какие данные требуется хранить в регистре, а система сама обеспечит запись и получение нужных данных простыми языковыми средствами.

Рассмотрим пример. Предположим, что в создаваемой программе торгово-складского учета требуется хранить сведения о количестве и стоимости каждого товара на каждом складе. В дальнейшем предполагается получать информацию такого типа: «остаток конкретного товара на конкретном складе», «остаток конкретного товара всего, на всех складах», «стоимость всех товаров на конкретном складе». В идеологии системы 1С:Предприятие регистр накопления такого вида представляет собой прямоугольную систему координат, на одной оси которой находятся склады, на другой — товары, а на пересечении конкретного склада и конкретного товара находятся цифры количества товара и стоимости товара.

Физический смысл регистра накопления сформулировать довольно сложно, и скорее всего, регистр накопления не имеет материального аналога. Поэтому определим, что регистр накопления — это переменная система координат, в узлах которой хранятся совокупные данные. Оси такой системы координат будем называть измерениями регистра, а хранящиеся в узлах данные — ресурсами регистра.


Общая информация о регистрах накопления


Движения регистра накопления

Регистр накопления недоступен пользователю для интерактивной работы с ним: для записи информации в регистры накопления и ее последующего извлечения используются исключительно средства встроенного языка.

Изменение состояния регистров накопления выполняется обычно при проведении документа, процедура проведения документа содержится в модуле документа. Такая процедура содержит алгоритм формирования сведений об изменениях в регистрах, которые необходимо выполнить при проведении документа. Эти сведения называются движениями регистра. Механизм подсчета итогов использует движения регистров для выполнения непосредственных изменений в регистрах накопления. Таким образом, движения регистров содержат только приращения (со знаком «плюс» или «минус») значений ресурсов регистра, а не итоговые величины значений.

Специалист, выполняющий конфигурирование системы, имеет возможность предоставить конечному пользователю средства просмотра движений регистров. Конфигуратор позволяет создавать экранные и печатные формы для просмотра и анализа движений регистров.

В процессе разработки конфигурации можно создать неограниченное количество регистров накопления. Однако, следует учитывать, что запись изменений в большом числе регистров при проведении документа может вызывать уменьшение скорости работы системы в целом.

Помимо измерений и ресурсов, для регистра накопления может быть создан набор реквизитов. Реквизиты позволяют включать в движения регистров различную дополнительную информацию. Реквизиты не влияют на значения ресурсов регистра и могут использоваться для анализа движений регистра.


Движения регистра накопления


Итоги регистра накопления

Как было написано выше, изменения в регистрах вносятся движениями регистра. Движения регистров оказывают влияние на его итоги. Итоги — это сводная информация регистров, которая получается путем суммирования значений, вносимых движениями регистров.

Итоги регистра накопления можно представить в виде таблицы с количеством колонок, равным сумме измерений и ресурсов регистра накопления. Количество строк таблицы будет зависеть от количества различных значений измерения и ресурсов:

Товар | Склад | Количество | Сумма
Стол | Розничный | 10 | 5000
Стол | Оптовый | 5 | 2500
Шкаф | Временный | 7 | 10500
Шкаф | Оптовый | 2 | 3000
Шкаф | Розничный | 10 | 1500

Из таблицы видно, что измерение «Товар» принимает значения «Стол», «Шкаф», а измерение «Склад» — «Временный», «Оптовый» и «Розничный». В колонках «Количество» и «Сумма», отражающих ресурсы регистра накопления, записаны количество и сумма каждого товара на каждом складе.

В отличие от движений регистра, нет возможности непосредственно просматривать итоги регистра накопления. Для обращения к итогам в конфигурации может быть создано необходимо число отчетов, который будут обращаться в итогами и выдавать их в виде товарных отчетов, складских карточек и ведомостей и т.д.


Итоги регистра накопления


Регистры остатков и регистры оборотов

В системе 1С: Предприятие возможно использование регистров накопления двух типов: регистры остатков и регистры оборотов.

Для регистра остатков методы встроенного языка позволяют получить остатки регистра накопления на заданный момент времени. Есть возможность фильтрации по значениям измерений, а также получения остатков в разрезе других измерений.

Регистры оборотов предназначены для хранения информации, для которой понятие остатка лишено смысла, например, сумм продаж в разрезе покупателей.

Рассмотрим в качестве примера отслеживание взаиморасчетов с покупателями товаров, которые производит или продает предприятие (потребителями услуг, оказываемых предприятием, и так далее). Можно утверждать, что ведение подобного учета — обязательная часть общего учета на любом предприятии.

Для того чтобы оперативно получать информацию о взаимной задолженности предприятия и покупателя, потребуется регистр «Взаиморасчеты», в котором для каждого покупателя будет храниться сумма задолженности. При совершении хозяйсгвенной операции состояние регистра будет соответствующим образом изменяться, каждый раз отражая текущее состояние взаиморасчетов. Регистр «Взаиморасчеты» — это регистр остатков.

Однако, быстро получить информацию об объеме закупок, совершенных данным покупателем за какой-либо период времени, из регистра «Взаиморасчеты» нельзя — он такой информации не хранит, и придется приложить дополнительные усилия для ее получения: например, можно включить в структуру регистра реквизит «Контрагент», а затем отбирать движения регистра по нужному контрагенту и вычислить общую сумму закупок. Но, когда необходимо получать эти сведения оперативно (например, при достижении определенного объема закупок покупателю должна предоставляться скидка), такой способ, конечно же, не подходит.

В этом случае решением проблемы может быть использование регистра оборотов. В таком регистре — назовем его «Объем закупок» — для каждого покупателя будет храниться информация об объеме закупок (об обороте покупателя).

Теперь, при совершении хозяйственных операций, необходимо будет изменять не только состояние регистра «Взаиморасчеты», но и регистр «Объем закупок». В этот регистр при совершении клиентом каждой покупки будет заноситься информация о сумме покупки. В результате в регистре «Объем закупок» будет постоянно накапливаться информация об общем объеме закупок клиента.

Из всего сказанного выше можно сделать выводы о преимуществах использования регистров.

Прежде всего, регистры используются для хранения информации, к которой требуется получать оперативный доступ. «Уровень оперативности» и, соответственно, целесообразность использования регистра должен определять специалист, выполняющий конфигурирование системы 1С: Предприятие, в соответствии с требованиями пользователей системы.

Также можно сказать, что регистры позволяют получать наиболее достоверную информацию о состоянии средств. Так как процессы сохранения документа и записи изменений в регистрах разделены (возможно сохранить документ, но не проводить его), может возникать расхождение между данными документов и информацией в регистрах. Но регистр, в отличие от документа, является хран и-лищем итоговой информации, поэтому именно запись изменений в регистры служит подтверждением того, что хозяйственная операция совершена.


Регистры остатков и регистры оборотов


Редактирование регистра накопления

Для работы с регистрами накопления предназначена ветвь «Регистры накопления» дерева конфигурации. Приемы создания, редактирования свойств и удаления регистров совпадают с общими приемами управления объектами, изложенными в параграфе « Создание и удаление объекта конфигурации ».

При редактировании регистра накопления определяется его вид, разрабатывается структура регистра: создаются наборы измерений, ресурсов и реквизитов регистра, если необходимо, создаются экранные и печатные формы просмотра движений регистра.

В этом разделе будут описаны уникальные свойства регистра накопления, в дополнение к общим свойствам объектов, о которых говорилось в параграфе « Свойства объекта конфигурации ».

Регистр редактируется в диалоге редактирования «Регистр накопления».

Оперативный (используется в оперативном учете). Установка этого свойства означает, что запись движений регистров выполняется в реальном времени. Граница актуальности для документов, записывающих в такой регистр, будет определяться только по оперативным регистрам.

Вид регистра. Если регистр предназначен для хранения остатков, выберите из списка значение «Остатки», если для хранения оборотов — значение «Обороты». Разница между регистрами остатков и оборотов рассматривалась .

Основные формы. Для регистра могут быть созданы несколько форм для просмотра его движений. Если форм для ввода и выбора несколько, то в свойстве «Основные формы — Списка» можно указать форму, которая будет использоваться по умолчанию.


Редактирование регистра накопления


Разработка структуры регистра накопления

Разработка структуры регистра заключается в создании наборов измерений, ресурсов и реквизитов.

Для управления списком измерений, ресурсов и реквизитов регистра и редактирования их свойств служат управляющие элементы групп «Измерения», «Ресурсы», «Реквизиты» окна редактирования «Регистр». С точки зрения настройки элементы этих групп одинаковы. Про порядок использования этих управляющих элементов можно прочитать в п. « Диалог редактирования объекта » .


Разработка структуры регистра накопления


Свойства измерения (ресурса, реквизита) регистра накопления

Свойства измерений, ресурсов и реквизитов редактируются при помощи палитры свойств. В основном они совпадают с общими свойствами объектов, о которых говорилось в п. « Свойства объекта конфигурации » . Ниже в этом параграфе будут описаны уникальные свойства измерений, ресурсов и реквизитов.

Тип данных . В отличие от измерений и реквизитов, объекты вида «Ресурс» могут хранить только один тип данных — «Число».

Запрет пустых значений. Установка этого флажка для измерения включает механизм запрета записи движений регистра с пустым значением измерения.

Индексировать. Данное свойство можно установить только для измерений. Установка свойства позволяет ускорить выполнение операций, обращающихся к данным регистра, например, в случае, если выбираются движения по конкретному значению данного измерения. К таким операциям относятся запросы с условием равенства данного измерения указанному значению, а также временный расчет и методы обхода движений объекта «РегистрНакопления» встроенного языка, использующие отбор по определенному значению измерения


Свойства измерения (ресурса, реквизита) регистра накопления


Упорядочивание списка измерений регистра накопления

Порядок расстановки измерений регистра накопления влияет на оптимизацию доступа к итогам регистра: измерения, к которым необходим быстрый доступ, следует располагать в начале списка измерений.


Упорядочивание списка измерений регистра накопления


Глава 5.Сравнение и объединение конфигураций

Режим сравнения и объединения конфигураций позволяет детально сравнить две конфигурации и объединить их. Возможно выборочное объединение по результатам сравнения.

Режимом объединения можно воспользоваться, например, в случае, когда одну конфигурацию параллельно разрабатывают несколько человек. Время от времени им необходимо объединять результаты работы (или хотя бы один раз объединить все результаты в конце разработки).

Режим сравнения и объединения конфигураций можно также использовать для сравнения двух конфигураций без объединения.

Наконец, в ситуации, когда в исходную конфигурацию нужно загрузить сделанные изменения, также полезно предварительно просмотреть и оценить их, воспользовавшись режимом сравнения и объединения конфигураций.

Сравнению в этом режиме подвергается как общие свойства объектов конфигураций, таких как справочники, документы, журналы, так и их отдельные реквизиты. Отдельно сравниваются формы объектов: тексты и макеты. При этом результаты сравнения общих свойств и текстов можно просмотреть детально, а по макетам и формам (диалогам) — только зафиксировать наличие различий.


Глава 5.Сравнение и объединение конфигураций


Условия сравнения конфигураций

При запуске режима сравнения программа производит анализ конфигураций и устанавливает взаимное соответствие объектов.

Объекты, которым «не досталось пары», могут быть либо новыми, либо удаленными, либо это объекты, относящиеся к одной категории, но называемые в разных конфигурациях по-разному. Для последних объектов соответствие можно установить интерактивно (см. параграф « Установка соответствия объектов » ).

При автоматической установке соответствия программа анализирует объекты конфигураций, имеющие одинаковые имена. Например, «Справочник.Товары» в одной конфигурации и «Справочник.Товары» в другой считаются одним справочником, им устанавливается соответствие и они будут сравниваться.

Среди объектов, имеющих разные имена, отдельно проводится сравнение внутренних идентификаторов, которые Конфигуратор присваивает автоматически при их создании. Присвоение внутренних идентификаторов необходимо для того, чтобы упростить установку соответствия объектов конфигураций и производить ее автоматически. Эта ситуация возникает, например, в том случае, когда в процессе развития конфигурации было изменено имя объекта. Если имена различны, а внутренние идентификаторы совпадают, то для таких объектов автоматически устанавливается соответствие.

Особым образом устанавливается соответствие форм. Форма может состоять из нескольких страниц. Сначала производится анализ по именам (не пустым); затем для страниц, имеющих разные имена, производят анализ по заголовкам страниц (не пустым), затем для страниц, имеющих разные заголовки, производят анализ по картинкам. Если установлено соответствие страниц, то будут сравниваться и объединяться расположенные в них элементы управления. Если соответствие страниц не установлено, то считается, что это разные страницы и в результирующей форме (после объединения) будут присутствовать все такие страницы отдельно.

Для страниц, у которых все три свойства (внутренний идентификатор, Заголовок и Картинка) пустые, будет производиться по парное объединение в соответствии с выбранным порядком следования.


Условия сравнения конфигураций


Запуск режима сравнения и объединения конфигураций

Как будет видно ниже, хотя сравниваемые конфигурации можно считать в основном равноправными (приоритет при объединении можно отдать любой из них), в определенном аспекте именно текущая конфигурация считается основной, в нее вносятся не повреждающие ее изменения из загружаемой конфигурации. Исходя из этих соображений, рекомендуется выбрать, какую из двух конфигураций сделать основной. Выбранная конфигурация становится основной, когда с ней запускается 1С:Предприятие в режиме Конфигуратора.

Загружаемую конфигурацию, которую можно будет сравнить и объединить с основной, необходимо предварительно сохранить в файл (см п. « Сохранение конфигурации в файл »).

Для загрузки второй конфигурации нужно выбрать пункт «Конфигурация — Объединение конфигураций». Появится стандартный диалог «Открыть файл конфигурации», в котором нужно найти и открыть файл с расширением *.cf загружаемой конфигурации.

Если основная конфигурация пустая (процесс конфигурирования еще не начинался), то Конфигуратор предложит выполнить полную загрузку конфигурации. При положительном ответе производится полная загрузка указанной конфигурации и открывается окно «Конфигурация». При отказе о полной загрузки производится сравнение конфигураций.

Процесс загрузки и сравнения загружаемой конфигурации с основной сопровождается сообщениями в строке состояния Конфигуратора. В этих сообщениях указываются объекты конфигураций, сравниваемые в настоящий момент. Также в строке состояния показывается индикатор процесса сравнения.

Процесс загрузки и сравнения может занимать продолжительное время, это зависит от размера сравниваемых конфигураций.


Запуск режима сравнения и объединения конфигураций


Окно Объединение конфигураций

После окончания процедуры сравнения на экран выводится окно «Объединение конфигураций». Оно позволяет:

• ознакомиться с тем, какие объекты в двух конфигурациях отличаются;

• выбрать объекты, по которым необходимо детально изучить различия;

• вызвать указанные объекты для просмотра и редактирования,

• задать, какие из объектов включить в объединение;

• установить соответствия объектов;

• установить режимы объединения конфигураций (для всей конфигурации или по каждому объекту);

• установить порядок подчиненных объектов (для всей конфигурации или по каждому объекту);

• сформировать отчет о различиях в конфигурациях;

• запустить процесс объединения конфигураций.

Окно (См. « Установка соответствия объектов ») содержит табличное поле, которое состоит из трех колонок. В первой колонке приводятся данные основной конфигурации (той информационной базы, которая открыта Конфигуратором), во второй колонке — данные загружаемой конфигурации, а третья предназначена для установки режима объединения и порядка подчиненных объектов.

В нижней части окна расположено поле выбора «Фильтр», с помощью которого выбирается режим просмотра изменений. При открытии окна «Объединение конфигураций» установлен фильтр «Показывать отличия в конфигурациях». Выбор других режимов позволяет изучить отличия в конфигурациях или совпадения.

При открытом окне «Объединение конфигураций» допускается производить просмотр и редактирование объектов основной и загружаемой конфигураций. Для редактирования свойств объекта укажите нужный объект в колонке основной или загружаемой конфигурации и в палитре свойств исправьте значение. Если редактируемый объект представляет собой форму, макет, интерфейс или другой «сложный» объект, этот объект можно открыть для редактирования с помощью выбора пункта «Открыть форму (макет / интерфейс)» из контекстного меню. Объекты основной конфигурация также можно выбрать для редактирования в окне «Конфигурация».

Если было произведено любое изменение (как в основной, так и в загружаемой конфигурациях), кнопка «Выполнить» становится недоступной и измененным объектам устанавливается статус «Неопределенный» (показывается серым фоном). При этом статус «Неопределенный» устанавливается также для всех объектов, связанных с измененным объектом. Чтобы продолжить работу в окне «Объединение конфигураций» следует нажать кнопку «Обновить». Конфигуратор производит повторное сравнение конфигураций и устанавливает соответствия объектов.


Окно Объединение конфигураций


Установка соответствия объектов

При сравнении конфигураций программа производит автоматическую установку соответствия объектов двух конфигураций друг другу. Так как соответствие производится по именам объектов, то в сравниваемых конфигурациях имена объектов могут совпадать. Однако суть объектов может быть разная. С другой стороны, имена могут быть различны, но суть объектов одна. В таких случаях для таких объектов нужно провести ручную установку соответствия объектов. Для отмены установленного соответствия выберите объект и в контекстном меню выберите пункт «Отменить соответствие объектов». При этом объектам устанавливается статус «Неопределенный». После завершения отмены соответствия для всех таких объектов нажмите кнопку «Обновить». Конфигуратор производит повторное сравнение конфигураций.

Для основной конфигурации объекты будут показаны бежевым фоном (присутствуют только в основной), для загружаемой — зеленым (присутствуют только в загружаемой).

Для установки соответствия выберите объект и в контекстном меню выберите пункт «Установить соответствие объектов». На экран выводится список объектов, с которыми допускается устанавливать соответствие. В список включаются объекты, совпадающие по виду, и для которых соответствие еще не установлено. Выберите объект и нажмите кнопку «ОК».


Установка соответствия объектов


Режим объединения

Режим объединения можно установить для каждого объединяемого объекта. Существует два вида режима: «Взять из загружаемой конфигурации» и «Объединять...», во втором случае обычно указывается приоритет конфигураций при объединении.

Выбор «Взять из загружаемой конфигурации» означает, что объект конфигурации будет добавлен, если он новый, или замещен, если он измененный. Причем переносится вся структура объекта, модули, описания, формы. При этом приоритет однозначно отдается загружаемой конфигурации.

При выборе метода «Объединять ...» происходящее при объединении конфигураций зависит от установленного приоритета.

Если из загружаемой конфигурации необходимо взять только новое и максимально сохранить старое, необходимо выбрать «Объединить» с приоритетом основной конфигурации. В этом режиме добавляются только новые объекты.

Тексты объединяются следующим образом:

Текст | Приоритет | Результат
Удаленное (имеется в основной конфигурации, отсутствует в загружаемой) | С приоритетом основной | Остается в тексте
Новое (имеется в загружаемой конфигурации и отсутствует в основной) |  | Добавляется
Измененное |  | Добавляется в виде комментариев из загружаемой конфигурации, а то, что было в основной, остается неизменным
Удаленное | С приоритетом загружаемой | Превращается в комментарии
Новое |  | Добавляется
Измененное |  | Измененное в основной конфигурации превращается в комментарии, а из загружаемой конфигурации — добавляется

Для модуля формы влияние выбора приоритета на результирующий текст можно проиллюстрировать следующим примером.

Текст модуля основной конфигурации:

Текст модуля загружаемой конфигурации:

Результат при объединении с приоритетом основной конфигурации:

Результат при объединении с приоритетом загружаемой конфигурации:

Для объектов, значения свойств которых определяются простым указанием в палитре свойств (например, Синоним, Комментарий), зависимость результата объединения от приоритета и наличия значений представлена в таблице:

Значение в основной | Значение в загружаемой | Приоритет конфигурации | Результат (значение выбирается из ...)
Задано | Задано | Приоритет основной | основной
Задано | Не задано |  | основной
Не задано | Задано |  | загружаемой
Задано | Задано | Приоритет загружаемой | загружаемой
Задано | Не задано |  | основной
Не задано | Задано |  | загружаемой

Если свойство какого-либо объекта может представлять результат составного значения объектов двух конфигураций (например, свойство Вводится на основании), то результат определяется простым объединением или выбирается из загружаемой конфигурации.

Макеты объединяются следующим образом:

Приоритет | Результат
Приоритет основной | Макет основной конфигурации остается
 | Макет загружаемой конфигурации добавляется, но, если его имя совпадает с именем макега основной конфигурации, оно изменяется (например, «Макет» -> «Макет!»); таким образом, по этому имени в объединенной конфигурации будет вызываться макет основной конфигурации, но макет загружаемой тоже не потерян.
Приоритет загружаемой | Макет загружаемой конфигурации добавляется
 | Макет основной конфигурации остается, но, если ее имя совпадает с именем макета загружаемой конфигурации, имя макета основной конфигурации изменяется (тем самым, макет основной конфигурации не потерян, но вызываться будет макет из загружаемой конфигурации).

Элементы управления, располагаемые в форме, не отображаются в окне «Объединение конфигураций» и, поэтому при объединении Конфигуратор производит анализ состава формы, определяет

список совпадающих (по именам) элементов управления, расположенных в пределах группы элементов (страница формы, элемент управления, который может содержать элементы управления, например, табличный документ) и, в зависимости от выбранного режима объединения, производит объединение. Новые элементы управления добавляются в форму. Совпадающие элементы (по именам) в основной форме будут заменены (заменяются свойства, размеры и расположение), если выбран приоритет загружаемой конфигурации, и оставлены без изменения, если выбран приоритет основной формы. Свойства элементов управления не объединяются. Элементы управления, имеющие одинаковое имя, но расположенные на разных страницах форм, при объединении будут присутствовать в форме, независимо от выбранного режима объединения.

Для некоторых объектов (реквизитов объектов) выбор режима объединения может отсутствовать. Так например, для реквизита с базовым типом (например «Число») режим объединения устанавливается только «Взять из загружаемой конфигурации».

Для некоторых объектов выбор приоритетности также может отсутствовать. Например, для свойства Подсистемы можно выбрать режим объединения «Взять из загружаемой конфигурации» и «Объединить». Если выбран режим «Объединить», то при объединении происходит простое объединение указанных подсистем двух конфигураций.


Режим объединения


Установка порядка подчиненных объектов

Для видов объектов, которые могут иметь неограниченное число подчиненных объектов (например, подчиненные объекты Реквизиты, Формы, Макеты, Табличные части справочников и документов), в некоторых случаях важен порядок следования объектов в каждой такой группе.

Если в процессе сравнения конфигураций Конфигуратор определил соответствие объектов, входящих в группу, но их порядок в конфигурациях различен, то в графе «Режим объединения и по рядок подчиненных объектов» можно указать нужный порядок следования объектов.

Для указания порядка выберите любой подчиненный объект и в третьей графе выберите вариант установки порядка: «Порядок из основной конфигурации» или «Порядок из загружаемой конфигурации».

Выбор порядка действует на все подчиненные объекты данного вида.

Если для выбранного объекта его подчиненные объекты изменены и расположены в другом порядке, то в третьей колонке можно выбрать только порядок. Режим объединения указывается в объекте верхнего уровня с помощью контекстного меню. Например, в обеих конфигурациях для документа «Счет» есть несколько подчиненных объектов типа «Формы». Они изменены и порядок их следования также изменен. Для выбора режима объединения укажите объект более высшего уровня («Формы» или «Счет») и в контекстном меню выберите нужный режим объединения.


Установка порядка подчиненных объектов


Просмотр различий

Перед объединением конфигураций полезно просмотреть конкретные различия их объектов.

Это можно сделать с помощью палитры свойств. Откройте палитру свойств и выберите нужный объект основной или загружаемой конфигурации. Для просмотра форм или макетов их можно открыть. При этом можно не просто просмотреть данные загружаемой конфигурации, но и внести в них необходимые исправления. Если исправления сделаны, то после окончания объединения Конфигуратор предложит сохранить сделанные в загружаемой конфигурации изменения.

Для просмотра различий в модулях в контекстном меню объекта выберите пункт «Показать различия в модулях».

При выборе пункта «Показать различия в модулях» открывается окно «Различие между: ...». Если сравниваемые тексты большие, перед открытием окна может пройти несколько секунд. Подробнее о просмотре различий см. параграф « Сравнение файлов » .


Просмотр различий


Отбор объектов и запуск процесса объединения

Указать, какие объекты при объединении конфигураций следует включить в процесс объединения, а какие исключить, позволяет флажок около каждого объекта в окне «Объединение конфигураций». Установленный флажок показывает, что данные объекты двух конфигураций будут объединяться.

Для включения всех или исключения всех объектов используйте установку или снятие пометки на имени конфигурации.

После просмотра изменений, выбора режима объединения и установки или снятия пометок включения в процесс объединения объектов конфигураций можно запустить процесс объединения кнопкой «Выполнить».


Отбор объектов и запуск процесса объединения


Глава 6.Редактор Форм

Форма — это специально созданный объект для ввода и просмотра какой-либо информации, а также для выполнения управления различными процессами. С помощью созданных форм программа запрашивает у пользователя ту информацию, которая необходима ей для дальнейшей работы, либо выдает какую-либо информацию пользователю для просмотра и редактирования.

Основное назначение формы — предоставить пользователю удобное средство для ввода и просмотра информации. Как и бумажный документ, форма позволяет быстро ввести необходимую информацию и запомнить ее для последующей обработки, а при необходимости — вновь вернуться к ранее введенным данным для просмотра или корректировки.

Форма состоит из диалога, модуля и реквизитов формы.

Диалог формы представляет собой прямоугольную область экрана, которая, в самом общем случае, содержит различные элементы управления; например, поясняющие надписи, поля ввода информации, элементы управления (например, кнопки) и т.д. С его помощью осуществляется взаимодействие пользователя с программой.

Модуль формы — программа на встроенном языке, отвечающая за работу с элементами управления формы, отработку предопределенных процедур и выполняющий различные вспомогательные вычисления. С помощью производится подготовка и обработка реквизитов формы и передача управления к исполнению, а также обработка действий пользователя.

Реквизиты формы — совокупность объектов различных типов, принадлежащих форме. В списке реквизитов есть главный реквизит (выделен жирным шрифтом), через который производится доступ к свойствам формы. Также список содержит реквизиты, размещенные дополнительно.

Окно для создания формы содержит три закладки, располагающихся снизу. На закладке «Диалог» производится проектирование собственно диалога формы. На закладке «Модуль» производится редактирование модуля формы. На закладке «Реквизиты» разработчик формы имеет возможность добавить новые реквизиты формы и указать им нужный тип.

Наиболее трудоемкая часть при создании формы — проектирование диалога, поэтому в настоящей главе основное место будет уделено описанию порядка создания и редактированию диалога формы.

В дальнейшем вместо термина диалог формы будет использоваться термин форма. Когда будет описываться работа в модуле формы или описание и использование реквизитов, будут использоваться термины модуль формы и реквизит формы или реквизиты формы.


Глава 6.Редактор Форм


Создание формы

Приемы создания и удаления формы, как объекта конфигурации, описаны в разделе « Создание и удаление объекта конфигурации ».

Для разработки форм объектов конфигурации используется специальный инструмент, называемый «Конструктор формы», который вызывается при создании нового объекта типа «Форма». Например:

• из диалога редактирования объекта конфигурации на закладке «Основное» — нажатием кнопки «Добавить»;

• из контекстного меню объекта конфигурации в окне «Конфигурация» выбором пунктов «Добавить».

Подробнее о работе конструктора « Конструкторы форм » .


Создание формы


Редактирование формы

Большинство видов объектов конфигурации имеют формы, с помощью которых производится ввод данных, ее просмотр и выбор, а также различные управляющие действия (например, построение отчетов).

Для редактирования формы выберите конкретный объект конфигурации, в списке форм укажите нужную форму и в палитре свойств в свойстве Форма нажмите ссылку Открыть.

Любая форма состоит из основной панели и элементов управления, размещенных на этой панели при создании формы. В форму можно вставлять другие панели, в которых также можно располагать другие элементы управления. Элементы управления можно также вставлять в элементы типа «Табличный документ» и «Табличное поле». Признаком размещения элемента управления является его перемещение вместе с элементом, в который он вставлен. Независимо от того, в каком элементе будет расположен элемент, он будет принадлежать форме. Поэтому обращение к этому элементу из модуля формы также не зависит от места его размещения (например: ЭлементыФормы. Список .ТекущаяСтрока , где Список — имя элемента управления).

Процесс редактирования формы заключается в выборе размеров, числа страниц и свойств формы, а также в размещении в пределах окна формы элементов управления различных типов, редактировании их свойств и настройке поведения элементов при изменении размеров формы.

Вставка в форму элементов управления описана в разделе «Вставка элементов управления в форму» на стр. 183.

Для редактирования окна формы вы можете использовать мышь или клавиатуру. При появлении редактируемой формы на экране становятся доступными кнопки панели инструментов «Редактор форм».

Установка правил поведения формы производится с помощью палитры свойств (см. раздел « Палитра свойств »). Описание свойств формы см. в разделе «Свойства формы» на стр. 226.


Редактирование формы


Страницы формы

Расположение закладок по границам формы и стиль написания заголовков страниц влияет на восприятие формы, придает форме собственный узнаваемый стиль, делает доступ к данным простым и понятным, а также позволяет разместить большой объем информации на ограниченной площади.

Например, если закладки содержат картинки или редко читаемый текст, то их можно разместить вертикально справа (европейский стиль), как алфавит в записной книжке, — в результате можно сэкономить немного места.

Расположение закладок снизу, скорее всего, будет к месту, если наиболее важные данные размещены на первой странице, а данные других страниц бывают редко востребованы. В этом случае внимание пользователя не будет отвлекаться чтением заголовков закладок (подсознательно просмотр осуществляется справа налево сверху вниз).

В некоторых случаях используют вложенные панели. При этом на странице формы располагается основной текст, остающийся неизменным, а на вложенной панели располагается информация, которая может листаться с помощью закладок вложенной панели. Сочетание вертикальных и горизонтальных основных закладок и закладок во вложенных панелях поможет визуально их отделять друг от друга. Листание закладок можно осуществлять из модуля с помощью методов встроенного языка.

При создании новой формы в ней создается главная панель, которая состоит из одной страницы. Если данных в создаваемой форме достаточно много, чтобы разместить их на одной с границе, или нужно подчеркнуть взаимозависимость параметров, их принадлежность к определенной логической группе, то в таких случаях в форму можно добавить новые страницы и на них расположить элементы управления.

Для добавления страницы в контекстном меню формы выберите пункт «Добавить страницу». Каждая страница может иметь закладку, щелкнув которую получают доступ к элементам управления, расположенным на этой странице. Закладка может иметь заголовок и картинку. Эти свойства задаются в палитре свойств в категории Текущая страница. Свойства можно не указывать, но для управления параметрами страницы, а также для облегчения процесса сравнения конфигураций (см. главу « Сравнение и объединение конфигураций »), хотя бы один из них рекомендуется указывать.

Расположение закладок и стилем их написания можно управлять (текст заголовка закладки может располагаться как горизонтально, так и вертикально, в заголовок можно добавить картинку или использовать только картинку и т.д.).

Расположение закладок определяется в палитре свойств формы в свойстве Отображение закладки категории Использование. Возможные варианты выбора: «Не отображать», «Сверху», «Сверху (с прокруткой)», «Сверху в несколько строк)», «Сверху (в несколько строк с перестановкой)», «Снизу», «Снизу (с прокруткой)», «Снизу в несколько строк)», «Снизу (в несколько строк с перестановкой)», «Слева (вертикально)», «Слева (горизонтально)», «Справа (вертикально)», «Справа (горизонтально)».

Порядком следования страниц также можно управлять. Для этого укажите нужную страницу и в контекстном меню формы выберите пункт «Сдвинуть вперед» или «Сдвинуть назад». Выбранная страница будет передвинута в соответствии с выбранной командой.

Ненужные страницы формы можно удалить. Для этого укажите нужную страницу и в контекстном меню формы выберите пункт «Удалить страницу».


Страницы формы


Рекомендации по оформлению

Чтобы формой было удобно пользоваться, она должна содержать нужные элементы управления, расположенные в определенном месте формы.

Размещение элементов управления должно выполняться осознано. Строго формализовать правила размещения невозможно, но некоторых рекомендаций стоит придерживаться.

Размещение элементов управления должно быть таким, чтобы информацию можно было легко читать и вводить. Элементы управления должны быть объединены в логические группы по смысловому содержанию. Порядок следования элементов должен соответствовать естественному порядку следования исходных данных.

Выравнивание границ элементов и их размеров, а также установка одинаковых вертикальных промежутков между ними воспринимается как принадлежность элементов к одной группе. Если в форме присутствует несколько групп элементов, то каждую группу желательно выделить (например, поместить в рамку, расположить в другой колонке или строке, сделать большим промежуток, установить текстовые или графические разделители).

Если создаваемая форма является виртуальным эквивалентом реального документа, то желательно располагать элементы управления в соответствии со структурой исходного документа.

Кнопки в форме должны быть единого размера. Нежелательно использование больших кнопок (они не воспринимаются как кнопки). Кнопки следует располагать в определенных местах и последовательности (в зависимости от вида формы). Наименования кнопок должны восприниматься однозначно. Использование картинок должно быть единообразным в различных формах и соответствовать смыслу действия, выполняемого при нажатии кнопки. Использование акселераторов и «горячих клавиш» также должно быть стандартизовано для различных форм.

При создании надписей желательно использовать одинаковые шрифты. Использование другого шрифта будет являться дополнительным средством привлечения внимания (например, заголовок группы элементов управления). Надписи, относящиеся к элементам одной группы, также желательно выравнивать, чтобы поставить им в соответствие элементы управления, которые эти надписи описывают.

Каждое поле ввода должно иметь описание.

Обход элементов управления должен быть в естественном порядке — слева направо сверху вниз.

Поведение элементов управления при изменении размеров формы также является важной характеристикой удобства пользования формой.

Редактор форм позволяет вставить в форму различные элементы управления, распределять их по страницам, задавать их размеры и выравнивать границы, определять механизм поведения в зависимости от различных действий пользователя (например, изменение размеров формы, выбора закладки, выбора режима) и т.д.

Для облегчения размещения элементов управления редактор форм предоставляет различные возможности. Это использование разметочной сетки, выравнивающих линий, механизма специальных маркеров, механизма привязки элементов к границам формы.


Рекомендации по оформлению


Вставка элементов управления в форму

Для создания всего многообразия форм для ввода информации в документы и справочники редактор форм использует различные элементы управления.

Для вставки в форму элементов управления выберите пункт «Форма — Вставить элемент управления». На экран выводится диалог выбора элемента.

В списке укажите нужный элемент и нажмите кнопку «ОК». Вставка производится стандартным способом.

Элемент управления имеет прямоугольную форму с маркерами управления размерами в виде небольших квадратов а по углам прямоугольника и на серединах сторон.

Точное позиционирование и задание размеров элемента производится в палитре свойств в категории Расположение.

Для изменения положения элемента управления с точностью до точки экрана или шага разметочной сетки (если установлено свойство Выравнивать по сетке) можно использовать клавиши управления курсором. Для изменения размеров с точностью до точки или шага разметочной сетки (если установлено свойство Выравнивать по сетке) можно использовать клавиши управления курсором с нажатым Shift.

Настройка элемента управления (указание элементу правил поведения, оформления и других свойств) производится в палитре свойств элемента.

При перемещении элементов управления в форме следует иметь в виду, что элементы управления должны полностью располагаться в пределах формы.

Вставленные таким образом элементы управления помимо диалога формы показываются в списке реквизитов формы на закладке «Реквизиты».


Вставка элементов управления в форму


Вставка элементов управления в табличный документ, расположенный в форме

В табличном документе, который выступает как элемент управления формы (т.е. расположенный в форме), также можно размещать элементы управления. Вставка производится аналогично вставке элемента управления в форму (подробнее см. главу « Табличный редактор »).


Вставка элементов управления в табличный документ, расположенный в форме


Работа с реквизитами формы

На закладке формы «Реквизиты» содержится список реквизитов и панель инструментов, с помощь которой можно создавать новые реквизиты, редактировать имеющиеся и удалять ненужные.

Кроме того, в меню «Действия» с помощью пункта «Перейти» производится переход к элементу управления, расположенному в диалоге формы, соответствующему выбранному реквизиту.


Работа с реквизитами формы


Использование режима Вставить данные

Если в процессе разработки конфигурации для объекта конфигурации были добавлены реквизиты, то для их размещения в форму можно использовать пункт «Форма — Вставить данные». На экран выводится диалог, в котором следует в колонке «Данные» отметить нужные данные, а в колонке «Элементы формы» выбрать вид элемента управления, с помощью которого в форме будет представлен (размещен) данный реквизит.

Для вставки данных нажмите кнопку «ОК». Диалог закрывается, а указатель курсора принимает вид +. Подведите его в нужное место формы и произведите вставку.

Если флажок «Вставить надписи» был установлен, то при размещении каждого данного будет дополнительно вставлена поясняющая надпись из свойства Синоним, а при его отсутствии — из свойства Имя.

Если флажок «Размещать в диалоге автоматически» был установлен, то после нажатия кнопки «ОК» указанные данные размещаются в диалоге автоматически.

При размещении новых данных не снимайте пометки для данных, уже размещенных в форме, иначе соответствующие им элементы управления будут удалены.


Использование режима Вставить данные


Разметочная сетка

Стратегия выравнивания заключается в создании компактных форм, не требующих больших усилий по выравниванию элементов управления.

Одним из простых приемов выравнивания элементов управления является выравнивание границ и размеров элементов по разметочной сетке. Она представляет собой сетку из горизонтальных и вертикальных линий, ориентируясь на которые, можно задавать точное положение элементов управления в окне формы и устанавливать их размеры. Вы можете управлять шагом разметочной сетки, включать и выключать привязку элементов формы к сетке, а также показывать сетку или прятать ее.

При создании новой формы размер шага разметочной сетки (по умолчанию) устанавливается из настроек параметров Конфигуратора (выберите пункт «Сервис — Параметры», откройте закладку «Форма»).

При перетаскивании элемента выравнивание всегда производится по верхнему левому углу. Если размер элемента не был кратным шагу сетки, то при перетаскивании не производится изменение его размера.

Управление разметочной сеткой производится в категории свойств формы Редактирование. Если для формы установлено свойство Выравнивать по сетке, разметка изображается точками, расположенными в местах пересечения линий разметки (можно использовать режим показа точек сетки в шахматном порядке).

Если свойство Выравнивать по сетке установлено, все располагаемые элементы управления будут автоматически размещаться вдоль линий разметки. Размер вставляемых элементов также будет автоматически устанавливаться кратным шагу сетки.

При изменении размера элемента (любым способом: указателем мыши или клавиатурой) размер изменяется такими образом, что изменяемая граница всегда размещается точно по разметочной сетке, не смотря на то, выровнена ли по разметочной сетке противоположная граница элемента управления или нет.

Изменение размеров формы при установленном свойстве Выравнивать по сетке также производится кратно шагу сетки.

Вы можете задать шаг сетки — размер ячеек сетки по горизонтали и вертикали. Для этого в свойствах формы Гор. шаг сетки или Верт. шаг сетки введите целое число от 1 до 99. Числа, задающие размер ячеек по горизонтали и вертикали, могут быть разными.

При выборе шага сетки нужно руководствоваться следующими соображениями: при маленьком шаге сложней производить выравнивание и требуется произвести больше действий, а при большом остаются большие промежутки между элементами, что приводит к увеличению размеров формы. Поэтому для создания «типовых» форм рекомендуется устанавливать шаг сетки от 4 до 8.


Разметочная сетка


Выравнивание элементов управления Выравнивающие линии

Выравнивающие линии — условные линии (видимые только при создании формы), которые служат для облегчения выравнивания и взаимного расположения элементов управления формы.

Выравнивающие линии могут отсутствовать. Для установки режима использования выравнивающих линий в свойствах формы установите свойство Использовать выравнивающие линии.

Если свойство установлено, то по умолчанию каждая страница формы содержит выравнивающие линии по периметру формы. Это краевые выравнивающие линии. Все элементы управления располагаются на странице в пределах, установленных этими линиями.

Положение выравнивающих линий можно изменять с помощью мыши.

На странице можно расположить дополнительные вертикальные и горизонтальные выравнивающие линии и также осуществлять по ним привязку места расположения элементов управления. Для этого установите указатель мыши в нужное место формы и в контекстном меню выберите пункт «Добавить вертикальную выравнивающую линию» или «Добавить горизонтальную выравнивающую линию».

Вставленную линию можно перемещать с помощью мыши. Перемещение дополнительных выравнивающих линий допускается в пределах, определенных краевыми выравнивающими линиями и выполняется также, как и перемещение краевых выравнивающих линий. Положение линии при перемещении показывается в строке состояния.

Выравнивающую линию можно копировать. Выполните те же действия, что и при перетаскивании, но с нажатой клавишей Ctrl.

Для удаления выравнивающей линии подведите указатель мыши к линии (так, чтобы он принял вид <-->) и в контекстном меню выберите пункт «Удалить выравнивающую линию».

Если требуется удалить все выравнивающие линии, в контекстном меню формы выберите пункт «Сбросить все выравнивающие линии». В этом случае сбрасываются все дополнительные выравнивающие линии, а краевые линии устанавливаются по периметру формы. При этом возможность прикрепления элементов управления к выравнивающим линиям (см. ниже) (если свойство Использовать выравнивающие линии установлено) остается.


Выравнивание элементов управления Выравнивающие линии


Прикрепление выравнивающей линии к элементу управления

При перемещении выравнивающей линии в момент ее приближения к границе элемента управления линия «прикрепляется» к элементу (сдвигается скачком, при продолжении перемещения не сразу открепляется от границы элемента). Таким образом, можно прикрепить все границы элемента. Прикрепление происходит также при перемещении элемента управления с помощью мыши.

Прикрепленные элементы можно перемещать и менять их размеры с помощью выравнивающих линий. Для этого достаточно переместить выравнивающую линию в нужном направлении. При этом перемещаются или изменяют размер все прикрепленные к перемещаемой линии элементы.

Если у элемента прикреплена только одна или две смежные границы, то при перемещении выравнивающей линии элемент перемещается.

Если прикрепить две противоположные границы элемента управления (двумя выравнивающими линиями), то при перемещении любой из этих линий размер элемента изменяется.


Прикрепление выравнивающей линии к элементу управления


Невидимые выравнивающие линии

Если свойство Использовать выравнивающие линии установлено и два или более элемента выровнены по левой или по верхней границам, то редактор форм устанавливает так называемую невидимую выравнивающую линию вдоль линии выровненных границ (линия действительно не видна, но обладает свойством прикрепления элементов).

Назначение невидимой выравнивающей линии в облегчении размещения элементов управления в случае, если требуется добавить элемент к уже установленным и выровненным элементам.

Если. перемещать элемент управления с помощью мыши, то при приближении к невидимой выравнивающей линии элемент прикрепляется к этой линии.

Если выровнены два элемента управления, то невидимая выравнивающая линия действует при перемещении любого из этих элементов.

Если в результате перемещения (перемещение закончено) одного из двух выровненных элементов управления выравнивание нарушается, то невидимая выравнивающая линия снимается.


Невидимые выравнивающие линии


Выравнивание элементов управления с помощью специальных маркеров

Выравнивание можно производить по координатам расположения элементов управления в строке состояния, но можно воспользоваться механизмом специальных маркеров выравнивания. Это синие и красные маркеры, располагающиеся рядом с угловыми маркерами элемента управления. Они «работают только в ограниченной зоне действия, которая определяется как зона в ±16 точек экрана (пикселей) от установленного элемента.

Рассмотрим следующий пример: необходимо произвести выравнивание левой границы двух элементов, расположенных один под другим. Укажите (щелкните мышью) устанавливаемый элемент (например, нижний). Переместите его любым способом в место, расположенное под другим элементом. Если левые границы совпали, то специальный маркер не показывается. Если размещаемый элемент расположен не точно, то рядом с угловым маркером будет показан специальный маркер выравнивания в виде синего треугольника. Его угол указывает направление желаемого смещения.

Перемещайте элемент или границу элемента в указанном направлении пока специальный маркер не пропадет.
С помощью специальных маркеров красного цвета показывается наложение одного элемента управления на другой. Направление угла маркера указывает, в какую сторону нужно сместить элемент или границу элемента, чтобы избежать наложения.


Выравнивание элементов управления с помощью специальных маркеров


Выполнение действий с группой выделенных элементов

Некоторые действия по выравниванию, изменению положения и другие выполняются с группой выделенных элементов.

Выбор группы производится стандартным образом с помощью мыши.

С группой выделенных элементов управления можно выполнять различные действия по выравниванию и изменению размеров с помощью специальных команд.

К таким действиям относятся:

• управление выравниванием;

• распределение элементов управления;

• установка размера.

Для группы элементов в палитре свойств можно установить одинаковые значения свойств (например, для пояснительных надписей указать вертикальное и горизонтальное положение, pазмep и цвет шрифта и т.д.).

Элементам группы можно также устанавливать и изменять привязки (о привязках см. раздел « Привязка элементов управления к границам формы » ).

Замечание. Все действия с группой выделенных элементов могут осуществляться только в том случае, когда элементы расположены в одной панели. Для любой выделенной группы можно выполнять только изменение или установку общих свойств элементов управления, входящих в группу.


Выполнение действий с группой выделенных элементов


Управление выравниванием и распределение элементов управления

Выравнивание элементов производится с помощью выбора пунктов «Форма — Выравнивание» или соответствующим этим командам кнопок панели инструментов «Выравнивание».

Пункты меню доступны (выравнивание производится), если выбрано более одного элемента управления.

Команды | Действия
«Выровнять влево» | производит выравнивание левых границ выбранных элементов. При этом их левые границы располагаются вдоль одной вертикальной прямой.
«Выровнять вправо» | — выравнивание правых границ.
«Выровнять вверх» | — выравнивание верхних границ.
«Выровнять вниз» | — выравнивание нижних границ
«Выровнять по центру вертикально» | — выравнивание по центру элементов вертикально
«Выровнять по центру горизонтально» | — выравнивание по центру элементов горизонтально
«Центрировать по горизонтали» | — размещение элемента или группы элементов по центру формы (по горизонтали)
«Центрировать по вертикали» | — размещение элемента или группы элементов по центру формы (по вертикали)
«Распределить по вертикали» | обеспечивает равномерное распределение элементов управления в заданном пространстве формы (по вертикали)
«Распределить по горизонтали» | обеспечивает равномерное распределение элементов управления в заданном пространстве формы (по горизонтали)

Выравнивание по центру (вертикально или горизонтально) производится по осям элементов.

При центрировании никаких изменений элементов внутри группы не производится. Вся группа элементов перемещается так, как если бы перемещался один элемент, образованный из всех выбранных элементов группы.

Чтобы обеспечить равномерное распределение элементов управления в заданном пространстве формы, удобно воспользоваться командами подменю «Форма — Распределить» «Распределить по вертикали» и «Распределить по горизонтали». Команды доступны, если выбрано более двух элементов управления.

При выполнении команды крайние элементы управления остаются на местах, а все остальные распределяются таким образом, чтобы промежутки между всеми выбранными элементами были одинаковыми. Средние элементы распределяются без привязки к разметочной сетке, даже если режим использования разметочной сетки установлен.


Управление выравниванием и распределение элементов управления


Установка размера

С помощью команд подменю «Форма — Размер» можно установить одинаковые размеры всех элементов, входящих в группу. Следует обратить внимание на то, что за образец выбирается элемент называемый мастером (на рисунке — левый элемент). Другие элементы имеют маркеры вида ••.

Чтобы сменить мастера, в группе элементов щелкните мышью нужный элемент.

Команда | Действия
«Одинаковая ширина» | устанавливает одинаковую ширину всех элементов группы.
«Одинаковая высота» | устанавливает одинаковую высоту всех элементов группы.
«Одинаковый размер» | устанавливает одинаковый размер всех элементов группы.


Установка размера


Порядок элементов

Когда элементы управления пересекаются (накладываются), то один элемент закрывает частично или полностью второй элемент. Установка порядка следования элементов производится с помощью команд подменю «Форма — Порядок».

Команда | Действия
«Поместить вверх» | перемещает указанный элемент на один слой вверх.
«Поместить вниз» | перемещает указанный элемент на один слой вниз.
«На передний план» | перемещает указанный элемент на передний план.
«На задний план» | перемещает указанный элемент на задний план.

Эти действия применяются как к одному элементу управления, так и к группе элементов


Порядок элементов


Привязка элементов управления к границам формы

В процессе работы с данными (просмотр, ввод или редактирование) иногда возникает необходимость изменения размеров открытых на экране форм. Например, форму растягивают, чтобы увидеть больше информации, или уменьшают, чтобы одновременно разместить на экране больше разных форм.

При этом желательно так настроить поведение различных элементов управления, чтобы определенная информация или элементы управления (например, кнопки) не пропадали за рамками формы, чтобы элементы перемещались или изменяли свои размеры в соответствии с изменением размеров формы, и при этом нужно, чтобы сохранялась общая структура экранной формы.

Для обеспечения естественного восприятия информации, поведение элементов управления при изменении размеров формы должно быть различным. Часть элементов должна оставаться на месте, одна часть перемещаться вместе с границами, а другая часть элементов должна изменять свои размер в соответствии с изменениями размеров формы.

Привязка — это зависимость положения границ элемента управления от положения границ формы. Границу элемента управления можно привязывать как к границе формы, так и к границе другого элемента.

Редактор форм предоставляет разнообразные средства настройки привязок. Настройку производят на этапе создания формы для каждого элемента управления или группы элементов. Привязке доступны элементы управления любого типа.

Существует два вида привязок: ручная (простая и сложная привязка границ элементов) и автоматическая привязки (автопривязка).

Ручная привязка может осуществляться в упрощенном режиме — выбором стратегии привязывания элемента управления и индивидуальной установкой привязок для каждой границы элемента по отдельности.

Стратегию привязки (поведение элемента при изменении размеров формы) также можно менять. Например, при простой горизонтальной привязке элемента к правой границе формы элемент будет изменять свое положение при смещении правой 1раницы формы. Расстояние между этими границами не меняется. Если установить пропорциональную зависимость, то при смещении границы формы границы элемента также будут смещаться, но расстояние между каждой границей до границ формы будет изменяться пропорционально соотношению расстояний каждой границы до границ формы.

В связи с тем, что число типов элементов и вариантов их расположения в форме достаточно велико, число всевозможных ком

бинаций привязок практически бесконечно. Поэтому рассмотрим основные приемы привязки и поведение элементов управления при изменении размеров формы.

Наличие привязки всегда показывается специальными маркерами, расположенными рядом с маркерами сторон элемента (элемент должен быть выбран).

Освоение приемов привязки рекомендуется начинать при включенном режиме просмотра привязок. Для включения показа привязок выберите пункт «Форма — Показать привязки», при этом в этом пункте меню выставляется флажок. Чтобы отключить показ привязок снова выберите этот пункт.

Для наглядности в Руководстве примеры привязок приведены с установленным режимом просмотра привязок. Для облегчения понимания сути привязок привязки показываются линиями, проведенными между привязанными границами. Линии имеют цвет и бывают сплошной и пунктирной.

• Сплошная линия — это первичная привязка («Привязать к...»);

• Пунктирная — это вторичная привязка («Сохранять пропорции до...»);

• Красные линии идут от панели;

• Синие — от элементов управления;

• Стрелка указывает направление влияния границы, т.е. какую границу толкнет (потянет за собой) данная граница при перемещении.

Настройка привязок производится в диалоге «Привязка границ для элемента ...», запускаемого по ссылке Установить правила свойства Привязка границ категории Расположение.

Устанавливать и изменять привязки можно сразу к нескольким элементам (предварительно следует выделить нужную группу элементов).

Для проверки поведения элементов управления формы (привязок) при изменении размеров формы воспользуйтесь режимом «Проверка». Для его включения выберите пункт «Форма — Проверка».

Важно! Каждую проектируемую форму нужно обязательно проверить на поведение элементов управления при изменении размеров формы. При этом следует опробовать все направления изменения в самых различных комбинациях. Рекомендуем проводить тестирование с помощью мыши. Запустите режим проверки формы. «Захватите» мышью любой угол проверяемой формы и начните перемещение границ во всех направлениях. Внимательно следите за поведением элементов управления. «Неправильное» поведение элементов управления следует исправить с помощью ручной привязки границ.


Привязка элементов управления к границам формы


Простая привязка границ

Настройка привязок производится на закладке «Простая». Группа реквизитов диалога «Привязать горизонтально» предназначена для настройки поведения элемента при горизонтальном изменении размеров формы. Группа реквизитов диалога «Привязать вертикально» — для настройки поведения элемента при вертикальном изменении размеров формы. Действия по настройке привязки в этих группах одинаковы, поэтому рассмотрим настройку на примере горизонтальной привязки.

В реквизите «Привязать к» указывается, к какому объекту будет осуществлена привязка.

При простой привязке элемент может быть привязан как к самой форме или панели, а также к элементам управления типа «Разделитель» (см. параграф « Область действия привязок » ). При этом в список объектов включаются только те разделители, которые попадают в зону пересечения с привязываемым элементом.

Зона пересечения определяется следующим образом: если мысленно перемещать один элемент вдоль выбранного направления (горизонтально или вертикально) и он пересечется с другим элементом, то они находятся в зоне пересечения. При этом следует учитывать способность элемента привязываться в указанном направлении (см. таблицу авто-привязок элементов управления). Зона пересечения определяется для состояния расположения элементов, как они расположены в форме при создании. В режиме «Предприятие» зона пересечения при изменении размеров формы не пересчитывается. Примеры взаимодействия нескольких элементов см. в параграфе « Автоматическая привязка нескольких элементов управления » .

Разделитель будет включен в список объектов, если он попал в зону пересечения привязываемого элемента управления. При этом учитывается ориентация разделителя (см. описание свойства Ориентация в параграфе « Категория свойств Характеристики » ). При горизонтальном перемещении элемента не учитываются горизонтальные разделители («лежащие»); и наоборот, при вертикальном перемещении элемента не учитываются вертикальные разделители.

В реквизите «Тип привязки» указывается способ привязки:

к левой границе элемент привязывается к левой границе области (элемент целиком перемещается вместе с перемещением левой границы области);

к правой границе элемент привязывается к правой границе области (элемент целиком перемещается вместе с перемещением правой границы области);

растягивать

правая граница элемента привязывается к правой границе области (при горизонтальном изменении размеров области, правая граница элемента перемещается вместе с перемещением правой границы области, при этом расстояние между границами остается неизменным);

пропорционально правая граница элемента привязывается к правой границе области таким образом, что при изменении размеров области соотношение расстояний от правой границы элемента до левой и правой границ области остается постоянным, аналогично привязывается левая граница элемента.

Во всех приведенных выше примерах, кроме последнего, элемент управления привязан жестко: при такой привязке изменения положения границы элемента относительно привязанной границы не происходит.

Аналогично производится настройка поведения элемента при вертикальном изменении размеров формы.

Реквизит «Ручная привязка» диалога «Привязка границ для элемента ...» предназначен для блокировки механизма авто-привязки (подробнее см. раздел « Сложная привязка границ »).


Простая привязка границ


Сложная привязка границ

Привязка производится на закладке «Сложная». На закладке находятся четыре группы реквизитов, заключенных в рамки. Каждая группа осуществляет привязку одной границы элемента. Заголовок рамки группы соответствует названию привязываемой границы элемента (например, группа «Левая граница» отвечает за привязку левой границы элемента). Действия по настройке привязки в этих группах одинаковы, поэтому рассмотрим настройку на примере привязки одной границы.

Реквизиты «Привязать к:» осуществляют первичную привязку. Следует выбрать объект, к которому привязывается граница, затем указывается к какой границе этого объекта будет привязан элемент. В список включаются все элементы управления текущей страницы формы. В том числе и сам привязываемый элемент управления. Это делается для установки таких привязок, которые не приводят к изменению размеров элемента, но элемент при этом может быть привязан к другим элементам области. Если в этом случае нужно будет перепривязать элемент к другому элементу, то достаточно будет изменить привязку только одной его границы. В списке границ выберите границу, к которой будет привязываться элемент.

Запрещается привязывать границу элемента к самой себе и противоречащие привязки («Привязать к:» и «Сохранять пропорции до» к одной и той же границе). В этом случае выдается сообщение «Правила привязки указаны неверно! Привязка не может быть отработана».

Реквизит «Сохранять пропорции до:» осуществляют вторичную привязку.

При расстановке пропорциональных привязок необходимо принимать во внимание некоторые особенности их обработки.

Например при пропорциональной привязке к форме элементы управления расположенные левее будут изменять свой размер на меньшую величину, чем расположенные ближе к правой границе формы.

Это связано с тем, что расчет приращения границы элемента управления, привязанной пропорционально, осуществляется по формуле:

AI = AL*AC/AB

где AI — величина изменения положения границы элемента;

AL — величина изменения положения границы формы;

AC — первоначальное расстояние от левой границы формы до границы элемента;

АВ — первоначальный размер формы

Как видно из формулы, изменение положения границы элемента линейно зависит от изменения размера формы, а значение коэффициента пропорциональности зависит положения границы элемента управления. Чем ближе граница элемента управления к правой границы формы, тем больше этот коэффициент.

На практике это приводит к тому, что поставленные рядом два поля редактора, имеющие изначально одинаковый размер после изменения размера формы становятся разными по ширине.

В качестве решения, компенсирующего данный эффект, заключается в размещении слева и справа от элементов разделителей со снятым свойством Видимость.


Сложная привязка границ


Автоматическая привязка границ, назначение авто-привязки

Автоматическая привязка границ — это свойство формы или панели, при котором элементы привязываются к границам автоматически. Каждый элемент управления (за исключением некоторых), располагаемый в форме, будет привязываться к форме или другим элементам по специальному алгоритму, применяемому автоматически.

Важно! Если режим просмотра привязок не установлен, то при установке режима авто-привязки внешне в форме ничего не меняется (элементы управления остаются на своих местах). Заметить изменение поведения элементов можно только при изменении размеров формы в режиме просмотра. При снятии флажка Авто-привязка границ установленные в автоматическом режиме привязки не снимаются. Если свойство Авто-привязка границ установлено по ошибке, то его отмена не приведет к прежнему результату (до установки). Поэтому, прежде, чем устанавливать этот режим, вы должны отчетливо представлять, для чего вам это нужно. В разработанных формах этот режим лучше не устанавливать.

Важно! Привязки, установленные при установке свойства Автопривязка границ, не снимаются при выборе пункта «Правка — Отменить».

Совет. Для полного снятия привязок у группы элементов управления выделите все эти элементы, в категории Расположение в свойстве Привязка границ по ссылке Установить правила откройте диалог привязки границ и нажмите кнопку «Сбросить все привязки». Если свойство Авто-привязка границ установлено, установите реквизиты «Ручная привязка».


Автоматическая привязка границ, назначение авто-привязки


Авто-привязка границ элементов управления

При создании новой формы или панели свойство Авто-привязка границ не установлено. Это означает, что для всех размещаемых элементов управления автоматическая привязка не производится. При изменении размеров формы или панели эти элементы управления будут оставаться на своих местах без изменения размеров или будут перемещаться в соответствии с привязками, установленными вручную.

Для установки режима авто-привязки границ в свойствах формы в категории свойств Основные, установите свойство Авто-привязка границ. При этом ко всем элементам формы, для которых не установлен режим «Ручная привязка», будет применена автоматическая привязка. Если до этого элемент был привязан, но флажок «Ручная привязка» не был установлен, то привязки этого элемента будут изменены.

Каждый новый элемент также будет автоматически привязываться к границам формы. Более того, при перемещении элемента будут изменяться и его привязки.

В таблице показаны возможности элемента управления изменять свои размеры при изменении размеров формы в режиме автопривязки в зависимости от типа элемента.

Элемент управления | Растягивается по горизонтали | Растягивается по вертикали
Диаграмма | Да | Да
 | Да | Да
Индикатор | если ориентирован горизонтально | если ориентирован вертикально
Календарь | Да | Да
Кнопка | Нет | Нет
Командная панель | если ориентирован горизонтально | если ориентирован вертикально
Надпись | Нет | Нет
Панель | Да | Да
Переключатель | Нет | Нет
Поле ввода | Да | если многострочный
Поле выбора | Да | Нет
Поле картинки | Да | Да
Поле списка | Да | Да
Полоса регулирования | если ориентирован горизонтально Да | если ориентирован вертикально Да
Разделитель | если ориентирован горизонтально Да | если ориентирован вертикально Да
Рамка группы | Да если внутри есть растягиваемые по горизонтали элементы | Да Если внутри есть растягиваемые по вертикали элементы
Табличное поле | Да | Да
Табличный документ | Да | Да
Текстовый документ | Да | Да
Флажок | Нет | Нет

Как видно из таблицы такие элементы управления как «Кнопка», «Надпись», «Переключатель» и «Флажок» автоматически не привязываются к границам формы.

Элементы управления «Индикатор», «Командная панель», «Полоса регулирования», «Разделитель» и «Рамка группы» привязываются к границам формы в зависимости от ориентации элемента управления (см. описание свойства Ориентация в параграфе « Категория свойств Характеристики » ).

«Рамка группы» привязывается к границе формы, если внутри есть элементы управления, растягиваемые по горизонтали или вертикали.

Указанные элементы управления можно привязать в режиме «Ручная привязка» (см. раздел « Простая привязка границ » и « Сложная привязка границ »).

Все остальные элементы привязываются к границам формы при установленной авто-привязке границ.

С помощью автоматической привязки не всегда удается реализовать более сложные механизмы взаимодействия элементов. С такими задачами позволяет справиться ручная привязка (см. раздел « Простая привязка границ » и « Сложная привязка границ »).


Авто-привязка границ элементов управления


Область действия привязок

Областью действия привязок в общем случае является форма.

В случае, когда в форму вставлен элемент управления типа «Панель», границы этой панели будут являться границами действия привязок для всех элементов, расположенных на этой панели. Для каждой панели можно установить или отменить режим автопривязки границ. Так как панель может содержать несколько страниц, то режим автопривязки действует на все страницы панели.

Элементы управления, расположенные в панели, привязываются к границам панели или к границам элементов управления, расположенные в панели. К границам формы эти элементы управления привязать нельзя.

Для организации области привязок применяют специальный элемент управления «Разделитель». Разделитель разбивает форму на области, внутри которых могут находиться элементы управления. В форму могут быть вставлены несколько разделителей. В этом случае форма будет разбита на несколько областей в соответствии с правилами определения зон пересечения. Если в форме уже были размещены элементы управления и для них не использовалась ручная привязка границ, то привязка их границ, попадающих в зону пересечения (о зоне ) с разделителем, будет изменена на привязку к границам разделителя автоматически.

Чтобы разделитель не был виден в действующей форме, у него можно снять установку флажка в свойстве Видимость. При этом все связанные с разделителем привязки будут действовать. Если в форме нет разделителя, то вся форма является одной областью.

Дальнейшее описание взаимодействия элементов управления будет производиться для отдельной области.


Область действия привязок


Автоматическая привязка нескольких элементов управления

Помимо привязки к границам формы на поведение элементов управления оказывает влияние их взаимное расположение. При рассмотрении взаимной привязки нужно отдельно рассматривать горизонтальное и вертикальное направления изменения размеров формы.

Два и более элемента управления могут привязываться к друг другу, если они расположены в зоне пересечения (см. параграф «Простая привязка границ»).

В самом простом случае, когда в области (по горизонтали задана левой границей формы и разделителем) расположен один элемент управления или несколько не взаимодействующих с друг другом элементов, обладающих свойством растягиваться по горизонтали (полей ввода)

По горизонтали:

• Левая граница полей ввода не привязывается. При этом при изменении размеров формы положение левой границы остается неизменным.

• Правая граница полей ввода привязывается к правой границе области (разделителю). При этом при изменении размеров формы расстояние от правой границы до границы области также остается неизменным.

Разделитель оставим видимым, чтобы наблюдать взаимосвязь элементов. Запустим режим проверки (выберите пункт «Форма — Проверить»). При горизонтальном увеличении размера окна происходит изменение размеров элементов.

Как видим надписи остались на прежнем месте, т.к. они не были привязаны к границам области, левые границы полей ввода также не привязаны и остались на месте. Правые границы полей ввода привязаны к правой границе области (к левой границе разделителя) и перемещаются месте с перемещением разделителя (расстоя ние от правой границы элементов до разделителя осталось прежним), поэтому размер полей ввода увеличился.

Расстояние между разделителем и правой границей формы увеличилось. Это связано с тем, что авто-привязка разделителя производится в режиме «Пропорционально». При такой привязке соотношение расстояний от границы элемента до границ области всегда остается одинаковым при любом изменении размера формы.

При уменьшении размеров формы нужно учитывать то, что для некоторых элементов управления (например, поле ввода) существует минимальный размер, достигнув которого элемент перестает уменьшаться.

При такой привязке размер элементов управления будет изменяться ровно на столько, на сколько изменился размер области. Это режим называется режимом «Растягивать».

Аналогичным образом привязка осуществляется для верхней и нижней границ элементов, обладающих свойствами изменять размеры при вертикальном изменении размеров формы.

В режиме редактирования формы при перемещении элемента управления его авто-привязки могут изменяться. Если элемент управления, обладающий свойством привязываться, попадает в зону пересечения с другим элементом, эти элементы привязываются к друг другу. Если элемент уходит из зоны пересечения с другим элементом, он привязывается к границам области или к границам других элементов, находящихся в зоне пересечения.

Если правый нижний элемент переместить вверх на столько, чтобы он попал в зону пересечения другого элемента, то редактор форм произведет их авто-привязку.

Если требуется отключить действие привязки некоторых элементов, то для этого нужно в диалоге установки привязок нажать кнопку «Сбросить все привязки» и установить режим «Ручная привязка», чтобы при перемещениях элемента и при размещении в форме других элементов для этого элемента не производилась авто-привязка границ (подробнее см. параграфы « Простая привязка границ » и « Сложная привязка границ »).

Если для элемента управления применялась настройка привязки с помощью диалога «Привязка границ для элемента ...», то для этого элемента автоматически устанавливается режим «Ручная привязка». Поэтому на него не будет действовать механизм автопривязки (изменение привязок при перемещении элемента, размещение новых элементов управления).

В форме с установленной авто-привязкой границ расположены три поля ввода одинакового размера. Запустим режим проверки (выберите пункт «Форма — Проверить»). При горизонтальном увеличении размера окна происходит изменение размеров элементов.

Как видим левая граница первого (слева) элемента привязана к левой границе формы и осталась на месте. Правая граница третьего (слева) элемента привязана к правой границе формы и перемещается месте с перемещением правой границы (расстояние от элемента до правой границы формы осталось прежним). Расстояния между элементами также осталось прежним, т.к. соседние границы привязаны жестко.

При созданий формы поля ввода имели одинаковый размер. Но при растяжении заметно, что их размер изменился не одинаково. Это результат жесткой привязки соседних границ элементов.

Если слева от элемента управления, который не обладает свойством авто-привязки границ (например, кнопка), расположен элемент способный изменять свой размер (например, поле ввода), то привязываемый элемент будет сдвигать не привязываемый элемент.

В некоторых случаях использование авто-привязки не требует ручной настройки привязок. Вформе размещены элементы управления «Список значений»; «Табличный документ»;«Многострочное поле для ввода» и кнопки. Изменение размеров формы не приводит к нежелательным последствиям.

При размещении элементов управления в элементе управления типа «Табличный документ» элементы привязываются к ячейке, в которой находится их верхний левый угол. При этом в режиме просмотра привязок привязки элементов управления в табличном документе не показываются. При изменении положения табличного документа расположенные в нем элементы управления будут перемещаться вместе с табличным документом. При изменении размеров ячеек или столбцов размеры элементов будут изменяться в соответствии с изменениями размеров ячеек и столбцов. Подробнее про размещение элементов управления в табличном документе см. главу « Табличный редактор ».


Автоматическая привязка нескольких элементов управления


Пересекающиеся элементы управления

При рассмотрении механизма работы привязок следует учитывать, что при перемещении границ формы элементы не могут пересекаться (если до этого не были пересекающимися), т.е. не накладываются друг на друга. Если при перемещении границ формы пересекающиеся элементы станут непересекающимися, то при обратном перемещении границ такие элементы не могут принять первоначальное положение.

Если после некоторых изменений размеров формы граница одного элемента достигнет границы другого элемента, то дальнейшее перемещение границы этого элемента становится невозможным, а вместе с ним также прекращают перемещения границы всех других элементов.

Рассмотрим следующий пример:
Верхнее поле ввода пересекается с разделителем. Границы другого поля привязаны к правой границе формы. А граница разделителя привязана пропорционально, поэтому характер перемещения границ этих элементов будет разный.
Запустим режим проверки. Увеличение размеров формы не приводит к необратимому состоянию, т.к. правая граница поля ввода перемещается «быстрее» разделителя.
Уменьшим горизонтальный размер формы. Граница верхнего поля ввода благодаря жесткой привязке в границе формы быстрее приблизится в левой границе формы, чем разделитель, поэтому поле ввода в какой-то момент перестанет пересекаться с разделителем. Затем попробуем снова увеличить размер формы:
Изменение положения границы первого поля ввода прекращается, когда она достигает разделителя.
Как видите, другое поле также прекращает изменение своих размеров.


Пересекающиеся элементы управления


Использование разделителей для коррекции механизма авто-привязок

Проектирование формы должно осуществляться с учетом изменения размеров форм. Поведение элементов управления необходимо настроить таким образом, чтобы сохранялась структура формы, не нарушалось выравнивание элементов, а сами элементы изменяли свои размеры сообразно здравому смыслу.

В форме расположены пять полей ввода и одна надпись, размещенных в форме в три колонки. Привязки элементов осуществляются с установленным свойством Авто-привязка границ.

При увеличении размеров формы элементы левой колонки пропорционально увеличиваю свой размер. Левые границы элементов средней колонки смещаются под воздействием правых границ элементов левой колонки. Размер надписи остается неизменным, это приводит к тому, что нарушается выравнивание левых границ правой колонки. Правые границы правой колонки привязаны к правой границе формы и выровнены. В результате для верхнего поля правой колонки нарушается выравнивание.

Для корректировки поведения вставим два разделителя между колонками элементов управления.

Как видим, изменение размеров полей ввода происходит неравномерно — размер полей правой колонки больше. Чтобы компенсировать разницу установим еще один разделитель между правыми границами правой колонки и правой границей формы.

Выводы: Использование разделителей для коррекции поведения элементов управления при изменении размеров формы самый простой, но не самый оптимальный способ, т.к. любой элемент управления в форме расходует системные ресурсы и вызывает лишние вычисления при каждом изменении размеров формы. Использование разделителей может быть полезно для понимания того, что нужно предпринять, чтобы произвести ручную коррекцию привязок.


Использование разделителей для коррекции механизма авто-привязок


Установка ручных привязок

Стандартное поведение авто-привязки элементов управления не всегда соответствует желаемому.

Предположим, нужно добиться, чтобы надпись изменяла свой размер в соответствии с изменениями размера формы. Необходимо выполнить ручную привязку. На закладке «Сложная» правую границу надписи следует привязать к форме с сохранением пропорций по правой границе формы. При проверке надпись меняет свой размер в соответствии с изменениями размеров формы.

Усложним задачу. Поле ввода многострочное. В этом случае желательно, чтобы надпись также могла быть многострочной. Изменим привязку нижней границы надписи следующим образом - нижняя граница жестко привязана в нижней границе формы, как и нижняя граница поля ввода (свойство авто-привязки многострочного поля ввода).

Снова усложним задачу. В созданную форму слева от надписи добавим еще одно многострочное поле ввода .При увеличении размеров формы вертикальное изменение отрабатывается хорошо, а при горизонтальном фиксированное положение левой границы надписи препятствует растягиванию полей ввода. Одним из простых решений может быть размещение разделителя между новым полем ввода и надписью левая граница надписи привязана к разделителю. При проверке видно, такое поведение элементов управления способствует лучшему восприятию информации. Недостатком поведения является наличие разделителя (как лишнего элемента). Используем знания о привязке левой границы надписи к разделителю и вместо разделителя выберем правую границу левого поля ввода (ПолеВвода2).


Установка ручных привязок


Категория свойств Основные

Заголовок — заголовок формы (строка которая будет выводиться в заголовке формы).

Ширина — определяет ширину формы.

Высота — определяет высоту формы.

Поведение Enter — тип поведения формы при нажатии клавиши Enter. Это свойство описывает поведение обхода элементов по нажатии клавиши Enter.

Возможные значения: «Кнопка по умолчанию» и «Переход по элементам формы».

Если выбран первый тип поведения формы, то при нажатии клавиши Enter в любом элементе формы становится активной кнопка, указанная как кнопка по умолчанию.

Если выбран второй тип поведения формы, то по нажатию клавиши Enter активным становится тот элемент формы, который стоит следующим в очередности обхода элементов формы.

Авто-привязка границ — автоматическая привязка границ. Авто-порядок обхода — автоматический порядок обхода.

Если свойство установлено, то устанавливается автоматический порядок обхода элементов управления в форме при нажатии клавиш Enter, Tab, Shift+Tab. В этом случае действует правило:«Сверху вниз, слева направо».

Если свойство не установлено, то порядок обхода элементов управления определяется при создании формы. В этом случае становится доступной команда «Правка — Порядок обхода». На экран выводится макет формы, все элементы которой имеют в верхнем левом углу поля с порядковым номером обхода.

Установка порядка обхода производится мышью. Необходимо последовательно щелкать мышью элементы управления в той последовательности, в которой следует производить обход. При этом в поле показывается порядковый номер обхода и фон номера меняет цвет с темно-серого на синий. Завершение установки порядка обхода производится щелчком мыши в любое другое место формы.

Режим прокруч. страниц Если свойство установлено, форма будет отображаться следующим образом: будут показываться все элементы всех страниц формы, при этом располагаться страницы будуг в последовательном порядке сверху вниз.

Каждая страница имеет заголовок с кнопками перехода и управления просмотром.

Если страниц много, можно воспользоваться переходом к нужной странице. Для этого в форме щелкните правой кнопкой мыши и в контекстном меню выберите нужную страницу.

Автоматический заголовок — признак автоматического формирования заголовка формы. Если свойство установлено, то формируется из названия документа, его номера и даты. Если свойство не установлено, то заголовок выбирается из свойства Заголовок.

Данные — имя значения, используемого для хранения данных, редактируемых элементом управления. Этот имя называют основным реквизитом формы. Он отображается на закладке «Реквизиты» формы жирным шрифтом.

Тип значения — тип данных, указанных в свойстве Данные.

Доступность — устанавливает, будет ли доступны все элементы управления формы или нет.Если свойство не установлено, элементы формы недоступны.


Категория свойств Основные


Категория свойств Редактирование

Использовать выравнивающие линии — использовать выравнивающие линии.

Если свойство установлено, то в форме можно расположить выравнивающие линии и осуществлять выравнивание элементов по этим линиям (подробнее см. раздел « Выравнивающие линии »).

Выравнивать по сетке — использовать сетку и производить выравнивание элементов управления по сетке( подробнее см. раздел « Разметочная сетка » .

Гор. шаг сетки — горизонтальный шаг сетки. Вер. шаг сетки — вертикальный шаг сетки.

Исп. только видимую область - если свойство установлено, запрещает размещать элементы управления за пределами видимой области панели. Если флажок снят, то элементы управления можно перемещать за видимые границы, при этом появляются линейки прокрутки.


Категория свойств Редактирование


Категория свойств Оформление

В свойствах категории Оформление указывается оформление всей формы.

Цвет фона — для формы.

Цвет текста — для формы.

Рамка — выбирается тип рамки, отображаемой вокруг формы. Цвет рамки — выбирается цвет рамки. Шрифт — выбирается шрифт текста.

Картинка — выбирается изображение картинки, которая будет располагаться на поверхности формы как фон.

Размер картинки — выбирается режим определения размера картинки в зависимости от размера формы.


Категория свойств Оформление


Категория свойств Текущая страница

Имя — имя страницы.

Заголовок страницы — строка, которая будет выводиться на закладке.

Картинка заголовка — картинка, которая будет выводиться на закладке.

Видимость страницы — устанавливает, будет ли данная страница видна или нет.

Доступность страницы — устанавливает, будет ли доступна данная страница или нет.


Категория свойств Текущая страница


Категория свойств Окно

Свойства категории Окно определяют, какое состояние окна формы будет при первом открытии.

Изменять размер — разрешает или запрещает изменять размер.

Положение окна — положение окна формы в прикрепленном состоянии.

Состояние окна - возможные состояния окна формы. Возможные состояния «Обычное», «Свободное», «Прикрепляемое» и «Прячущееся». Подробнее о поведении окон в зависимости от состояния см. раздел « Состояние (режим размещения) окна » .


Категория свойств Окно


Категория свойств События

Свойства этой категории определяют поведение формы или элементов управления при определенных действиях, например, при открытии формы, при начале выбора значения, при начале редактирования, при переходе с одной строки на другую в табличном поле и т.д.

При работе с элементами управления большинство действий может инициировать запуск связанных с этими действиями процедур. В теле каждой процедуры языковыми средствами описывается обработка события.

Инициализация создания процедуры, отвечающей за отработку события, производится нажатием кнопки палитры свойств, расположенной справа от реквизита с наименованием события в категории свойств События. Например, для элемента управления «Табличное поле» список событий выглядит следующим образом:

Процедуры создаются в модуле формы объекта конфигурации, в который вставлен элемент управления «Табличное поле».

В режиме работы с табличным полем при наступлении событий управление выполнением программы передается процедуре, связанной с этим событием.

Список событий для формы и условия их наступления приведен в таблице:

Событие | Условие наступления
Перед открытием | вызывается перед открытием формы, до показа ее пользователю. Можно отказаться от открытия
При открытии | вызывается при открытии формы, до ее показа. Отказаться от открытия нельзя
При повторном открытии | вызывается при попытке открыть уже открытую форму
При обновлении | вызывается при обновлении формы или при изменении данных формы
Перед закрытием | вызывается перед закрытием формы. Можно отказаться от закрытия или отменить стандартную обработку закрытия
При закрытии | вызывается при закрытии формы. Отказаться от закрытия нельзя
Обработка выбора | обработка выбора или подбора, вызывается при выборе значения в подчиненной форме
Активирован объект | вызывается для оповещения об изменении активного объекта во владельце формы, например при вызове метода ОповеститьОбАктивизацииОбъекта
Записан новый объект | вызывается для оповещения о записи нового объекта в другой форме
Обработка оповещения | обработка пользовательского оповещения
Внешнее событие | обработка внешнего события
При смене страницы | вызывается при переключении с одной закладки на другую
Перед сохранением значений | вызывается перед записью набора сохраняемых значений. Действие возможно отменить в обработке
После восстановле- ния значений | вызывается после считывания набора

При выполнении некоторых действии могут запускаться сразу несколько процедур. Например, при переходе между ячейками таблицы инициируются события: Активизация ячейки. Активизация строки (если при переходе сменилась строка). Активизация колонки (если при переходе сменилась колонка).

В модуле формы можно создать несколько процедур, запускаемых по одному виду событий. В реквизите свойств, соответствующему событию следует из поля списка процедур выбрать ту, которая будет запускаться при возникновении данного события. Если при этом выборе Конфигуратор обнаружит, что другая процедура не используется, то на экран выводится запрос на удаление этой процедуры.

Если в реквизите выбора процедуры вручную изменить наименование существующей процедуры, то Конфигуратор анализирует использование прежнего названия. Если обнаружится, что прежняя процедура не используется, то на экран выводится запрос на переименование этой процедуры. Если ответить утвердительно. То прежняя процедура переименовывается, иначе будет создана новая процедура с введенным именем.

Если в форме есть несколько элементов управления «Табличное поле», то они могут использовать общие процедуры отработки однотипных событий.


Категория свойств События


Элементы управления, размещаемые в форме

Процедура размещения элемента управления в форме описана в разделе « Вставка и размещение элементов упраления в форме » .

Поведение элементов управления настраивается в палитре свойств путем установки и выбора значений. Некоторые свойства элементов управления присущи всем или большинству типов элементов управления. Такие свойства описываются в параграфе « Общие свойства элементов управления » . Индивидуальные свойства приводятся в описании каждого элемента управления.


Элементы управления, размещаемые в форме


Общие свойства элементов управления

Существует ряд свойств, которые присущи всем или большинству типов элементов управления. Обычно такие свойства имеют одинаковое назначение и редактируются одинаковым образом. Ниже будут описаны такие свойства, а в параграфах, посвященных отдельным типам элементов управления, будет изложен порядок редактирования уникальных свойств элементов.

Для удобства описания свойства будут сгруппированы по категориям палитры свойств.

Некоторые свойства, описываемые ниже, для некоторых элементов управления могут отсутствовать.


Общие свойства элементов управления


Категория свойств Основные

Описание таких свойств, как Имя, Синоним, Комментарий смотрите в параграфе « Свойства объекта конфигурации » .

Изменяет данные — если свойство установлено, то элемент управления непосредственно не связан с данными, но косвенно изменяет их.

Пропускать при вводе — если свойство установлено, элемент управления будет пропущен при обходе клавишей Enter.

Первый в группе — если свойство установлено, то элемент управления является первым в группе однотипных элементов управления, расположенных последовательно в порядке обхода формы (в основном используется для элементов типа «Переключатель»).

Видимость — устанавливает, будет ли элемент управления виден или нет.

Доступность — устанавливает, будет ли доступен элемент управления или нет.


Категория свойств Расположение

Привязка границ — по ссылке Установить правила производится установка привязки границ элемента управления (см. раздел « Привязка элементов управления к границам формы »). Привязка влияет на изменение расположения и размеров при изменении размеров формы или движениях разделителей.

Порядковый номер — номер элемента управления в порядке обхода формы (см. описание свойства формы Авто-порядок обхода в параграфе « Свойства формы - Категория свойств Основные »).

Лево — позиция левой границы расположения элемента управления.

Верх — позиция верхней границы расположения элемента управления.

Ширина — ширина элемента управления.

Высота — высота элемента управления.

Активизировать по умолчанию — если свойство установлено, данный элемент управление будет активизирован при открытии формы. На одной странице формы может быть только один элемент управления с установленным свойством. Установка свойства для другого элемента приводит к снятию свойства у элемента, для которого оно было установлено


Категория свойств Расположение


Категория свойств Оформление

Цвет фона... — цвет фона элемента управления. Цвет выбирается из палитры цветов или из стилей.

Рамка — тип рамки отображаемой вокруг элемента управления. Выбирается тип рамки по образцу или из стилей.

Цвет рамки — цвет рамки отображаемой вокруг элемента управления.

Подсказка — текст подсказки, которая будет выдаваться для пояснения назначения элемента управления.

Для элементов управления, имеющих в своем составе текст (Рамка, Кнопка, Флажок, Календарь, Регулятор, Поле списка и др.) состав свойств категории Оформление дополнительно содержит свойства:

Цвет текста — цвет текста (поля редактирования, выбора, надписи и т.д.) элемента управления.

Шрифт — шрифт текста элемента управления. Задается вид шрифта, размер, начертание, или выбирается из стиля.

Прозрачный фон — если свойство установлено, то отображение элемента управления производится с прозрачным фоном (становится виден элемент, расположенный под данным элементом управления).


Особенные свойства элементов управления

К таким свойствам относятся Данные и Тип значения .

Данные — указывается реквизит формы, чье значение будет редактироваться элементом управления.

Тип значения — если свойство Данные не выбрано, то указывается тип элемента управления.

Если свойство Данные выбрано, то поведение элемента управления определяется свойствами реквизита формы.

Например, если требуется, чтобы значение реквизитов можно было просмотреть или отредактировать в различных местах формы (на разных страницах, закладках), то можно разместить элемент управления «Поле ввода» (или «Надпись» для просмотра) и в свойстве Данные указать имя реквизита, который является местом хранения информации. Таких дополнительных элементов управления можно расположить столько, сколько требуется. Другим примером может служить использование элементов управления «Индикатор» и «Регулятор».

Пример использования и настройки формы с использованием свойств Данные и Тип значения также см. в параграфе « Пример создания формы журнала » главы «Объекты конфигурации».


Особенные свойства элементов управления


Диаграмма

Информацию по элементу управления «Диаграмма» см. главу « Диаграмма ».


Диаграмма


Индикатор

Элемент управления «Индикатор» предназначен для индикации текущего состояния реквизита формы (элемента управления), используемого для хранения данных указывается в свойстве Данные. Сам элемент не формирует никаких событий и не изменяет значения этого элемента управления.


Индикатор


Категория свойств Данные

Мин. значение — минимальное числовое значение (если не указано, то не ограничивается).

Макс. значение — максимальное числовое значение (если не указано, то не ограничивается).


Категория свойств Данные


Категория свойств Характеристики

Ориентация — вертикальное или горизонтальное расположение элемента управления в форме. Если указано «Авто», то ориентация выбирается по соотношению сторон: если высота больше ширины, то элемент ориентирован вертикально, если высота меньше ширины, то элемент ориентирован горизонтально.

Стиль отображения — показывать сплошную полосу или прерывистую.

Показывать проценты — устанавливает режим отображения в индикаторе процента текущего состояния.


Категория свойств Характеристики


Календарь

Элемент управления «Календарь» предназначен для выбора и отображения даты.


Календарь


Категория свойств Основные

Данные — указывается имя элемента управления или реквизит формы, чье значение будет показано в календаре.

Тип значения — только «Дата».

Режим ввода даты — выбирается режим ввода даты (только дату, дату и время или только время).


Категория свойств Основны е


Категория свойств События

При изменении - данных вызывается при изменении данных

Выбор - вызывается по двойному щелчку или нажатию Enter


Кнопка

Элемент управления «Кнопка» предназначен для запуска определенного обработчика (процедуры на встроенном языке, расположенной в модуле формы на закладке «Модуль») нажатия этого элемента (по клавише Enter или мышью). При нажатии программа запускает процедуру, определенную в свойстве Нажатие категории События.


Кнопка


Категория свойств Основные

Заголовок — текст надписи элемента управления.

Кнопка по умолчанию — основная кнопка, которая будет отрабатывать по нажатию Ctrl+Enter. Если в форме несколько кнопок, то только одна может иметь установленное свойство Кнопка по умолчанию.

Источник действия — определяет источник действий для кнопки.


Категория свойств Оформление

Положение картинки — положение картинки относительно основной части элемента управления (слева или справа от текста).

Картинка — выбор изображения картинки.

Размер картинки — выбор режима определения размера картинки в зависимости от размера элемента управления. Возможные значения: «Реальный размер», «Растянуть», «Пропорционально», «Черепица», «Авторазмер».


Категория свойств Характеристики

Горизонтальное положение — определяет выравнивание текста по горизонтали.

Вертикальное положение — определяет выравнивание текста по вертикали.

Многострочность — отображение длинного текста кнопки в несколько строк.


Командная панель

Элемент управления «Командная панель» (панель инструментов) предназначен для размещения в форме набора команд, с помощью которых производится управление информацией, размещенной в форме. Командная панель представляет собой окно с набором кнопок. Нажатие мышью на любую из кнопок вызывает немедленное выполнение связанной с этой кнопкой команды.

В форме может быть несколько командных панелей. Конфигуратор не ограничивает их число.

Любую командную панель можно дополнить новыми командами, а ненужные введенные команды удалить.

Для каждой панели можно указать свойство Заполнять автоматически и выбрать различные источники действий. В этом случае Конфигуратор произведет формирование состава команд панели автоматически на основе вида формы и указанных источников. Вставленные таким образом команды удалить и исправить нельзя, можно только добавить новые команды. При снятии флажка свойства командной панели Заполнять автоматически удаляются все команды, вставленные автоматически. В командной панели остаются только команды, вставленные вручную.

Приемы создания и редактирования подробно описаны в разделе « Редактор индивидуальных пользовательских интерфейсов » .


Командная панель


Категория свойств Основные

Заполнять автоматически — при установке данного свойства командная панель будет заполняться автоматически (ручное заполнение панели также возможно). Если свойство установлено, то состав кнопок определяется с учетом свойства Источник действий, видом формы (например, для объекта конфигурации «Справочник» существуют следующие виды форм: «Форма списка», «Форма элемента», «Форма группы», «Форма выбора справочника» и «Форма выбора группы справочника»)

Источник действия — определяет источник действий для командной панели. Можно указать «Все источники» или выбрать конкретный источник действий. Элементы управления, размещенные в форме, «способны» предоставлять набор действий, связанный с их собственными свойствами. Так, например, со списком можно производить различные действия по добавлению, редактированию, удалению, отбору, просмотру и другие действия, со списком-деревом — действия отбора и сортировки, с табличным полем — действия по добавлению, редактированию, удалению, упорядочивания и сортировки. Кроме того, сама форма также может являться источником. В свойстве можно указать конкретный элемент или форму или выбрать в качестве источника все элементы и форму.


Категория свойств Характеристики

Ориентация — вертикальное или горизонтальное расположение элемента управления в форме (авто, горизонтальная, вертикальная). Если указано «Авто», то ориентация выбирается по соотношению сторон: если высота больше ширины, то элемент ориентирован вертикально, если высота меньше ширины, то элемент ориентирован горизонтально.

Выравнивание кнопок — определяет расположение кнопок в панели инструментов (слева, по центру, справа).


Надпись

Элемент управления «Надпись» предназначен для размещения в форме различных поясняющих надписей, а также ссылок (гипер-ссылок). Механизм ссылки позволяет организовать отработку нажатия надписи (по клавише Enter или мышью). По ссылке программа запускает процедуру, определенную в свойстве Нажатие категории События.


Надпись


Категория свойств Основные

Заголовок — текст надписи элемента управления.

Гипперссылка — данный элемент управления может использоваться для вызова других режимов.

Бегущая строка — использовать режим бегущей строки. Возможные значения: «Не использовать», «Очень медленно», «Медленно», «Нормально», «Быстро», «Очень быстро».


Категория свойств Оформление

Выделять отрицательные — выводить отрицательные числа специальным цветом или нет.


Категория свойств Характеристики

Горизонтальное положение — определяет выравнивание текста по горизонтали.

Вертикальное положение — определяет выравнивание текста по вертикали. Если выбрано «по центру», то текст надписи не переносится по словам.


Панель

Элемент управления «Панель» предназначен для облегчения редактирования форм, динамически меняющих состав своих элементов в зависимости от действий пользователя.

При вставке элемента управления «Панель» в форму появляется элемент, содержащий одну закладку «Страница 1». Страница — это воображаемая поверхность, параллельная плоскости формы, предназначенная для размещения других элементов управления.

Панель может содержать несколько страниц. Приемы добавления и управления страницами совпадают с приемами управления страниц в форме (см. параграф « Страницы формы »)

Управление страницами панели средствами встроенного языка. Таким образом, можно распределить элементы управления по различным страницам панели для того, чтобы в зависимости от ситуации показывать на форме только нужные элементы , а остальные - скрывать.

В связи с тем, что свойства панели практически полностью совпадают со свойствами формы, укажем только различия.


Панель


Категория свойств Основная

Панель в отличии от свойств формы, не имеет свойств Заголовок, Автоматический заголовок, Данные, Тип данных.

Имя — имя элемента управления, по которому будет выполняться обращение к панели в алгоритме модуля.


Категория свойств Основная


Категория свойств Использование

Отображение закладки — вариант отображения закладок. Выбирается не только граница, вдоль которой производится размещение закладки, но ориентация текста закладки (для закладок, расположенных справа или слева).

Распределять по страницам — устанавливает, будет ли панель распределять элементы управления по отдельным страницам.


Категория свойств Использование


Категория свойств Текущая страница

Имя — имя страницы, по которому к свойствам страницы можно обращаться средствами встроенного языка.

Заголовок страницы — строка текста, которая будет выводиться на закладке.

Картинка заголовка — картинка, которая будет выводиться на закладке.

Видимость страницы — устанавливает, будет ли данная страница видна или нет.

Доступность страницы — устанавливает, будет ли доступна данная страница или нет.


Категория свойств События

При смене страницы - вызывается при переключении с одной закладки панели на другую


Переключатель

Элементы управления «Переключатель» используют в тех случаях, когда требуется выбрать (указать) только одно значение из небольшого числа возможных фиксированных вариантов (например, пол сотрудника «Мужской» или «Женский»). Поэтому такие элементы не размещают в одиночку.

Для: переключателей, относящихся к одной категории, существует понятие «группа», а элемент, который обычно располагает в форме первым, должен иметь установленное свойство Первый в группе. Не зависимо от числа элементов типа «Переключатель», входящих в группу, все они будут определять выбор значения только одного реквизита. Для элемента «первого в группе» можно выбрать реквизит формы, который хранит состояние переключателя, или использовать собственно реквизит «Переключатель», который создается при размещении в форме. В этом случае такой реквизит имеет тип «Число».

Если в форме расположены несколько групп переключателей, то для каждой группы должен существовать элемент в установленным свойством Первый в группе. Если такие группы располагаются последовательно, то нужно указать, какие их них относятся к одной группе, а какие к другой. Это делается с помощью механизма установки порядка обхода элементов в форме (см. свойство формы « Автопорядок обхода ». ). Если при установке порядка обхода выбран элемент с установленным свойством Первый в группе, то все последующие указанные элементы типа «Переключатель» будут относиться к этому элементу до элемента другого типа или другого элемента с установленным свойством Первый в группе.


Переключатель


Категория свойств Характеристики

Положение заголовка — положение заголовка относительно поля редактирования элемента управления (текст справа или слева).

Горизонтальное положение — определяет выравнивание текста по горизонтали.

Вертикальное положение — определяет выравнивание текста по вертикали.


Категория свойств Использование

Отображать закладки — вариант отображения закладок.

Распределять по страницам — устанавливает, будет ли панель распределять элементы управления по отдельным страницам.

Использование — указывается, для каких типов элементов (группа, элемент или для обоих) требуется применить форму, свойство появляется, если выбрана ФормаЭлемента или ФормаГруппы справочника.


Поле ввода

Элемент управления «Поле ввода» предназначен для ввода и редактирования информации. Поле ввода является одним из наиболее распространенных элементов управления. Оно используется для ввода значении непосредственно в поле, для выбора значений из списков и для выбора ссылок на различные объекты. Набор различных кнопок управления существенно расширяет сферу его применения.

Поле ввода связано с объектом «Реквизит формы», используемого для хранения данных, который может иметь различный тип. Выбор типа данных определяет способ редактирования.

Свойства поля ввода, определяющие поведение поля («Тип данных», «Длина», «Точность» и др.) задаются на этапе редактирования объекта конфигурации.


Поле ввода


Категория свойств Основные

Данные — имя данных, используемых для хранения значений, редактируемых элементом управления. Для форм типообразующих объектов данных («Справочник», «Документ» и т.д.) допускается выбор любого реквизита из списка доступных для выбора. В этом случае свойство Тип значения становится недоступным.

Тип значения — тип данных, используемых для хранения значений, редактируемых элементом управления.

В зависимости от выбранного типа данных, появляются дополнительные свойства, определяющие размер и точность (для чисел), длина — для строки, формат представления даты.

Для типа «Число»:

Мин. значение — минимальное числовое значение (если не указано то не ограничивается).

Макс. значение — максимальное числовое значение (если не указано то не ограничивается).

Для типа «Строка»:

Многострочный — содержит признак возможности ввода текста, состоящего из нескольких строк.

Маска — маска определяющая ввод символов в строке (может содержать определенные символы и специальные символы маски).

Режим пароля — режим при котором вводимые символы будут отображаться специализированным символом.

Для типа «Дата»:

Режим ввода даты — режим ввода даты (только дату, дату и время или только время).


Категория свойств Характеристики

Выбирать тип — если значение в данном элементе управления может принимать разные типы, то данной свойство запрещает выбор типа пользователем.

Только просмотр — полностью запрещает изменение значения (и редактированием текста и кнопками).

Редактирование текста — доступно или нет редактирование текста в поле ввода (не влияет на использование кнопок).

Автоперенос строк — разрешен или нет автоматический перенос строк.

Длина дробной части — В дробной части числа всегда будут выводиться все разряды (в противном случае незначащие нули вводиться не будут).

Вертикальное положение — определяет выравнивание текста по вертикали.

Горизонтальное положение — определяет выравнивание текста по горизонтали.


Категория свойств Использование

Свойства этой категории определяют использование стандартных кнопок, располагаемых в правой части поля ввода.

Кнопка списка выбора — если флажок установлен, в поле ввода будет добавлена кнопка раскрытия выпадающего списка, для выбора значения.

Кнопка выбора — использование кнопки выбора. Кнопка очистки,— использование кнопки очистки значения.

Кнопка регулирования — использование кнопки регулирования (увеличения и уменьшения значения).

Кнопка открытия — использование кнопки открытия объекта, 'выбранного в поле ввода.

Авто-выбор. Если свойство установлено, то при помещении курсора в поле ввода будет автоматически открываться соответствующий список для выбора значения и вставки его в поле ввода.

Быстрый выбор — будет выполняться выбор из выпадающего списка.

Выбор групп и элементов — свойство доступно только для поля ввода типа «СправочникСсылка». Если установлено, то будет доступен выбор групп справочника, элементов или и того и другого (при выборе не базовых типов данных).

Если в свойстве Тип значения выбран не базовый тип («Число», «Строка»), а объект конфигурации (например, «Справочник-Ссылка-Номенклатура»), то в категорию свойств Использование

добавляются два свойства:

Форма выбора. Свойство доступно в том случае, когда поле ввода связано с данными, имеющими тип значения «СправочникСсылка». Свойство позволяет выбрать форму, которая будет использоваться для выбора элемента справочника. Различные формы справочника создаются при разработке справочника в процессе создания конфигурации.

Сочетание клавиш — определяет комбинацию клавиш, по которой может производиться вызов указанной в свойстве Форма выбора формы.


Категория свойств Оформление

Выделять отрицательные — выводить отрицательные числа специальным цветом или нет (если выбран числовой тин).

Картинка — выбор изображения картинки.

Картинка кнопки выбора — картинка, которая будет отображаться на кнопке выбора.

Высота списка выбора — высота списка выбора в строках (если не указана, то выбирается автоматически).

Ширина списка выбора — ширина списка выбора в Строках (если не указана, то выбирается автоматически).


Категория свойств События

Событие | Условие наступления
При изменении данных | вызывается при смене выбора (определяется только для элемента «Первого в группе»)
Начало выбора | вызывается при нажатии кнопки выбора или нажатии клавиши F4
Начало выбора из списка | вызывается при нажатии на кнопку выбора из списка
Очистка | вызывается при нажатии кнопки очистки или нажатии комбинации клавиш; Shift+F4
Регулирование | вызывается при нажатии на одну из кнопок регулирования.
Открытие (редактирование) | вызывается при нажатии на кнопку открытия
Обработка выбора | вызывается после осуществления выбора, но до помещения выбранного значения в элемент управления


Поле выбора

Элемент управления «Поле выбора» предназначей для организации выбора значения из списка значений, определенного заранее в свойстве Строки списка выбора палитры свойств или сформированного в модуле формы.


Поле выбора


Категория свойств Использование

Свойства этой категории определяют использование стандартных кнопок, располагаемых в правой части поля выбора.

Кнопка выбора — использование кнопки выбора.

Кнопка очистки — использование кнопки очистки значения.

Кнопка регулирования — использование кнопки регулирования (увеличения и уменьшения значения).

Кнопка открытия — использование кнопки открытия объекта, выбранного в поле ввода.

Строки списка выбора — задаются строки списка выбора (значениями списка будут являться номера строк).


Категория свойств События

Событие | Условие наступления
При изменении данных | вызывается при смене выбора (определяется только для элемента первого в группе)
Начало выбора | вызывается при нажатии кнопки выбора или нажатии клавиши F4
Начало выбора из списка | вызывается при нажатии на кнопку выбора из списка
Очистка | вызывается при нажатии кнопки очистки или нажатии комбинации клавиш Shift+F4
Регулирование | вызывается при нажатии на одну из кнопок регулирования
Открытие (редактирование) Обработка выбора | вызывается при нажатии на кнопку открытия вызывается после осуществления выбора, но до помещения выбранного значения в элемент управления


Поле картинки

Элемент управления «Поле картинки» предназначен для размещения в форме различных картинок. Механизм ссылок позволяет связать с полем картинки некоторые действия, выполняемые при нажатии на нее.


Поле картинки


Категория свойств Основные

Картинка — выбирается изображение картинки.

Размер картинки — режим определения размера картинки в зависимости от размера элемента управления.

Гиперссылка — данный элемент управления может использоваться для вызова других режимов. Если свойство установлено, то можно указать свойство.


Категория свойств События

Нажатие - выбирается процедура при нажатии кнопки мышью или клавишей Enter


Поле списка

Элемент управления «Поле списка» предназначен для визуализации агрегатного типа данных СписокЗначений. Все действия по управлению списком значений (добавление значения в список, удаление значения из списка, сортировка списка и другие) выполняются только средствами встроенного языка.


Поле списка


Категория свойств Использование

Отображать картинку — отображать картинку в колонке.

Отображать пометку — будут выводиться пометки в колонке или нет.


Категория свойств События

Событие | Условие наступления
Выбор | вызывается при двойном щелчке или нажатии Enter в строке
При активизации строки, | вызывается при активизации строки
Изменение пометки | вызывается после изменения пометки


Полоса регулирования

Элемент управления «Полоса регулирования» предназначен для быстрого и наглядного ввода значений типа «Число». По внешнему виду он напоминает обычный линейный регулятор, у которого введенное значение определяется положением «бегунка» и значениями минимума (левой / нижней границы) и максимума (правой / верхней границы).

Перемещение «бегунка» можно производить клавишами управления курсором, но удобнее с помощью указателя мыши.


Полоса регулирования


Категория свойств Данные

Мин. значение — минимальное числовое значение (если не указано то не ограничивается).

Макс. значение — максимальное числовое значение (если не указано то не ограничивается).

Шаг — шаг изменения значения.


Категория свойств Характеристики

Большой шаг — шаг листания страницами при нажатии клавиш PgUp (уменьшает значение) и PgDn (увеличивает значение).

Отображение разметки — как будет отображаться разметка. Возможные значения: «Не отображать», «Сверху (слева)», «Снизу(справа)», «С обеих сторон».

Ориентация — вертикальное или горизонтальное расположение элемента управления в форме. Если указано «Авто», то ориентация выбирается по соотношению сторон элемента: если высота больше ширины, то элемент ориентирован вертикально, если высота меньше ширины, то элемент ориентирован горизонтально.

Шаг разметки — шаг, с которым будет отображаться разметка.


Разделитель

Специальный элемент управления «Разделитель» предназначен для организации и управления областями формы. В режиме 1C: Предприятие (если для элементов управления типа «Разделитель» установлены свойства Доступность и Видимость) с помо щью разделителей производится перераспределение области формы (см. параграф « Область действия привязок » .

Разделитель обладает способностью «захватываться» мышью и перемещаться внутри формы в ее пределах с учетом возможности расположения других элементов управления и ориентации разделителя. При этом все элементы управления, привязанные к разделителю, будут изменять свои размеры или перемещаться в соответствии с установленными привязками. Размеры формы при этом не изменяются. Это позволяет использовать разделители для перераспределения пространства формы без изменения ее размеров.

Элементы управления этого типа не имеют свойства Тип данных и не связываются ни с какими другими объектами конфигурации.


Разделитель


Категория свойств Характеристики

Ориентация — вертикальное или горизонтальное расположение элемента управления в форме. Если указано «Авто», то ориентация выбирается по соотношению сторон. Если высота больше ширины, то элемент ориентирован вертикально, если высота меньше ширины, то элемент ориентирован горизонтально.


Рамка группы

Элемент управления «Рамка группы» предназначен для оформления формы. С его помощью производится визуальное объединение нескольких элементов управления, относящихся к определенной смысловой группе элементов.


Рамка группы


Категория свойств Основные

Заголовок — текст надписи элемента управления.

Скругленная рамка — скругленная рамка.


Табличное поле

Элемент управления «Табличное поле» состоит из собственно табличного поля, шапки, подвала и ячеек. Каждую часть элемента можно настраивать.

После создания (размещения в форме) табличное поле нужно активизировать и настроить его внешний вид.

Свойства табличного поля можно разделить на две группы. В первую группу входят свойства табличного поля в целом, как элемента.

Вторую группу свойств табличного поля образуют свойства ее составных частей.


Табличное поле


Настройка табличного поля

Задача настройки состоит в определении формата, специфического для каждой из частей, их размера и расположения.

Для редактирования этих свойств табличного поля используется панель свойств, которую можно вызвать, выбрав пункт «Правка — Свойства».

Если требуется выделить одну из составляющих частей элемента, после выбора элемента управления «Табличное поле» просто щелкните эту область мышью. После этого с помощью палитры свойств можно настроить поведение каждой составляющей элемента.


Настройка табличного поля


Категория свойств Основные

Тип значения — тип данных, используемых для хранения данных, редактируемых элементом управления. При ручном размещении тип данных назначается (по умолчанию) «ТаблицаЗначеиий». Если в данных выбран реквизит объекта конфигурации, к которому принадлежит форма, то выбор типа данных будет недоступен. При этом состав свойств элемента управления может быть различным. При выборе объекта конфигурации в таблицу автоматически вставляются колонки, соответствующие реквизитам объекта конфигурации. Состав свойств табличного поля также может меняться (определяется свойствами объекта конфигурации).


Категория свойств Использование

Только просмотр — если данное свойства установлено, запрещено изменение значения (и редактированием текста и кнопками).


Категория свойств Характеристики

Состав свойств категории Использование зависит от объекта конфигурации, выбранного в качестве типа данных.

Режим выделения — режим выделения строк (одиночный или множественный).

Режим ввода строк — режим ввода строк. Определяет, где будет создаваться новая строка (в конце списка, в конце окна, после текущей строки, перед текущей строкой).

Шапка — если свойство установлено, то шапка показывается.

Подвал — если свойство установлено, то подвал показывается.

Высота шапки — определяет высоту строк подвала, чтобы можно было выводить текст заголовков колонок из двух и более строк или с авто-переносом.

Высота подвала — определяет высоту строк подвала, чтобы можно было выводить текст заголовков колонок из двух и более строк или с авто-переносом.

Гор. полоса прокрутки — вариант вывода горизонтальной полосы прокрутки. Возможный выбор: не использовать, использовать всегда, использовать автоматически. По умолчанию выбирается «использовать автоматически» (если не все колонки помещаются, то показывается полоса прокрутки).

Верт. полоса прокрутки — вариант вывода вертикальной полосы прокрутки. Возможный выбор: не использовать, использовать всегда, использовать автоматически. По умолчанию выбирается «использовать автоматически» (если не все колонки помещаются, то показывается полоса прокрутки).

Фиксация слева — количество фиксированных слева колонок. При горизонтальной прокрутке указанное число колонок не будет скролироваться.

Фиксация справа — количество фиксированных справа колонок.При горизонтальной прокрутке указанное число колонок не будет скролироваться.

Авто-ввод новой строки — если свойство установлено, то после завершения (успешного) ввода новой строки — автоматически начинается ввод следующей.

Нач. отображение списка — при открытии формы переходить в начало или конец таблицы.


Категория свойств Оформление

Цвет фона поля — определяется цвет фона поля (редактирования, выбора и т.д.) элемента управления.

Цвет текста поля — определяется цвет текста поля (редактирования, выбора и т.д.) элемента управления.

Рамка — определяется тип рамки отображаемой вокруг элемента управления.

Цвет рамки — определяется цвет рамки отображаемой вокруг элемента управления.

Шрифт — определяется шрифт текста элемента управления.

Горизонтальные линии — если установлен, то строки отделяются друг от друга горизонтальными линиями.

Вертикальные линии — если установлен, то колонки отделяются друг от друга вертикальными линиями.

Цвет фона заголовка — определяется цвет фона заголовка таблицы.

Цвет текста заголовка — определяется цвет текста заголовка таблицы.

Цвет фона подвала — определяется цвет фона подвала таблицы.

Цвет текста подвала — определяется цвет текста подвала таблицы.

Цвет фона выделения — определяется цвет фона выделенных строк.

Цвет текста выделения — определяется цвет текста выделенных строк.

Цвет фона чередования строк — определяется цвет фона чередования строк.

Чередование цветов строк— если установлен, то цвет фона строк чередуется.

Шрифт шапки — определяется шрифт шапки таблицы.

Шрифт подвала — определяется шрифт подвала таблицы.


Категория свойств События

Событие | Условие наступления
Выбор | При двойном щелчке мыши или нажатии Enter
При активизации строки | При активизации строки
При активизации колонки | При активизации колонки
При активизации ячейки | При активизации ячейки
Перед добавлением | При вызове режима добавления строки
Перед изменением | При вызове режима изменения строки
Перед удалением | При вызове удаления строки
При начале редактирования | При входе в режим редактирования строки
При окончании редактирования | При выходе из режима редактирования строки
При выводе строки | Вызывается при выводе строки
Выбор значения | Вызывается при выборе значения из списка в режиме выбора


Добавление, размещение и удаление колонок

Таблица состоит из колонок и строк. Число строк определяется числом данных, а число колонок, их заголовки, расположение, оформление и другие свойства обычно определяются на этапе разработки конфигурации.

Для добавления колонки в контекстном меню выберите пункт «Добавить колонку». В результате будет вставлена новая колонка. Ей будет присвоено наименование (заголовок) по умолчанию, состоящий из строки «Колонка» и числа, обозначающего порядковый номер колонки в создаваемом табличном поле. Текст заголовка можно изменить.

Для удаления колонки выберите колонку ив контекстном меню выберите пункт «Удалить колонку».

Новые колонки размещаются в таблице справа. Они имеют ширину, устанавливаемую по умолчанию. Чтобы переместить колонку на другое место, выберите ее (щелкните ее мышью), в поле колонки нажмите левую кнопку мыши и не отпуская ее переместите на новое место. При перемещении новая позиция колонки будет показываться парой красных маркеров в виде стрелок, показывающих перед или после какой колонки установить выбранную колонку. При отпускании клавиши мыши колонка устанавливается на новое место.

Если в таблицу вставлено больше колонок, чем может быть показано в окне элемента. Воспользуйтесь горизонтальной линейкой прокрутки.

Если установлено свойство Подвал, то вместе с колонкой перемещается и подвал, относящийся к этой колонке.

Ширину колонки можно установить с помощью мыши. Для этого подведите указатель мыши к правой границе колонки. Он примет вид < - > Потяните границу влево или вправо. При изменений размеров выбранной колонки изменяется размер колонки, расположенной справа.

Если в табличное поле требуется добавить новую колонку, предназначенную для нового реквизита, то это можно сделать с помощью пункта «Форма — Вставить данные». При размещении колонки ее свойства определяются свойствами реквизита.


Добавление, размещение и удаление колонок


Свойства колонок

Если выделить колонку (щелкнуть указателем мыши в области наименования колонки),то можно увидеть палитру свойств указанной колонки. В палитре свойств задается наименование и расположение колонки, тип данных, их представление, выбирается оформление.


Свойства колонок


Категория свойств Основные

Имя — имя элемента управления, по которому будет выполняться обращение к колонке в модуле.

Если табличное поле имеет тип «ТаблицаЗначений» или «ДеревоЗначений», то категория содержит свойства:

Данные — имя колонки данных.

Элемент управления — выбирается вид элемента управления, с помощь которого будут вводиться или показываться данные, относящиеся к этой колонке.

Тип значения — тип данных, используемых для хранения значений, редактируемых элементом управления. Выбор осуществляется из базовых типов данных и из прикладных типов данных. При выборе базовых типов могут дополнительно выводиться реквизиты панели свойств, относящиеся к выбранному типу (для типа «Строка» требуется дополнительно указать ее размер, для «Дата» — режим ввода даты (только дату, дату и время или только время), и т.д.).

Данные флажка — указывается имя флажка.

Данные картинки — указывается имя картинки.

Если табличное поле связано с объектом конфигурации, то указанные выше свойства заменяются на:

Значение — указывается имя реквизита объекта, относящегося к этой колонке.

Значение флажка — выбирается значение флажка (если указан).

Доступность — если установлен, то данная колонка доступна.

Видимость — если установлен, то данная колонка выводится при работе.

Только просмотр — если установлен, то полностью запрещает изменение значения (и редактированием текста и кнопками).

Текст шапки — указывается текст шапки (заголовок колонки).

Текст подвала — указывается текст подвала.

Если в реквизите свойств Колонка выбран «Данные», то в панели свойств выводятся дополнительные реквизиты.


Категория свойств Характеристики

Положение — выбирается положение колонки. Возможные значения: новая колонка, на следующей строке, в той же колонке.

Если табличное поле имеет тип «ТаблицаЗначений» или «ДеревоЗначений», то категория содержит свойства:

Горизонт. положение в шапке — выбирается положение текста в шапке колонки.

Горизонтальное положение — выбирается положение текста в области данных. При выборе «Автоматически» программа будет производить выравнивание исходя из типа данных (строки выравниваются влево, а числа — вправо).

Горизонт, положение в подвале — выбирается положение текста в подвале колонки.

Если табличное поле связано с объектом конфигурации, то указанные выше свойства заменяются на:

Начальное положение списка — начальное отображение списка (в начало или конец).


Свойства ячеек

Ячейки таблицы располагаются под колонками так, как показано на рисунке:

Ячейка относится к той колонке, под которой она расположена. Выбор ячейки осуществляется с помощью щелчка мыши в предполагаемое место ячейки. При выборе ячейки подсвечивается колонка к которой относится ячейка.


Свойства ячеек


Категория свойств Основные

Доступность — если свойство установлено, то все ячейки данной колонки будут доступны.


Категория свойств Характеристики

Выбирать тип — если значение в данном элементе управления может принимать разные типы, то данной свойство запрещает выбор типа пользователем.

Только просмотр — если установлен, то полностью запрещает изменение значения (и редактированием текста и кнопками).

Редактирование текста — если установлен, то устанавливает доступность редактирования текста в поле ввода (не влияет на использование кнопок).

Авто перенос строк — разрешен или нет автоматически перенос строк (доступен для текстовых типов значений).

Фиксированная длина дробной части— если установлен, то в дробной части числа всегда будут выводиться все разряды (в противном случае незначащие нули вводиться не будут) (доступен для числовых типов значений).

Вертикальное положение — выбирается способ выравнивания текста по вертикали (возможные значения: прижать вверх, центрировать, прижать вниз).

Горизонтальное положение — выбирается способ выравнивания текста по горизонтали (возможные значения: прижать влево, центрировать, прижать вправо, автоматически; в последнем случае выравнивание выбирается по типу данных — для строковых выравнивается влево, для числовых — вправо).

Автовыбор. Если свойство установлено, то при помещении курсора в ячейку будет автоматически открываться соответствующий список для выбора значения и вставки его в ячейку.

Сочетание клавиш — определяет комбинацию клавиш, по которой может производиться вызов указанной в свойстве Форма выбора формы.


Категория свойств Использование

Категория свойств показывается в палитре свойств, если табличное поле связано с объектом конфигурации.

Кнопка списка выбора — если установлено, то используется выпадающей список для выбора значения.

Кнопка выбора — если установлено, то используется кнопка выбора.

Кнопка очистки — если установлено, то используется кнопка очистки.

Кнопка регулирования — если установлено, то используется Кнопка регулирования (увеличения и уменьшения значения).

Кнопка открытия — если установлено, то используется кнопка открытия объекта выбранного в поле ввода.


Категория свойств Оформление

Цвет фона поля — определяется цвет фона поля (редактирования, выбора и т.д.) элемента управления.

Цвет текста поля — определяется цвет текета поля (редактирования, выбора и т.д.) элемента управления.

Цвет фона кнопки — определяется цвет фона кнопки элемента управления.

Цвет текста кнопки — определяется цвет текста кнопки элемента управления.

Рамка — определяется тип рамки отображаемой вокруг элемента управления.

Цвет рамки — определяется цвет рамки отображаемой вокруг элемента управления.

Шрифт — определяется шрифт текста элемента управления.

Выделять отрицательные — если установлен, то вывод отрицательных чисел производится специальным цветом.

Картинка — выбор изображения картинки.

Картинка кнопки выбора — выбор картинки, которая будет отображаться на кнопке выбора.

Высота списка выбора — высота списка выбора в строках (если не указана, то выбирается автоматически).

Ширина списка выбора — ширина списка выбора в строках (если не указана, то выбирается автоматически).

Подсказка — Текст подсказки которая будет выдаваться для пояснения назначения элемента управления .


Категория свойств События

Категория свойств показывается в палитре свойств, если табличное поле связано с объектом конфигурации.

Список обрабатываемых событий ячейки представлен в таблице:

Событие | Условие наступления
При изменении данных | Вызывается при изменении данных в ячейке
Начало выбора | Вызывается при нажатии кнопки выбора или нажатии клавиши F4
Начало выбора из списка | Вызывается при нажатии на кнопку выбора из списка
Очистка | Вызывается при нажатии кнопки очистки или нажатии комбинации клавиш Shift+F4
Регулирование | Вызывается при нажатии на одну из кнопок регулирования
Открытие (редактирование) | Вызывается при нажатии на кнопку открытия
Обработка выбора | Вызывается после осуществления выбора но до помещения выбранного значения в элемент управления


Табличный документ

Информацию по элементу управления «Табличный документ» см. главу « Табличный редактор ».


Табличный документ


Текстовый документ

Элемент управления «Текстовый документ» предназначен для размещения текстового редактора в разрабатываемой форме. Элементы этого типа не связываются с объектами конфигурации. Содержимое формируется и сохраняется только из модуля формы.


Текстовый документ


Категория свойств Оформление

Рамка — тип рамки отображаемой вокруг элемента управления.

Цвет рамки — выбор цвета рамки.

Расширение — используемое расширение редактора. Возможные значения: «Не указано», «HTML», «Текст запроса»


Конструкторы форм

Для каждого объекта конфигурации, в составе которого может находиться подчиненные объекты типа «Форма», при добавлении новой формы запускается Конструктор формы Это специальный мастер, с помощью которого производится выбор вида формы и размещаются реквизиты объекта конфигурации Не смотря на существенные различил типов объектов, для которых производится создание формы, конструкторы имеют много общего Поэтому рассмотрим работу конструктора форм на примере конструктора формы документа

При создании новой формы объекта на экран выводится конструктор формы

Группа элементов управления «Выберите тип формы» предназначена для выбора типа формы (определяется видом выбранного объекта конфигурации, для которого создается форма) Для объекта конфигурации «Документ» это «Форма списка документов», «Форма выбора документа», «Форма документа», «Произвольная форма (пустая форма)».

Если у объекта несколько форм одного типа, то одну из них можно выбрать в качестве основной Если при вызове формы объекта не указано явно, какую именно форму следует вызвать, на экран будет выводиться основная форма Для указания основной формы при создании установите флажок «Назначить форму основной» В дальнейшем выбор основной формы можно изменить в диалоге редактирования объекта (п.« Диалог редактирования объекта ») на закладке «Прочее».

Укажите Имя формы, Синоним и Комментарий если нажать кнопку «Готово», то конструктор самостоятельно разместит элеметы управления в форме и откроет форму для редактирования.

Если есть необходимость нестандартного размещения основных элементов управления (например, не нужно размещать некоторые элементы или требуется отличный от стандартного вид представления), то нажмите кнопку «Далее» Состав реквизитов определяется выбором типа формы Для типа формы «Форма документа» состав реквизитов состоит из реквизитов шапки и табличной части.

На этом шаге конструктора формы следует выбрать реквизиты, которые необходимо вставить в форму. Выбор осуществляется в графе «Реквизиты» установкой пометки слева от наименования элемента. Тип представления выбирается в графе «Элементы формы» для каждого реквизита. Укажите вид представления основных элементов управления (надпись, поле ввода, флажок и т.д.).В приведенном примере в состав реквизитов вошел реквизит «Учет номенклатуры». Это табличное поле, для учета данных по движению регистра накопления «Учет номенклатуры», указанному на закладке «Движения» диалога редактирования объекта.

В реквизите «Располагать элементы управления в ... колонку(и)» указывается число колонок располагаемых в форме элементов. Нажмите кнопку «Готово».

Если установлен флажок «Открыть форму для редактирования», то на экран выводится созданная форма, которую можно редактировать (вставлять элементы управления, настраивать их поведение и т.д.).

После работы конструктора форм можно продолжить работу с формой. Например, разместить в ней новые страницы, дополнительные элементы управления, изменить расположение элементов относительно друг друга, распределить их по страницам и т.д. В результате получаем форму документа «РасходнаяНакладная»:


Конструкторы форм


Модуль

Как уже говорилось, форма — это совокупность трех составляющих: диалога, который представляет визуальное средство представления и ввода информации, модуля , в котором находится программа на встроенном языке, и списка реквизитов , в которых хранятся дополнительные данные, размещенные в диалоге.

Программы, расположенные в форме, выполняют различные действия с реквизитами формы, выполняют различную подготовительную обработку данных и событий, непосредственно связанных с диалогом.

Помимо модулей формы некоторые типы объектов конфигурации могут иметь модуль, в котором производится выполнение основных действий для данного объекта. К таким объектам относятся объекты типа «Справочник», «Документа, «Отчет» и «Обработка».

Не зависимо от числа форм, модуль для каждого объекта может быть только один. В модуле производятся основные действия, связанные с назначением объекта. В нем производится обработка предварительно введенных и установленных в диалоге формы значений реквизитов, запись или выборка требуемой информации или формирование выходной формы с использованием макетов.

Объект может иметь несколько форм. Число форм определяется вариантностью различных видов срезов исходной информации. Но не зависимо от сочетания этих параметров данный отчет всегда будет оперировать с одним и тем же набором исходных данных.


Глава 7.Диаграмма

Диаграмма — элемент управления, предназначенный для визуального представления табличных данных (например, результатов отчетов).


Глава 7. Диаграмма


Основные принципы и понятия

Элемент управления «Диаграмма» можно размещать в форме , таблице (макете и табличном документе).

Элемент управления «Диаграмма» состоит из собственно диаграммы, в которой расположены три области: построения, легенды и заголовка. Каждую область можно перемещать внутри диаграммы, изменять ее размер, настраивать или убирать из диаграммы (кроме области построения). При изменении размеров диаграммы размеры областей также меняются пропорционально изменению размеров элемента.

После создания диаграмму нужно активизировать, например, двойным щелчком мыши, и настроить ее внешний вид.

Свойства диаграммы можно разделить на две группы.

В первую группу входят свойства диаграммы в целом, как графического объекта. Для редактирования этих свойств используется панель свойств, которую можно вызвать, выбрав пункт «Правка — Свойства».

Вторую группу свойств диаграммы образуют свойства ее составных частей: общей области диаграммы, области построения диаграммы, заголовки и легенды.

Диаграмма представляет собой определенную фигуру, которая строится на основе матрицы данных. Данные, организованные в виде матрицы, удобно представить как значения, полученные в результате замеров, причем замеры производились сериями. Для матрицы значений размером [M,N] М — количество точек, заме рами в которых получены значения, N — количество серий значений (далее — серий).

Для количественной ориентации в диаграмме используются координатные оси. Каждому значению, отмеченному на оси, соответствует поясняющая метка (далее — метка). В зависимости от типа координатной оси, метка может быть рассчитанной, или определяться при заполнении данными. Например, для объемной диаграммы по одной горизонтальной оси откладываются номера замеров (1, 2, 3...), по другой — наименования серий, а по вертикальной оси — значения (числовые данные, по которым строится диаграмма).

С точки зрения настройки, диаграмма состоит из четырех областей:

• общая область диаграммы, или, для краткости, просто область диаграммы - совокупность всех областей, образующих диаграмму;

• область построения диаграммы - содержит координатное пространство и изображенную на нем фигуру;

• заголовок диаграммы;

• легенда - вспомогательная область, содержали» список меток, соответствующих сериям.


Основные принципы и понятия


Создание элемента управления Диаграмма

Элемент управления типа «Диаграмма» может размещаться в форме и табличном документе.

Для размещения диаграммы откройте форму и выберите пункт «Форма — Вставить элемент управления», в открывшемся диалоге выбора элементов выберите диаграмму.

Для табличного документа выберите пункт «Таблица — Вставить рисунок — Диаграмма».

Если перед вставкой элемент управления «Диаграмма» область диаграммы не выделена, то после размещения элемента управления на экран выводится диалог «Диапазон» для определения области данных, на основании которых строится диаграмма. Выделите область данных (если данных пока нет, то можно просто указать место, в котором они будут расположены) и нажмите кнопку диалога «Диапазон».


Создание элемента управления Диаграмма


Настройка диаграммы

Настройка диаграммы обычно проводится на этапе конфигурирования. Задача настройки состоит в определении формата, специфического для каждой из областей, их размера и расположения. При этом настройка ограничена пределами, определяемыми теми требованиями, которые различные типы диаграмм предъявляют к организации данных (см. ниже).

Для получения доступа к свойствам диаграммы в форме выберите элемент «Диаграммам, а в табличном документе дважды щелкните ее мышью. Если требуется выделить одну из областей, после выбора элемента управления «Диаграмма» просто щелкните эту область мышью. После этого с помощью палитры свойств можно настроить поведение области диаграммы. Для возврата к свойствам диаграммы снова щелкните мышью выбранную область.


Настройка диаграммы


Категория свойств Основные

Имя — только для элемента, расположенного форме. Служит для доступа к свойствам диаграммы из модуля.

Активизировать по умолчанию — только для элемента, расположенного в форме. Если свойство установлено, данный элемент управления будет активизирован при открытии формы.

Тип диаграммы — служит для выбора типа диаграммы.

Максимум серий — указывает алгоритм построения диаграммы в зависимости от числа серий. Если выбрано «Не задано», то в диаграмму выводятся все серии. Если выбрано «Ограниченно», то в область построения и область легенды будет выводиться число серий, не больше, чем указано в свойстве Количество. В случае, когда общее число серий превышает предельное, формируется дополнительная серия «Сводная». Общее число серий будет определяться максимальным количеством (с учетом «Сводной»). Кроме нее будут показаны только те серии, которые выбираются по следующему алгоритму; по каждой серии ищется максимальное точечное значение (по модулю), эти значения сортируются и выбирается то их число, которое возможно для показа (Количество). Значения непоказанных серий суммируются в сводной серии по каждой точке.

Если выбрано значение Максимум серий «Процент», то выполняется другой алгоритм показа серий: выбирается абсолютный максимум по всем точкам всех серий, вычисляется пороговое значение отбора (выбранное значение умножается на величину процента, заданного в реквизите «Величина»), если в серии есть значения, превышающие это пороговое значение, эта серия будет показана. Значения непоказанных серий суммируются в сводной серии по каждой точке.

Активная точка — выбор точки, для которой производится построение диаграммы всех разновидностей типов «Круговая».

Активная серия — выбор серии, для которой производится построение диаграммы всех разновидностей типов «Биржевая».

Базовое значение — указывает начальное значение координат (ординаты). Часто бывает, что изменение параметра, показываемого в диаграмме, несоизмеримо малы по сравнению с его минимальным значением. Для этого случая рекомендуется установить в качестве базового значения значение, приближающееся к минимальному значению.

Изменяет данные — только для элемента, расположенного в форме. Элемент формы непосредственно не связан с данными, но косвенно изменяет их.

Пропускать при вводе — только для элемента, расположенного в форме. Если данное свойства установлено, то элемент управления будет пропущен при обходе клавишей Enter.

Первый в группе — только для элемента, расположенного в форме. Устанавливает элемент управления первым в группе элементов управления, расположенных последовательно в порядке обхода формы.

Контекстное меню— только для элемента, расположенного в форме. Определяет контекстное меню, которое будет отображаться при нажатии на элементе управления правой клавишей мыши.

Видимость — только для элемента, расположенного в форме. Устанавливает - будет ли данный элемент управления виден или нет.

Доступность — определяет, будет ли доступен элемент управления диаграмма.


Категория свойств Оформление

Состав свойств данной категории зависит от выбранного типа Диаграммы. Есть общие свойства, присущие всем типам диаграмм.

Тип рамки — определяет тип рамки.

Цвет рамки — если рамка задана, то в реквизите определяется ее цвет

Прозрачный фон — определяет прозрачность фона под диаграммой.

Цвет фона — определяет цвет фона.

Состав свойств, относящимся к определенным типам диаграмм.

Тип диаграммы | Состав дополнительных свойств категории Оформление
График График по шагам График с областями График с областями и накоплением | Окантовка — окантовка черным цветом областей на диаграмме
Гистограмма Гистограмма с накоплением | Режим пробелов — пробелы между точками на гистограммах
Гистограмма горизонтальная | Окантовка — окантовка черным цветом областей на диаграмме
Гистограмма с накоплением горизонтальная | Градиент — градиентная закраска плоских гистограмм
Гистограмма объемная Гистограмма с накоплением объемная Гистограмма горизонтальная объемная Гистограмма с накоплением горизонтальная объемная | Режим пробелов — пробелы между точками на гистограммах Окантовка — окантовка черным цветом областей на диаграмме Свет — осветление и затемнение участков объемных диаграмм
Круговая Круговая объемная | Вид подписей к круговой диаграмме — способ формирования подписей к круговым диаграммам Автоматическое раздвижение секторов — режим раздвижения секторов круговых диаграмм Окантовка — окантовка черным цветом областей на диаграмме
Биржевая Биржевая "свеча" | Режим пробелов — пробелы между точками на гистограммах Окантовка — окантовка черным цветом областей на диаграмме
Изометрическая обычная Изометрическая непрерывная Изометрическая лента Изометрическая пирамида | Ориентация — ориентация координатной системы для изометрических диаграмм Режим пробелов — пробелы между точками на гистограммах Окантовка — окантовка черным цветом областей на диаграмме Свет — осветление и затемнение участков объемных диаграмм

Режим пробелов — возможные варианты выбора: «Без пробела», «Половинная ширина» и «Полная ширина».

Вид подписей к круговой диаграмме - возможные значения: «Нет» (нет подписей), «Имя серии», «Значение», «Процент», «Имя серии + процент». «Имя серии + значение», «Имя серии + значение + процент», «Значение + процент». Выбирать вид подписей нужно осмотрительно, т.к. программа показывает подписи целиком за счет уменьшения размера.

Автоматическое раздвижение секторов — возможные значения: «Нет» (нет выдвижения), «Все» (выдвигаются все секции), «Максимальная серия» (выдвигается секция, имеющая максимальное значение), «Минимальная секция» (выдвигается секция, имеющая минимальное значение).


Категория свойств Серии

Генерация имен серий — если заранее не известно, сколько серий будет показано в диаграмме, то их имена можно формировать автоматически. Если свойство установлено, то программа при будет генерировать имена новых серий (например «Серия1», «Серия2» и т.д.).

Настройка серий — если свойство установлено, то становятся доступными свойства серий (имя, оформление серии и др.). Устанавливаемые настройки будут запоминаться. Если свойство не установлено или в процессе исполнения количество серий или точек превысило число настроенных, то свойства новых серий (точек) будут генерироваться по следующему алгоритму: Линии сплошные, толщиной 3. Цвета: Есть восемь стандартных цветов. Выбирается цвет по остатку от деления номера серии на 8. Настройки по умолчанию для объединенной серии выбираются как для серии 7.

Количество серий — свойство появляется, если диаграмма вставлена в форму. Свойство задает максимальное число показываемых серий. Остальные сери будут объединены в сводную серию.

Текущая серия — выбирается серия, для которой требуется произвести настройку.

Имя — задается имя выбранной в «Текущая сериям серии (показывается области легенды и на осях области построения диаграммы).

Раздвигать — свойство применимо для круговых типов диаграмм; если установлено, то определяет поведение сектора, при котором сектор диаграммы, относящийся к выбранной в свойстве Текущая серия серии, будет отображаться отодвинутым от центра.

Цвет — определяет цвет линий и областей выбранной серии.

Маркер — свойство применимо для диаграмм типа «График»; определяется вид маркера, которым будет помечаться каждая точка выбранной серии.

Стиль линии — свойство применимо для диаграмм типа «График»; определяется вид и толщина линии, которой рисуется график выбранной серии.


Категория свойств Серии


Категория свойств Точки

Генерация имен точек— если заранее не известно, сколько серий будет показано в диаграмме, то их имена можно формировать автоматически. Если свойство установлено, то программа будет генерировать имена новых точек.

Настройка точек — если свойство установлено, то можно редактировать другие свойства точки (число точек должно быть больше 0).

Количество точек — свойство появляется, если диаграмма вставлена в форму; задается максимальное число точек. Для табличного документа число точек задается выбором диапазона в категории Область данных.

Текущая точка — выбирается точка, для которой требуется редактировать имя (только для элемента формы).

Имя - задается имя точки (только для элемента формы).


Категория свойств Точки


Категория свойств Характеристики

Отображать заголовок - если свойство установлено, то показывается область заголовка .

Отображать легенду - если свойство установлено, то показывается область легенды.


Категория свойств Область данных

Категория показывается, если диаграмма вставлена в табличный документ.

Серии в — указывается расположение серий (в строках или столбцах исходных данных).

Диапазон — задает диапазон ячеек, в которых расположены исходные данные для построения диаграммы. Диапазон может быть переназначен, для этого в свойстве Диапазон нажмите кнопку выбора. На экран выводится диалог «Диапазон».Введите новый диапазон или с помощью указателя мыши выделите новый диапазон (при выделении диапазона учтите, что левая колонка и верхняя строка определяют серии и точки диаграммы). В качестве диапазона можно указывать именованные области. Для окончания выбора диапазона нажмите кнопку диалога «Диапазон».


Категория свойств Область данных


Категория свойств События

Категория появляется, если диаграмма вставлена в форму.

Выбор — выбирается процедура из модуля формы, которая будет отрабатываться при выборе значения.

Обработка расшифровки — обработка события, возникающего при выборе ячейки с расшифровкой.


Формат областей построения легенды и заголовка диаграммы

Для областей в палитре свойств задается их оформление. Выбирается вид рамки, ее цвет, толщина, определяется фон. Для надписей определяются шрифты (вид, размер, начертание) и цвет текста. Для области заголовка указывается текст заголовка.


Формат областей построения легенды и заголовка диаграммы


Категория свойств Оформление

Для всех областей общими настройками будут выбор рамки, ее цвета, цвета фона и его прозрачности, выбор шрифта текста.

Рамка — определяет тип рамки.

Цвет рамки — если рамка задана, то в реквизите определяется ее цвет.

Прозрачный фон — определяет прозрачность фона области.

Цвет фона — доступен только для табличного документа; определяет цвет фона области.

Шрифт — задает шрифт текста (заголовок диаграммы, наименования серий, точек, показания шкалы). Шрифт показа значений круговой диаграммы выбирается по установкам других значения Тип диаграммы , например, Гистограмма.

Для области построения диаграммы в палитре свойств задается оформление:

Отображать шкалу — если установлено, то шкала будет показываться.

Стиль линий — выбирается стиль разметочных линий.

Цвет линий — задается цвет линий шкалы диаграммы.

Цвет текста — задается цвет текста области построение.


Глава 8.Редактор текстов

Текстовый редактор системы 1С: Предприятие предоставляет пользователю все основные функции, необходимые при редактировании текстов. При работе с текстовым редактором доступны операции с блоками текста, функции поиска и замены, цветовое выделение синтаксических элементов программных модулей. Так как работа с любым текстовым редактором в системе MS Windows осуществляется примерно одинаковым образом, в данной главе сначала будет дано описание специфических возможностей редактора текстов системы 1С: Предприятие, а затем изложены основные приемы по редактированию текстов.

В системе 1С: Предприятие текстовый редактор используется в двух режимах: для редактирования текстовых документов и — как составная часть редактора форм — для редактирования текстов модулей.

В данном разделе приводится описание особенностей работы редактора текстов при редактировании текстов модулей. О редактировании текстовых документов см. Приложение 1. «Редактор текстов» Руководства пользователя.


Глава 8.Редактор текстов


Редактирование модулей

Редактирование модулей чаще всего выполняется в процессе создания формы объекта конфигурации, а также при разработке модулей документов и расчетов. В этом случае текстовый редактор выступает как составная часть редактора форм и вызывается щелчком мыши на закладке «Модуль» в диалоге редактора форм.

Для редактирования глобального или общего модуля текстовый редактор вызывается в виде отдельного окна. Для открытия глобального модуля щелкните правой кнопкой мыши по имени конфигурации (самая верхняя строка дерева конфигурации) и в контекстном меню выберите пункт «Открыть модуль» и для открытия общего модуля дважды щелкните мышью по имени Модуля в окне «Конфигурация».

Процесс редактирования текста программного модуля ничем не отличается от процесса редактирования текстовых документов, вы можете использовать все возможности редактора текстов.

В этом разделе будут описаны специфические режимы редактора текстов, которые доступны при редактировании модулей.


Редактирование модулей


Выделение цветом синтаксических конструкций

Для удобства редактирования текстов модулей текстовый редактор имеет функцию выделения цветом элементов встроенного языка системы 1С: Предприятие — ключевых слов, констант различных типов, операторов, комментариев и других. Цвета, которыми будут выделяться разные типы синтаксических конструкций, можно установить в диалоге «Параметры», который открывается выбором пункта «Сервис — Параметры» (о настройке параметров текстового редактора см. раздел « Установка параметров текста модуля » ).

В общем случае, когда текстовый редактор вызывается для редактирования текста модуля, эта функция включается автоматически. Однако в некоторых случаях текст модуля может быть расположен во внешнем текстовом файле. Тогда при открытии такого файла Конфигуратор не распознает модуль, и будет считать его обычным текстовым документом. В этом случае при редактировании текста будут недоступны выделение цветом синтаксических конструкций и автоматическое форматирование текста модуля. Чтобы указать Конфигуратору, что редактируется модуль, а не «текстовый документ, служит пункт «Текст — Текст модуля», выполняющий функцию переключателя. Когда он включен (слева от слов «Текст модуля» в меню появляется отметка), текстовый редактор считает загруженный в него текст текстом модуля и выделяет цветом найденные синтаксические конструкции. Если этот режим включен при редактировании обычного текстового документа, для вывода текста будет также использоваться шрифт, установленный для текстов модулей в режиме «Сервис — Параметры».

Настройка параметров системы 1С: Предприятие позволяет отключить режим выделения цветом синтаксических конструкций, тогда выбор пункта «Текст модуля» не включит выделение цветом синтаксических конструкций модуля, а будет использовать только установки шрифта модуля и шага табуляции.

Если режим выделения цветом синтаксических конструкций выключен, для вывода текста используются цвета операционной системы.


Выделение цветом синтаксических конструкций


Группировка

В модулях или в текстовых документах просматриваемых в режиме «Текст модуля» некоторые синтаксические конструкции автоматически объединяются в группы. К таким конструкциям относятся Процедура... КонецПроцедуры, Если... Тогда... КонецЕсли, Пока ... Цикл ... КонецЦикла и другие.

Группы текста позволяют лучше воспринимать различные части текста, а также переносить и копировать группу целиком.

В первой строке в крайней левой колонке окна редактора текстов для обозначения группы программа размещает специальный маркер - с вертикальной линией на всю длину группы. Свернутая группа помечается маркером +

Свернуть и развернуть группу можно с помощью мыши. Для этого достаточно щелкнуть левой клавишей мыши в маркер группы.

С помощью команд, выполняемых де, клавиатуры можно легко управлять состоянием групп

Клавиши | Действия
Ctrl+Num – | сворачивает группу (курсор может быть в любом месте группы)
Ctrl+Num + | разворачивает группу (курсор должен быть в первой строке группы)
Ctrl+Shift+Num - | сворачивает все группы
Ctrl+Shift+Num + | разворачивает все группы

При написании текста модуля группы создаются для всех синтаксических конструкций любого уровня вложенности с помощью пункта «Текст — Группировки - Обновить группировки» или автоматически при сохранении текста. Первым уровнем считается уровень описания процедур и функций, вторым - синтаксических конструкций, вложенных только в тело процедуры или функции, но не в тело других синтаксических конструкций.

О настройке режима группировки см. параграф « Настройка показа группировки ».


Группировка


Форматирование модуля

Редактор текстов системы 1C: Предприятие включает ряд режимов, облегчающих разработку модулей.


Форматирование модуля


Форматирование синтаксических конструкций

Хорошим стилем написания модулей считается использование синтаксического отступа - выделения лидирующими пробелами (табуляцией) управляющих конструкций встроенного языка системы 1C: Предприятие, например, так, как это показано в приведенном ниже фрагменте модуля.

Процедура ЗаполнитьСЗУчета (СЗ, ТолькоСКорреспондециями) Экспорт

СЗ. Очистить ();

Для Каждого Регистр Из Метаданные . РегистрыБухгалтерии Цикл

Если Регистр . Корреспонденция Или Не ТолькоСКорреспондециями Тогда

СЗ. Добавить (Регистр . Имя, Регистр. Представление());

КонецЕсли;

КонецЦикла;

КонецПроцедуры

В данном фрагменте строки модуля, расположенные внутри структурных операторов Если ...Тогда... КонецЕсли и Пока... Цикл.. КонецЦикла, смещены вправо, чтобы подчеркнуть их «вложенность». Текст модуля, отформатированный с использованием синтаксического отступа, удобнее в восприятии и проще в отладке.

Текстовый редактор системы 1C: Предприятие предоставляет функции автоматического форматирования управляющих конструкций встроенного языка. В режиме установки параметров системы (меню «Сервис» главного меню Конфигуратора, закладка «Модули») можно выбрать один из двух видов отступа.

Синтаксический отступ выполняет автоматическое форматирование текста модуля, смещая вправо текст, расположенный внутри управляющих конструкций типа Если... Тогда ... КонецЕсли, Пока ... Цикл... КонецЦикла и подобных. Смещение выполняется за счет добавления в начало строк необходимого количества знаков табуляции.

«Обыкновенный» отступ автоматически выравнивает текст строки по левой границе предыдущей строки.

Если автоотступ отключен, никаких дополнительных символов в текст добавляться не будет.

Кроме форматирования текста модуля в процессе ввода, можно также автоматически отформатировать уже введенный текст. Для этого необходимо выделить блок текста, который требуется отформатировать, и выбрать пункт «Текст — Блок — Форматировать». При этом текстовый редактор проанализирует текст моду ля и произведет его форматирование, при котором содержимое каждой синтаксической конструкции будет сдвинуто вправо на величину табуляции, не зависимо от первоначального расположения строк (лидирующих пробелов).

Блок текста также можно целиком сдвигать вправо или влево с шагом табуляции. Для этого необходимо выделить блок текста и. выбрать команду «Текст — Блок — Сдвинуть вправо» («Текст — Блок — Сдвинуть влево»).

Текстовый редактор системы 1C: Предприятие осуществляет автоматическое удаление пробелов на концах строк. Это выполняется при записи модуля.


Форматирование синтаксических конструкций


Вставка / удаление признака комментария

При отладке модулей зачастую бывает необходимо на время «отключить» некоторые строки модуля, чтобы они не исполнялись при работе системы. Обычно это выполняется путем превращения таких строк в комментарии - добавлением перед ними признака комментария « //». Позднее, чтобы опять «включить» закомментированные строки в работу, признак комментария удаляется.

Для выключения (и последующего включения) больших фрагментов модуля удобно использовать режим автоматической установки признаков комментария у всех строк выделенного блока.

Для этого следует выделить блок текста и выбрать пункт «Текст— Блок— Добавить комментарий» («Текст— Блок - Удалить комментарий»).

При удалении комментария, если перед строкой установлено несколько признаков комментария, удаляется только один .


Вставка / удаление признака комментария


Переход по процедурам и функциям модуля

При значительном количестве имеющихся в модуле описаний процедур и функции удобно использовать режим поиска процедур, который предоставляет редактор текстов системы 1С: Предприятие.

Если воспользоваться пунктом «Правка — Процедуры и функции», на экран будет выдан диалог, содержащий список всех процедур и функции редактируемого модуля.

Имена процедур и функций в списке выдаются в порядке их расположения в модуле. Если включена опция «Сортировка», список будет отсортирован по алфавиту.

Для перехода к нужной процедуре или функции необходимо выделить ее имя в списке и нажать кнопку «Перейти».


Переход по процедурам и функциям модуля


Синтаксический контроль модуля

Редактируемый модуль может быть проверен на правильность использования синтаксических конструкций встроенного языка.

Для выполнения синтаксического контроля модуля необходимо воспользоваться пунктом «Текст - Синтаксический контроль». При синтаксическом контроле обычного (не глобального и не общего) модуля сначала будет выполнен контроль глобального и общих модулей, а затем - редактируемого модуля.

При наличии ошибок в модуле их список будет выдан в окне сообщений с указанием полного адреса месторасположения ошибки с указанием номеров строк модуля, в которых обнаружены ошибки. При подведении указателя мыши к строке, содержащей сообщение о месте и виде ошибке, он принимает вид увеличительного стекла. Для перехода к строке модуля, вызвавшей ошибку, следует дважды щелкнуть мышью по этому сообщению. Если модуль, содержащий ошибку, закрыт, он будет открыт автоматически.

Если ошибки не обнаружены, в окно сообщений будет выдано сообщение об отсутствии ошибок в модуле.

В режиме настройки параметров Конфигуратора (пункт «Сервис — Параметры» закладка «Текст модуля» реквизит «Проверять автоматически») можно включить режим автоматической проверки модуля. В этом случае, если модуль был изменен, при закрытии окна модуля или при сохранении конфигурации в целом будет выполняться синтаксический контроль модуля.

Режим автоматической проверки удобно использовать, когда производится отладка какого-либо элемента конфигурации.

Для полного синтаксического контроля всех модулей конфигурации за один проход следует выбрать пункт «Конфигурация — Синтаксический контроль модулей». Сообщения о найденных ошибках будут выдаваться в окно сообщений. В дальнейшем к строкам модулей с ошибками можно переходить двойным щелчком мыши, как это описано выше.

В процессе исправления ошибок в модулях можно получить подсказку по встроенному языку, вызвав Синтакс - Помощник и найдя в нем описание нужного элемента встроенного языка (см. раздел « Синтакс-Помощник » ).

Подсказку по конкретному элементу языка (оператору, процедуре функции, свойству, методу) можно получить, если поместить курсор в модуле на этот элемент языка и нажать клавиши Ctrl+Fl. В Синтакс-Помощнике будет выдано описание выбранного элемента встроенного языка.


Синтаксический контроль модуля


Глава 9.Табличный редактор

Для создания различных печатных форм, а также форм, предназначенных для представления и ввода информации с использованием таблиц, в системе 1C: Предприятие используется специализированный табличный редактор.

В дальнейшем в настоящей главе наряду с терминами табличный документ и печатная форма будет использоваться термин: таблица.


Глава 9.Табличный редактор


Что такое таблица в системе 1C: Предприятие

Табличный редактор в системе 1C: Предприятие с первого взгляда может показаться похожим на «обычные» электронные таблицы. Но это не так.

Таблица в системе 1С: Предприятие, как и любая другая таблица, представляет собой совокупность ячеек прямоугольной формы, организованных в строки и столбцы.

Каждый столбец и каждая строка имеет свой уникальный номер. Строки и столбцы нумеруются независимо, нумерация начинается с 1 и ведется от левого верхнего угла таблицы. Таким образом, любая ячейка может быть обозначена парой чисел — номером строки и номером столбца, на пересечении которых она находится.

Кроме того, отдельным ячейкам и их диапазонам (компактным группам прямоугольной формы) можно присваивать собственные имена для удобства обращения к ним. Для присваивания имен и работы с ними используется панель редактирования, диалог «Имена», а также палитра свойств.

Самая верхняя ячейка столбца называется «заголовком столбца». В ней выводится номер столбца, кроме того, она используется для выделения столбца и изменения его ширины. Аналогичное назначение имеет и самая левая ячейка строки, которая называется «заголовком строки».

Хотя в программе реализована возможность использования таблицы для непосредственного ввода, обработки и отображения данных различных типов, как в «обычных» электронных таблицах (использование таблиц, размещенных в форме), таблицы в системе 1С: Предприятие используются в основном для представления уже обработанной информации, в частности, описания печатной формы отчета. Обработка информации и помещение ее в нужные места таблицы для большинства объектов конфигурации выполняется программными модулями на языке системы 1С: Предприятие.

В системе программ 1С: Предприятие табличный редактор применяется для работы с отдельными табличными документами и макетами печатных форм.

Табличный документ хранится вне конфигурации в файле на диске. Обычно он представляет «готовую» печатную форму и используется самостоятельно.

Макет хранится внутри конфигурации. Макеты бывают общими и располагаются на ветви «Общие — Макеты» (например, макеты стандартных платежных документов, печатающихся из различных документов) и относиться к определенному объекту конфигурации (например, карточка основного средства). Объект конфигурации может иметь несколько различные макетов печатных форм.

Элемент управления типа «Табличный документ» может располагаться в форме. В этом режиме в таблицу можно вставить другие элементы управления (подробнее об этом см. главу « Редактор форм »).

С точки зрения приемов работы с макетами и табличными документами они практически полностью совпадают, поэтому сначала приведем описание различий, а потом (начиная с раздела « Работа с таблицей ») опишем приемы работы с таблицами .


Что такое таблица в системе 1C: Предприятие


Работа с макетом

Создание, выбор, удаление и переименование объектов типа «Макеты» выполняется стандартным для объекта конфигурации образом, как описано в разделе « Создание и удаление объекта конфигурации ».


Работа с макетом


Общие принципы проектирования макета

Проектирование макета заключается в «рисовании» составных частей - кирпичиков — именованных областей, из которых затем будет «собрана» готовая выходная форма — отчет. Так как практически все деловые документы имеют «прямоугольную» структуру, удобнее всего создавать макеты таких документов в редакторе, способном манипулировать прямоугольными элементами.

Именно таким редактором и является табличный редактор, входящий в систему 1C: Предприятие. В процессе создания макета вы можете: вводить в ячейки таблицы разнообразный текст; задавать параметры форматирования, как тексту, так и ячейке в целом; изменять высоту строк и ширину столбцов таблицы; включать в макет рисованные элементы — линии и прямоугольники, а также другие графические объекты: картинки, OLE-объекты и диаграммы, различные элементы управления, определять оформление, как всей таблицы, так и отдельных ячеек или групп ячеек.

Практически каждый отчет состоит из так называемой шапки (заголовка) отчета, в которой указывается наименование отчета, исходные параметры построения. Для формирования таких данных создают именованную область, которую чаще всего называют «Шапка». Если в отчете присутствует табличная часть, то в шапку обычно включают наименования граф таблицы.

Для вывода строк таблицы создают именованные области (в показанном на рисунке примере это «Строка»), отвечающие за вывод различной информации в табличную часть. Число строк табличной части обычно при подготовке макета узнать невозможно, но структурно информация в табличной части повторяется, поэтому при построении отчета используют одни и те же области, описывающие отдельную строку. Ячейкам, предназначенным для вывода конкретной информации, ставят в соответствие переменные (в приведенном примере это «Счет», «Наименование», «Цена», «Сумма» и др.). При выводе очередной строки этим переменным присваивают содержимое каждой выводимой строки, а затем уже включают сформированную область в состав отчета. Так происходит до тех пор, пока не будет выведена вся информация табличной части.

Обычно завершается отчет выводом итоговых данных и реквизитами ответственных лиц. Эти данные обычно размещаю в области, именуемой «Подвал».

В окончательном виде макет - представляет собой совокупность прямоугольных областей, каждая из которых служит для выдачи какой-то части готового отчета: область для выдачи заголовочной части (наименования, даты и т.п.) область для выдачи шапки табличной части и так далее.

Сам процесс построения отчета происходит следующим образом.

В начале отчет строится как пустая таблица. Необходимо иметь в виду, что макет не связан напрямую с готовым отчетом. Скорее, макет представляет собой некий конструктор, набор областей, из которых в процессе работы программного модуля складывается готовый отчет.

В процессе обработки алгоритма отчета из макета в нужном порядке извлекаются поименованные области, транслируются (вместо имен переменных подставляются их значения) и копируются в таблицу готового отчета. Средства языка формирования отчетов позволяют наращивать отчет как вниз, так и вправо.

Подробнее о работе с именованными областями см. параграф « Работа с именованными областями » .


Общие принципы проектирования макета


Работа с таблицей, размещенной в форме

Другой способ построения отчета заключается в том, что пользователь вводит данные в предназначенные для этого ячейки таблицы, размещенной в форме, как элемент управления.

В процессе ввода эти данные обрабатываются процедурами, написанными на встроенном языке, располагаемые в модуле формы. Результаты расчетов могут использоваться при вычислении других ячеек таблицы,

После ввода данных можно распечатать отчет и сохранить его для последующей работы.


Работа с таблицей, размещенной в форме


Работа с табличным документом

Табличный редактор системы 1С: Предприятие может использоваться для создания документов табличного типа. Чтобы создать новый табличный документ, выберите пункт «Файл — Новый». В появившемся запросе выберите строку «Табличный документ» и нажмите кнопку «ОК». Будет открыто окно табличного редактора, содержащее пустой документ.

Чтобы открыть существующий табличный документ, выберите пункт «Файл — Открыть». На экран будет выдан стандартный диалог открытия файла. В этом диалоге выберите имя файла документа.


Работа с табличным документом


Сохранение табличного документа

Табличный документ хранят в файл для того, чтобы его в дальнейшем можно было бы открыть, просмотреть и распечатать. Чтобы сохранить табличный документ в виде файла, выберите пункт «Файл — Сохранить». В диалоге сохранения файла можно укажите имя файла.

Обычно табличные документы сохраняются в специальном формате, используемом системой 1C: Предприятие для хранения табличных документов. Такие файлы имеют расширение *.MXL. Сохраненные таким образом табличные документы можно открыть через меню «Файл» главного меню Конфигуратора.

Однако, существует возможность сохранить табличный документ в форматах: «Таблица Excel» (расширение *.XLS), «HTML Документ» (расширение *.НТМ или *.HTML), текстовом формате (расширение *.ТХТ), текстовом файле UNICODE (расширение *.ТХТ), и табличном документе v7.x (формата предыдущих версий системы 1С:Предприятие) (расширение *. MXL). Для этого выберите пункт «Файл — Сохранить копию» и в диалоге выберите формат файла.

Сохранение в формате «Таблица Excel» позволяет открывать сохраненный файл в электронной таблице MS Excel.

Сохранение в формате «HTML Документ» позволяет открывать сохраненный файл любым средством для просмотра HTML-документов, например, MS Internet Explorer .


Сохранение табличного документа


Просмотр таблицы

Перемещение по таблице. Согласно общей концепции интерфейса MS Windows, окно таблицы в любой момент времени показывает только часть таблицы, лежащей «под» этим окном. Для перехода к любой ячейке в видимой области таблицы достаточно щелкнуть эту ячейку мышью. Выбранная ячейка становится активной. Для вывода на экран скрытых за границами окна областей таблицы используются линейки прокрутки.

Управление видом таблицы. При помощи пунктов подменю «Таблица — Режимы» можно управлять отображением различных областей и компонентов таблицы: заголовков строк и столбцов, сеткой таблицы и т.д.

Кратко поясним назначение пунктов меню «Режимы». Каждый пункт и каждая кнопка работает как переключатель: выбор (нажатие) вызывает или прекращает отображение соответствующей области таблицы:

Пункт меню | Действие
Зафиксировать таблицу | фиксирует верхние строки и левые столбцы таблицы таким образом, чтобы при листании таблицы они постоянно присутствовали на экране;
Отображать сетку | включает и отключает показ сетки таблицы — тонких линий, разделяющих ячейки таблицы;
Отображать заголовки | управляет показом заголовков строк и столбцов таблицы;
Отображать секции | включает и отключает показ именованных областей слева от заголовков строк и сверху от заголовков столбцов;
Только просмотр | включает и отключает запрет на любые изменения в таблице
Отображать примечания | включает и отключает режим показа примечаний
Отображать именованные ячейки | включает и отключает режим показа именованных областей (ячеек)
Черно-белый просмотр | отключает и включает показ цветов, заданных для таблицы. При включении этого пункта (в меню напротив него появляется галочка) все цвета будут определяться установками операционной системы MS Windows;
Режим просмотра страниц | отключает и включает показ минимального количества строк (определяется, введенной информацией), области печати, разрывов страниц
Масштаб | дискретно масштабирует изображение.

Масштабирование изображения. Для удобства просмотра таблицы изображение можно дискретно масштабировать. Для выбора масштаба изображения используется подменю «Таблица — Вид — Масштаб»: при выборе этого пункта открывается подменю, в котором можно выбрать желаемый масштаб изображения таблицы.

Если у вас мышь имеет специальное колесико прокрутки, то для масштабирования нажмите клавишу Ctrl и, не отпуская ее, поверните колесико. Движением колесика от себя вы увеличиваете масштаб, к себе — уменьшаете.

Фиксация таблицы (шапки и боковика). Редактор таблиц системы 1С: Предприятие позволяет зафиксировать верхние строки и левые столбцы таблицы таким образом, чтобы при листании таблицы они постоянно присутствовали на экране. Это удобно, когда требуется просматривать какую-либо информацию, оформленную в виде таблицы большого размера. В этом случае на экране постоянно будут присутствовать шапка и боковик таблицы.

Чтобы зафиксировать верхние строки таблицы, следует выделить строку таблицы целиком и выбрать пункт «Таблица — Вид — Зафиксировать таблицу». Зафиксированы будут все строки, расположенные выше выделенной строки.

Чтобы зафиксировать столбцы таблицы, следует выделить столбец таблицы целиком. Зафиксированы будут столбцы, расположенные слева от выделенного столбца.

Чтобы зафиксировать одновременно строки и столбцы таблицы, следует выделить одну ячейку таблицы. Зафиксированы будут строки и столбцы, расположенные соответственно выше и левее выделенной ячейки.

Замечание. Фиксация строк и столбцов таблицы не переносится в готовую таблица. В этом случае необходимо использовать установку свойств таблицы с помощью встроенного языка.

Если в таблице существуют зафиксированные строки и (или) столбцы, для отмены фиксации следует повторно выбрать пункт «Зафиксировать таблицу».

Защита от редактирования. Для запрета редактирования таблицы используется пункт «Таблица — Вид — Только просмотр». Установка атрибута «Только просмотр» для готовой таблицы возможна из встроенного языка системы 1С: Предприятие. Кроме этого, для защиты от редактирования можно использовать установку свойства таблицы Защита с помощью встроенного языка метод встроенного языка, который полностью защищает готовую таблицу от редактирования и копирования (в том числе через Буфер Обмена MS Windows).


Просмотр таблицы


Выделение ячеек, строк и столбцов таблицы

Все действия по редактированию данных, содержащихся в таблице, производятся в активной ячейке. Кроме этого, некоторые операции возможно выполнять над произвольной группой ячеек или только над диапазоном ячеек (так мы будем называть компактную группу ячеек, имеющую прямоугольную форму).

Перед выполнением таких операций соответствующая ячейка» диапазон или группа ячеек таблицы должны быть выделены. Номера колонок и строк выделенной группы ячеек также выделяются. Что позволяет быстрее определить положение группы.

Выделение какого-либо элемента (ячейки) таблицы или группы элементов выполняется стандартными для MS Windows действиями. Для снятия выделения щелкните мышью любую ячейку.


Выделение ячеек, строк и столбцов таблицы


Имена

Отдельным ячейкам таблицы, диапазонам ячеек и графическим объектам можно присваивать имена.

Работа с именами производится при помощи диалога «Имена» в панели редактирования

Диалог вызывается выбором пункта «Таблица — Имена— Имена». Для присвоения имени выделите нужную область, откройте диалог «Имена», введите имя в поле ввода и выберите кнопку «Присвоить». Для удаления имени выберите его из списка и нажмите кнопку «Удалить». При нажатии кнопки «Выбрать» область, соответствующая выбранному имени, становится выделенной. Кнопка «Закрыть» закрывает диалог.

Если целиком выделить сроку или несколько строк (столбец или несколько столбцов) и этой области назначить имя, то при установленном режиме «Отображение именованных строк/столбцов» имена областей показываются слева (для строк) и сверху (для столбцов). «Внутренние» именованные области показываются при установленном режиме «Отображать именованные ячейки» штриховкой. В центре области помещается имя области.

Областям таблицы, не имеющим имени, присвоенного пользователем, программа формирует имена автоматически. Эти имена не присутствуют в списке диалога «Имена». Их можно видеть на панели редактирования (см. параграф «Ввод и редактирование имен» на стр. 331). Области таблицы нельзя присвоить имя, совпадающее с автоматически формируемым именем. Эти имена имеют вид, например:

R5C7 | для ячейки, находящейся на пересечении пятой строки и седьмого столбца;
R5C7:R8C15 | для диапазона ячеек в виде прямоугольника, ограниченного по вертикали пятой и восьмой строка ми и по горизонтали седьмым и пятнадцатым столбцом;
R6 | для шестой строки;
R3:R9 | для диапазона строк с третьей по девятую;
С2 | для второго столбца;
С11:С20 | для диапазона столбцов с одиннадцатого по двадцатый;
D12 | для рисунка, где 12 - порядковый номер графического объекта;
Т | для всей таблицы.

Имена областей уникальны в пределах одного документа, т.е. различные области должны иметь различные имена, причем регистр букв в именах не различается. Присваивание какой-либо области имени, уже использованного для другой области, не допускается. Чтобы для существующего имени изменить диапазон, нужно сначала удалить имя, а затем назначить его нудному диапазону ячеек.

Присваивание какой-либо области нового имени отменяет ранее присвоенное имя, которое при этом исчезает из списка. Если две области совпадают не полностью, они могут иметь каждая свое имя. Например, одна из областей может являться частью другой, или они могут пересекаться только частично; в последнем случае их пересечению также вполне можно присвоить собственное имя. Требование уникальности имени не допускает только полного совпадения областей с разными именами (и, конечно, совпадения имен различных областей).

Именованные области могут иметь общие строки или столбцы или группу ячеек.

К именованным областям или графическим объектам таблицы можно обращаться из встроенного языка, используя метод Область().


Имена


Поиск и замена

Табличный редактор системы 1С: Предприятие позволяет искать в таблице любую последовательность символов, а также заменять ее другой последовательностью.

Поиск. Для осуществления поиска необходимо выбрать пункт «Правка — Найти». На экран будет выдан диалог для установки параметров поиска.

В поле «Искать» этого диалога следует ввести образец для поиска. Длина строки — образца поиска — не должна превышать 256 символов.

Чтобы различать при поиске прописные и строчные буквы, включите опцию «Учитывать регистр».

При включенной опции «Ячейки целиком» будут найдены только те ячейки, в которых с искомым текстом совпадает весь текст ячейки, а не его часть. Всего имеется восемь вариантов обхода документа при поиске. Нужный вариант выбирается с помощью группы «Направление» и поля со списком «Просматривать». Все варианты обхода являются циклическими.

Группа «Направление» позволяет указать общее направление поиска: «Вперед» — по строкам вправо и по столбцам вниз от текущей позиции; «Назад» — по строкам влево и по столбцам вверх от текущей позиции.

Поле со списком «Просматривать» позволяет задать диапазон и порядок перебора направлений Поиска, предоставляя выбор из четырех вариантов:

  1. По столбцам искать в пределах столбца как по текущему, после достижения конца (или начала) столбца менять столбец поиска, сдвигаясь вправо или влево на одну ячейку в указанном общем направлении, после достижения конца (или начала) документа циклически переходить к началу (или концу),
  2. По строкам искать в пределах строки как по текущей, после достижения конца (или начала) строки менять строку поиска, сдвигаясь вниз или вверх на одну ячейку в указанном общем направлении, после достижения конца (начала) документа циклически переходить к началу (концу);
  3. По текущему столбцу искать, начиная от текущей ячейки, сдвигаясь вниз или вверх в пределах столбца в зависимости от указанного общего направления; после достижения конца столбца (или начала - при направлении назад) циклически переходить к началу (или, соответственно, к концу);
  4. По текущей строке искать, начиная от текущей ячейки, вправо или влево в зависимости от указанного общего направления; после достижения конца строки (или начала - при направлении назад) циклически переходить к началу (или, соответственно, к концу).

После установки необходимых параметров для выполнения поиска следует нажать кнопку «Искать». Если ячейка с указанной последовательностью символов будет найдена, то она станет текущей.

Независимо от ранее заданного общего направления, можно повторить поиск, задав ему направление «Вперед», если выбрать пункт «Правка — Поиск - Найти следующий» или нажать клавиши F3.

Независимо от ранее заданного общего направления, можно повторить поиск, задав ему направление «Назад», если выбрать пункт «Правка — Поиск - Найти предыдущий» или нажать клавиши Shift+F3.

Для повторения поиска с теми же параметрами, какие были в ю6-следпем поиске, можно нажать клавишу F3.

Замена. Для выполнения замены символьной строки необходимо выбрать пункт «Правка — Заменить». На экран будет выдан диалог для установки параметров замены.

В поле «Искать» этого диалога следует ввести образец для поиска. В поле «Заменить» необходимо указать последовательность символов, на которую будет заменяться образец поиска, указанный в поле «Искать».

Чтобы различать при поиске прописные и строчные буквы, включите опцию «Учитывать регистр».

При включенной опции «Ячейки целиком» будут найдены только те ячейки, в которых весь текст ячейки, а не его часть, совпадает с искомым текстом.

В поле со списком «Просматривать» можно задать порядок перебора направлений поиска заменяемого значения в направлении «Вперед», выбрав один из четырех вариантов, как при поиске.

При замене не применяется общее направление поиска «Назад».

После установки необходимых параметров для начала процесса поиска и замены следует нажать кнопку «Искать».

Если ячейка с указанной последовательностью символов будет найдена, то она станет текущей.

Для замены найденной последовательности символов следует нажать кнопку «Заменить», будет произведена ее замена, и поиск будет продолжен дальше.

Чтобы заменить сразу все вхождения искомой строки следует нажать кнопку «Заменить все».


Поиск и замена


Изменение высоты строк и ширины столбцов

Вы можете изменять высоту и ширину строк вручную или автоматически.

Изменение высоты строк и ширины столбцов «вручную». Для изменения высоты строки установите указатель мыши на нижнюю границу заголовка строки. Теперь вы можете, перемещая мышью границу заголовка, установить нужную высоту строки.

Для изменения ширины столбца установите указатель мыши на правую границу заголовка столбца.

Теперь вы можете, перемещая мышью границу заголовка, установить нужную ширину столбца таблицы.

Изменение высоты строк и ширины столбцов автоматически. Для изменения высоты строки автоматически выделите нужную строку, щелкнув по ее заголовку левой кнопкой мыши. Затем выберите пункт «Таблица — Высота строки». В выданном на экран запросе укажите требуемую высоту строки в пунктах (1 пункт равен 1/72 дюйма) и нажмите кнопку «OK» — высота строки будет установлена равной указанному значению.

Если в запросе указать «авто», то высота строки устанавливается равной максимальной высоте текста в этой строке.

Выбор «авто» включает режим автоматического изменения высоты строки в зависимости от высоты введенного в строку текста.

При переносе строки в готовую таблицу, высота строки также будет автоматически установлена в соответствии с высотой текста в этой строке.

Порядок автоматической установки ширины столбца отличается от установки высоты строки. Поясним это подробнее.

При создании новой таблицы ширина всех ее столбцов устанавливается равной стандартной ширине столбца, которая по умолчанию равна 9 символам шрифта, установленного для текста таблицы.

Заданную по умолчанию стандартную ширину столбца таблицы можно изменить. Для этого необходимо выделить всю таблицу, выбрать пункт «Таблица - Ширина столбца» и в появившемся запросе ввести число — новую стандартную ширину столбца, выраженную в количестве символов шрифта, установленного для текста таблицы. После нажатия кнопки «ОК» ширина всех столбцов таблицы будет изменена в соответствии с введенным значением.

Изменения ширины столбца производится аналогично изменению высоты строки.

Если в ячейках введена информация и требуется установить минимальную ширину колонок или высоту строк, то достаточно дважды щелкнуть мышью разделитель колонок или строк. При этом программа определит максимальную ширину или высоту по введенному тексту и изменит размер таким образом, чтобы введенный текст полностью размещался в ячейках.


Изменение высоты строк и ширины столбцов


Ввод текста в ячейку

Будем называть текстом любую комбинацию символов, включающую буквы, цифры, знаки препинания, пробелы и служебные символы. Числа, введенные в ячейку, также считаются текстом.

Текст может быть введен в любую ячейку таблицы. При формировании документа или отчета текст ячейки обрабатывается в зависимости от установленных свойств ячейки, и после обработки переносится в готовый отчет.

Ввод текста и установка его атрибутов выполняются только в активной ячейке. Чтобы сделать ячейку активной, щелкните на ней левой кнопкой мыши.

Для ввода текста в пустую ячейку, просто начните набирать нужные символы на клавиатуре. Ячейка перейдет в режим редактирования — в ней появится текстовый курсор (мигающая вертикальная черта), и в ячейке будет отображаться вводимый текст. Для окончания ввода текста нажмите Enter. Закончить редактирование текста можно также, щелкнув мышью любую невыделенную ячейку. Это действие равносильно нажатию клавиши Enter.

Если редактируемая ячейка уже содержала какой-либо текст, то при вводе новых символов этот текст будет удален.

Если необходимо отредактировать текст в ячейке, не замещая, а дополняя существующий текст, — перед вводом текста нажмите клавишу Enter или F2, или выберите ячейку двойным щелчком мыши. Тогда ячейка перейдет в режим редактирования, и можно поместить курсор в нужную позицию текста, используя клавиши управления курсором или мышь.

Важно. Следует особо отметить комбинацию Shift+Enter. Нажатие этих клавиш позволяет начать новую строку текста в ячейке, не прекращая редактирование ячейки.

Чтобы отменить изменения, сделанные в тексте ячейки, нажмите Esc до окончания редактирования в ней.

Если текст полностью не помещается в ячейке, то для его показа будет использовано пространство соседних по горизонтали ячеек (слева, справа или с обеих сторон, что зависит от типа выравнивания текста в ячейке).

Если необходимо ввести одинаковый текст сразу в несколько ячеек, то выделите эти ячейки и в свойстве Текст введите нужный текст. Для размещения текста в ячейках нажмите кнопку «Сохранить» панели инструментов палитры свойств. Или запомните нужный текст в Буфере Обмена, выделите группу ячеек (не обязательно последовательных) и вставьте текст из Буфера Обмена.

Ввести текст в ячейку можно также с помощью панели редактирования.

Введенный текст можно расположить под произвольным углом наклона. Для этого выделите ячейки, текст которых требуется расположить под углом, и в свойстве Ориентация укажите нужный угол наклона от -360 до 360.

Для каждой ячейки таблицы можно создать примечание — произвольный текст, описывающий данную ячейку. Ячейка, содержащая примечание, помечается маркером в виде красного треугольника, расположенного в правом верхнем углу ячейки. Если установлен режим «Отображать примечания» (нажата кнопка), то текст примечания показывается всегда. Если режим не установлен, то примечание показывается в виде ярлыка при подведении указателя мыши к ячейке.

Клавиши, используемые для редактирования. В процессе редактирования текста в ячейке таблицы вы можете использовать те же клавиши и комбинации клавиш, которые используются в других приложениях MS Windows.

Если какие-либо действия с таблицей были сделаны по ошибке, то их можно отменить. Для этого в редакторе имеется средство отмены. После ошибочных действий выберите пункт «Правка - Отмена». Редактор позволяет отменить все произведенные изменения, выполненные после открытия или создания таблицы.

Если требуется вернуть назад отмененные действия, то выберите пункт «Правка — Вернуть».


Ввод текста в ячейку


Просмотр и редактирование свойств таблицы и ячеек

Настройка поведения таблицы и поведения ячейки иди группы ячеек производится в палитре свойств.

В свойствах таблицы определяют направление перехода при нажатии клавиши Enter, задание области печати, области повторяющихся частей документа и т.д.

В свойствах ячейки или группы ячеек определяется тип информации, способ и формат представления этой информации в ячейках, размеры ячеек и другие параметры.

При открытии или создании таблицы палитра свойств показывает свойства ячеек. Чтобы перейти к просмотру и редактированию свойств таблицы в верхней строке палитры свойств в списке выберите «Табличный документ». Для просмотра и редактирования свойств ячейки или группы ячеек в верхней строке палитры свойств в списке выберите «Ячейки».


Просмотр и редактирование свойств таблицы и ячеек


Свойства таблицы

Настройка производится в палитре свойств таблицы. Для их показа в верхней строке палитры свойств в списке выберите «Табличный документ».

Макет — если свойство установлено, то данная таблица является макетом.

Итоги по горизонтали — определяется положение итоговой строки для горизонтальной группы (см. раздел «Удаление именованных областей»).

Итоги по вертикали — определяется положение итогового столбца для вертикальной группы (см. раздел « Удаление именованных областей »).

Картинка — выбор картинки фона (см. раздел « Установка изображения в качестве фона листа » на стр. 318).

Фиксированный фон — если свойство установлено и выбрана фондовая картинка, то при скролировании таблицы фон остается неподвижен, в противном случае фон скролируется вместе с таблицей.

Переход после ввода — выбирается направление перехода после нажатия клавиши Enter. Возможные варианты выбора: «Нет» — не переходить, «Вниз» — переходить на ячейку, расположенную под текущей, «Вправо» — переходить на ячейку, расположенную справа от текущей.

Область печати — определяется область таблицы, которая будет печататься (см. раздел « Определение области печати »).

Повторяющиеся строки — определяются строки таблицы, которые будут печататься на каждом новом листе (см. раздел « Определение области печати »).

Повторяющиеся столбцы — определяются столбцы таблицы, которые будут печататься на каждом новом листе (см. раздел « Определение повторяющихся строк и столбцов »).

Свойства Итоги по горизонтали и Итоги по вертикали определяют те строки и столбцы, которые логически относятся к группе, но должны оставаться при сворачивании показа самой группы.

Рассмотрим пример расчетов, исходная таблица данных показана на рисунке:


Свойства таблицы


Установка изображения в качестве фона листа

Для оформления таблицы можно в качестве фона использовать рисунок, который выбирается из библиотеки картинок или из внешнего файла.

Для выбора фоновой картинки в палитры свойств таблицы в свойстве Картинка нажмите кнопку выбора. На экран выводится диалог выбора картинки:

Выберите картинку из библиотеки или из файла. В выбранной картинке можно установить прозрачным (убрать) любой из имеющихся на картинке цветов. Для этого щелкните кнопку «Установить прозрачный цвет». Подведите указатель к цвету картинки, который нужно сделать прозрачным, и щелкните левой кнопкой мыши. Установленную прозрачность можно отменить, для этого нажмите кнопку «Убрать прозрачность».

Для установки фона нажмите кнопку «ОК».

Чтобы убрать фоновую картинку из таблицы, в диалоге фоновой картинки нажмите кнопку «Очистить».

В палитре свойств, при установленном свойстве Фиксированный фон, выбранный фон остается неподвижным при скролировании таблицы.


Установка изображения в качестве фона листа


Определение области печати

Если требуется, чтобы печаталась не вся таблица, а только ее часть (последовательно расположенные строки или столбцы или группа ячеек), то в свойстве Область печати указывается область печати.

Область печати может быть указана явно в формате диапазона, например, R5C7:R8C15 для диапазона ячеек в виде прямоугольника или R3:R9 для диапазона строк с третьей по девятую, D12 для рисунка), именами заранее присвоенными областям. Если используются имена, то после ввода имени области они заменяются на указание диапазона.

Область печати может быть указана с помощью диалога «Диапазон», вызываемого кнопкой выбора свойства Область печати.

Когда диалог вызван, то с помощью мыши или клавиатуры (см. раздел « Выделение ячеек, строк и столбцов таблицы ») укажите требуемый диапазон, затем нажмите кнопку выбора диалога «Диапазон». Выбранный диапазон будет указан в свойстве 06ластъ печати.

Область печати может быть также указана с помощью команд меню (см. раздел « Задание области печати » раздела « Вставка элементов управления »).


Определение области печати


Настройка печати

Установка и отмена режима просмотра страниц производится выбором пункта «Таблица — Режимы — Режим просмотра страниц». Область печати можно увидеть, если установлен режим просмотра страниц.


Настройка печати


Определение повторяющихся строк и столбцов

При разработке различных отчетов следует учитывать, что таблицы могут не помещаться на один лист целиком. В этом случае желательно, чтобы на каждом следующем листе повторялась «шапка» таблицы (для длинной таблицы) или «боковик» (для широкой).

Табличный редактор системы 1С: Предприятие позволяет легко настраивать просмотр таблиц. Для этих целей используется механизм определения повторяющихся строк и столбцов.

Область повторяющихся строк указывается в свойстве Повторяющиеся строки, столбцов — в свойстве Повторяющиеся столбцы.

Способ указания диапазона подробно описан в разделе « Определение области печати ».


Определение повторяющихся строк и столбцов


Свойства ячеек таблицы

В таблице можно настроить поведение каждой отдельно ячейки или группы ячеек.

Настройка производится в палитре свойств ячеек. Для просмотра и редактирования свойств ячейки или группы ячеек в верхней строке палитры свойств в списке выберите «Ячейки».

Набор свойств, которые открыты для просмотра и редактирования, относится ко всем выделенным ячейкам таблицы. Если установить значение некоторого свойства, то это значение будет установлено для всей выделенной области.


Свойства ячеек таблицы


Категория свойств Основные

Текст — текст, размещенный в ячейке. Свойство показывается, если в категории Макет не установлено свойство Значение и в свойстве Заполнение категории Макет выбрано значение Текст или Шаблон.

Размещение — пункты свойства Размещение позволяют установить, как показывать текст, если он не помещается в ячейке целиком (см. таблицу:

Расположение | Пояснение текста
Авто | Не помещающийся по ширине текст будет показан в соседних по горизонтали ячейках, если в них, в свою очередь, нет текста.
Обрезать | Видимая часть текста будет ограничена левой и правой границами ячейки.
Забивать | Видимая часть текста будет ограничена левой и правой границами ячейки, при этом все символы видимой части текста будут заменены на символы «#». (Применяется в случае, когда обрезанный текст может восприниматься ошибочно. Пример: число).
Переносить | Не помещающийся по ширине текст будет переноситься на следующие строки ячейки.

Имя — имя области (подробней об именах областей см. параграф « Имена »).

Защита — если установлено, то выбранные ячейки и рисунки защищены от изменения .


Категории свойств Макет

Категория свойств Макет показывается, если в свойствах таблицы установлено свойство Макет.

Заполнение. Пункты свойства Заполнение устанавливают, какого рода информация введена в ячейку. Свойство показывается, если в категории Макет не установлено свойство Значение. Они изменяют внешний вид ячейки, а используются только в процессе обработки шаблона при формировании готовой таблицы.

Пункты этого списка имеют следующий смысл (см. таблицу).

Формат | Пояснение данных
Текст | Информация в ячейке является текстом и при формировании таблицы будет перенесена из исходной таблицы в готовую таблицу без изменений.
Параметр | Информация в ячейке представляет собой параметр, имя которого указывается в свойстве Параметр.
Шаблон | Информация в ячейке представляет собой текст с включенными в него выражениями на встроенном языке системы 1C: Предприятие, заключенными в квадратные скобки. При формировании таблицы выражения будут вычислены, а их результаты будут включены в текст вместо самих выражений. Место, отводимое в тексте для вывода результатов выражений, определяется длиной этих результатов.

Информация в ячейке готовой таблицы преобразуется в тип «строка».

Параметр —поле параметра для вывода содержимого ячейки. Свойство показывается, если в категории Значения установлено свойство Содержит значение или когда в свойстве Заполнение категории Макет выбрано значение «Параметр».

Параметр расшифровки — указывается имя параметра, по которому программа производит обработку расшифровки значения, находящегося в ячейке.

Когда готовая таблица открыта в режиме «Только просмотр», при помещении указателя мыши над ячейкой, содержащей заполненное поле «Расшифровка», указатель принимает форму лупы или руки (для ячейки-ссылки, для этого требуется, чтобы свойство ячейки Гиперссылка было установлено). Это значит, что возможна детализация (расшифровка) данных таблицы. Теперь, если дважды щелкнуть левой кнопкой мыши на этой ячейке (или сделать ее активной и нажать клавишу Enter), а для Гиперссылки просто щелкнуть мышью, значение поля будет выдано на экран:

• значения типа «строка», «число», «дата» и «перечисление» будут выданы для просмотра;

• если значение имеет тип «документ», соответствующий документ будет открыт для просмотра и редактирования;

• если значение является элементом справочника, этот элемент будет открыт для просмотра и редактирования в диалоге. Если при настройке свойств справочника было задано редактирование в списке, будет открыта таблица справочника, а указатель в таблице будет установлен на нужный элемент справочника.

Эта обработка расшифровки называется стандартной и не требует никаких дополнительных настроек.

Если требуется, чтобы обработка расшифровки производилась особенным образом, то необходимо в свойствах табличного документа (размещенного в форму) в категории свойств События для свойства Обработка расшифровки указать имя процедуры, осуществляющей обработку события, возникающего при выборе ячейки с расшифровкой. В модуле формы в теле этой процедуры средствами встроенного языка описать обработку расшифровки.

Проиллюстрируем сказанное примером. Для отчета создана форма и макет "Шаблон". Макет содержит именованные области «Шапка», «Строка» и «Итоги». Область «Строка» содержит ячейку, в параметрах расшифровки которой указано имя параметра расшифровки Расшифровка. В форме размещен элемент управления «Табличный документ» с именем ТаблицаРезультат, свойство Обработка расшифровки которого указывает на процедуру обработки выбора ячейки ОбработкаРасшифровки, расположенной в модуле формы.

Формирование табличного документа производится по следующей примерной схеме:

// Инициализация табличного документа и диаграммы

ТабДок = ЭлементыФормы. ТаблицаРезультат ;

ТабДок. Очистить ();

Макет = ОбработкаОбъект.ПолучитьМакет( "Шаблон" );

// Выдадим шапки

Секция=Макет. ПолучитьОбласть("Шапка" );

Секция . Параметры.ПериодС =ПериодС;

Секция. Параметры .ПериодПо =ПериодПо;

// также формируются другие параметры папки

ТабДок .Вывести (Секция );

// сформируем запрос

// запрос сформирован и выполни

// обработка строк запроса

Пока <указывается условие цикла > Цикл

Секция = Макет.ПолучитьОбласть ("Строка");

Секция.Параметры .Наименование=< укаэывается значение>;

Секция .Параметры. Расшифровка=<указывается значение >;

// также формируются другие параметры строки

ТабДок.Вывести (Секция);

КонецЦикла;

// Выдадим в документ итоговую запись

Секция =Макет. ПолучитьОбласть("Итоги");

Секция.Параметры .Количество = ОбщиеИтогиКоличество;

Секция .Параметры. Сумма = ОбщиеИтогиСумма ;

// также формируются другие параметры

ТабДок .Вывести ( Секция);

// обновим документ

ТабДок.ТолькоПросмотр = Истина;

ТабДок Показать ();

Пример реализации процедуры обработки выбора расшифровки:

Процедура ОбработкаРасшифровки ( Эл ,Расшифровка , СтандартнаяОбработка)

СтандартнаяОбработка =Ложь;

ТипРасшифровки = ТипЗнч( Расшифровка );

Если ТипРасшифровки=ТипСправочникСсылка .Контрагент Тогда

ИмяФормыОтчета= "ФормаОтчета1 ";

Иначе

ИмяФормыОтчета="ФормаОтчета2" ;

КонецЕсли;

ФормаОтчета= ОбработкаОбъект.ПолучитьФорму (ИмяФормыОтчета);

ФормаОтчета.ВыполнитьОтчет (Расшифровка, ПериодС,ПериодПо );

Формаотчета. Открыть();

КонецПроцедуры

Если отчет выводится в табличный документ, то при выборе ячейки, отрабатывается только стандартная обработка расшифровки.

Использование расшифровки — определяется использование указанной для ячейки выражения расшифровки. При выборе:

«Ячейка» расшифровка возможна только для указанной ячейки, при выборе «Строка» расшифровка действует в каждой ячейке текущей строки, если выбрано «Не использовать», то, несмотря на то, что выражение расшифровки указано, расшифровка не действует, указатель не принимает форму лупы или руки (для ячейки-ссылки) и выбор в ячейке не отрабатывается.


Категории свойств Макет


Категория свойств Значения

Содержит значение — если установлено, то ячейка содержит значение Установка свойства влияет на состав свойств других категорий

Тип данных — тип данных ячейки. Для таблицы перечень содержит базовые типы (Число, Строка, Дата и Булево). Для элемента управления формы типа «Табличный документ» помимо базовых видов перечень дополнительно содержит типы, определенные для текущей конфигурации — документы, справочники, перечисления и т.д. Кроме того, можно установить тип данных «Произвольный» В таком случае он может быть определен уже во время заполнения формы с помощью средств встроенного языка.

Выбор типа содержимого производится в списке или в диалоге «Редактирование типа данных», вызываемого по кнопке, расположенной справа от кнопки списка. В последнем случае на экран выводится диалог:

Для строкового и числового типов, кроме того, может быть задана длина, а для числового — точность представления и признаки разделения триад цифр и неотрицательности Для типа «Дата» определяется форма представления даты - Дата, Время, Дата + Время.

Бели флажок «Составной тип данных не установлен, то в диалоге Можно выбрать только один тип: Если установить флажок, то тип содержимого может иметь составной тип.

Элемент управления — выбирается элемент управления для редактирования содержимого ячейки. Список возможных значений зависит от выбранного типа содержимого. Например, при выборе в Тип данных значения «Число», в качестве редактора можно выбрать «Поле ввода» или «Флажок». Для выбранного типа редактора в список объектов (Ячейки, Табличный документ) будет добавлена строка, содержащая тип редактора Поле ввода или Флажок. Состав свойств палитры свойств данного объекта определяется типом выбранного элемента управления.

Формат отображения — задается форматная строка которая будет использоваться при выводе значения. Если не производить настройку формата изображения, то формат будет выбран из региональных настроек информационной базы (о форматной строке, используемой по умолчанию, см. параграф « Региональные установки информационной базы » ).

Формат можно ввести вручную или с помощью диалога.

При нажатии кнопки выбора на экран выводится диалог настройки формата отображения.

Элементы управления, с помощью которых выбирается формат представления, размещены на трех закладках по типам данных: число, дата и логические значения.

Если какое-то значение не выбрано, то оно выбирается из настроек, устанавливаемых по умолчанию.

Результат выбора настройки можно посмотреть в разделе «Примера»

Внизу диалога расположена область, в которую выводится строка соответствующая произведенному выбору настроек.


Категория свойств Значения


Категория свойств Положение

По горизонтали - задает выравнивание текста в ячейке таблицы по горизонтали:

Лево - выравнивание текста по левой границе ячейки;

Право - выравнивание текста по правой границе ячейки;

Центр По ширине - текст размещается вдоль вертикальной линии, проходящей через центр ячейки;

Авто - текст выравнивается одновременно по правой и по левой границам ячейки. Высота и ширина ячейки автоматически устанавливаются такими, чтобы текст в ячейке был виден полностью, в зависимости от типа содержимого ячейки Например, для строк будет выбран тип выравнивания «Лево», для чисел — «Право».

По выделенным столбцам — если установлено, то текст, введенный в самой левой ячейке выделенной в данный момент области, будет расположен в соответствии с выбранным вариантом горизонтального положения в пределах всей выделенной области. Этот режим используется, прежде всего, для того, чтобы отцентрировать текст в пределах нескольких ячеек в строке .

По вертикали — задает выравнивание текста в ячейке таблицы по вертикали

Низ текст располагается вдоль нижней границы ячейку;

Верх текст располагается вдоль верхней границы ячейки;

Центр текст размещается вдоль горизонтальной линии, проходящей через центр ячейки.

Ориентация — определяет угол наклона текста в ячейке (изменяется от -360" до 360")


Категория свойств Положение


Категория свойств Оформление

Шрифт — выбирается гарнитура (начертание) шрифта.

Размер шрифта — выбирается размер шрифта.

Жирность - стиль шрифта.

Курсив — стиль шрифта.

Подчеркивание — стиль шрифта.

Цвет текста — выбирается цвет шрифта.


Панель редактирования

Панель редактирования — горизонтальная панель, находящаяся в верхней части окна программы и служащая для просмотра и редактирования текстов ячеек таблицы.


Панель редактирования


Отображение панели редактирования

Видимость панели редактирования включается и выключается выбором пункта «Таблица — Панель редактирования». При включении панели редактирования этот пункт отмечается галочкой. Если включить режим «Только просмотр», этот пункт меню делается недоступным (в том состоянии, в каком был, включенном или выключенном).

На панели редактирования имеется кнопка «Прикрепить», которая определяет, будет ли панель редактирования присутствовать на экране постоянно.


Отображение панели редактирования


Ввод и редактирование текста

Основную часть панели редактирования занимает расположенное справа поле ввода, в котором отображается текст или параметр расшифровки выделенной ячейки — для ячейки таблицы, настроенной для режима ввода данных, текст или расшифровка — для «обычной» таблицы.

Для изменения текста можно щелкнуть левой кнопкой мыши по полю ввода и внести необходимые изменения в текст. Для завершения редактирования можно нажать клавишу Enter или щелкнуть мышью в любое место таблицы или по кнопке V («зеленая галочка»), расположенной слева от поля ввода. Для отказа от изменений, сделанных в поле ввода можно нажать клавишу Esc или щелкнуть мышью по кнопке Х («красный крестик») слева от по ля ввода. Нужно отметить, что эти кнопки видны только при редактировании содержимого поля ввода.

Кроме того, на панели редактирования располагается переключатель в виде кнопки =(«равно»). С его помощью можно переключать режим показа и редактирования в поле ввода текста / параметра расшифровки. Если переключатель не нажат, то в поле ввода отображается и редактируется текст ячейки, а если нажат — параметр расшифровки. Для переключения режима нужно щелкнуть мышью по этому переключателю.


Ввод и редактирование текста


Ввод и редактирование имен

В левой части панели редактирования расположено поле со списком, служащее для задания имен отдельным ячейкам, диапазонам ячеек и рисункам (подробнее об именах см. раздел « Имена » ). В этом поле отображается имя выделенного в данный момент диапазона ячеек или рисунка. Если выделенному элементу имя не было присвоено, то в этом поле отображается автоматически формируемое имя, состоящее из номера строки и номера столбца.

Если для выделенной области имя было задано, то оно выводится в поле со списком. Для того чтобы присвоить имя области или рисунку, ее (его) необходимо выделить, щелкнуть мышью, набрать имя в поле со списком и нажать клавишу Enter или щелкнуть мышью таблицу. Для отказа от ввода необходимо нажать клавишу Esc. Набранное имя не должно соответствовать автоматически формируемому имени какого-либо диапазона. В случае, если оно может быть проинтерпретировано таким образом, при нажатии клавиши Enter выделенной становится область с таким автоматическим именем, а присвоения не происходит. То есть, такое имя не попадает в список имен, присвоенных пользователем.

Имена областей уникальны, т.е. различные области должны иметь различные имена, причем регистр букв в именах не различается.

При щелчке мышью по стрелочке с правой стороны поля имен или при нажатии клавиши F4 в то время, когда это поле активно, появляется выпадающий список всех имен, заданных для данной таблицы. Его можно прокручивать клавишами «Вверх» и «Вниз» или мышью и выбирать одно из имен нажатием клавиши Enter или щелчком мыши. При этом область, соответствующая выбранному имени, становится выделенной.

Чтобы удалить ранее заданное имя, необходимо выбрать его из списка поля имен или выделить область таблицы, для которой, оно задано, удалить весь текст в поле имен и нажать клавишу Enter. Данное действие приводит к тому, что имя удаляется из, списка, а идентификация области меняется на автоматическую.


Ввод и редактирование имен


Перемещение и копирование ячеек

Любую ячейку или диапазон ячеек таблицы можно переместить в другое место таблицы. Точнее, перемещается не сама ячейка, а содержащийся в ней текст и атрибуты форматирования ячейки. Также можно копировать ячейку, перенося, таким образом, атрибуты форматирования ячейки-образца в другие ячейки таблицы.

Перемещение ячеек. Для перемещения ячейки или диапазона ячеек выполните следующие действия:

выделите ячейку или диапазон ячеек, которые требуется перенести:

укажите мышью на рамку, обрамляющую ячейки, так, чтобы указатель мыши принял форму стрелки

перетащите ячейки на новое место.

Если необходимо переместить ячейки в ту часть таблицы, которая скрыта границами окна, — подведите указатель мыши к краю видимой части таблицы, и таблица начнет автоматически «прокручиваться».

Копирование ячеек . С помощью мыши легко выполняется копирование ячейки или диапазона ячеек. Для этого выполните те же действия, что и при перетаскивании, но при нажатой клавише Ctrl.

Использование Буфера Обмена. Для перемещения и копирования ячеек можно использовать также Буфер Обмена MS Windows.

Разрешается копирование блока смежных ячеек (расположенных рядом).

Для копирования в Буфер Обмена можно использовать кнопку «М» («Запомнить в Буфер Обмена как число») панели инструментов, в этом случае в Буфере Обмена будет запомнено содержимое ячейки как число (если копируемая ячейка содержала число). Если выделен диапазон ячеек, то при нажатии кнопки «М» в Буфер Обмена будет помещенная сумма чисел, находящихся в выделенных ячейках.

Следует заметить, что копия ячейки остается в Буфере Обмена до тех пор, пока он не будет очищен или в него не будет помещена какая-либо другая информация. Это свойство можно использовать, когда необходимо создать несколько копий одной и той же ячейки. Например, скопируйте одну ячейку, затем выделите блок ячеек и командой «Вставить» содержимое Буфера Обмена вставляется в каждую ячейку блока. Таким образом, можно скопировать сразу несколько смежных (расположенных рядом) ячеек. Но при выделении блока следует учитывать, что размеры (число и порядок ячеек) блока должны быть кратны размерам копируемых ячеек. В противном случае будет выдано предупреждение: «Выделение не соответствует вставляемому блоку».

Если при перемещении или копировании вместо команды «Вставить» использовать команду «Специальная вставка», на экран будет выдан запрос.

Установкой соответствующих опций этого опроса можно указать, что необходимо вставить в таблицу: ячейку целиком, только текст, значения ячеек, формат, обрамление, примечания или имена.

Опция «Заменять форматы колонок» позволяет сохранять исходный формат колонок, установленный в исходном документе.

«Расширенное» перетаскивание для перемещения и копирования ячеек можно использовать также правую кнопку мыши, при этом осуществляется так называемая «расширенная» операция перетаскивания. Если не считать замены левой кнопки мыши на правую, способ осуществления операции тот же, как при описанном выше перемещении, но при отпускании кнопки возникает контекстное меню. Это меню позволяет определить, что именно будет сделано с помощью расширенной операции перетаскивания, перемещение, копирование или копирование с вышеописанной специальной вставкой. Можно также отменить операцию.


Перемещение и копирование ячеек


Добавление и удаление ячеек

Достаточно часто возникает необходимость добавить в существующую таблицу новую ячейку, или вставить целиком строку или столбец, а также удалить существующие строки или столбцы.

Вставка строки (столбца). Для вставки строки или столбца выполните следующие действия (следует учесть, что новые строки помещаются в таблицу сверху от выделенных, а новые столбцы — слева):

  • выделите в таблице такое количество строк или столбцов, которое необходимо вставить, и в том месте, которое должны будут занимать вставляемые строки или столбцы;
  • выберите пункт «Таблица — Раздвинуть».

Удаление строки (столбца). Для удаления строки или столбца выполните следующие действия:

  • выделите в таблице те строки или столбцы, которые необходимо удалить;
  • выберите пункт «Таблица — Удалить».

Выделенные строки или столбцы удаляются из таблицы вместе с содержащимся в них текстом. Их место занимают строки, расположенные снизу, или столбцы, расположенные справа.

Вставка ячейки. В любое место существующей таблицы можно вставить новую ячейку.

Для вставки ячейки выполните следующие действия:

  • выделите в таблице ячейку, на место которой должна быть вставлена новая ячейка;
  • выберите пункт «Таблица — Раздвинуть»;
  • в выданном на экран запросе выберите, куда надо сдвинуть ячейки, чтобы освободить место для вставляемой ячейки: горизонтально - будут сдвинуты ячейки, расположенные справа or выделенной ячейки, вертикально — расположенные ниже,
  • нажмите кнопку «ОК».

Вставка диапазона ячеек. В случае необходимости в таблицу можно вставить диапазон ячеек.

Для вставки диапазона выполните следующие действия:

  • выделите в таблице диапазон такого же размера, какой необходимо вставить, и в том месте, которое должен будет занимать вставляемый диапазон;
  • выберите пункт «Таблица — Раздвинуть».
  • в выданном на экран запросе выберите, куда надо сдвинуть ячейки, чтобы освободить место для вставляемого диапазона:
  • горизонтально — будут сдвинуты ячейки, расположенные справа от выделенного диапазона, вертикально — расположенные ниже;
  • нажмите кнопку «ОК»

Удаление диапазона ячеек. Для удаления диапазона выполните следующие действия:

  • выделите в таблице диапазон, который необходимо удалить;
  • выберите пункт «Таблица — Удалить»,
  • в выданном на экран запросе выберите, какой диапазон займет место удаленного «горизонтально» — место удаленного займет диапазон, расположенный справа от него, «вертикально» — диапазон, расположенный ниже;
  • нажмите кнопку «ОК»


Добавление и удаление ячеек


Разбиение ячеек

Табличный редактор системы 1C: Предприятие позволяет разбивать выбранные ячейки по горизонтали или вертикали.

Для разбиения ячейки укажите нужную ячейку и выберите пункт «Таблица — Разбить ячейку» На экран выводится диалог с запросом

вида разделения


Разбиение ячеек


Задание различной ширины колонок

В табличном редакторе системы 1С: Предприятие существует возможность задания различной ширины колонок для различных строк. Выделите одну или несколько строк таблицы. Подведите указатель мыши к разделителю колонок, нажмите левую кнопку мыши и, не отпуская ее, потяните в нужную сторону (например, влево), отпустите кнопку мыши. На экран выводится запрос на подтверждение выполнения действий с сообщением «Для выделенных строк будет создан новый формат строк» При нажатии кнопки «ОК» произойдет форматирование


Задание различной ширины колонок


Скрытие и отображение строк и столбцов

Для удобства просмотра информации табличный редактор системы 1С: Предприятие предоставляет возможность скрытия и отображения строк и столбцов таблицы. Для этого выделим строки и в контекстном меню выберем пункт «Скрыть». Для отображения скрытых строк таблицы выделите любую область, в которую входят скрытые строки, и в контекстном меню выберем пункт «Отобразить».Для отображения всех скрытых областей выделите всю таблицу.


Скрытие и отображение строк и столбцов


Объединение ячеек

При создании макета печатной формы документа часто возникает необходимость размещения текста в области, занимаемой несколькими ячейками (как по горизонтали, так и по вертикали) Для выравнивания текста в пределах нескольких ячеек можно использовать функцию объединения ячеек. Если несколько ячеек объединены в одну, при выравнивании текста границами выравнивания будут считаться границы этой объединенной ячейки.

Для объединения ячеек необходимо выделить желаемый диапазон ячеек и выбрать пункт «Таблица — Объединить».

Если в объединяемых ячейках был текст, он пропадет, за исключением текста левой верхней ячейки, который станет текстом объединенной ячейки.

Для разъединения объединенной ячейки достаточно выделить ее и повторно выбрать пункт «Таблица — Объединить».

Если в объединенной ячейке был текст, при разъединении он попадет в левую верхнюю ячейку, независимо от условий форматирования (например, он мог располагаться в правом нижнем углу объединенной ячейки, будучи, сдвинут вправо по горизонтали и вниз по вертикали).


Объединение ячеек


Работа с именованными областями таблицы

В таблице можно группе ячеек присвоить имя, чтобы по этому имени можно было с помощью средств встроенного языка оперировать областью. Именованные области имеет смысл использовать при создании макета отчета. Для табличного документа именованные области носят второстепенный характер и поэтому не отображаются в таблице как в макете.

Подготовка макета начинается с формирования «кирпичиков», из которых строится отчет. Этими кирпичиками являются именованные области.


Работа с именованными областями таблицы


Создание именованной области

Именованные области бывают горизонтальные (включают в себя отмеченные строки) и вертикальные (включают в себя отмеченные столбцы), а также прямоугольными, включающими смежные ячейки.

Для создания именованной области выделите требуемую область и выберите пункт «Таблица — Имена — Назначить имя». В открывшемся диалоге укажите имя области (см. параграф « Имена »).


Создание именованной области


Режим просмотра именованных областей

Просмотр именованных строк и столбцов возможен при включенном режиме «Таблица — Имена — Отображение именованные строки / столбцы».

Имена областей показываются для строк между заголовками строк и самой областью, для столбцов — между заголовками столбцов и самой областью.

Просмотр прямоугольных именованных областей возможен при включенном режиме «Таблица — Имена — Отображать именованные ячейки».

Имена областей показываются в виде заштрихованной области. Имя выводится в середине области.


Режим просмотра именованных областей


Удаление именованных областей

Для удаления именованной области выделите область, затем выберите пункт «Таблица — Имена — Убрать имя».


Удаление именованных областей


Изменение размеров именованных областей

Если область состоит более чем из одной строки или столбца, то для изменения размеров именованной области выделите строки или столбцы внутри области и затем выберите пункт «Таблица - Раздвинуть».

Если область состоит из одной строки или столбца, то увеличить размер области нельзя. Нужно убрать имя и создать именованную область заново.

Для уменьшения размера области выделите нужное число строк или столбцов, которые нужно удалить, и в контекстном меню выберите пункт «Удалить».

Для прямоугольной области можно производить аналогичные действия. В случае, когда выделяется не строки или столбцы, а отдельные ячейки изменение размеров области не производится.


Изменение размеров именованных областей


Работа с группами таблицы

В табличном редакторе системы 1С: Предприятие существует возможность создания групп строк или столбцов таблицы.

Группы можно создавать, удалять, расширять (включать в них дополнительные соседние строки или столбцы), создавать вложенные или внешние группы.


Работа с группами таблицы


Создание группы

Группы бывают горизонтальные (включают в себя отмеченные строки) и вертикальные (включают в себя отмеченные столбцы).

Для создания группы необходимо сначала отметить необходимые строки или столбцы, затем выбрать пункт «Таблица — Группы — Объединить в группу».


Создание группы


Режим просмотра групп

Просмотр групп возможен при включенном режиме «Таблица — Вид — Отображать группы».

Группы показываются маркерами с идущими тонкими линиями, обозначающими размер группы.

Показом строк и колонок, объединенных в группы, можно управлять. Для управления удобно пользоваться специальными маркерами. Есть две группы маркеров.

  • Маркеры первой группы (маркер уровней) размещены в левом верхнем углу таблицы и пронумерованы. Маркер с самым большим номером предназначен для отображения всех групп. Нажатие каждого предыдущего маркера скрывает все группы данного уровня, но не влияет на «более» внешние группы.
  • Маркеры второй группы (маркер группы) располагаются рядом с группой. Они имеют два состояния: «-» — группа показана; и «+» — группа скрыта. С помощью этих маркеров управляют показом конкретной группы. Указателем мыши нужно щелкнуть маркер группы. Группа скрывается, если была показана и отображается, если была скрыта. Маркер при этом меняет свой вид.

Строка или столбец, напротив которой расположен маркер, называется итоговой строкой. Положение итоговой строки можно менять. Для горизонтальных групп итоговая строка может располагаться сверху или снизу от группы. Для вертикальных групп итоговая строка может располагаться справа или слева от группы. Положение итоговой строки задается в свойствах таблицы Итоги по горизонтали и Итоги по вертикали. При смене положения итоговой строки положение маркера группы также меняется. Установка свойств расположения итоговых строк распространяется на все группы таблицы.


Режим просмотра групп


Удаление группы

Для удаления группы, выделите группу (все строки или столбцы, входящие в группы), затем выберите пункт «Таблица Исключить из группы».


Удаление группы


Изменение размеров группы. Вложенные и внешние группы

При работе с группами можно изменять размеры группы (расширять - включать дополнительные соседние строки или столбцы, сужать — исключать крайние строки или столбцы), создавать вложенные или внешние группы.

Расширение групп. Для расширения группы необходимо выполнить следующие действия:

  • выделите строки или столбцы, которые необходимо включить в новую группу,

· выберите пункт «Таблица - Группы — Включить в группу».

В зависимости от взаимного расположения выделенного диапазона и существующей группы редактор таблиц выполнит одно из следующих действий:

  • если отмеченная область строк или столбцов не пересекается с существующими группами, то будет создана новая именованная группа;
  • если отмеченная область строк или столбцов частично пересекается с существующей группой, то существующая группа будет расширена за счет соседних отмеченных строк или столбцов;
  • если отмеченная область строк или столбцов находится внутри существующей группы, то будет создана новая группа, вложенная в существующую;
  • если отмеченная область строк или столбцов охватывает полностью существующую группу, то будет создана новая группа, внешняя для существующей, так, что существующая группа будет вложена в новую.

Сужение группы. Для сужения группы необходимо выполнить следующие действия:

  • выделите нужные строки или столбцы;

· выберите пункт «Таблица - Группы — Исключить из группы».

В зависимости от взаимного расположения выделенного диапазона и существующей группы редактор таблиц выполнит одно из следующих действий:

  • если отмеченная область строк или столбцов не пересекается с существующими группами, то никаких действий не произойдет;
  • если отмеченная область строк или столбцов находится внутри существующей группы, то никаких действий не произойдет;
  • если отмеченная область строк или столбцов пересекается с существующей группой, то группа будет сужена за счет отмеченных строк или столбцов;
  • если отмеченная область строк или столбцов охватывает полностью существующую группу, то группа будет удалена полностью.


Изменение размеров группы. Вложенные и внешние группы


Использование графических объектов

При создании таблиц можно использовать графические объекты. Их применение позволяет улучшить оформление документов или внести в описание формы мелкие добавления, не затрагивая структуры макета

К графическим элементам относятся линии, прямоугольники, овалы, тексты, картинки, внедренные объекты (OLE-объекты) и диаграммы.

Текстом в табличном редакторе системы 1С: Предприятие называется рамка с текстом внутри.

Ниже будет рассмотрена работа со всеми графическими объектами за исключением OLE-объектов и диаграмм. Особенности работы с OLE-объектами будут рассмотрены в параграфе « Работа с OLE-объектами » ; с диаграммами — в параграфе « Работа с диаграммой » .

Свойства графических объектов подробно описаны в разделах Руководства, относящихся к данным объектам.

В этом разделе описываются способы размещения графических объектов в таблице.


Использование графических объектов


Вставка графических объектов

Вставка рисованных элементов в таблицу производится при помощи выбора нужного пункта «Таблица — Рисунки» стандартным для MS Windows образом. Настройка графических объектов производится палитре свойств.

Для размещения картинки предварительно выберите ту ячейку таблицы, где должен находиться верхний левый угол картинки, затем выберите пункт «Таблица — Картинка — Рисунки». На экран будет выдан диалог выбора картинки.

Картинку можно выбирать из картинок библиотеки (представлены в списке «Библиотека») или из файла. Для выбора из файла нажмите кнопку «Выбрать из файла». На экран выводится стандартный диалог открытия файла, в котором можно указать имя файла, содержащего картинку. Если отказаться от указания имени файла, в таблице будет «зарезервировано место» под картинку. Вставленные изображения вставляются со своим оригинальным размером.

Если выбран файл, то для указанной картинки можно указать, какой цвет картинки будет прозрачным. Обычно в качестве такого цвета выбирают фон картинки, чтобы он не закрывал информацию, расположенную под картинкой.

Картинка всегда вставляется реального размера. Размер области для размещения картинки можно изменить. Для этого выберите объект «Картинка», указателем мыши переместите границу или угол объекта в нужном направлении. Если требуется сохранить пропорции области, то предварительно нажмите клавишу Shift.

В свойстве Размер картинки выберите способ размещения картинки в области:

Способ | Описание
Реальный размер | картинка выводится в оригинальном размере. Если реальный размер меньше размера области, то остаток области не заполняется; если реальный размер больше размера области, то показывается только часть картинки.
Растянуть | картинка полностью размещается в области, не зависимо от ее размеров.
Пропорционально | при выводе картинки всегда сохраняется пропорции оригинального размера. Выбирается наименьший размер, который может разместиться в области, по нему по исходной пропорции вычисляется другой размер картинки и производится размещение картинки.
Черепица | картинка всегда выводится в оригинальном размере. Если размеры области больше, чем оригинальный размер картинки, то программа повторяет выбранную картинку таким образом, чтобы заполнить всю оставшуюся часть области.

Вставляемые стандартные графические объекты (прямоугольник, овал и текст) могут быть прозрачными или иметь различную заливку. По умолчанию при размещении графического объекта в таблице устанавливается сплошная заливка. Выбор вида заливки осуществляется в свойстве Узор категории свойств Фон. Также можно задать цвет фона и цвет узора.

У вставленных графических объектов в свойстве Стиль линии можно выбрать вид линии (границы), а в свойстве Цвет линии задать ее цвет.


Вставка графических объектов


Привязка графических объектов

Вставленные графические объекты автоматически привязываются к ячейкам таблицы. Привязка осуществляется для верхнего левого и нижнего правого углов объекта. При изменении ширины или высоты строк или столбцов, расположенных между этими углами, размер объекта также меняется.


Привязка графических объектов


Выделение графических объектов

Перед тем, как проводить какие-либо манипуляции с графическим объектом, его необходимо выделить.

Выделение можно производить двумя способами: непосредственным выбором объектов или используя режим выделения графических объектов.

В первом случае для выделения одного объекта необходимо щелкнуть на нем левой кнопкой мыши. Если выделяется прямоугольник, овал или текст, то вокруг него появятся восемь небольших квадратных маркеров: четыре из них расположены в середине каждой из четырех сторон рамки и четыре — в ее углах. Эти маркеры служат для изменения размеров объекта. Если перед началом перемещения нажать клавишу Shift и, не отпуская ее потянуть мышью за угловой маркер, то размеры объекта изменяются пропорционально существующим размерам объекта. Если выделяется линия, то маркеры появятся только в ее начальной и конечной точках.

Для выделения нескольких графических объектов используйте следующий способ: выделите первый объект, затем нажмите клавишу Shift и, не отпуская ее, выделите остальные объекты. Восемь маркеров появятся на воображаемой рамке, включающей все выделенные объекты.

Для снятия выделения с объекта или объектов достаточно щелкнуть мышью в любом свободном от объектов месте таблицы.

Во втором случае выделением графического объекта производится с помощью указателя мыши, которым «рисуется» прямоугольная область. Все графические объекты, полностью попавшие в эту зону, выделяются. Режим выделения устанавливается выбором пункта «Таблица — Рисунки — Выделение рисованных объектов».

Для выключения режима выделения графических объектов следует повторно выбрать пункт «Таблица — Рисунки — Выделение рисованных объектов».


Выделение графических объектов


Выравнивание группы графических объектов

Выравнивание графических объектов производится с помощью кнопок панели инструментов «Выравнивание». Команды доступны (выравнивание производится), если выбрано более одного объектов.

Выровнять влево производит выравнивание левых границ выбранных объектов. При этом их левые границы располагаются вдоль одной вертикальной прямой.

Выровнять вправо выравнивание правых границ.

Выровнять вверх выравнивание верхних границ.

Выровнять вниз выравнивание нижних границ.

Выбранную группу объектов можно также выровнять по центру вертикально или горизонтально. Для этого предназначены команды «Выровнять по центру вертикально» и «Выровнять по центру горизонтально». При этом выравнивание производится по осям объектов.


Выравнивание группы графических объектов


Установка размера группы графических объектов

С помощью кнопок панели инструментов «Выравнивание» можно установить одинаковые размеры всех объектов, входящих в группу. Следует обратить внимание на то, что за образец выбирается тот объект, маркеры которого имеют вид пустого квадрата . Этот объект называется мастером. Другие объекты имеют маркеры вида темного квадрата. Чтобы сменить мастера, в группе объектов щелкните мышью нужный объект.

Одинаковая ширина устанавливает одинаковую ширину всех объектов группы.

Одинаковая высота устанавливает одинаковую высоту всех объектов группы.

Одинаковый размер устанавливает одинаковый размер всех объектов группы.


Установка размера группы графических объектов


Перемещение и копирование графических объектов

Любой графический объект можно перемещать по таблице, а также копировать, создавая несколько объектов на основе одного объекта-образца.

Перемещение графического объекта. Для перемещения графического объекта надо перетащить его мышью в новое место. Пунктирная рамка (или линия — если перемещается линия), которая обозначает объект при движении мыши, поможет разместить его в таблице.

Перемещение графического объекта происходит также при нажатии на клавиатуре клавиш управления курсором.

Копирование графического объекта. Для копирования графического объекта перетащите его мышью при нажатой клавише Ctrl.

Если в процессе переноса копии объекта отпустить клавишу Ctrl, объект будет не скопирован, а перемещен.

Использование Буфера Обмена. Для перемещения и копирования графических объектов можно использовать Буфер Обмена MS Windows.

Положение вставленного объекта (или группы объектов) будет определяться следующим образом: в левый верхний угол активной ячейки таблицы помещается левый верхний угол воображаемой прямоугольной рамки, обведенной вокруг вставляемых объектов.


Перемещение и копирование графических объектов


Изменение размеров графических объектов

Размер любого графического объекта можно изменить. Для этого используются маркеры, которые появляются вокруг объекта (или группы объектов) при его выделении. Изменение размеров производится стандартным для MS Windows способом.


Изменение размеров графических объектов


Изменение порядка расположения графических объектов

Когда несколько графических объектов частично или полностью перекрывают друг друга, важно задать для них порядок расположения для достижения требуемого изобразительного эффекта.

Новый рисованный объект всегда помещается на передний план и перекрывает объекты, оказавшиеся под ним. Если представить, что все объекты помещаются один над другим, то получится многослойная конструкция, в которой каждый объект имеет свой порядок следования (слой). В верхнем слое располагается объект, который всегда следует впереди всех объектов. С помощью команд управления порядком расположения можно принудительно поместить объект позади всех других объектов (в нижний слой), и, наоборот, перенести вперед всех (в верхний слой), а также на один слой вверх или вниз.

Для переноса объекта необходимо выделить объект и в подменю «Порядок» контекстного меню выбрать один из пунктов

• на передний план для переноса объекта вперед всех объектов;

• на задний план для переноса объекта позади всех других объектов

• переместить вверх для переноса объекта на один слой вверх;

• переместить вниз для переноса объекта на один слой вниз.


Изменение порядка расположения графических объектов


Удаление графических объектов

Для удаления рисованного объекта необходимо выделить его и выбрать пункт «Правка — Удалить». Удалить объект можно, если предварительно выделить весь диапазон ячеек, на которых располагается графических объект. Если при выделении какая-то часть объекта окажется на других ячейках, объект останется в таблице, однако, его размеры при этом могут быть изменены.


Удаление графических объектов


Группировка графических объектов

Несколько графических объектов можно сгруппировать (объединить их в один графический объект).

Для группировки графических объектов выделите несколько объектов любым способом.

Выберите пункт «Таблица — Рисунки — Сгруппировать».

Над составным графическим объектом, полученным путем группировки нескольких объектов, можно производить действия как над обычным графическим объектом.

Если требуется, составной объект можно разгруппировать. Для этого укажите составной графический объект и выберите пункт «Таблица — Рисунки — Разгруппировать».


Группировка графических объектов


Имена графических объектов

Графическим объектам, как и ячейкам таблицы, можно присваивать имена. Имена присваиваются при помощи диалога «Имена» (пункт «Таблица — Имена») (подробнее см. параграф « Имена ») или при помощи панели редактирования (подробнее см. параграф « Панель редактирования »).

Вновь создаваемым графическим объектам Конфигуратор присваивает имена по умолчанию, состоящие из буквы D и порядкового номера графического объекта.


Имена графических объектов


Работа с OLE-объектами

Одной из универсальных возможностей приложений, работающих в операционной системе MS Windows 95 (Windows NT), является возможность использования внедренных объектов, называемых также OLE-объектами. OLE-объект — это часть текущего документа, которая создана другим Windows-приложением. Такой OLE-объект, как и любой рисованный объект, является полноценной частью документа с той лишь разницей, что для редактирования такого объекта будет загружено приложение, которым этот объект создан.

Для создания OLE-объекта необходимо выполнить следующие действия:

• выберите пункт «Таблица - Рисунки — Вставить объект»;

• нарисуйте мышью прямоугольник желаемого размера в том месте, где предполагается разместить OLE-объект;

• в выданном на экран запросе выберите тип внедряемого объекта;

Это вызовет загрузку той Windows-программы, которая поддерживает редактирование объектов указанного типа. При этом внешний вид окна Конфигуратора несколько изменится: в главном и контекстных меню появятся функции, а на рабочем поле — панели инструментов, характерные для вызванной программы.

Внимание. Программы для создания OLE-объектов не входят в комплект поставки. Это отдельные Windows-приложения, являющиеся лицензионными программными продуктами. 06 использовании вызванной программы следует читать в документации, поставляемой с ней.

• если требуется, отредактируйте OLE-объект;

• закончите редактирование OLE-объекта, щелкнув мышью в любом месте рабочего поля таблицы вне объекта.

После создания OLE-объекта он обладает всеми свойствами, присущими «обычным» рисованным объектам: вы можете менять его размер и положение, копировать, используя мышь или Буфер Обмена, как угодно компоновать с другими объектами и удалять за ненадобностью. О выполнении этих операций можно узнать из параграфа « Использование графических объектов ».

Но кроме этого, OLE-объект может быть отредактирован — его содержимое можно изменить. Для редактирования OLE-объекта необходимо дважды щелкнуть на нем мышью. В результате будет загружена та Windows-программа, в которой был создан данный объект, и вы можете отредактировать внедренный объект.


Работа с OLE-объектами


Работа с диаграммой

Табличный редактор позволяет включать специальный графический объект — диаграмму, которая позволяет размещать в таблицах системы 1С: Предприятие диаграммы и графики различного вида.

Для создания диаграммы необходимо выполнить следующие действия:

• выберите пункт «Таблица — Рисунки — Диаграмма»;

• в таблице нарисуйте мышью прямоугольник желаемого размера в том месте, где предполагается поместить диаграмму;

• укажите диапазон ячеек, на основании которых будет построена диаграмма (диапазон можно изменить в любой момент времени).

Если предварительно выделить нужный диапазон ячеек, то при вставке диаграммы табличный редактор не выдаст запрос на ввод диапазона.

После создания диаграмму нужно активизировать, например, двойным щелчком мыши, и настроить ее внешний вид (см. главу « Диаграмма »).


Работа с диаграммой


Область данных диаграммы

Для табличного документа можно так настроить диаграмму, чтобы она использовала данные, введенные в таблице.

Предположим, в таблице имеются некоторые данные. Для построения гистограммы на основе этих данных следует выполнить следующие действия:

• выделите область ячеек, включающую таблицу (в данном примере, обведена жирной рамкой);

• выберите пункт «Таблица — Рисунки — Диаграмма»;

• разместите диаграмму.

В табличном документе появится элемент «Диаграмма», который представляет указанные данные в графическом виде. Вид диаграммы, заголовок, размеры областей, цвета построения и многие другие параметры настраиваются в палитре свойств диаграммы.

Подробнее про настройку объекта «Диаграмма» см. главу « Диаграмма ».


Область данных диаграммы


Вставка элементов управления

В таблицу, вставленную в форму, можно вставлять различные элементы управления. Вставка осуществляется стандартным образом, как описывается в главе «Редактор форм».

Во вставленные элементы управления (например, панель, табличный документ) можно также вставлять элементы управления.


Вставка элементов управления


Привязка элементов управления

Вставленный элемент управления автоматически привязывается к таблице. Привязка осуществляется для верхнего левого и нижнего правого углов объекта. При изменении ширины или высоты строк или столбцов, расположенных между этими углами, размер элемента также меняется.


Привязка элементов управления


Размещение элементов управления в таблице

Размещение элементов управления в таблице, вставленной в форму, имеет свои особенности. При размещении в таблице у элемента управления в палитре свойств добавляется свойство Встроен в таблицу. Если свойство установлено, то элемент полностью занимает ячейку, к которой привязан верхний левый угол. Если свойство не установлено, то элемент можно расположить поверх других ячеек.

Для каждой ячейки, в которую встроен элемента управления, в список объектов палитры свойств (верхняя строка палитры) добавляется строка, для получения доступа к свойствам этого элемента.

Если в палитре свойств встроенного элемента управления не установлено свойство Видимость, то в режиме 1C: Предприятие доступ к этому элементу производится двойным щелчком мыши в ячейку, в которой расположен элемент управления. В Конфигураторе для проверки работы формы можно запустить режим просмотра формы (выберите пункт «Форма — Проверить»).


Размещение элементов управления в таблице


Настройка печати

Для просмотра результатов некоторых установок, описываемых в этом разделе, рекомендуем установить режим просмотра страниц (выберите пункт «Таблица — Вид — Режим просмотра страниц»).


Колонтитулы

Колонтитулы — это области вверху и внизу страницы, служащие для вывода какого-либо повторяющегося текста на каждой странице документа: номера страницы, названия документа, даты и времени создания, другой информации. Для создания колонтитула используется пункт «Таблица — Настройки печати — Колонтитул».

При выборе этого пункта меню па экран выдается диалог, в котором следует выбрать, какой колонтитул необходимо создать — верхний или нижний, указать текст и стиль колонтитулов.

Для каждого колонтитула указывается, с какой страницы начинать печатать колонтитул, как его расположить и каким шрифтом печатать.


Колонтитулы


Разбиение на страницы

При печати таблиц большого размера редактор таблиц системы 1С: Предприятие выполняет автоматическое разбиение документа на страницы в соответствии с установками параметров страницы. Кроме того, при разбиении на страницы учитываются принудительные переводы страницы и установки положения на странице.

Установки положения на странице не переносятся из таблицы в готовый документ.

Принудительный перевод страницы. Для принудительной расстановки переводов страниц можно воспользоваться пунктом «Таблица — Настройки печати — Вставить разрыв страницы».

Для вставки горизонтального перевода страницы следует выделить ячейку или строку таблицы и выбрать пункт «Таблица — Настройки печати — Вставить разрыв страницы». Перевод страницы будет вставлен над выделенной ячейкой или строкой. Он будет обозначен пунктирной линией.

Чтобы убрать горизонтальный перевод страницы, необходимо выделить ячейку или строку под переводом страницы и выбрать пункт «Таблица — Настройки печати — Удалить разрыв страницы».

Для вставки вертикального перевода страницы следует выделить столбец таблицы и выбрать пункт «Таблица — Настройки печати — Вставить разрыв страницы». Перевод страницы будет вставлен слева от выделенного столбца, он будет обозначен пунктирной линией.

Чтобы убрать перевод страницы по вертикали, необходимо выделить столбец слева от перевода страницы и выбрать пункт «Таблица — Настройки печати — Удалить разрыв страницы».

Положение на странице. Для любой строки или столбца таблицы (а также диапазона строк или столбцов) могут быть заданы параметры размещения на странице. Для этого необходимо выделить соответствующий диапазон и в палитре свойств (для объекта типа «Ячейки») в категории Параграф установить свойство Начало страницы или Конец следующим.

Для изменения положения на странице следует вновь выделить соответствующий диапазон и снять свойство Начало страницы или Конец следующим.


Разбиение на страницы


Автоматическое повторение строк и столбцов

Для любой строки и столбца таблицы (а также для диапазона строк и столбцов) можно задать повторение при печати на каждой странице. Для этого необходимо выделить строку или диапазон строк (столбец или диапазон столбцов) и выбрать пункт «Таблица — Настройки печати — Повторять на каждом листе».

Диапазон, который выбран для повторения, на первом листе будет размещен так, как он расположен в таблице, то есть в соответствии со своим положением на листе относительно заголовков строк и столбцов. На последующих листах повторяющиеся строки будут располагаться вверху листа, а столбцы — слева.

Убрать повторение на каждом листе можно, выбрав пункт «Таблица — Настройки печати — Удалить повторение». Настройка будет снята со всех диапазонов, для которых оно было установлено ранее.

Установки автоматического повторения строк и столбцов не переносятся из таблицы в готовый документ. Кроме того, области повторения можно просмотреть и изменить в палитре свойств табличного документа.


Автоматическое повторение строк и столбцов


Задание области печати

Вместо печати всей таблицы целиком, редактор таблиц позволяет задать область печати — диапазон, который будет напечатан.

Для задания области печати следует выделить диапазон в таблице и выбрать пункт «Таблица — Задать область печати».

Отменить печать диапазона можно, выбрав «Таблица — Убрать область печати».

Для таблицы область печати может быть также указана в свойствах палитры свойств таблицы (см. раздел « Определение области печати » раздела « Свойства таблицы »).


Задание области печати


Настройка параметров страницы

Режим настройки параметров страницы позволяет выбрать печатающее устройство и установить размер и ориентацию бумаги, на которой будет производиться печать таблицы. Для вызова этого режима выберите пункт «Файл — Параметры страницы». На экран будет выдан диалог «Параметры страницы»:

Назначение управляющих элементов диалога в большинстве своем стандартно для многих программ MS Windows. Пояснения требуют те особенности, которые касаются редактора таблиц системы 1С:Предприятие Экземпляров на страницу. Группа «Экземпляров на страницу» позволяет выбрать количество экземпляров документа, которые при печати будут помещаться на 1 страницу (экземпляры помещаются один под другим).

Если выбрана опция «Авто», то программа сама будет определять количество экземпляров: если при выбранном размере листа и полях печати на странице помещается 2 экземпляра документа целиком, то будет напечатано два экземпляра, а если не помещается — то один.

Колонтитулы. Группа «Колонтитулы» позволяет задать размеры области листа, которая будет отводиться для печати колонтитулов. Размеры задаются в миллиметрах и отсчитываются от верхнего или нижнего поля в сторону соответствующего края листа.

Масштаб. Поле «Масштаб» позволяет задать масштаб печати таблицы. Установленный масштаб не влияет на масштаб просмотра документа в редакторе таблиц.

По ширине листа. Если включен данный режим, редактор таблиц автоматически подбирается масштаб таким образом, чтобы документ при печати умещался по ширине на один лист.

Черно-белая печать. Если включен данный режим, цвета, заданные для таблицы, игнорируются, и документ выводится на печать в черно-белом режиме.


Настройка параметров страницы


Печать таблицы

Просмотр документа перед печатью. Вы можете перед печатью просмотреть документ в том виде, как он будет напечатан. Для этого следует выбрать пункт «Файл — Просмотр».

При просмотре можно использовать кнопки «След.» и «Пред.» для вывода на экран следующей и предыдущей страниц просматриваемого документа и кнопку «2 Стр./1 Стр.» для переключения в режим одновременного просмотра двух страниц документа и обратно.

Для изменения масштаба изображения надо использовать мышь или кнопки «Развернуть» и «Свернуть».

Если указатель мыши находится в пределах просматриваемого документа, нажатие левой кнопки дискретно увеличивает масштаб изображения. Всего существует 3 фиксированных масштаба просмотра; при достижении самого крупного нажатие левой кнопки мыши вновь показывает документ в самом мелком масштабе.

Нажатие кнопки «Развернуть» увеличивает масштаб на 1 шаг, нажатие кнопки «Свернуть» — уменьшает.

Для выхода из режима предварительного просмотра следует нажать кнопку «Закрыть».

При показе документа будут использоваться параметры печати, установленные в режиме настройки параметров страницы. Это размер бумаги, границы области печати, масштаб и др. Будут использоваться и параметры размещения строк и столбцов, установленные в редакторе таблиц. Это принудительное разбиение на страницы, повторение строк и столбцов, параметры размещения строк и столбцов, установленные в режиме «Положение на странице» и др.

Печать документа. Для вывода документа на принтер выберите пункт «Файл — Печать». На экран будет выдан стандартный диалог для настройки параметров печати.

В этом диалоге следует установить необходимые параметры печати: выбрать принтер, диапазон страниц для печати, количество копий, — и нажать кнопку «ОК» для выполнения печати.


Печать таблицы


Глава 10.HTML-редактор

С помощью HTML-редактора создаются гипертекстовые документы (HTML-документы). Они используются для создания пользовательских описаний.


Глава 10. HTML-редактор


Создание HTML-документа

Для создания нового HTML-документа выберите пункт «Файл — Новый». В открывшемся диалоге выбора вида документа выберите «HTML-документ» и нажмите кнопку «ОК». Программа создаст пустой документ и выводит на экран окно для его редактирования.

На закладке «Редактирование» производится ввод и редактирование документа в визуальном режиме, на закладке «Текст» - можно редактировать создаваемый документ в формате HTML. На закладке «Просмотр» просматривают результат редактирования.


Создание HTML-документа


Создание описания объекта конфигурации

В дереве объектов конфигурации выберите объект конфигурации или подчиненный объект (например, форму). В палитре свойств в категории Справочная информация для открытия описания используйте ссылку - Открыть .


Сохранение

HTML-документ сохранить в файл, для того, чтобы его в дальнейшем можно было бы открыть, просмотреть и отредактировать.

Чтобы сохранить HTML-документ в виде файла, выберите пункт «Файл — Сохранить».

В диалоге сохранения файла выберите каталог и укажите имя файла. Нажмите кнопку «Сохранить».


Сохранение


Редактирование

Создание HTML-документа напоминает работу с обычным текстовым редактором.

Однако имеются некоторые особенности. Так, например, в HTML-документ можно вставлять картинки, таблицы, надписи, а также размещать ссылки на другие документы.


Редактирование


Ввод текста

Ввод текста подробно описан в разделе « Текстовый редактор ». Поэтому в текущем разделе будут указаны только особенности ввода текста при создании HTML-документа.


Ввод текста


Форматирование текста

Текст HTML-документа можно форматировать, т.е. устанавливать его стиль (фонт, размер, наклон, отступы и т.д.). При копировании текста из других текстовых редакторов, например, MS Word, сохраняется исходное форматирование текста.


Форматирование текста


Вставка и работа с таблицей

В HTML-документ можно вставлять таблицы. Для вставки таблицы выберите пункт «Таблица — Вставить таблицу». В открывшемся диалоге укажите количество строк и столбцов.

Если в дальнейшем в процессе редактирования выяснится, что указанного количества строк или столбцов не хватает, их можно добавить.

Для работы с таблицей (вставка, удаление строк, столбцов и ячеек) предназначены команды, выполняемые при выборе пунктов меню «Таблица» главного меню Конфигуратора.

Пункт меню -таблица | Действия
Вставить строку | Сверху от текущей строки добавляется новая строка
Удалить строку | Удаляется текущая строка
Вставить столбец | Справа от текущего столбца добавляется новый столбец
Удалить столбец | Удаляется текущий столбец
Вставить ячейку | В таблицу слева от текущей ячейки добавляется ячейка. При этом все ячейки справа сдвигаются.
Удалить ячейку | Удаляет текущую ячейку. Все ячейки справа сдвигаются влево
Объединить ячейки | Объединяет две ячейки, текущую ячейку, расположенную справа от текущей. При этом введенная информация в этих ячейках также объединяется. Если требуется объединить больше чем две ячейки, выполните эту операцию несколько раз
Разбить ячейку | Разделяет текущую ячейку на две ячейки


Вставка и работа с таблицей


Вставка картинки

В HTML-документ можно вставлять картинки.

Для вставки картинки выберите пункт «Элементы — Вставить картинку». В открывшемся диалоге укажите адрес картинки (путь и имя файла картинки) или выберите файл в стандартном диалоге выбора файла. В поле «Текст» введите поясняющий текст, который будет появляться в режиме просмотра в виде ярлыка при помещении указателя мыши над картинкой.

В группе реквизитов «Расположение» укажите, если требуется, выравнивание картинки (как располагается картинка в документе).

Значение выравнивание | Действия
Не задано | Картинка располагается в тексте
Лево | Картинка располагается в новой строке прижатой к левой границе документа
Право | Картинка располагается в новой строке прижатой к правой границе документа
Поверх текста | Картинка располагается в тексте с выравниванием по центру картинки
Низ | Картинка располагается в тексте с выравниванием
Центр | Картинка располагается в тексте
Верх | Картинка располагается в тексте

Если требуется поместить картинку в рамку, в реквизите диалога «Рамка» укажите толщину рамки. Если толщина равна 0, то рамка не рисуется.

Для вставки картинки нажмите кнопку «ОК».

Указанные в диалоге реквизиты можно изменить в панели свойств картинки.

Вставленную картинку можно переместить. Для этого укажите картинку и перетащите ее мышью в нужное место документа. При этом свойство картинки «Положение» не меняется, т.е. если установлено не «Лево» и не «Право», то картинку можно расположить в тексте, в противном случае картинка будет располагаться в новой строке.

Картинку можно копировать. Копирование осуществляется стандартным образом (с помощью Буфера Обмена или с помощью мыши при нажатой клавише Ctrl).

Картинку можно расположить в любой части HTML-документа (текст, таблица и надпись).


Вставка картинки


Надпись

Надпись — специальный объект HTML-документа. Он представляет собой область, в которую можно разместить текст, таблицу, картинку или другую надпись. При просмотре надписи вложенные объекты непрерывно прокручиваются справа налево.

Размер надписи можно изменить. Для этого выделите надпись и с помощью мыши переместите маркер надписи.

Надписи можно располагать в тексте и в таблице.


Ссылки

Для создания гипертекста в HTML-документе можно создавать ссылки.

Выделите объект (текст или картинку), выберите пункт «Элементы — Ссылка». На экран выводится диалог формирования ссылки.

В реквизите «Адрес» укажите адрес гиперссылки. Для создания ссылки нажмите кнопку «ОК».

Выделенный объект форматируется в соответствии со стилем гиперссылки. Обычно это синий цвет текста с подчеркиванием. Картинка помещается в рамку синего цвета.

В режиме просмотра при подведении указателя мыши к объекту, содержащему ссылку, указатель приобретает форму руки.


Ссылки


Линия

Для вставки линии выберите пункт «Элементы — Линия». С помощью линий производится зрительное разделение документа.


Линия


Редактирование в HTML-формате

Возможности редактора HTML-документов, предоставляемые на закладке «Редактирование», ограничены. Однако, на закладке «Текст» разработчик может отредактировать документ в формате HTML-кода.

Помимо редактирования на закладке «Текст», для каждого HTML-элемента, размещенного в документе, можно в палитре свойств, просмотреть и отредактировать HTML-атрибуты. Чтобы включить возможность редактирования HTML-атрибутов, следует в меню выбрать пункт «Элементы — Отображать атрибуты». В палитре свойств будут отображаться HTML-атрибуты, которым можно присваивать значения.


Редактирование в HTML-формате


Просмотр результата

Для просмотра результата редактирования HTML-документа перейдите на закладку «Просмотр» и проверьте работу объектов документа.


Просмотр результата


Глава 11.Администрирование

При работе пользователей с системой 1С: Предприятие в сети значение приобретают два вопроса — интеграция и разделение доступа.

Каждый пользователь системы должен иметь свободный доступ к общей информации, такой, как справочники, константы или перечисления.

С другой стороны, необходимо, чтобы каждый пользователь имел дело только с той информацией, которая необходима ему для работы, и никак не мог своими неосторожными действиями повлиять на работу других пользователей или на работоспособность системы в целом.

Конфигуратор системы 1С: Предприятие содержит развитые средства администрирования, предназначенные для решения указанных задач.

Прежде всего, в процессе создания конфигурации создается необходимое число типовых наборов прав (ролей и интерфейсов), описывающих полномочия различных категорий пользователей на доступ к информации, обрабатываемой системой. Роли могут быть заданы в достаточно широких пределах — от возможности только просмотра ограниченного числа видов документов до полного набора прав по вводу, просмотру, корректировке и удалению любых видов данных. Порядок создания типовых наборов ролей и их редактирование излагается в параграфе « Роли » главы «Объекты конфигурации». Создание пользовательских интерфейсов описан в параграфе « Редактор индивидуальных пользовательских интерфейсов » главы «Объекты конфигурации».

Для эффективной работы пользователей в процессе настройки конфигурации задачи для каждого пользователя может быть создан индивидуальный пользовательский интерфейс. Такой интерфейс включает команды главного меню и панели инструментов, настроенные на работу пользователя с той информацией, доступ к который разрешен его набором прав.

Наконец, в системе 1С: Предприятие существует возможность создания списка пользователей, которым разрешена работа с системой. Этот список будет использоваться для авторизации пользователя при его входе в систему. Следует обратить внимание, что список пользователей системы 1С: Предприятие не является частью конфигурации задачи: он создается отдельно в конкретной организации, в которой используется система.

Для каждого пользователя может быть установлен пароль на вход в систему. Пароль используется для подтверждения прав пользователей на работу в системе 1C: Предприятие.

В этой главе будут рассмотрены вопросы ведения списка пользователей системы 1С: Предприятие и назначения пользователям наборов прав и интерфейсов.


Глава 11.Администрирование


Ведение списка пользователей

Список пользователей вызывается на экран выбором пункта «Администрирование — Пользователи».

Окно со списком пользователей имеет панель инструментов и табличное поле с двумя колонками.

В колонке «Имя» выводится список пользователей, зарегистрированных для работы с системой 1С: Предприятие.

Колонка «Полное имя» может содержать расшифровку имени, выданного в первой колонке.


Ведение списка пользователей


Создание нового пользователя

Для создания нового пользователя необходимо выбрать пункт «Действия — Добавить» диалога «Список пользователей». На экран будет выдан диалог для редактирования параметров пользователя.

На закладке «Основные» указываются имя, полное имя и пароль (указывать не обязательно) для входа в систему. Пароль запрашивается при запуске системы 1С: Предприятие.

На закладке «Права доступа» указываются роль и основной интерфейс. Если ролей в конфигурации определено несколько, то для пользователя можно также указать несколько ролей.

В качестве интерфейса можно выбрать один из созданных в конфигурации интерфейсов.

В диалоге для редактирования свойств пользователя не обязательно заполнять сразу все поля — это можно сделать позднее.

Совет. Желательно задавать пользователям смысловые имена, используя фамилию сотрудника, наименование должности, характер выполняемых им функций и тому подобное. В дальнейшем это имя будет использоваться сотрудником для входа в систему 1 С: Предприятие.


Создание нового пользователя


Копирование пользователя

Нового пользователя можно создать путем копирования существующего пользователя. Используя такую возможность, нет необходимости создавать нового пользователя «с нуля» — достаточно скопировать одного из уже существующих в списке пользователей и отредактировать его свойства.

Для копирования используются возможности Буфера Обмена MS Windows.

При копировании имя пользователя может быть преобразовано с целью соблюдения уникальности. Остальные свойства нового пользователя будут такие же, как и у пользователя, выбранного в качестве образца.


Копирование пользователя


Установка пароля

С целью предотвращения входа пользователей в систему 1С: Предприятие под чужими именами, каждому пользователю, которому разрешена работа с системой, может быть установлен пароль на вход. Как и имя пользователя, пароль служит для подтверждения полномочий пользователя на работу в системе.

В поле для ввода пароля введите пароль пользователя. Пароль представляет собой произвольную строку, состоящую из букв и цифр. Пароль не должен содержать пробелов и специальных символов, размер пароля не должен превышать 255 символов.

При вводе пароль отображается звездочками, поэтому будьте внимательны.

После ввода пароля нажмите кнопку «ОК». Если вы передумали устанавливать пароль, нажмите кнопку «Отмена».

Внимание! Присвоенный пользователю пароль нельзя посмотреть, поэтому будьте внимательны при установке пароля и твердо запомните его.

Если пользователь забыл свой пароль, необходимо задать ему новый пароль.


Установка пароля


Удаление пользователя

Для удаления пользователя из списка выделите имя пользователя, которого необходимо удалить, и выберите пункт «Действия — Удалить» диалога «Список пользователей».

В появившемся на экране запросе нажмите «ОК» для подтверждения удаления пользователя.


Удаление пользователя


Редактирование свойств пользователя

Для редактирования параметров пользователя выберите пункт «Администрирование — Пользователи». В списке пользователей выберите нужного пользователя и выберите пункт «Действия — Изменить» диалога «Список пользователей».

В диалоге «Параметры пользователя» измените параметры.


Редактирование свойств пользователя


Региональные установки информационной базы

Режим настройки региональных установок информационной базы позволяет управлять форматом отображения даты, времени, чисел, логических констант. Для вызова режима выберите пункт «Администрирование — региональные установки ИБ».

Если ни одно из свойств не установлено, то язык и форматы отображения чисел даты и времени будут определяться настройками операционной системы.

В нижней части диалога выводятся примеры отображения числе даты и времени с выбранными в диалоге установками.

Язык. Выбор языка (страны) для данной установки информационной базы.

Разделитель дробной части. Символ-разделитель целой и дробной части чисел можно выбрать из выпадающего списка или указать самостоятельно в поле ввода. Пример символа будет выведен в рамке слева от поля ввода.

Разделитель групп. Символ-разделитель групп цифр в целой части числа можно выбрать из выпадающего списка или указать самостоятельно в поле ввода. Пример символа будет выведен в рамке слева от поля ввода

Группировка Свойство задает формат группировки цифр в целой части числе. Форматную строку можно выбрать из выпадающего списка или указать самостоятельно.

Формат группировки указывается следующим образом:

<количество цифр в группе><символ-разделитель>... ...<0>.

В качестве символа-разделителя можно использовать любой символ, отличный от цифры.

Например, последовательность символов «3,2,0» означает, что цифры будут сгруппированы следующим образом (отсчет цифр в числе идет слева направо только в целой части):

• первую группу образуют первые три цифры числа;

• затем идет символ-разделитель групп (заданный настройками операционной системы или указанный в свойстве «Разделитель групп);

• все оставшиеся цифры числа будут сгруппированы по две.

Символ «0» в конце форматной строки означает «и так же — до конца», то есть, если в вышеприведенном примере форматной строки убрать «0», указав -«3,2», группировка изменится следующим образом:

• первую группу образуют первые три цифры числа;

• затем идет символ-разделитель групп;

• вторую группу образуют следующие 3 цифры числа;

• затем идет символ-разделитель групп;

• все оставшиеся цифры числа будут собраны вместе.

Ввод одного символа «0» в этом поле означает, что цифры в целой части чисел не будут разделяться на группы.

Представление отрицательных чисел. Из выпадающего списка можно выбрать вид отрицательных чисел. Выбор «Авто» означает, что вид отрицательных чисел будет определяться установками операционной системы.

Формат даты. Устанавливает формат отображения даты. Можно использовать в различных сочетаниях символы:

• d число месяца. Числа меньше 10 выводятся без лидирующего нуля;

• dd число месяца. Числа меньше 10 выводятся с лидирующим нулем;

• М номер месяца. Номера месяцев меньше 10 выводятся без лидирующего нуля;

• MM номер месяца. Номера месяцев меньше 10 выводятся с лидирующим нулем;

• мммм наименование месяца словами;

• У две последние цифры года. Года меньше 10 выводятся без лидирующего нуля;

• УУ две последние цифры года. Года меньше 10 выводятся с лидирующим нулем;

• УУУУ год четырьмя цифрами.

Перечисленные выше символы и группы символов можно указывать в любой последовательности. Для разделения дня, месяца и года можно указывать различные символы-разделители.

Формат времени. Устанавливает формат отображения времени, Можно использовать в различных сочетаниях символы:

• h,H часы в 12-часовом (h) или 24-часовом (Н) формате. Часы меньше 10 выводятся без лидирующего нуля;

• hh.HH часы в 12-часовом (hh) или 24-часовом (НН) формате. Часы меньше 10 выводятся с лидирующим нулем;

• m минуты. Минуты меньше 10 выводятся без лидирующего нуля;

• mm минуты. Минуты меньше 10 выводятся с лидирующим нулем;

• s секунды. Секунды меньше 10 выводятся без лидирующего нуля;

• SS секунды. Секунды меньше 10 выводятся с лидирующим нулем.

Перечисленные выше символы и группы символов можно указывать в любой последовательности. Для разделения часов, минут и секунд можно указывать различные символы-разделители.

Логическое ложь, логическое истина. Позволяет указать вид логических констант. Можно выбрать из выпадающего списка, либо ввести самостоятельно.


Региональные установки информационной базы


Глава 12.Сервисные возможности

Система 1С: Предприятие включает в себя массу различных сервисных возможностей и вспомогательных режимов. Они описаны в этой главе.


Глава 12.Сервисные возможности


Служебные окна

В процессе работы с Конфигуратором для выдачи пользователю различной вспомогательной информации используются служебные окна. К таким окнам относятся:

• окно сообщений;

• окно результата поиска во всех текстах;

• шаблоны текста;

• Синтакс-Помощник.

Первые два вида окон автоматически вызываются на экран в случае необходимости (шаблоны текста и Синтакс - Помощника вызываются пользователем).

Назначение каждого из перечисленных окон описано в соответствующих разделах данного Руководства, а в настоящем параграфе будут изложены общие приемы работы с такими окнами.

Для управления окнами используются контекстные меню, вызываемые в заголовке окна и внутри окна. С помощью первых производится управление поведением самого окна (подробнее см. раздел « Состояние (режим размещения) окна »), а с помощью вторых — действия с содержимым окна.


Служебные окна


Состояние (режим размещения) окна

Окна могут размещаться на экране в разных режимах. Это:

• обычное расположение, когда окно располагается только внутри рабочей области программы,

• свободное расположение, когда окно может свободно перемещаться по всему экрану (не только внутри рабочей области программы),

• прикрепляемое, когда окно может « прикрепиться» к границам рабочей области программы,

• прячущееся, (только для некоторых типов окон, например, служебных окон, калькулятора и календаря).

Для изменения способа размещения в контекстном меню заголовка окна выберите требуемый вид размещения. Изменить режим размещения можно также с помощью перетаскивания окна мышью. Для перетаскивания окна следует в области заголовка окна нажать левую кнопку мыши и, не отпуская ее, перетащить окно в другое место.

Если выбран режим «Прикрепляемое», то при перетаскивании окна при приближении к границе рабочей области программы контур окна может измениться. Если в этот момент отпустить кнопку мыши, то окно прикрепится. Для изменения размера прикрепленного окна подведите указатель мыши к свободной (обращенной в сторону рабочей области) границе. Потяните границу мышью.

Окна, не относящиеся к формам, определяемым в конфигурации (списки и элементы справочников, журналы документов и документы и др.), за исключением табличных и текстовых документов, можно размещать на экране в режиме «Прячущееся». Если выбрать режим «Прячущееся», то сбоку рабочей области программы появляется дополнительная строка для ярлыков окон, в которую добавляется ярлык текущего окна, а само окно прикрепляется к этой стороне рабочей области. Расположение этой строки определяется расположением окна в режиме «Прикрепляемое». В этом режиме окно остается на экране, пока активно. Как только активизировать любое другое окно, предыдущее окно прячется. Чтобы показать это окно необходимо подвести указатель мыши к ярлыку данного окна (щелкать кнопкой мыши не нужно). При выводе указателя мыши вне окна, прячущееся окно автоматически убирается с экрана.


Состояние (режим размещения) окна


Настройка параметров Конфигуратора

Для установки различных параметров работы Конфигуратора используется функция «Сервис — Параметры». Диалог «Параметры» организован в виде картотеки. Все параметры, которые можно установить, объединены в группы. Для доступа к управляющим элементам конкретной группы щелкните мышью на соответствующей закладке в окне диалога.


Настройка параметров Конфигуратора


Установка параметров редактора

Управляющие элементы закладки «Тексты» позволяют настроить поведение редактора текстовых документов.

Перетаскивание текста. В редакторе текстов для перемещения и копирования блоков текста можно использовать режим «drag & drop» («перенеси и оставь»).

Разрешить помешать курсор после концов строк. Если установлено, то курсор можно помещать после концов строк. В противном случае положение курсора ограничивается положением символа «перевод строки».

Отображать пробелы и табуляцию. Если установлено, то символы пробелов и табуляции будут показываться в тексте. Этот режим устанавливается для проверки форматирования текста. Если установлено свойство «Отображать пробелы и табуляцию, то становится доступными свойства Пробел и Табуляция для ввода символов, которыми будет осуществляться показ пробелов и табуляции.

Пробел. Указывается символ показа пробелов. Табуляция. Указывается символ показа табуляции.

Заменять табуляцию при вводе. Если установлено, то при вводе текста символ табуляции заменяется на установленное в свойстве Ширина табуляции число пробелов.

Ширина табуляции. Устанавливает соответствие символа табуляции числу символов при вводе текста.

Автоотступ. Устанавливает или отменяет автоматический отступ при вводе символа «Перевод строки» (по нажатии клавиши Enter).

Шрифт. Выбор шрифта, используемого при вводе текста. Для ввода текста модулей рекомендуется выбирать моноширинные шрифты (например, Courier).

Использовать автозамену. Если установлено, то вводимый текст, если он совпадает с текстом, указанным в шаблоне в реквизите «Автоматически заменять строку», будет заменяться на текст шаблона. Для того, чтобы вводимый текст заменялся на текст шаблона, нужно после набора строки нажать клавишу «пробел» или Enter.


Установка параметров редактора


Установка параметров текста модуля

Управляющие элементы закладки «Тексты модулей» позволяют настроить выделение цветом синтаксических конструкций в модулях, автоотступ, и задать шаг табуляции для модулей, а также настраивается группировка.

На этой закладке размещена панель с двумя закладками, с помощью которой производится настройка редактирования и настройка группировки в модулях

На закладке «Редактирование» определяется выделение цветом синтаксических конструкций в модулях, автоотступ и задать шаг табуляции для модулей.

Выделение цветом синтаксических конструкций. Воспринимать текст модуля легче, если определенные синтаксические конструкции (константы, имени, оператора, комментария и т.д.) будут выделены цветом. Цвет также выполняет дополнительную функцию проверки правильности при вводе текста модуля. В случае неправильного написания наименования оператора, он не будет выделен нужным цветом. Для каждой конструкции (константы, имени, оператора, комментария и т.д.) можно определить свой цвет.

Запретить выделение цветом. Если установлено, то текст модуля будет показан как обычный текст, а настройка выделения цветом будет недоступна.

Проверять автоматически. Текст модуля будет автоматически проверяться на наличие синтаксических ошибок при записи и закрытии.

Использовать автозамену. Если установлено, то вводимый текст, если он совпадает с текстом, указанным в шаблоне в реквизите «Автоматически заменять строку», будет заменяться на текст шаблона. Для того, чтобы вводимый текст заменялся на текст шаблона, нужно после набора строки нажать клавишу «пробел» или Enter.

Заменять табуляцию при вводе. Если установлено, то при вводе текста символ табуляции заменяется на установленное в свойстве Ширина табуляции число пробелов.

Ширина табуляции. Указывается эквивалентное число символов Пробел для одного символа табуляции.

Автоотступ. Устанавливает или отменяет автоматический отступ при вводе символа «Перевод строки» (по нажатии клавиши Enter). При выборе значения «Синтаксический» ввод текста модуля будет производиться в учетом текущей синтаксической конструкции.

Шрифт. Выбор шрифта, используемого при вводе текста. Для ввода текста модулей рекомендуется выбирать моноширинные шрифты (например - Courier).

Панель окна модуля. Если свойство установлено, то в модулях будет показываться панель инструментов, с помощью которой можно управлять группами, производить выбор нужной процедуры или функции, а также показывается наименование текущей процедуры или функции.


Установка параметров текста модуля


Настройка показа группировки

В диалоге «Параметры» (пункт «Сервис — Параметры») на закладке «Тексты модулей» производится настройка представления текста. При выборе этой страницы диалога становится доступными различные реквизиты настроек Настройки объединены в два раздела и каждый размещен на отдельной закладке. На закладке «Группировка» производится установка режимов группировки и сворачивания различных синтаксических конструкций. В таблице по строкам представлены виды конструкций.

В колонке «Группировать» установленный флажок означает, что данная синтаксическая конструкция будет автоматически сгруппирована. Следует учитывать, что группируются только синтаксические конструкции второго уровня вложенности.

В колонке «Сворачивать» установленный флажок означает, что данная синтаксическая конструкция будет автоматически свернута при открытии модуля.


Настройка показа группировки


Установка параметров редактирования формы

На закладке «Форма» диалога настройки параметров «Параметры» указываются значения некоторых свойств форм, устанавливаемых по умолчанию при создании каждой новой формы. Поэтому, установку параметров в диалоге настройка следует производить с таким расчетом, чтобы устанавливаемые параметры были типичными в большинстве случаев например, установка свойства Отображать сетку приводит к тому, что при создании новой формы сразу будет показываться разметочная сетка. Отображение сетки для конкретной формы можно отменить но, если для большинства форм выравнивание элементов управления производится не по разметочной сетке, то у данного параметра лучше снять установку.


Установка параметров редактирования формы


Сетка

Выравнивать по сетке. Если установлено, то в новой форме при размещении элементов управления может использоваться разметочная сетка (вставляемые элементы управления будут выравниваться по линиям сетки и принимать размер, кратным шагу сетки).

Отображать сетку . Если установлено, то в новой форме разметочная сетка будет показываться.

Шахматный порядок. Если установлено, то в новой форме разметочная сетка будет показываться точками, расположенными в шахматном порядке. Если не установлено, то точки располагаются в местах пересечения разметочных линий.

Шаг по горизонтали. Указывается размер разметочной сетки для новой формы по горизонтали.

Шаг по вертикали . Указывается размер разметочной сетки для новой формы по вертикали.


Сетка


Указатели

При пересечении. Если установлено, то в новой форме будут показываться маркеры выравнивания для пересекающихся элементов управления.

При неровном взаиморасположении . Если установлено, то в новой форме будут показываться маркеры выравнивания для элементов управления, чьи границы не выровнены.

При привязке границ. Если установлено, то в новой форме будут показываться маркеры привязки границ элементов управления.


Указатели


Авто прокрутка

Использовать . Если установлено, то в форме (свойство Исп. только видимую область не установлено, т.е. разрешено перемещать элементы управления за пределы видимой области формы) при переносе элемента управления за видимую границу формы, при изменении размеров, при котором граница начинает выходить за пределы формы, а также при начале выделения группы элементов, при котором указатель мыши начинает выходить за пределы видимой области формы, включается режим автопрокрутки. В форму добавляется горизонтальная и/или вертикальная линейка прокрутки, с помощью которой производится просмотр формы. Режим автопрокрутки включается при приближении к границе формы (20 пикселей). При этом, чем ближе приближение, тем быстрее производится прокрутка. Прокрутка включается не сразу, а спустя некоторую паузу, чтобы можно было успеть разместить элемент управления непосредственно у края формы.

Пауза перед началом. Определяет паузу (в сек.) перед началом прокрутки.


Авто прокрутка


Выравнивающие линии

Использовать. Если установлено, то в новой форме будут использоваться выравнивающие линии (подробнее о выравнивающих линиях см. раздел « Выравнивающие линии »).

Область срабатывания. Указывается размер области срабатывания прикрепления к выравнивающей линии при размещении элементов управления.


Выравнивающие линии


Установка параметров администрирования

На закладке «Администрирование» устанавливается время обновления просмотра наличия активных пользователей данной информационной базы (работающих в данный момент времени).


Установка параметров администрирования


Калькулятор

Описание работы с калькулятором см. раздел «Калькулятор» Руководства пользователя.


Калькулятор


Календарь

Описание работы с календарем см. раздел «Календарь» Руководства пользователя.


Шаблоны текста

Конфигуратор системы 1С: Предприятие имеет возможность сохранения часто используемых фрагментов текста и быстрой вставки запомненных фрагментов в редактируемый текстовый документ или модуль.

Фрагменту текста ставится в соответствие условная комбинация символов — краткое имя фрагмента, называемое шаблоном. Если в параметрах Конфигуратора включен режим автоподстановки, то нужный фрагмент текста будет автоматически вставляться в редактор при вводе шаблона (внимание : режим автоподстановки включается отдельно для модулей и текста на разных закладках окна настройки параметров Конфигуратора!).


Шаблоны текста


Ведение списка шаблонов

Текстовый редактор позволяет использовать шаблоны, расположенные в различных файлах.

Настройка шаблонов выполняется в режиме, который можно вызвать, выбрав пункт «Сервис — Шаблоны текста»;

Ведение списка шаблонов выполняется в окне «Шаблоны текста».

Шаблоны хранятся в файлах. Для включения файлов шаблонов выберите пункт «Действия — Файлы шаблонов» окна «Шаблоны текста». На экран выводится диалог «Настройка шаблонов».

В списке файлов помимо стандартных файлов шаблонов можно включить пользовательские файлы. Для добавления файла шаблона нажмите кнопку - панели инструментов окна настройки шаблонов. С новой строке справа нажмите кнопку и выберите файл шаблона.

Для упорядочивания файлов в списке используйте кнопки («Переместить вверх») и («Переместить вниз»).

Для удаления ненужного шаблона выберите его в списке файлов и нажмите кнопку («Удалить»),


Ведение списка шаблонов


Редактирование шаблона

Для редактирования существующего файла выберите пункт «Действия — Изменить». На экран выводится диалог редактирования шаблонов, расположенных в файле.

Диалог содержит панель инструментов, с помощью которой ведется создание групп шаблонов и отдельных шаблонов, удаление ненужных шаблонов и упорядочивание списка. В левой части диалога расположено дерево шаблонов. В правой части производится редактирование наименования группы шаблонов и редактирование шаблона.

Для удобства использования шаблоны можно группировать по папкам. Для создания группы щелкните мышью кнопку +. Введите наименование группы в реквизите «Название».

Для создания шаблона выберите группу, в которой будет размешен шаблон, и щелкните мышью кнопку . В реквизите «Название» укажите наименование шаблона (по этому наименованию производится выбор нужного шаблона при вставке в редактируемый текст). В реквизите Автоматически заменять строку укажите начальную часть строки, при написании которой в окне текстового документа программа произведет подстановку написанного текста текстом из шаблона (если включен режим автоподстановки). Автоподстановка производится после набора последовательности и нажатии клавиши Enter иди клавиши «пробел». В многострочном поле «Текст шаблона» введите текст, которым должен быть заменен текст, указанный в поле «Автоматически заменять строку», или который записывается в текст документа при выборе шаблона.

Чтобы шаблон был доступен при интерактивном выборе, установите флажок «Включать в контекстное меню».

Выбор шаблона для вставки в текст (модуль) осуществляется из контекстного меню из списка шаблонов. Шаблоны размещаются в списке, если установлен флажок «Включать в контекстное меню».


Редактирование шаблона


Управляющие конструкции шаблона

Структурно шаблон может состоять из статической (неизменяемой части) и динамической, содержание которой контекстно-зависимо и не может быть задано наперед. Например, оператор «Если» встроенного языка имеет следующую конструкцию:

Если <? "Условие" > Тогда

Иначе

КонецЕсли;

<?"Условие" > — это контекстно-зависимая часть шаблона.

Для универсальности использования шаблона применяется механизм вставки управляющей конструкции. В тексте шаблона размещают управляющие конструкции — последовательности символов, которые при вставке заменяющего текста шаблона вызывают выполнение каких-либо действий. Например, управляющие конструкции позволяют запрашивать у пользователя какую-либо информацию и помещать эту информацию во вставляемый текст.

Управляющие конструкции в шаблон можно вставлять вручную или использовать специальный запрос для интерактивной вставки управляющих конструкций.

Установите курсор в то место шаблона, которое содержит переменную часть, и нажмите кнопку «<-> Вставка...». На экран выводится диалог «Вставка управляющей конструкции».

В реквизите Подсказка указывается строка текста, которая выводится в виде пояснения к выполняемому действию при запросе на ввод контекстно-зависимой части шаблона. Так как шаблон может содержать несколько управляющих конструкций, ввод которых осуществляется последовательно, этот текст поясняет суть выполняемых действий, и место размещения переменной части.

Группа переключателей позволяет выбрать вид управляющей конструкции, вставляемой в шаблон.

Произвольный запрос. Используется для ввода произвольного текста. В тексте шаблона появится управляющая конструкция вида <?"Текст подсказки"> . Управляющая конструкция типа «произвольный запрос» используется следующим образом. Если в заменяющем тексте встречается конструкция <? "Текст подсказки">, то перед вставкой заменяющего текста на экран будет выдан запрос с текстом подсказки и полем для ввода текста. В поле ввода можно указать текст, который будет вставлен в заменяющий текст вместо конструкции <? "Текст подсказки">. Конструкций типа «произвольный запрос» в заменяющем тексте может быть несколько, причем несколько конструкций могут иметь одинаковый текст подсказки. При вставке заменяющего текста на каждую из различающихся конструкций будет выдан свой запрос для ввода текста. На каждый набор одинаковых конструкций будет выдан один общий запрос, а введенный в запрос текст заменит все одинаковые конструкции.

Специальный запрос. Используется для ввода выбора объектов конфигурации. Для помещения в шаблон управляющей конструкции выбора типа объекта конфигурации с помощью окна «Вставка управляющей конструкции» нужно в поле «Название» поместить имя запроса и в списке выбрать объект конфигурации: Справочник.

После нажатия "ОК " в текст шаблона будет помещена управляющая конструкция.

Если при выборе шаблона (или при автоподстановке) выбрать данный шаблон, то на экран выводится запрос выбора вида справочника.

Установка курсора. Используется для установки курсора в указанное место после вставки текста шаблона. В заменяющий текст шаблона будет вставлена конструкция вида <?>. Такая конструкция указывает, куда следует поместить курсор после ввода заменяющего текста. Если таких конструкций в заменяющем тексте несколько, то курсор будет установлен на место первой по порядку конструкции <?>.

При написании текста шаблона допускается многократное использование управляющих конструкций, а также использование уже готовых шаблонов.


Управляющие конструкции шаблона


Синтакс-Помощник

Синтакс-Помощник — средство, облегчающее разработку модулей. Основная задача Синтакс-Помощника — предоставить специалисту, выполняющему конфигурирование системы 1С: Предприятие, оперативную подсказку по встроенному языку. Для вызова Синтакс-Помощника служит пункт «Сервис — Синтакс-Помощник».


Синтакс-Помощник


Окно Синтакс-Помощника

Окно Синтакс-Помощника является прикрепляемым окном (см. п. « Служебные окна »), поэтому удобно располагать его, «прикрепив» к боковой стороне главного окна Конфигуратора.

Окно Синтакс-Помощника состоит из двух частей.

В верхней части в виде дерева выдается список элементов встроенного языка системы 1С: Предприятие: операторов, управляющих конструкций, процедур и функций, системных констант и др. Для удобства все элементы встроенного языка объединены в тематические разделы, представленные в виде ветвей дерева.

Работа в окне Синтакс-Помощника стандартна для иерархических структур данных, представленных в виде дерева. Для быстрого раскрытия ветви рекомендуем использовать клавиши «+», «-» и «*» цифровой клавиатуры. «+» раскрывает ветвь на один уровень, «-» — сворачивает, «*» — раскрывает все подветви данной ветви.

В нижней части окна Синтакс-Помощника выдается краткое описание элемента встроенного языка, выбранного в верхнем окне. Для получения описания следует выбрать наименование элемента языка в верхней части окна Синтакс-Помощника.

В окне расположена панель инструментов, с помощью которой можно просмотреть историю выбранных ранее описаниям.


Окно Синтакс-Помощника


Копирование элементов встроенного языка

Синтакс-Помощник имеет функцию копирования выбранного элемента встроенного языка в редактор текстов.

Для копирования необходимо выделить наименование нужного элемента языка в древовидном списке и использовать Буфер Обмена. В окно редактора текстов, в место расположения курсора будет перенесена «заготовка» элемента встроенного языка.

Кроме использования Буфера Обмена, для переноса «заготовок» элементов встроенного языка можно использовать режим «перенеси и оставь» («drag & drop»): достаточно перетащить мышью выбранный элемент встроенного языка из окна Синтакс-Помощника в окно редактора текстов.


Копирование элементов встроенного языка


Поиск в Синтакс-Помощнике

Для удобства поиска в Синтакс-Помощнике нужного элемента языка существует специальный режим контекстного поиска.

Для вызова режима контекстного поиска необходимо выбрать пункт «Поиск в Синтакс-Помощнике» в контекстном меню текстового редактора. На экран выводится диалог «Контекстный поиск».

Диалог содержит строку поиска — поле ввода со списком для быстрого поиска в списке элементов, список элементов встроенного языка и список вхождений конкретного элемента.

Для поиска нужного элемента языка можно набирать первые символы элемента на клавиатуре — курсор в списке элементов языка будет установлен на первый элемент, начало которого совпадает с указанными символами. В списке вхождений появится список тематических разделов, имеющих отношение к выделенному элементу. Теперь, если нажать кнопку «ОК», диалог контекстного поиска будет закрыт, а в окне Синтакс-Помощника будет выдано описание найденного элемента языка, выбранное в окне вхождений.

Перейти из списка к описанию найденного элемента языка также можно, дважды щелкнув на элементе языка в списке элементов или на тематическом разделе в списке вхождений левой кнопкой мыши.

Описание элемента встроенного языка можно искать в Спитаке-Помощнике непосредственно при редактировании модуля. Для выполнения поиска следует поместить курсор на элемент встроенного языка, по которому требуется получить подсказку, или выделить блок текста, и нажать клавиши Ctrl+Fl.

Если слово, на котором находится текстовый курсор, или выделенный блок, является элементом встроенного языка, описанным в Синтакс-Помощнике, сразу откроется окно Син-такс-Помощника с описанием этого элемента языка.

Если элемент встроенного языка описан в нескольких тематических разделах Синтакс-Помощника, то сначала откроется окно контекстного поиска с этим элементом для выбора нужного тематического раздела.

Если выбранное слово или блок текста не являются элементами встроенного языка, при нажатии клавиш Ctrl+Fl также будет открыто окно контекстного поиска в Синтакс-Помощнике.

Произведенный поиск запоминается в списке, который можно вызвать, в поле «Строка поиска».

После того, как элемент встроенного языка найден, и окно Синтакс-Помощника открыто, для повторного поиска используйте пункт «Найти» контекстного меню списка элементов встроенного языка.


Поиск в Синтакс-Помощнике


Панели инструментов

В операционной системе MS Windows управление работой приложения осуществляется при помощи набора команд, доступ к которым, в соответствии в принятым в MS Windows стандартом, организован в виде меню. Для быстрого доступа к часто используемым командам используют так называемые панели инструментов.

Панель инструментов представляет собой окно с набором кнопок. Нажатие мышью на любую из кнопок вызывает немедленное выполнение связанной с этой кнопкой команды. Как правило, каждая кнопка снабжена картинкой, образно отражающей характер команды, связанной с этой кнопкой.

Панели инструментов можно располагать в любом удобном месте: как «прижав» к какой-либо стороне окна программы, так и «подвесив» в любом месте экрана. При перемещении панели инструментов ее будущее положение показывается инверсным прямоугольником.

Система 1С: Предприятие использует панели инструментов двух типов: жестко связанные с окном и плавающие.

Панели, жестко привязанные к какому-либо окну, обычно содержат кнопки, предназначенные для работы с информацией, расположенной только в этом окне. Они занимают в окне фиксированное положение (обычно под заголовком окна) и не могут изменяться пользователем.

Плавающие панели инструментов содержат, как правило, кнопки для вызова команд общего применения, не привязанных к информации конкретного окна. Количество панелей инструментов, одновременно находящихся в главном окне Конфигуратора, может меняться в зависимости от режима работы программы. Кроме того, можно определять собственные панели инструментов, компонуя их из заранее заданного набора кнопок.

Управление панелями инструментов ведется при помощи пункт «Сервис — Настройка...» или выбором пункта «Настройка...» в контекстном меню, вызываемом в области панелей инструментов или строки состояния.


Панели инструментов


Виды панелей инструментов

В Конфигураторе могут существовать следующие виды «плавающих» панелей инструментов.

Системные панели инструментов. Эти панели инструментов «зашиты» в программу и не могут быть удалены средствами системы 1С: Предприятие. Можно изменить состав находящихся на них кнопок и даже удалить все кнопки, однако программа «помнит» конфигурацию таких панелей и по команде пользователе может ее восстановить.

Панели инструментов, создаваемые пользователем. В процессе работы с Конфигуратором пользователь может создать свои собственные панели инструментов. Такие панели создаются из заранее заданного набора кнопок и их количество не ограничено.


Виды панелей инструментов


Управление панелями инструментов

Для управления панелями инструментов выберите пункт - «Сервис — Настройка...» или из контекстного меню панелей инструментов.

Диалог «Настройка» содержит две закладки. Для доступа к управляющим элементам конкретной закладки необходимо щелкнуть мышью ее название.


Управление панелями инструментов


Закладка Панели инструментов

С помощью управляющих элементов данной закладки ведется вся работа по созданию, редактированию и удалению панелей инструментов

В списке панелей инструментов символом v отмечены панели, находящиеся в настоящий момент на экране. Эту отметку можно ставить и снимать, щелкая мышью в рамке слева от имени панели инструментов, и, таким образом, вызывать выбранную панель инструментов на экран и убирать ее. Управление возможно только теми панелями, которые в данный момент могут быть использованы. Например, при редактировании текстового документа могут быть использована панель «Текст». Поэтому при настройке можно указать, следует ли панель «Текст» показывать при редактировании текстов или нет.

При первом открытии этого диалога в списке панелей инструментов будут присутствовать только системные панели. При создании пользователем новых панелей инструментов в список будут добавлены их названия.


Закладка Панели инструментов


Создание панелей инструментов

Для создания панели инструментов необходимо перейти в закладку «Панели инструментов» и нажать кнопку «Создать». В появившемся запросе необходимо ввести имя новой панели инструментов. После нажатия кнопки «ОК» на экране появится новая панель инструментов — пока еще без кнопок.


Создание панелей инструментов


Переименование панели инструментов

Переименовывать можно только панели инструментов, созданные пользователем.

Для переименования панели необходимо выбрать ее имя в списке нажать кнопку «Переименовать», указать новое имя.


Переименование панели инструментов


Удаление панели инструментов

Удалить можно только панели инструментов, созданные пользователем.

Для удаления панели необходимо выбрать ее имя в списке и нажать кнопку «Удалить». Панель инструментов удаляется без дополнительного предупреждения.


Удаление панели инструментов


Восстановление системных панелей инструментов

Системные панели инструментов, измененные в результате редактирования, можно восстановить в первоначальном виде. Для этого необходимо выбрать имя системной панели в списке и нажать кнопку «Сброс».


Восстановление системных панелей инструментов


Редактирование панелей инструментов

При редактировании панелей инструментов можно изменять состав и взаимное расположение кнопок, что позволяет организовать панели инструментов наиболее удобным образом. Редактирование выполняется при помощи закладки «Команды» диалога «Настройка».

Все кнопки, которые могут быть размещены на панелях инструментов, для удобства, объединены в несколько категорий. Список категорий размещается в списке «Категории».

Если выбрать в этом списке имя какой-либо категории, в списке «Команды» выдается набор команд, входящих в эту категорию. Этот набор не может быть изменен.

Чтобы узнать назначение конкретной кнопки, необходимо щелкнуть на ней мышью — в нижней части закладки будет выдано описание кнопки.

Все действия по редактированию панелей инструментов выполняются методом «drag & drop» («перенеси и оставь»).

Для того чтобы добавить кнопку на панель инструментов, необходимо перетащить ее мышью на эту панель с закладки «Команды» или с другой панели. Если при перетаскивании кнопки с панели на панель держать нажатой клавишу Ctrl, кнопка будет скопирована на вторую панель и останется на первой.

Для удаления кнопки с панели инструментов необходимо перетащить ее мышью в любое место окна программы.


Редактирование панелей инструментов


Сравнение файлов

Режим сравнения файлов дает возможность пользователю сравнить. 2 любых файла. Для сравнения файлов необходимо выбрать пункт «Файл — Сравнить файлы». На экран будет выдан диалог для выбора сравниваемых файлов.

В полях «Сравнить» и «С» необходимо указать имена сравниваемых файлов. Имена файлов можно ввести вручную, выбрать из выпадающего списка или нажатием кнопки вызвать стандартный диалог открытия файл и выбрать файл в этом диалоге.

Установка флажка «Игнорировать пустое пространство» означает, что пробелы сравниваться не будут.

Флажок «Различать регистр» позволяет при сравнении различать прописные и строчные буквы. Если флажок установлен, одна и та же прописная и строчная буква будут считаться разными символами.

Для начала сравнения необходимо нажать кнопку «ОК».

В зависимости от типа сравниваемых файлов, режим предоставляет различные возможности сравнения.

В двоичных файлах определяется только наличие или отсутствие различий, о чем выдается соответствующее сообщение.

Для текстовых файлов на экран будет выдано окно просмотра различий. В двух колонках окна просмотра различий будут помещены сравниваемые тексты. В текстах разными цветами выделены удаленные, измененные и добавленные (новые) строки. В окне имеется панель инструментов со стандартными для текстового редактора 1С: Предприятия кнопками поиска и закладок, а также двумя кнопками, специфическими для данного окна. Это большие желто-зеленые стрелки, направленные одна вверх, другая вниз, служащие для перехода на начало ближайшего предыдущего или последующего измененного текста. С их помощью осуществляется быстрый переход к следующему - или предыдущему различающемуся тексту.

Различия в сравниваемых текстах показываются с помощью цвета текста. Цвет текста можно настроить (запускается диалог настройки цветов). По умолчанию удаленный текст показывается синим цветом, добавленный — зеленым, а измененный — красным.

В левой части окна показывается текст файла, указанного в поле «Сравнить», в правой — в поле «С». Нажатием на кнопку можно поменять местами сравниваемые файлы. При этом меняется и цвет пометки. Если первоначально в левой части был показан удаленный текст, то при смене порядка сравнения этот текст, в правой части будет показан как добавленный.

При открытии файлов для сравнения при помощи стандартного диалога открытия файлов, в поле «Тип файлов» можно указать любой тип открываемого файла.


Сравнение файлов


Глава 13.Отладчик

Отладчик — вспомогательный, инструмент, облегчающий разработку программных модулей системы 1C: Предприятие. Отладчик предоставляет следующие возможности:

• пошаговое выполнение модуля;

• расстановка точек останова;

• прерывание и продолжение выполнения модуля;

• возможность отладки нескольких модулей одновременно;

• вычисление выражений для анализа состояния переменных;

• просмотр стека вызовов процедур и функций;

• возможность остановки по возникновению ошибки;

• возможность редактирования модуля в процессе отладки;

• замеры производительности.


Глава 13.Отладчик


Использование Отладчика

Ниже приведен порядок использования 1С: Отладчика.

Отладчик является встроенным в Конфигуратор инструментом. Для его использования необходимо, чтобы одновременно с Конфигуратором была запущена отлаживаемая конфигурация в режиме «1С: Предприятие». Последовательность запуска программ не имеет значения (кроме случая использования Отладчика для замера производительности; для этого случая порядок действий описан ниже в соответствующем разделе).

Внимание. Недоступны для отладки общие модули, выполняемые на сервере (модули, у которых установлено свойство «Преимущественно на сервере», и сервер приложений существует).

Процесс отладки заключается в последовательном выполнении следующих действий:

• запустите Конфигуратор и откройте модуль, предназначенный для отладки;

• расставьте в требуемых строках модуля точки останова;

• перейдите в режим запуска «Ю.Предприятие»;

• выполните действия, которые вызовут исполнение отлаживаемого модуля (например, проведите документ или сформируйте отчет);

• после того, как сработала точка останова, управление автоматически перейдет к Отладчику.

• проведите пошаговое выполнение нужного вам фрагмента модуля.

С помощью табло и диалога «Выражение» вы можете получить значения интересующих вас выражений. Стек вызовов позволяет проследить последовательность вызова процедур и функций.

В случае, если вы не хотите продолжать пошаговое выполнение модуля дальше, с помощью команды «Отладка — Продолжить отладку» разрешите системе 1C: Предприятие свободное выполнение модуля (до следующей точки останова). Система 1С: Предприятие активизируется автоматически.

В случае, если вы хотите прервать процесс отладки в целом, снимите все точки останова со всех модулей. Если вы хотите прервать отладку только данного модуля, воспользуйтесь командой «Отладка — Прекратить».

Внимание. Хотя в процессе отладки возможно редактирование отлаживаемого модуля, Отладчик не производит компилирование измененного кода — продолжается отладка кода на момент запуска Отладчика. Для отладки изменений потребуется повторно запустить Отладчик.

Далее в этом разделе более подробно описаны функции Отладчика.


Использование Отладчика


Запуск Отладчика

Если конфигурация не запущена в режиме 1С: Предприятие, то для начала отладки выберите пункт «Отладка — Начать отладку». Конфигуратор запускает конфигурацию в режиме 1С: Предприятие.

Если конфигурация запущена в режиме 1С: Предприятие, то выберите пункт «Отладка — Подключиться». На экран выводится окно для выбора процесса. Обычно список содержит одну строку с указанием на запущенную в режиме 1С: Предприятие конфигурацию. Если запущено несколько приложений 1С:Предприятие с данной конфигурацией, то список может содержать несколько строк. В список процессов включается только те процессы, которые имеют совокупность следующих совпадающих данных: номер версии приложения, каталог информационной базы, не запущен другой Отладчик. Выбор процесса указывает Отладчику, какой процесс будет отлаживаться.


Запуск Отладчика


Отладка внешних обработок

Для отладки модуля внешней обработки необходимо открыть файл внешней обработки в Конфигураторе, воспользовавшись пунктом «Файл — Открыть».

В дальнейшем с модулем внешней обработки в Отладчике можно работать так же, как и с любым другим модулем.


Отладка внешних обработок


Точка останова

Точкой останова называется маркер, устанавливаемый на конкретную строку программного модуля. При достижении точки останова исполнение программного модуля останавливается, и управление передается Отладчику.

В левой колонке текста модуля специальными значками показываются текущая точка останова, места останова и состояние точек останова.

Команда | Пояснение
Точка останова | Устанавливает, либо стирает точку останова на той строке, на которой стоит курсор. Установить или снять точку останова можно также двойным щелчком мыши на желтой полосе в левой части окна модуля
Точка останова с условием | Устанавливает точку останова и выдает запрос для ввода условия останова — логического выражения. Останов в указанной точке будет выполняться, только если условие останова истинно.
Отключить точку останова | В случае, если на той строке, на которой стоит курсор, находится точка останова, включает либо отключает ее действие
Убрать все точки останова | Стирает все ранее расставленные точки останова во всех модулях
Отключить все точки останова | Запрещает действия всех ранее расставленных точек останова во всех модулях, не удаляя их
Список точек останова | Просмотр и управление точками управления
Останавливаться по ошибке | При возникновении ошибки Отладчик останавливает выполнение и переходит в строке модуля, вызвавшей ошибку

Установленные точки останова запоминаются при закрытии конфигурации. Если снова открыть конфигурацию, то посмотреть список точек останова можно с помощью диалога «Точки остановки», вызываемого пунктом меню «Отладка — Список точек останова».

С помощью флажков в колонке «Вкл./выкл.» можно управлять состоянием точек остановки. Если флажок установлен, то при отладке на данной точке Отладчик выполнит остановку. Чтобы убрать точку остановки, в панели инструментов диалога нажмите кнопку («Удалить точку остановки»).

Для перехода к выбранной точки останова в панели инструментов диалога, нажмите кнопку («Перейти к исходному коду»).


Точка останова


Пошаговое выполнение

В режиме пошагового исполнения система 1С:Предприятие, выполнив очередную команду, ждет от Отладчика инструкций о продолжении работы.

В начале отладки в меню «Отладка» система добавляет пункты, с помощью которых осуществляется управление процессом отладки.

На каждом шаге исполнения модуля существует 5 вариантов продолжения. Для выбора варианта продолжения используются пункты меню «Отладка» (см. таблицу).

Команда | Пояснение
Шагнуть в | В случае, если следующим выполняемым оператором модуля является вызов функции или процедуры, начинается ее пошаговое выполнение, иначе Отладчик переходит к следующему оператору
Шагнуть через | Если следующим выполняемым оператором модуля является вызов функции или процедуры, она выполняется целиком (не пошагово) и Отладчик переходит к следующему оператору
Шагнуть из | Прервать пошаговое выполнение функции или процедуры и остановиться на первом операторе, находящемся после ее вызова
Идти до курсора | Прервать пошаговое выполнение модуля, выполнять все операторы до той строки, на которой стоит курсор.
Продолжить | Прервать пошаговое выполнение модуля и продолжить свободное выполнение.

Команда «Отладка — Прекратить» прекращает выполнение модуля и возвращает управление системе 1C: Предприятие. Данная команда позволяет начать пошаговое выполнение модуля, начиная с исполняемой в этот момент строки. Данная команда полезна при анализе «зацикливания» модуля.


Пошаговое выполнение


Диалог Выражение

Кроме использования табло, во время пошагового выполнения имеется возможность рассчитать выражение с помощью диалога «Выражение». Этот диалог вызывается на экран выбором пункта «Отладка — Вычислить выражение».

В поле «Выражение» этого диалога необходимо ввести выражение на встроенном языке системы 1C: Предприятие. Выражение можно ввести «вручную» или из списка ранее введенных выражений.

Если при вызове диалога «Выражение» курсор в окне модуля находится на каком-либо выражении, оно автоматически подставляется в поле «Выражение».

Для вычисления выражения следует нажать кнопку «Рассчитать». Результат вычисления выражения будет выдан в поле «Значение».

Кнопка «Включить в табло» помещает введенное выражение в табло. Это позволит в дальнейшем прослеживать изменение результата вычисления выражения в процессе отладки модуля. При этом выражение размещается в новой строке табло. Если окно табло на экране нет, то оно открывается.


Диалог Выражение


Табло

Табло — специальное окно, в котором отображаются результаты вычисления переменных и введенных в него формул в процессе выполнения программы в режиме отладки. Вызов табло на экран выполняется выбором пункта меню «Отладка — Табло» доступным в режиме отладки.

Табло представляет собой четырехстраничную форму, каждая страница которой содержит таблицу для ввода переменных и формул, результаты вычисления которых необходимо контролировать. Формулы могут включать арифметические выражения, выражения с использованием функций и процедур встроенного языка системы 1С: Предприятие, а также функции и процедуры глобального и общих модулей.

Каждая формула вводится в первую колонку таблицы и должна находиться на отдельной строке. Результат вычисления формулы выдается в колонке «Значение». В колонке «Тип» выводится тип выражения. Если формула введена неправильно, то вместо результата появится фраза «Обнаружены синтаксические ошибки!».

Результат расчета может быть скопирован в Буфер Обмена выбором пункта «Копировать результат» контекстного меню второй колонки.

Если в процессе работы исходные данные, используемые в формулах, изменились, то для получения актуальных результатов расчетов необходимо выполнить обновление. Для этого в контекстном меню табло выберите пункт «Пересчитать» или «Пересчитать все».

С точки зрения выбора страниц, табло работает в двух режимах: в первом страницы выбираются с помощью закладок, располагающихся внизу, во втором — с помощью контекстного меню. Выбор режима производится установкой или снятием флажка в пункте «Закладки» контекстного меню.

Для очистки содержимого строки табло необходимо выбрать строку и нажать клавишу Del.

Окно табло может размещаться на экране в различных режимах.


Табло


Стек вызовов

Стек вызовов показывает последовательность вызовов процедур и функций, приведшую к строке модуля, которая отлаживается в данный момент.

Двойным щелчком мыши на имени процедуры в стеке вызова можно перейти в соответствующую строку процедуры.


Стек вызовов


Замеры производительности

С помощью Отладчика можно оценить скорость работы всей конфигурации или ее части. Измеряется частота использования конкретных участков кода и скорость их выполнения. Если имеется несколько способов решения какой-либо задачи, можно реализовать их все, после чего выбрать самый быстрый.

При этом необходимо иметь в виду, что сравнение нужно производить в одинаковых условиях. Например, если во время выполнения задачи одним из сравниваемых способов процессор компьютера был загружен еще какой-либо задачей, это может повлиять на достоверность сравнения. Возможны и другие, менее очевидные причины, по которым условия измерения окажутся различными. Поэтому при сравнении двух способов выполнения задачи, имеющих близкую производительность, желательно делать с каждым из них несколько замеров — для оценки и усреднения случайного разброса.

Для замера производительности выберите команду «Отладка — Замер производительности». При повторном выборе команды замер прекратится и откроется окно с его результатами.


Замеры производительности


Варианты порядка действий

Если нужно измерить производительность конфигурации, включая участок, выполняемый при старте системы, необходимо сначала выбрать эту команду, затем запустить 1C: Предприятие. Время, прошедшее между стартом замера и началом работы системы не будет учитываться в результатах замера.

Если участок, выполняемый при старте системы, включать в замер не требуется, необходимо сначала запустить 1C: Предприятие, подготовить его к выполнению требуемого участка, затем перейти в Отладчик и включить замер.

Если в замер нужно включить участок, выполняемый при окончании работы 1С Предприятия, то, независимо от того, использовался ли вариант 1 или 2 для начала замера, нужно завершить работу 1С: Предприятия, после чего перейти в Отладчик. В этом случае прекращать замер вручную не нужно. Как только будут подведены итоги замера, его результаты появятся на экране.

Если участок, выполняемый при окончании работы 1С: Предприятия, включать в замер не требуется, то для появления результатов замера его нужно закончить. Например, для анализа процедуры проведения какого-либо документа запустите 1C: Предприятие, откройте документ, заполните его, перейдите в Отладчик, включите замер, перейдите в 1С: Предприятие, проведите документ, перейдите в Отладчик и закончите замер.


Варианты порядка действий


Результаты замера

Результаты замера — ссылки на конкретные строки модуля, с указанием частоты их выполнения и длительности — представляются в виде таблицы, состоящей из следующих колонок:

Модуль | содержит название модуля
Номер строки | номер строки модуля;
Строка | текст данной строки модуля;
Кол. | количество вызовов данной строки за время замера;
Врем. | суммарное время (сек.) выполнения данной строки за время замера;
%(Врем.) | процент суммарного времени выполнения данной строки к общему времени замера (общее время замера равно сумме всех промежутков времени, в которые выполнялся код конфигурации).

Управления показом результатов замера для строк, в которых присутствуют вызовы процедур (функций), написанных на встроенном языке системы 1С: Предприятие, выполняется флажком «Для вызовов процедур и функций включать время выполнения».

Если флажок снят, в результат замера будет включено время выполнения только самой строки модуля, но не время работы процедуры (функции), которая вызывается в данной строке. В этом случае суммарное время выполнения данной строки (в колонке «Врем.») не будет отражать реального времени, потраченного системой на отработку данной строки: необходимо иметь в виду, что выполнение вызванной процедуры (функции) может занимать, в общем случае, значительное время, которое в данном случае не будет включено в результат.

Если флажок установлен, то, наоборот, в результат замера будет включено и время выполнения самой строки модуля, и время работы процедуры (функции), которая вызывается в данной строке. В этом случае суммарное время выполнения данной строки будет показывать реальное время, потраченное системой на отработку данной строки. Также следует иметь в виду, что результат в колонке «%(Врем.)», будет показывать реальное соотношение времени выполнения данной строки ко всему времени замера, однако общая сумма результатов этой колонки не будет равна 100%.

Кроме специального окна, результаты замера можно видеть непосредственно в окне с исходным кодом модуля. Если в Отладчике открыто окно с замером, в окнах модулей появляется колонка, показывающая количество вызовов данной строки и процент времени ее работы к общему времени.

Двойным щелчком мыши по строке в окне результатов замера можно переключиться на соответствующую строку в окне модуля, и наоборот. На рисунке зафиксирован вид экрана после такого переключения с первой строки в окне результатов замера в окно модуля (и обратно): в окне модуля видна соответствующая строка (здесь — также первая).

Если открыто несколько замеров одновременно, то в окнах с текстами модулей появится соответствующее количество колонок.


Результаты замера


Сортировка результатов замера

Результаты замера могут быть отсортированы по любой колонке отчета.

Сортировка осуществляется щелчком мышью на заголовке одной из колонок. Щелчок на заголовках «Модуль» или «Строка» дает сортировку по номерам строк «Кол.» — по количеству вызовов строки «Врем.» или «%(Врем.)» — по времени работы.


Сортировка результатов замера


Выборочное суммирование результатов замера

Для анализа результатов замера могут оказаться полезными суммарные характеристики. Если в окне результатов отметить несколько строк, их суммарные характеристики — суммы количества вызовов, времени работы в секундах и в процентах — отображаются в нижней части окна. Выбор несколько строк осуществляется стандартным для MS Windows способом.

Флажок «Для вызовов процедур и функций включать время выполнения» служит для выбора одного из двух методов приблизительного отслеживания уровней вложенности при суммировании. Если в данном модуле имеются и строка, вызывающая некоторую процедуру, и строки текста самой процедуры, то, конечно, не следует помечать и то и другое: это приведет к повторному учету в сумме одного и того же времени выполнения. Если все же приходится пометить их (например, слишком много усилий пришлось бы потратить на отслеживание), то можно снять флажок: повторного учета не будет. С другой стороны, если все вызываемые процедуры — внешние по отношению к модулю, флажок лучше включить. Тогда в общее время выполнения будет включено время отработки этих процедур, что лучше соответствует реальному времени работы.


Выборочное суммирование результатов замера


Сохранение результатов

Результат замера можно сохранить в файл с помощью команд «Файл — Сохранить» и «Файл — Сохранить как». В стандартном диалоге сохранения выберите каталог и укажите имя файла. Файл результатов имеют расширение «*.pff».

Открыть файл с замером можно командой «Открыть замер» меню «Производительность».


Сохранение результатов